All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] drm: deprecate DRM_FORMAT_MOD_NONE
@ 2020-10-26 13:17 Simon Ser
  2020-10-26 13:18 ` Bas Nieuwenhuizen
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: Simon Ser @ 2020-10-26 13:17 UTC (permalink / raw)
  To: dri-devel

DRM_FORMAT_MOD_NONE is in the list of vendors, which is pretty
confusing. We already have DRM_FORMAT_MOD_VENDOR_NONE. Move it down in
the list of format modifiers.

DRM_FORMAT_MOD_NONE is an alias for DRM_FORMAT_MOD_LINEAR, however the
name is confusing: NONE doesn't mean that the modifier is implicit,
instead it means that the layout is linear. Deprecate it.

Signed-off-by: Simon Ser <contact@emersion.fr>
Suggested-by: Bas Nieuwenhuizen <bas@basnieuwenhuizen.nl>
Cc: Daniel Vetter <daniel@ffwll.ch>
Cc: Pekka Paalanen <ppaalanen@gmail.com>
---
 include/uapi/drm/drm_fourcc.h | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

diff --git a/include/uapi/drm/drm_fourcc.h b/include/uapi/drm/drm_fourcc.h
index d720f1e8ae5e..ca1d5587b5fc 100644
--- a/include/uapi/drm/drm_fourcc.h
+++ b/include/uapi/drm/drm_fourcc.h
@@ -350,7 +350,6 @@ extern "C" {
  */
 
 /* Vendor Ids: */
-#define DRM_FORMAT_MOD_NONE           0
 #define DRM_FORMAT_MOD_VENDOR_NONE    0
 #define DRM_FORMAT_MOD_VENDOR_INTEL   0x01
 #define DRM_FORMAT_MOD_VENDOR_AMD     0x02
@@ -422,6 +421,14 @@ extern "C" {
  */
 #define DRM_FORMAT_MOD_LINEAR	fourcc_mod_code(NONE, 0)
 
+/*
+ * Deprecated: use DRM_FORMAT_MOD_LINEAR instead
+ *
+ * The "none" format modifier doesn't actually mean that the modifier is
+ * implicit, instead it means that the layout is linear.
+ */
+#define DRM_FORMAT_MOD_NONE	0
+
 /* Intel framebuffer modifiers */
 
 /*
-- 
2.28.0


_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH] drm: deprecate DRM_FORMAT_MOD_NONE
  2020-10-26 13:17 [PATCH] drm: deprecate DRM_FORMAT_MOD_NONE Simon Ser
@ 2020-10-26 13:18 ` Bas Nieuwenhuizen
  2020-10-26 13:21 ` Pekka Paalanen
  2020-10-26 15:27 ` Daniel Vetter
  2 siblings, 0 replies; 4+ messages in thread
From: Bas Nieuwenhuizen @ 2020-10-26 13:18 UTC (permalink / raw)
  To: Simon Ser; +Cc: ML dri-devel

Reviewed-by: Bas Nieuwenhuizen <bas@basnieuwenhuizen.nl>

On Mon, Oct 26, 2020 at 2:17 PM Simon Ser <contact@emersion.fr> wrote:
>
> DRM_FORMAT_MOD_NONE is in the list of vendors, which is pretty
> confusing. We already have DRM_FORMAT_MOD_VENDOR_NONE. Move it down in
> the list of format modifiers.
>
> DRM_FORMAT_MOD_NONE is an alias for DRM_FORMAT_MOD_LINEAR, however the
> name is confusing: NONE doesn't mean that the modifier is implicit,
> instead it means that the layout is linear. Deprecate it.
>
> Signed-off-by: Simon Ser <contact@emersion.fr>
> Suggested-by: Bas Nieuwenhuizen <bas@basnieuwenhuizen.nl>
> Cc: Daniel Vetter <daniel@ffwll.ch>
> Cc: Pekka Paalanen <ppaalanen@gmail.com>
> ---
>  include/uapi/drm/drm_fourcc.h | 9 ++++++++-
>  1 file changed, 8 insertions(+), 1 deletion(-)
>
> diff --git a/include/uapi/drm/drm_fourcc.h b/include/uapi/drm/drm_fourcc.h
> index d720f1e8ae5e..ca1d5587b5fc 100644
> --- a/include/uapi/drm/drm_fourcc.h
> +++ b/include/uapi/drm/drm_fourcc.h
> @@ -350,7 +350,6 @@ extern "C" {
>   */
>
>  /* Vendor Ids: */
> -#define DRM_FORMAT_MOD_NONE           0
>  #define DRM_FORMAT_MOD_VENDOR_NONE    0
>  #define DRM_FORMAT_MOD_VENDOR_INTEL   0x01
>  #define DRM_FORMAT_MOD_VENDOR_AMD     0x02
> @@ -422,6 +421,14 @@ extern "C" {
>   */
>  #define DRM_FORMAT_MOD_LINEAR  fourcc_mod_code(NONE, 0)
>
> +/*
> + * Deprecated: use DRM_FORMAT_MOD_LINEAR instead
> + *
> + * The "none" format modifier doesn't actually mean that the modifier is
> + * implicit, instead it means that the layout is linear.
> + */
> +#define DRM_FORMAT_MOD_NONE    0
> +
>  /* Intel framebuffer modifiers */
>
>  /*
> --
> 2.28.0
>
>
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] drm: deprecate DRM_FORMAT_MOD_NONE
  2020-10-26 13:17 [PATCH] drm: deprecate DRM_FORMAT_MOD_NONE Simon Ser
  2020-10-26 13:18 ` Bas Nieuwenhuizen
@ 2020-10-26 13:21 ` Pekka Paalanen
  2020-10-26 15:27 ` Daniel Vetter
  2 siblings, 0 replies; 4+ messages in thread
From: Pekka Paalanen @ 2020-10-26 13:21 UTC (permalink / raw)
  To: Simon Ser; +Cc: dri-devel


[-- Attachment #1.1: Type: text/plain, Size: 1711 bytes --]

On Mon, 26 Oct 2020 13:17:02 +0000
Simon Ser <contact@emersion.fr> wrote:

> DRM_FORMAT_MOD_NONE is in the list of vendors, which is pretty
> confusing. We already have DRM_FORMAT_MOD_VENDOR_NONE. Move it down in
> the list of format modifiers.
> 
> DRM_FORMAT_MOD_NONE is an alias for DRM_FORMAT_MOD_LINEAR, however the
> name is confusing: NONE doesn't mean that the modifier is implicit,
> instead it means that the layout is linear. Deprecate it.
> 
> Signed-off-by: Simon Ser <contact@emersion.fr>
> Suggested-by: Bas Nieuwenhuizen <bas@basnieuwenhuizen.nl>
> Cc: Daniel Vetter <daniel@ffwll.ch>
> Cc: Pekka Paalanen <ppaalanen@gmail.com>
> ---
>  include/uapi/drm/drm_fourcc.h | 9 ++++++++-
>  1 file changed, 8 insertions(+), 1 deletion(-)
> 
> diff --git a/include/uapi/drm/drm_fourcc.h b/include/uapi/drm/drm_fourcc.h
> index d720f1e8ae5e..ca1d5587b5fc 100644
> --- a/include/uapi/drm/drm_fourcc.h
> +++ b/include/uapi/drm/drm_fourcc.h
> @@ -350,7 +350,6 @@ extern "C" {
>   */
>  
>  /* Vendor Ids: */
> -#define DRM_FORMAT_MOD_NONE           0
>  #define DRM_FORMAT_MOD_VENDOR_NONE    0
>  #define DRM_FORMAT_MOD_VENDOR_INTEL   0x01
>  #define DRM_FORMAT_MOD_VENDOR_AMD     0x02
> @@ -422,6 +421,14 @@ extern "C" {
>   */
>  #define DRM_FORMAT_MOD_LINEAR	fourcc_mod_code(NONE, 0)
>  
> +/*
> + * Deprecated: use DRM_FORMAT_MOD_LINEAR instead
> + *
> + * The "none" format modifier doesn't actually mean that the modifier is
> + * implicit, instead it means that the layout is linear.
> + */
> +#define DRM_FORMAT_MOD_NONE	0
> +
>  /* Intel framebuffer modifiers */
>  
>  /*

Reviewed-by: Pekka Paalanen <pekka.paalanen@collabora.com>


Thanks,
pq

[-- Attachment #1.2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

[-- Attachment #2: Type: text/plain, Size: 160 bytes --]

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] drm: deprecate DRM_FORMAT_MOD_NONE
  2020-10-26 13:17 [PATCH] drm: deprecate DRM_FORMAT_MOD_NONE Simon Ser
  2020-10-26 13:18 ` Bas Nieuwenhuizen
  2020-10-26 13:21 ` Pekka Paalanen
@ 2020-10-26 15:27 ` Daniel Vetter
  2 siblings, 0 replies; 4+ messages in thread
From: Daniel Vetter @ 2020-10-26 15:27 UTC (permalink / raw)
  To: Simon Ser; +Cc: dri-devel

On Mon, Oct 26, 2020 at 2:17 PM Simon Ser <contact@emersion.fr> wrote:
>
> DRM_FORMAT_MOD_NONE is in the list of vendors, which is pretty
> confusing. We already have DRM_FORMAT_MOD_VENDOR_NONE. Move it down in
> the list of format modifiers.
>
> DRM_FORMAT_MOD_NONE is an alias for DRM_FORMAT_MOD_LINEAR, however the
> name is confusing: NONE doesn't mean that the modifier is implicit,
> instead it means that the layout is linear. Deprecate it.
>
> Signed-off-by: Simon Ser <contact@emersion.fr>
> Suggested-by: Bas Nieuwenhuizen <bas@basnieuwenhuizen.nl>
> Cc: Daniel Vetter <daniel@ffwll.ch>
> Cc: Pekka Paalanen <ppaalanen@gmail.com>
> ---
>  include/uapi/drm/drm_fourcc.h | 9 ++++++++-
>  1 file changed, 8 insertions(+), 1 deletion(-)
>
> diff --git a/include/uapi/drm/drm_fourcc.h b/include/uapi/drm/drm_fourcc.h
> index d720f1e8ae5e..ca1d5587b5fc 100644
> --- a/include/uapi/drm/drm_fourcc.h
> +++ b/include/uapi/drm/drm_fourcc.h
> @@ -350,7 +350,6 @@ extern "C" {
>   */
>
>  /* Vendor Ids: */
> -#define DRM_FORMAT_MOD_NONE           0
>  #define DRM_FORMAT_MOD_VENDOR_NONE    0
>  #define DRM_FORMAT_MOD_VENDOR_INTEL   0x01
>  #define DRM_FORMAT_MOD_VENDOR_AMD     0x02
> @@ -422,6 +421,14 @@ extern "C" {
>   */
>  #define DRM_FORMAT_MOD_LINEAR  fourcc_mod_code(NONE, 0)
>
> +/*
> + * Deprecated: use DRM_FORMAT_MOD_LINEAR instead
> + *
> + * The "none" format modifier doesn't actually mean that the modifier is
> + * implicit, instead it means that the layout is linear.
> + */

Maybe mention that "are modifiers used" is out-of-band information
carried in e.g. the modifier flag for addfb2 (or for EGL in the
presence/absence of the modifier settings when initializing a buffer).
Either way,

Acked-by: Daniel Vetter <daniel.vetter@ffwll.ch>

> +#define DRM_FORMAT_MOD_NONE    0
> +
>  /* Intel framebuffer modifiers */
>
>  /*
> --
> 2.28.0
>
>


-- 
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2020-10-26 15:27 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-10-26 13:17 [PATCH] drm: deprecate DRM_FORMAT_MOD_NONE Simon Ser
2020-10-26 13:18 ` Bas Nieuwenhuizen
2020-10-26 13:21 ` Pekka Paalanen
2020-10-26 15:27 ` Daniel Vetter

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.