All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v4 0/9] gpiolib: acpi: pin configuration fixes
@ 2020-11-06 19:22 Andy Shevchenko
  2020-11-06 19:22 ` [PATCH v4 1/9] gpiolib: acpi: Respect bias settings for GpioInt() resource Andy Shevchenko
                   ` (8 more replies)
  0 siblings, 9 replies; 17+ messages in thread
From: Andy Shevchenko @ 2020-11-06 19:22 UTC (permalink / raw)
  To: Linus Walleij, Bartosz Golaszewski, linux-gpio, Mika Westerberg
  Cc: Andy Shevchenko, Jamie McClymont, Hans de Goede

There are two fixes (and several cleanups) that allow to take into
consideration more parameters in ACPI, i.e. bias for GpioInt() and
debounce time for Operation Regions, Events and GpioInt() resources.

The first patch highly depends on Intel pin control driver changes
(they are material for v5.10 [1]), so this is probably not supposed
to be backported (at least right now).

The last patch adds Intel GPIO tree as official one for ACPI GPIO
changes.

Assuming [1] makes v5.10 this series can be sent as PR to Linus
for v5.11 cycle.

Cc: Jamie McClymont <jamie@kwiius.com>
Cc: Mika Westerberg <mika.westerberg@linux.intel.com>
Cc: Hans de Goede <hdegoede@redhat.com>

[1]: https://lore.kernel.org/linux-gpio/20201106181938.GA41213@black.fi.intel.com/

Changelog v4:
- extended debounce setting to ACPI events and Operation Regions
- added Ack (Linus)
- added few more cleanup patches, including MAINTAINERS update

Changelog v3:
- dropped upstreamed OF patch
- added debounce fix

Andy Shevchenko (9):
  gpiolib: acpi: Respect bias settings for GpioInt() resource
  gpiolib: acpi: Use named item for enum gpiod_flags variable
  gpiolib: acpi: Take into account debounce settings
  gpiolib: acpi: Move acpi_gpio_to_gpiod_flags() upper in the code
  gpiolib: acpi: Make acpi_gpio_to_gpiod_flags() usable for GpioInt()
  gpiolib: acpi: Extract acpi_request_own_gpiod() helper
  gpiolib: acpi: Convert pin_index to be u16
  gpiolib: acpi: Use BIT() macro to increase readability
  gpiolib: acpi: Make Intel GPIO tree official for GPIO ACPI work

 MAINTAINERS                 |   1 +
 drivers/gpio/gpiolib-acpi.c | 130 +++++++++++++++++++++---------------
 drivers/gpio/gpiolib-acpi.h |   2 +
 3 files changed, 81 insertions(+), 52 deletions(-)

-- 
2.28.0


^ permalink raw reply	[flat|nested] 17+ messages in thread

end of thread, other threads:[~2020-11-09 15:42 UTC | newest]

Thread overview: 17+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-11-06 19:22 [PATCH v4 0/9] gpiolib: acpi: pin configuration fixes Andy Shevchenko
2020-11-06 19:22 ` [PATCH v4 1/9] gpiolib: acpi: Respect bias settings for GpioInt() resource Andy Shevchenko
2020-11-06 19:22 ` [PATCH v4 2/9] gpiolib: acpi: Use named item for enum gpiod_flags variable Andy Shevchenko
2020-11-06 19:22 ` [PATCH v4 3/9] gpiolib: acpi: Take into account debounce settings Andy Shevchenko
2020-11-07 14:44   ` Hans de Goede
2020-11-07 15:26     ` Andy Shevchenko
2020-11-08  9:31       ` Hans de Goede
2020-11-08  9:31       ` Hans de Goede
2020-11-09 11:45         ` Andy Shevchenko
2020-11-09 11:53           ` Hans de Goede
2020-11-09 15:43             ` Andy Shevchenko
2020-11-06 19:22 ` [PATCH v4 4/9] gpiolib: acpi: Move acpi_gpio_to_gpiod_flags() upper in the code Andy Shevchenko
2020-11-06 19:23 ` [PATCH v4 5/9] gpiolib: acpi: Make acpi_gpio_to_gpiod_flags() usable for GpioInt() Andy Shevchenko
2020-11-06 19:23 ` [PATCH v4 6/9] gpiolib: acpi: Extract acpi_request_own_gpiod() helper Andy Shevchenko
2020-11-06 19:23 ` [PATCH v4 7/9] gpiolib: acpi: Convert pin_index to be u16 Andy Shevchenko
2020-11-06 19:23 ` [PATCH v4 8/9] gpiolib: acpi: Use BIT() macro to increase readability Andy Shevchenko
2020-11-06 19:23 ` [PATCH v4 9/9] gpiolib: acpi: Make Intel GPIO tree official for GPIO ACPI work Andy Shevchenko

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.