All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 00/11] dm: Simplify livetree handling
@ 2020-11-29  0:49 Simon Glass
  2020-11-29  0:50 ` [PATCH 01/11] dm: core: Rename device_bind() to device_bind_offset() Simon Glass
                   ` (21 more replies)
  0 siblings, 22 replies; 35+ messages in thread
From: Simon Glass @ 2020-11-29  0:49 UTC (permalink / raw)
  To: u-boot

At present there are separate code paths for livetree and flattree in
places where they can be made common. Also there are a few functions
that support flattree but can be moved over to use the livetree API (i.e.
ofnode instead of a DT offset).

This series tidies up these areas.


Simon Glass (11):
  dm: core: Rename device_bind() to device_bind_offset()
  dm: core: Rename device_bind_ofnode() to device_bind()
  dm: core: Add a livetree function to check node status
  dm: Remove uses of device_bind_offset()
  dm: Drop uses of dev_set_of_offset()
  dm: core: Drop dev_set_of_offset()
  dm: core: Drop device_bind_offset()
  dm: core: Add an ofnode function to get the devicetree root
  dm: core: Combine the flattree and livetree binding code
  dm: core: Drop unused parameter from dm_scan_fdt()
  dm: core: Drop unused parameter from dm_extended_scan_fdt()

 drivers/clk/at91/compat.c                   | 20 ++---
 drivers/clk/clk.c                           |  2 +-
 drivers/core/device.c                       | 10 +--
 drivers/core/ofnode.c                       | 10 +++
 drivers/core/root.c                         | 97 ++++++---------------
 drivers/firmware/scmi/scmi_agent-uclass.c   |  4 +-
 drivers/gpio/dwapb_gpio.c                   |  4 +-
 drivers/gpio/mt7621_gpio.c                  |  5 +-
 drivers/gpio/s5p_gpio.c                     |  6 +-
 drivers/gpio/sunxi_gpio.c                   |  5 +-
 drivers/gpio/tegra186_gpio.c                |  3 +-
 drivers/gpio/tegra_gpio.c                   |  4 +-
 drivers/misc/i2c_eeprom.c                   |  4 +-
 drivers/mtd/spi/sandbox.c                   |  2 +-
 drivers/net/mvpp2.c                         |  4 +-
 drivers/pci/pci-uclass.c                    |  4 +-
 drivers/pci/pci_mvebu.c                     |  4 +-
 drivers/pinctrl/broadcom/pinctrl-bcm283x.c  |  2 +-
 drivers/pinctrl/meson/pinctrl-meson.c       |  5 +-
 drivers/pinctrl/mscc/pinctrl-jr2.c          |  2 +-
 drivers/pinctrl/mscc/pinctrl-luton.c        |  2 +-
 drivers/pinctrl/mscc/pinctrl-ocelot.c       |  2 +-
 drivers/pinctrl/mscc/pinctrl-serval.c       |  2 +-
 drivers/pinctrl/mscc/pinctrl-servalt.c      |  2 +-
 drivers/pinctrl/mvebu/pinctrl-armada-37xx.c |  8 +-
 drivers/usb/host/usb-uclass.c               |  4 +-
 include/dm/device-internal.h                | 10 +--
 include/dm/device.h                         |  5 --
 include/dm/ofnode.h                         | 23 +++++
 include/dm/root.h                           |  8 +-
 test/dm/core.c                              |  6 +-
 test/dm/ofnode.c                            | 12 +++
 test/dm/test-fdt.c                          |  4 +-
 test/dm/test-main.c                         |  4 +-
 34 files changed, 130 insertions(+), 159 deletions(-)

-- 
2.29.2.454.gaff20da3a2-goog

^ permalink raw reply	[flat|nested] 35+ messages in thread

end of thread, other threads:[~2021-02-01 12:14 UTC | newest]

Thread overview: 35+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-11-29  0:49 [PATCH 00/11] dm: Simplify livetree handling Simon Glass
2020-11-29  0:50 ` [PATCH 01/11] dm: core: Rename device_bind() to device_bind_offset() Simon Glass
2020-11-29  0:50 ` [PATCH 02/11] dm: core: Rename device_bind_ofnode() to device_bind() Simon Glass
2020-11-29  0:50 ` [PATCH 03/11] dm: core: Add a livetree function to check node status Simon Glass
2020-11-29  0:50 ` [PATCH 04/11] dm: Remove uses of device_bind_offset() Simon Glass
2020-11-29  0:50 ` [PATCH 05/11] dm: Drop uses of dev_set_of_offset() Simon Glass
2020-11-29  0:50 ` [PATCH 06/11] dm: core: Drop dev_set_of_offset() Simon Glass
2020-11-29  0:50 ` [PATCH 07/11] dm: core: Drop device_bind_offset() Simon Glass
2020-11-29  0:50 ` [PATCH 08/11] dm: core: Add an ofnode function to get the devicetree root Simon Glass
2020-11-29  0:50 ` [PATCH 09/11] dm: core: Combine the flattree and livetree binding code Simon Glass
2020-11-29  0:50 ` [PATCH 10/11] dm: core: Drop unused parameter from dm_scan_fdt() Simon Glass
2020-11-29  0:50 ` [PATCH 11/11] dm: core: Drop unused parameter from dm_extended_scan_fdt() Simon Glass
2020-12-10  0:26 ` Simon Glass
2020-12-10  0:26 ` [PATCH 10/11] dm: core: Drop unused parameter from dm_scan_fdt() Simon Glass
2020-12-10  0:26 ` [PATCH 09/11] dm: core: Combine the flattree and livetree binding code Simon Glass
2020-12-10  0:26 ` [PATCH 08/11] dm: core: Add an ofnode function to get the devicetree root Simon Glass
2020-12-10  0:26 ` [PATCH 07/11] dm: core: Drop device_bind_offset() Simon Glass
2020-12-10  0:26 ` [PATCH 06/11] dm: core: Drop dev_set_of_offset() Simon Glass
2020-12-10  0:26 ` [PATCH 05/11] dm: Drop uses of dev_set_of_offset() Simon Glass
2020-12-10  0:26   ` Simon Glass
2020-12-10  0:26 ` [PATCH 04/11] dm: Remove uses of device_bind_offset() Simon Glass
2020-12-10  0:26   ` Simon Glass
2021-01-31  9:18   ` Eugen.Hristev at microchip.com
2021-01-31  9:18     ` Eugen.Hristev
2021-01-31 15:37     ` Simon Glass
2021-01-31 15:37       ` Simon Glass
2021-02-01  8:13       ` Eugen.Hristev at microchip.com
2021-02-01  8:13         ` Eugen.Hristev
2021-02-01 12:02         ` Simon Glass
2021-02-01 12:02           ` Simon Glass
2021-02-01 12:14           ` Eugen.Hristev at microchip.com
2020-12-10  0:26 ` [PATCH 03/11] dm: core: Add a livetree function to check node status Simon Glass
2020-12-10  0:26 ` [PATCH 02/11] dm: core: Rename device_bind_ofnode() to device_bind() Simon Glass
2020-12-10  0:26 ` [PATCH 01/11] dm: core: Rename device_bind() to device_bind_offset() Simon Glass
2020-12-10  0:26   ` Simon Glass

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.