All of lore.kernel.org
 help / color / mirror / Atom feed
* [libgpiod][PATCH v2 0/7] treewide: remove more cruft and add some improvements
@ 2021-01-15 10:30 Bartosz Golaszewski
  2021-01-15 10:30 ` [libgpiod][PATCH v2 1/7] treewide: remove helpers for opening chips by name & number Bartosz Golaszewski
                   ` (7 more replies)
  0 siblings, 8 replies; 14+ messages in thread
From: Bartosz Golaszewski @ 2021-01-15 10:30 UTC (permalink / raw)
  To: Kent Gibson, Andy Shevchenko, Linus Walleij
  Cc: linux-gpio, Bartosz Golaszewski

From: Bartosz Golaszewski <bgolaszewski@baylibre.com>

This is another batch of improvements to libgpiod before we overhaul the
data structure model.

The last patch adds the kernel uapi header to the repository so that we
no longer depend on its presence on the host system.

v1 -> v2:
- rename BIAS_NONE to BIAS_UNKNOWN
- rename DRIVE_NONE to DRIVE_PUSH_PULL
- rename BIAS_DISABLE to BIAS_DISABLED

Bartosz Golaszewski (7):
  treewide: remove helpers for opening chips by name & number
  treewide: simplify the active-low line property
  treewide: rename BIAS_AS_IS to BIAS_UNKNOWN
  treewide: rename BIAS_DISABLE to BIAS_DISABLED
  treewide: make drive settings an enum
  bindings: cxx: line: reorder bias mapping entries
  core: add the kernel uapi header to the repository

 bindings/cxx/chip.cpp                  |  41 +-
 bindings/cxx/examples/gpioinfocxx.cpp  |   3 +-
 bindings/cxx/gpiod.hpp                 |  61 +--
 bindings/cxx/line.cpp                  |  28 +-
 bindings/cxx/line_bulk.cpp             |   4 +-
 bindings/cxx/tests/tests-chip.cpp      |  97 +----
 bindings/cxx/tests/tests-event.cpp     |  14 +-
 bindings/cxx/tests/tests-iter.cpp      |   2 +-
 bindings/cxx/tests/tests-line.cpp      |  97 ++---
 bindings/python/examples/gpioinfo.py   |   4 +-
 bindings/python/gpiodmodule.c          | 187 +++------
 bindings/python/tests/gpiod_py_test.py | 177 ++++-----
 configure.ac                           |  12 +-
 include/gpiod.h                        |  69 +---
 lib/Makefile.am                        |   2 +-
 lib/core.c                             |  35 +-
 lib/helpers.c                          |  57 ---
 lib/uapi/gpio.h                        | 522 +++++++++++++++++++++++++
 tests/tests-chip.c                     |  41 --
 tests/tests-event.c                    |   2 +-
 tests/tests-line.c                     | 110 +++---
 tools/gpiodetect.c                     |   2 +-
 tools/gpiofind.c                       |   2 +-
 tools/gpioget.c                        |   2 +-
 tools/gpioinfo.c                       |  30 +-
 tools/gpiomon.c                        |   2 +-
 tools/gpioset.c                        |   2 +-
 tools/tools-common.c                   |  59 ++-
 tools/tools-common.h                   |   3 +
 29 files changed, 934 insertions(+), 733 deletions(-)
 create mode 100644 lib/uapi/gpio.h

-- 
2.29.1


^ permalink raw reply	[flat|nested] 14+ messages in thread

end of thread, other threads:[~2021-01-19  0:28 UTC | newest]

Thread overview: 14+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-01-15 10:30 [libgpiod][PATCH v2 0/7] treewide: remove more cruft and add some improvements Bartosz Golaszewski
2021-01-15 10:30 ` [libgpiod][PATCH v2 1/7] treewide: remove helpers for opening chips by name & number Bartosz Golaszewski
2021-01-15 10:30 ` [libgpiod][PATCH v2 2/7] treewide: simplify the active-low line property Bartosz Golaszewski
2021-01-15 10:30 ` [libgpiod][PATCH v2 3/7] treewide: rename BIAS_AS_IS to BIAS_UNKNOWN Bartosz Golaszewski
2021-01-18  0:07   ` Kent Gibson
2021-01-18 11:40     ` Bartosz Golaszewski
2021-01-19  0:27       ` Kent Gibson
2021-01-15 10:30 ` [libgpiod][PATCH v2 4/7] treewide: rename BIAS_DISABLE to BIAS_DISABLED Bartosz Golaszewski
2021-01-15 10:30 ` [libgpiod][PATCH v2 5/7] treewide: make drive settings an enum Bartosz Golaszewski
2021-01-15 10:30 ` [libgpiod][PATCH v2 6/7] bindings: cxx: line: reorder bias mapping entries Bartosz Golaszewski
2021-01-15 10:30 ` [libgpiod][PATCH v2 7/7] core: add the kernel uapi header to the repository Bartosz Golaszewski
2021-01-18  0:22   ` Kent Gibson
2021-01-18  9:57     ` Bartosz Golaszewski
2021-01-18  1:01 ` [libgpiod][PATCH v2 0/7] treewide: remove more cruft and add some improvements Kent Gibson

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.