All of lore.kernel.org
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@lst.de>
To: Shiyang Ruan <ruansy.fnst@cn.fujitsu.com>
Cc: linux-kernel@vger.kernel.org, linux-xfs@vger.kernel.org,
	linux-nvdimm@lists.01.org, linux-mm@kvack.org,
	linux-fsdevel@vger.kernel.org, dm-devel@redhat.com,
	darrick.wong@oracle.com, david@fromorbit.com, hch@lst.de,
	agk@redhat.com, snitzer@redhat.com, rgoldwyn@suse.de,
	qi.fuli@fujitsu.com, y-goto@fujitsu.com
Subject: Re: [PATCH v3 06/11] mm, pmem: Implement ->memory_failure() in pmem driver
Date: Wed, 10 Feb 2021 14:41:00 +0100	[thread overview]
Message-ID: <20210210134100.GE30109@lst.de> (raw)
In-Reply-To: <20210208105530.3072869-7-ruansy.fnst@cn.fujitsu.com>

> +static int pmem_pagemap_memory_failure(struct dev_pagemap *pgmap,
> +		unsigned long pfn, int flags)
> +{
> +	struct pmem_device *pdev;
> +	struct gendisk *disk;
> +	loff_t disk_offset;
> +	int rc = 0;
> +	unsigned long size = page_size(pfn_to_page(pfn));
> +
> +	pdev = container_of(pgmap, struct pmem_device, pgmap);
> +	disk = pdev->disk;

Would be nice to initialize this at the time of declaration:

	struct pmem_device *pdev =
		container_of(pgmap, struct pmem_device, pgmap);
	struct gendisk *disk = pdev->disk
	unsigned long size = page_size(pfn_to_page(pfn));

> +	if (!disk)
> +		return -ENXIO;
> +
> +	disk_offset = PFN_PHYS(pfn) - pdev->phys_addr - pdev->data_offset;
> +	if (disk->fops->corrupted_range) {
> +		rc = disk->fops->corrupted_range(disk, NULL, disk_offset,
> +						 size, &flags);
> +		if (rc == -ENODEV)
> +			rc = -ENXIO;
> +	} else
> +		rc = -EOPNOTSUPP;

Why do we need the disk and fops check here? A pgmap registered by pmem.c
should always have a disk with pmem_fops.  And more importantly this
has no business going through the block layer.

Instead the file system should deposit a callback when starting to use
the dax_device using fs_dax_get_by_bdev / dax_get_by_host and a private
data (the superblock), and we avoid all the lookup problems.

> +int mf_generic_kill_procs(unsigned long long pfn, int flags)

This function seems to be only used inside of memory-failure.c, so it
could be marked static.  Also I'd name it dax_generic_memory_failure
or something like that to match the naming of the ->memory_failure
pgmap operation.

Also maybe just splitting this out into a helper would be a nice prep
patch.
_______________________________________________
Linux-nvdimm mailing list -- linux-nvdimm@lists.01.org
To unsubscribe send an email to linux-nvdimm-leave@lists.01.org

WARNING: multiple messages have this Message-ID (diff)
From: Christoph Hellwig <hch@lst.de>
To: Shiyang Ruan <ruansy.fnst@cn.fujitsu.com>
Cc: linux-kernel@vger.kernel.org, linux-xfs@vger.kernel.org,
	linux-nvdimm@lists.01.org, linux-mm@kvack.org,
	linux-fsdevel@vger.kernel.org, dm-devel@redhat.com,
	darrick.wong@oracle.com, dan.j.williams@intel.com,
	david@fromorbit.com, hch@lst.de, agk@redhat.com,
	snitzer@redhat.com, rgoldwyn@suse.de, qi.fuli@fujitsu.com,
	y-goto@fujitsu.com
Subject: Re: [PATCH v3 06/11] mm, pmem: Implement ->memory_failure() in pmem driver
Date: Wed, 10 Feb 2021 14:41:00 +0100	[thread overview]
Message-ID: <20210210134100.GE30109@lst.de> (raw)
In-Reply-To: <20210208105530.3072869-7-ruansy.fnst@cn.fujitsu.com>

> +static int pmem_pagemap_memory_failure(struct dev_pagemap *pgmap,
> +		unsigned long pfn, int flags)
> +{
> +	struct pmem_device *pdev;
> +	struct gendisk *disk;
> +	loff_t disk_offset;
> +	int rc = 0;
> +	unsigned long size = page_size(pfn_to_page(pfn));
> +
> +	pdev = container_of(pgmap, struct pmem_device, pgmap);
> +	disk = pdev->disk;

Would be nice to initialize this at the time of declaration:

	struct pmem_device *pdev =
		container_of(pgmap, struct pmem_device, pgmap);
	struct gendisk *disk = pdev->disk
	unsigned long size = page_size(pfn_to_page(pfn));

> +	if (!disk)
> +		return -ENXIO;
> +
> +	disk_offset = PFN_PHYS(pfn) - pdev->phys_addr - pdev->data_offset;
> +	if (disk->fops->corrupted_range) {
> +		rc = disk->fops->corrupted_range(disk, NULL, disk_offset,
> +						 size, &flags);
> +		if (rc == -ENODEV)
> +			rc = -ENXIO;
> +	} else
> +		rc = -EOPNOTSUPP;

Why do we need the disk and fops check here? A pgmap registered by pmem.c
should always have a disk with pmem_fops.  And more importantly this
has no business going through the block layer.

Instead the file system should deposit a callback when starting to use
the dax_device using fs_dax_get_by_bdev / dax_get_by_host and a private
data (the superblock), and we avoid all the lookup problems.

> +int mf_generic_kill_procs(unsigned long long pfn, int flags)

This function seems to be only used inside of memory-failure.c, so it
could be marked static.  Also I'd name it dax_generic_memory_failure
or something like that to match the naming of the ->memory_failure
pgmap operation.

Also maybe just splitting this out into a helper would be a nice prep
patch.

WARNING: multiple messages have this Message-ID (diff)
From: Christoph Hellwig <hch@lst.de>
To: Shiyang Ruan <ruansy.fnst@cn.fujitsu.com>
Cc: y-goto@fujitsu.com, qi.fuli@fujitsu.com, snitzer@redhat.com,
	linux-nvdimm@lists.01.org, rgoldwyn@suse.de,
	darrick.wong@oracle.com, david@fromorbit.com,
	linux-kernel@vger.kernel.org, linux-xfs@vger.kernel.org,
	linux-mm@kvack.org, dm-devel@redhat.com,
	linux-fsdevel@vger.kernel.org, dan.j.williams@intel.com,
	hch@lst.de, agk@redhat.com
Subject: Re: [dm-devel] [PATCH v3 06/11] mm, pmem: Implement ->memory_failure() in pmem driver
Date: Wed, 10 Feb 2021 14:41:00 +0100	[thread overview]
Message-ID: <20210210134100.GE30109@lst.de> (raw)
In-Reply-To: <20210208105530.3072869-7-ruansy.fnst@cn.fujitsu.com>

> +static int pmem_pagemap_memory_failure(struct dev_pagemap *pgmap,
> +		unsigned long pfn, int flags)
> +{
> +	struct pmem_device *pdev;
> +	struct gendisk *disk;
> +	loff_t disk_offset;
> +	int rc = 0;
> +	unsigned long size = page_size(pfn_to_page(pfn));
> +
> +	pdev = container_of(pgmap, struct pmem_device, pgmap);
> +	disk = pdev->disk;

Would be nice to initialize this at the time of declaration:

	struct pmem_device *pdev =
		container_of(pgmap, struct pmem_device, pgmap);
	struct gendisk *disk = pdev->disk
	unsigned long size = page_size(pfn_to_page(pfn));

> +	if (!disk)
> +		return -ENXIO;
> +
> +	disk_offset = PFN_PHYS(pfn) - pdev->phys_addr - pdev->data_offset;
> +	if (disk->fops->corrupted_range) {
> +		rc = disk->fops->corrupted_range(disk, NULL, disk_offset,
> +						 size, &flags);
> +		if (rc == -ENODEV)
> +			rc = -ENXIO;
> +	} else
> +		rc = -EOPNOTSUPP;

Why do we need the disk and fops check here? A pgmap registered by pmem.c
should always have a disk with pmem_fops.  And more importantly this
has no business going through the block layer.

Instead the file system should deposit a callback when starting to use
the dax_device using fs_dax_get_by_bdev / dax_get_by_host and a private
data (the superblock), and we avoid all the lookup problems.

> +int mf_generic_kill_procs(unsigned long long pfn, int flags)

This function seems to be only used inside of memory-failure.c, so it
could be marked static.  Also I'd name it dax_generic_memory_failure
or something like that to match the naming of the ->memory_failure
pgmap operation.

Also maybe just splitting this out into a helper would be a nice prep
patch.

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel


  reply	other threads:[~2021-02-10 13:41 UTC|newest]

Thread overview: 117+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-02-08 10:55 [PATCH v3 00/11] fsdax: introduce fs query to support reflink Shiyang Ruan
2021-02-08 10:55 ` [dm-devel] " Shiyang Ruan
2021-02-08 10:55 ` Shiyang Ruan
2021-02-08 10:55 ` [PATCH v3 01/11] pagemap: Introduce ->memory_failure() Shiyang Ruan
2021-02-08 10:55   ` [dm-devel] " Shiyang Ruan
2021-02-08 10:55   ` Shiyang Ruan
2021-02-10 13:20   ` Christoph Hellwig
2021-02-10 13:20     ` [dm-devel] " Christoph Hellwig
2021-02-10 13:20     ` Christoph Hellwig
2021-03-06 20:36   ` Dan Williams
2021-03-06 20:36     ` [dm-devel] " Dan Williams
2021-03-06 20:36     ` Dan Williams
2021-03-06 20:36     ` Dan Williams
2021-03-08  3:38     ` ruansy.fnst
2021-03-08  3:38       ` [dm-devel] " ruansy.fnst
2021-03-08  3:38       ` ruansy.fnst
2021-03-08  5:23       ` Dan Williams
2021-03-08  5:23         ` [dm-devel] " Dan Williams
2021-03-08  5:23         ` Dan Williams
2021-03-08  5:23         ` Dan Williams
2021-03-08 11:34         ` ruansy.fnst
2021-03-08 11:34           ` [dm-devel] " ruansy.fnst
2021-03-08 11:34           ` ruansy.fnst
2021-03-08 18:01           ` Dan Williams
2021-03-08 18:01             ` [dm-devel] " Dan Williams
2021-03-08 18:01             ` Dan Williams
2021-03-08 18:01             ` Dan Williams
2021-03-12 10:18             ` ruansy.fnst
2021-03-12 10:18               ` [dm-devel] " ruansy.fnst
2021-03-12 10:18               ` ruansy.fnst
2021-03-19  2:17               ` ruansy.fnst
2021-03-19  2:17                 ` [dm-devel] " ruansy.fnst
2021-03-19  2:17                 ` ruansy.fnst
2021-03-24  2:19                 ` Dan Williams
2021-03-24  2:19                   ` [dm-devel] " Dan Williams
2021-03-24  2:19                   ` Dan Williams
2021-03-24  2:19                   ` Dan Williams
2021-03-24  7:47                   ` Christoph Hellwig
2021-03-24  7:47                     ` [dm-devel] " Christoph Hellwig
2021-03-24  7:47                     ` Christoph Hellwig
2021-03-24 16:37                     ` Dan Williams
2021-03-24 16:37                       ` [dm-devel] " Dan Williams
2021-03-24 16:37                       ` Dan Williams
2021-03-24 16:37                       ` Dan Williams
2021-03-24 17:39                       ` Christoph Hellwig
2021-03-24 17:39                         ` [dm-devel] " Christoph Hellwig
2021-03-24 17:39                         ` Christoph Hellwig
2021-03-24 18:00                         ` Dan Williams
2021-03-24 18:00                           ` [dm-devel] " Dan Williams
2021-03-24 18:00                           ` Dan Williams
2021-03-24 18:00                           ` Dan Williams
2021-02-08 10:55 ` [PATCH v3 02/11] blk: Introduce ->corrupted_range() for block device Shiyang Ruan
2021-02-08 10:55   ` [dm-devel] " Shiyang Ruan
2021-02-08 10:55   ` Shiyang Ruan
2021-02-10 13:21   ` Christoph Hellwig
2021-02-10 13:21     ` [dm-devel] " Christoph Hellwig
2021-02-10 13:21     ` Christoph Hellwig
2021-03-04 22:42     ` Darrick J. Wong
2021-03-04 22:42       ` [dm-devel] " Darrick J. Wong
2021-03-04 22:42       ` Darrick J. Wong
2021-03-05  6:10       ` Christoph Hellwig
2021-03-05  6:10         ` [dm-devel] " Christoph Hellwig
2021-03-05  6:10         ` Christoph Hellwig
2021-02-08 10:55 ` [PATCH v3 03/11] fs: Introduce ->corrupted_range() for superblock Shiyang Ruan
2021-02-08 10:55   ` [dm-devel] " Shiyang Ruan
2021-02-08 10:55   ` Shiyang Ruan
2021-02-08 10:55 ` [PATCH v3 04/11] block_dev: Introduce bd_corrupted_range() for block device Shiyang Ruan
2021-02-08 10:55   ` [dm-devel] " Shiyang Ruan
2021-02-08 10:55   ` Shiyang Ruan
2021-02-08 10:55 ` [PATCH v3 05/11] mm, fsdax: Refactor memory-failure handler for dax mapping Shiyang Ruan
2021-02-08 10:55   ` [dm-devel] " Shiyang Ruan
2021-02-08 10:55   ` Shiyang Ruan
2021-02-10 13:33   ` Christoph Hellwig
2021-02-10 13:33     ` [dm-devel] " Christoph Hellwig
2021-02-10 13:33     ` Christoph Hellwig
2021-02-17  2:56     ` Ruan Shiyang
2021-02-17  2:56       ` [dm-devel] " Ruan Shiyang
2021-02-17  2:56       ` Ruan Shiyang
2021-02-18  8:32       ` Christoph Hellwig
2021-02-18  8:32         ` [dm-devel] " Christoph Hellwig
2021-02-18  8:32         ` Christoph Hellwig
2021-02-18  8:59         ` Ruan Shiyang
2021-02-18  8:59           ` [dm-devel] " Ruan Shiyang
2021-02-18  8:59           ` Ruan Shiyang
2021-03-16  3:21   ` zhong jiang
2021-03-16  3:21     ` [dm-devel] " zhong jiang
2021-03-16  3:21     ` zhong jiang
2021-03-17  3:46     ` ruansy.fnst
2021-03-17  3:46       ` [dm-devel] " ruansy.fnst
2021-03-17  3:46       ` ruansy.fnst
2021-02-08 10:55 ` [PATCH v3 06/11] mm, pmem: Implement ->memory_failure() in pmem driver Shiyang Ruan
2021-02-08 10:55   ` [dm-devel] " Shiyang Ruan
2021-02-08 10:55   ` Shiyang Ruan
2021-02-10 13:41   ` Christoph Hellwig [this message]
2021-02-10 13:41     ` [dm-devel] " Christoph Hellwig
2021-02-10 13:41     ` Christoph Hellwig
2021-02-08 10:55 ` [PATCH v3 07/11] pmem: Implement ->corrupted_range() for " Shiyang Ruan
2021-02-08 10:55   ` [dm-devel] " Shiyang Ruan
2021-02-08 10:55   ` Shiyang Ruan
2021-02-08 10:55 ` [PATCH v3 08/11] dm: Introduce ->rmap() to find bdev offset Shiyang Ruan
2021-02-08 10:55   ` [dm-devel] " Shiyang Ruan
2021-02-08 10:55   ` Shiyang Ruan
2021-02-08 10:55 ` [PATCH v3 09/11] md: Implement ->corrupted_range() Shiyang Ruan
2021-02-08 10:55   ` [dm-devel] " Shiyang Ruan
2021-02-08 10:55   ` Shiyang Ruan
2021-02-08 10:55 ` [PATCH v3 10/11] xfs: Implement ->corrupted_range() for XFS Shiyang Ruan
2021-02-08 10:55   ` [dm-devel] " Shiyang Ruan
2021-02-08 10:55   ` Shiyang Ruan
2021-02-10 13:44   ` Christoph Hellwig
2021-02-10 13:44     ` [dm-devel] " Christoph Hellwig
2021-02-10 13:44     ` Christoph Hellwig
2021-02-08 10:55 ` [PATCH v3 11/11] fs/dax: Remove useless functions Shiyang Ruan
2021-02-08 10:55   ` [dm-devel] " Shiyang Ruan
2021-02-08 10:55   ` Shiyang Ruan
2021-02-10 13:09   ` Christoph Hellwig
2021-02-10 13:09     ` [dm-devel] " Christoph Hellwig
2021-02-10 13:09     ` Christoph Hellwig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210210134100.GE30109@lst.de \
    --to=hch@lst.de \
    --cc=agk@redhat.com \
    --cc=darrick.wong@oracle.com \
    --cc=david@fromorbit.com \
    --cc=dm-devel@redhat.com \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-nvdimm@lists.01.org \
    --cc=linux-xfs@vger.kernel.org \
    --cc=qi.fuli@fujitsu.com \
    --cc=rgoldwyn@suse.de \
    --cc=ruansy.fnst@cn.fujitsu.com \
    --cc=snitzer@redhat.com \
    --cc=y-goto@fujitsu.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.