All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2 0/6] Rationalise __alloc_pages wrappers
@ 2021-02-15 21:01 Matthew Wilcox (Oracle)
  2021-02-15 21:01 ` [PATCH v2 1/6] mm/page_alloc: Rename alloc_mask to alloc_gfp Matthew Wilcox (Oracle)
                   ` (5 more replies)
  0 siblings, 6 replies; 12+ messages in thread
From: Matthew Wilcox (Oracle) @ 2021-02-15 21:01 UTC (permalink / raw)
  To: Andrew Morton; +Cc: Matthew Wilcox (Oracle), linux-mm, Mike Rapoport

I was poking around the __alloc_pages variants trying to understand
why they each exist, and couldn't really find a good justification for
keeping __alloc_pages and __alloc_pages_nodemask as separate functions.
That led to getting rid of alloc_pages_current() and then I noticed the
documentation was bad, and then I noticed it wasn't included at all ...
anyway, this is all cleanups & doc fixes.

v2:
 - Added acks from Vlastimil (patches 2-4) & Michel (patches 3-4)
 - Added patches 1, 5 and 6

Matthew Wilcox (Oracle) (6):
  mm/page_alloc: Rename alloc_mask to alloc_gfp
  mm/page_alloc: Rename gfp_mask to gfp
  mm/page_alloc: Combine __alloc_pages and __alloc_pages_nodemask
  mm/mempolicy: Rename alloc_pages_current to alloc_pages
  mm/mempolicy: Rewrite alloc_pages documentation
  mm/mempolicy: Fix mpol_misplaced kernel-doc

 Documentation/admin-guide/mm/transhuge.rst |  2 +-
 Documentation/core-api/mm-api.rst          |  1 +
 include/linux/gfp.h                        | 21 +++--------
 mm/hugetlb.c                               |  2 +-
 mm/internal.h                              |  4 +--
 mm/mempolicy.c                             | 42 ++++++++++------------
 mm/migrate.c                               |  2 +-
 mm/page_alloc.c                            | 34 +++++++++---------
 8 files changed, 46 insertions(+), 62 deletions(-)

-- 
2.29.2



^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2021-02-16  8:22 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-02-15 21:01 [PATCH v2 0/6] Rationalise __alloc_pages wrappers Matthew Wilcox (Oracle)
2021-02-15 21:01 ` [PATCH v2 1/6] mm/page_alloc: Rename alloc_mask to alloc_gfp Matthew Wilcox (Oracle)
2021-02-15 21:01 ` [PATCH v2 2/6] mm/page_alloc: Rename gfp_mask to gfp Matthew Wilcox (Oracle)
2021-02-15 21:02 ` [PATCH v2 3/6] mm/page_alloc: Combine __alloc_pages and __alloc_pages_nodemask Matthew Wilcox (Oracle)
2021-02-15 21:02 ` [PATCH v2 4/6] mm/mempolicy: Rename alloc_pages_current to alloc_pages Matthew Wilcox (Oracle)
2021-02-15 21:02 ` [PATCH v2 5/6] mm/mempolicy: Rewrite alloc_pages documentation Matthew Wilcox (Oracle)
2021-02-15 21:47   ` Mike Rapoport
2021-02-15 22:32     ` Matthew Wilcox
2021-02-16  5:37       ` Mike Rapoport
2021-02-16  8:22   ` Michal Hocko
2021-02-15 21:02 ` [PATCH v2 6/6] mm/mempolicy: Fix mpol_misplaced kernel-doc Matthew Wilcox (Oracle)
2021-02-15 21:51   ` Mike Rapoport

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.