All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/4] Couple of misc patches
@ 2021-02-17 13:12 Nikolay Borisov
  2021-02-17 13:12 ` [PATCH 1/4] btrfs: Make btrfs_replace_file_extents take btrfs_inode Nikolay Borisov
                   ` (4 more replies)
  0 siblings, 5 replies; 6+ messages in thread
From: Nikolay Borisov @ 2021-02-17 13:12 UTC (permalink / raw)
  To: linux-btrfs; +Cc: Nikolay Borisov

Here are 4 patches which are independent of one another. The first 2 just
change two more function to take btrfs_inode. Patch 3 just extends the usage of
in_range which renders offset_in_entry redundant thus removing the function.
Final patch just restructures btrfs_inc_block_group_ro to use a do{} while() loo
rather than a label-based. This doesn't introduce extra nesting so I don't know
why the label approach was chosen in the first place.

Nikolay Borisov (4):
  btrfs: Make btrfs_replace_file_extents take btrfs_inode
  btrfs: Make find_desired_extent take btrfs_inode
  btrfs: Replace offset_in_entry with in_range
  btrfs: Replace opencoded while loop with proper construct

 fs/btrfs/block-group.c  | 42 ++++++++++++++------------
 fs/btrfs/ctree.h        |  5 ++--
 fs/btrfs/file.c         | 66 ++++++++++++++++++++---------------------
 fs/btrfs/inode.c        |  2 +-
 fs/btrfs/ordered-data.c | 19 +++---------
 fs/btrfs/reflink.c      | 10 +++----
 6 files changed, 68 insertions(+), 76 deletions(-)

--
2.25.1


^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2021-02-17 17:50 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-02-17 13:12 [PATCH 0/4] Couple of misc patches Nikolay Borisov
2021-02-17 13:12 ` [PATCH 1/4] btrfs: Make btrfs_replace_file_extents take btrfs_inode Nikolay Borisov
2021-02-17 13:12 ` [PATCH 2/4] btrfs: Make find_desired_extent " Nikolay Borisov
2021-02-17 13:12 ` [PATCH 3/4] btrfs: Replace offset_in_entry with in_range Nikolay Borisov
2021-02-17 13:12 ` [PATCH 4/4] btrfs: Replace opencoded while loop with proper construct Nikolay Borisov
2021-02-17 17:47 ` [PATCH 0/4] Couple of misc patches David Sterba

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.