All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH net-next v4 00/13] net: xps: improve the xps maps handling
@ 2021-03-18 18:37 Antoine Tenart
  2021-03-18 18:37 ` [PATCH net-next v4 01/13] net-sysfs: convert xps_cpus_show to bitmap_zalloc Antoine Tenart
                   ` (13 more replies)
  0 siblings, 14 replies; 15+ messages in thread
From: Antoine Tenart @ 2021-03-18 18:37 UTC (permalink / raw)
  To: davem, kuba, alexander.duyck; +Cc: Antoine Tenart, netdev

Hello,

This series aims at fixing various issues with the xps code, including
out-of-bound accesses and use-after-free. While doing so we try to
improve the xps code maintainability and readability.

The main change is moving dev->num_tc and dev->nr_ids in the xps maps, to
avoid out-of-bound accesses as those two fields can be updated after the
maps have been allocated. This allows further reworks, to improve the
xps code readability and allow to stop taking the rtnl lock when
reading the maps in sysfs. The maps are moved to an array in net_device,
which simplifies the code a lot.

One future improvement may be to remove the use of xps_map_mutex from
net/core/dev.c, but that may require extra care.

Thanks!
Antoine

Since v3:
  - Removed the 3 patches about the rtnl lock and __netif_set_xps_queue
    as there are extra issues. Those patches were not tied to the
    others, and I'll see want can be done as a separate effort.
  - One small fix in patch 12.

Since v2:
  - Patches 13-16 are new to the series.
  - Fixed another issue I found while preparing v3 (use after free of
    old xps maps).
  - Kept the rtnl lock when calling netdev_get_tx_queue and
    netdev_txq_to_tc.
  - Use get_device/put_device when using the sb_dev.
  - Take the rtnl lock in mlx5 and virtio_net when calling
    netif_set_xps_queue.
  - Fixed a coding style issue.

Since v1:
  - Reordered the patches to improve readability and avoid introducing
    issues in between patches.
  - Use dev_maps->nr_ids to allocate the mask in xps_queue_show but
    still default to nr_cpu_ids/dev->num_rx_queues in xps_queue_show
    when dev_maps hasn't been allocated yet for backward
    compatibility.:w


Antoine Tenart (13):
  net-sysfs: convert xps_cpus_show to bitmap_zalloc
  net-sysfs: store the return of get_netdev_queue_index in an unsigned
    int
  net-sysfs: make xps_cpus_show and xps_rxqs_show consistent
  net: embed num_tc in the xps maps
  net: embed nr_ids in the xps maps
  net: remove the xps possible_mask
  net: move the xps maps to an array
  net: add an helper to copy xps maps to the new dev_maps
  net: improve queue removal readability in __netif_set_xps_queue
  net-sysfs: move the rtnl unlock up in the xps show helpers
  net-sysfs: move the xps cpus/rxqs retrieval in a common function
  net: fix use after free in xps
  net: NULL the old xps map entries when freeing them

 drivers/net/virtio_net.c  |   2 +-
 include/linux/netdevice.h |  27 ++++-
 net/core/dev.c            | 247 ++++++++++++++++++++------------------
 net/core/net-sysfs.c      | 177 +++++++++++----------------
 4 files changed, 222 insertions(+), 231 deletions(-)

-- 
2.30.2


^ permalink raw reply	[flat|nested] 15+ messages in thread

end of thread, other threads:[~2021-03-18 23:11 UTC | newest]

Thread overview: 15+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-03-18 18:37 [PATCH net-next v4 00/13] net: xps: improve the xps maps handling Antoine Tenart
2021-03-18 18:37 ` [PATCH net-next v4 01/13] net-sysfs: convert xps_cpus_show to bitmap_zalloc Antoine Tenart
2021-03-18 18:37 ` [PATCH net-next v4 02/13] net-sysfs: store the return of get_netdev_queue_index in an unsigned int Antoine Tenart
2021-03-18 18:37 ` [PATCH net-next v4 03/13] net-sysfs: make xps_cpus_show and xps_rxqs_show consistent Antoine Tenart
2021-03-18 18:37 ` [PATCH net-next v4 04/13] net: embed num_tc in the xps maps Antoine Tenart
2021-03-18 18:37 ` [PATCH net-next v4 05/13] net: embed nr_ids " Antoine Tenart
2021-03-18 18:37 ` [PATCH net-next v4 06/13] net: remove the xps possible_mask Antoine Tenart
2021-03-18 18:37 ` [PATCH net-next v4 07/13] net: move the xps maps to an array Antoine Tenart
2021-03-18 18:37 ` [PATCH net-next v4 08/13] net: add an helper to copy xps maps to the new dev_maps Antoine Tenart
2021-03-18 18:37 ` [PATCH net-next v4 09/13] net: improve queue removal readability in __netif_set_xps_queue Antoine Tenart
2021-03-18 18:37 ` [PATCH net-next v4 10/13] net-sysfs: move the rtnl unlock up in the xps show helpers Antoine Tenart
2021-03-18 18:37 ` [PATCH net-next v4 11/13] net-sysfs: move the xps cpus/rxqs retrieval in a common function Antoine Tenart
2021-03-18 18:37 ` [PATCH net-next v4 12/13] net: fix use after free in xps Antoine Tenart
2021-03-18 18:37 ` [PATCH net-next v4 13/13] net: NULL the old xps map entries when freeing them Antoine Tenart
2021-03-18 23:10 ` [PATCH net-next v4 00/13] net: xps: improve the xps maps handling patchwork-bot+netdevbpf

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.