All of lore.kernel.org
 help / color / mirror / Atom feed
* [virtio-comment] [PATCH] Update VIRTIO_F_EVENT_IDX throughout
@ 2021-04-29 23:10 Joel Nider
  2021-04-30 11:27 ` Cornelia Huck
  0 siblings, 1 reply; 4+ messages in thread
From: Joel Nider @ 2021-04-29 23:10 UTC (permalink / raw)
  To: virtio-comment; +Cc: Joel Nider

This flag has been called by many names in the past
(VIRTIO_RING_F_EVENT_IDX, VIRTIO_F_RING_EVENT_IDX) and there are
just a few stragglers left to clean up.

Signed-off-by: Joel Nider <joel@nider.org>
---
 content.tex     | 2 +-
 packed-ring.tex | 4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/content.tex b/content.tex
index 9232d5c..5a803dc 100644
--- a/content.tex
+++ b/content.tex
@@ -6581,7 +6581,7 @@ \chapter{Reserved Feature Bits}\label{sec:Reserved Feature Bits}
 Descriptors}~\nameref{sec:Basic Facilities of a Virtio Device /
 Virtqueues / The Virtqueue Descriptor Table / Indirect
 Descriptors} and \ref{sec:Packed Virtqueues / Indirect Flag: Scatter-Gather Support}~\nameref{sec:Packed Virtqueues / Indirect Flag: Scatter-Gather Support}.
-  \item[VIRTIO_F_RING_EVENT_IDX(29)] This feature enables the \field{used_event}
+  \item[VIRTIO_F_EVENT_IDX(29)] This feature enables the \field{used_event}
   and the \field{avail_event} fields as described in
 \ref{sec:Basic Facilities of a Virtio Device / Virtqueues / Used Buffer Notification Suppression}, \ref{sec:Basic Facilities of a Virtio Device / Virtqueues / The Virtqueue Used Ring} and \ref{sec:Packed Virtqueues / Driver and Device Event Suppression}.
 
diff --git a/packed-ring.tex b/packed-ring.tex
index ea92543..a9e6c16 100644
--- a/packed-ring.tex
+++ b/packed-ring.tex
@@ -336,7 +336,7 @@ \subsection{Driver and Device Event Suppression}
 /*
  * Enable events for a specific descriptor
  * (as specified by Descriptor Ring Change Event Offset/Wrap Counter).
- * Only valid if VIRTIO_F_RING_EVENT_IDX has been negotiated.
+ * Only valid if VIRTIO_F_EVENT_IDX has been negotiated.
  */
 #define RING_EVENT_FLAGS_DESC 0x2
 /* The value 0x3 is reserved */
@@ -597,7 +597,7 @@ \subsubsection{Implementation Example}\label{sec:Basic Facilities of a Virtio De
 
 Below is a driver code example. It does not attempt to reduce
 the number of available buffer notifications, neither does it support
-the VIRTIO_F_RING_EVENT_IDX feature.
+the VIRTIO_F_EVENT_IDX feature.
 
 \begin{lstlisting}
 /* Note: vq->avail_wrap_count is initialized to 1 */
-- 
2.25.1


This publicly archived list offers a means to provide input to the
OASIS Virtual I/O Device (VIRTIO) TC.

In order to verify user consent to the Feedback License terms and
to minimize spam in the list archive, subscription is required
before posting.

Subscribe: virtio-comment-subscribe@lists.oasis-open.org
Unsubscribe: virtio-comment-unsubscribe@lists.oasis-open.org
List help: virtio-comment-help@lists.oasis-open.org
List archive: https://lists.oasis-open.org/archives/virtio-comment/
Feedback License: https://www.oasis-open.org/who/ipr/feedback_license.pdf
List Guidelines: https://www.oasis-open.org/policies-guidelines/mailing-lists
Committee: https://www.oasis-open.org/committees/virtio/
Join OASIS: https://www.oasis-open.org/join/


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [virtio-comment] [PATCH] Update VIRTIO_F_EVENT_IDX throughout
  2021-04-29 23:10 [virtio-comment] [PATCH] Update VIRTIO_F_EVENT_IDX throughout Joel Nider
@ 2021-04-30 11:27 ` Cornelia Huck
  2021-04-30 16:27   ` Joel Nider
  0 siblings, 1 reply; 4+ messages in thread
From: Cornelia Huck @ 2021-04-30 11:27 UTC (permalink / raw)
  To: Joel Nider; +Cc: virtio-comment

On Thu, 29 Apr 2021 16:10:16 -0700
Joel Nider <joel@nider.org> wrote:

> This flag has been called by many names in the past
> (VIRTIO_RING_F_EVENT_IDX, VIRTIO_F_RING_EVENT_IDX) and there are
> just a few stragglers left to clean up.
> 
> Signed-off-by: Joel Nider <joel@nider.org>
> ---
>  content.tex     | 2 +-
>  packed-ring.tex | 4 ++--
>  2 files changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/content.tex b/content.tex
> index 9232d5c..5a803dc 100644
> --- a/content.tex
> +++ b/content.tex
> @@ -6581,7 +6581,7 @@ \chapter{Reserved Feature Bits}\label{sec:Reserved Feature Bits}
>  Descriptors}~\nameref{sec:Basic Facilities of a Virtio Device /
>  Virtqueues / The Virtqueue Descriptor Table / Indirect
>  Descriptors} and \ref{sec:Packed Virtqueues / Indirect Flag: Scatter-Gather Support}~\nameref{sec:Packed Virtqueues / Indirect Flag: Scatter-Gather Support}.
> -  \item[VIRTIO_F_RING_EVENT_IDX(29)] This feature enables the \field{used_event}
> +  \item[VIRTIO_F_EVENT_IDX(29)] This feature enables the \field{used_event}

Hm. The VIRTIO_F_RING_ version actually matches well with
VIRTIO_F_RING_INDIRECT_DESC and VIRTIO_F_RING_PACKED. While the latter
is used consistently throughout the spec, we seem to use
VIRTIO_F_INDIRECT_DESC in other places. For added variety, Linux and
QEMU use VIRTIO_RING_F_INDIRECT_DESC and VIRTIO_RING_F_EVENT_IDX (but
VIRTIO_F_RING_PACKED.)

We should be consistent within the spec, so I'd vote for using the
VIRTIO_F_RING_ versions everywhere here. (The Linux/QEMU variants are
still easily recognizable, so there's actually not much potential for
confusion.) The only downside is that this would mean more changes.

Opinions?

>    and the \field{avail_event} fields as described in
>  \ref{sec:Basic Facilities of a Virtio Device / Virtqueues / Used Buffer Notification Suppression}, \ref{sec:Basic Facilities of a Virtio Device / Virtqueues / The Virtqueue Used Ring} and \ref{sec:Packed Virtqueues / Driver and Device Event Suppression}.
>  
> diff --git a/packed-ring.tex b/packed-ring.tex
> index ea92543..a9e6c16 100644
> --- a/packed-ring.tex
> +++ b/packed-ring.tex
> @@ -336,7 +336,7 @@ \subsection{Driver and Device Event Suppression}
>  /*
>   * Enable events for a specific descriptor
>   * (as specified by Descriptor Ring Change Event Offset/Wrap Counter).
> - * Only valid if VIRTIO_F_RING_EVENT_IDX has been negotiated.
> + * Only valid if VIRTIO_F_EVENT_IDX has been negotiated.
>   */
>  #define RING_EVENT_FLAGS_DESC 0x2
>  /* The value 0x3 is reserved */
> @@ -597,7 +597,7 @@ \subsubsection{Implementation Example}\label{sec:Basic Facilities of a Virtio De
>  
>  Below is a driver code example. It does not attempt to reduce
>  the number of available buffer notifications, neither does it support
> -the VIRTIO_F_RING_EVENT_IDX feature.
> +the VIRTIO_F_EVENT_IDX feature.
>  
>  \begin{lstlisting}
>  /* Note: vq->avail_wrap_count is initialized to 1 */


This publicly archived list offers a means to provide input to the
OASIS Virtual I/O Device (VIRTIO) TC.

In order to verify user consent to the Feedback License terms and
to minimize spam in the list archive, subscription is required
before posting.

Subscribe: virtio-comment-subscribe@lists.oasis-open.org
Unsubscribe: virtio-comment-unsubscribe@lists.oasis-open.org
List help: virtio-comment-help@lists.oasis-open.org
List archive: https://lists.oasis-open.org/archives/virtio-comment/
Feedback License: https://www.oasis-open.org/who/ipr/feedback_license.pdf
List Guidelines: https://www.oasis-open.org/policies-guidelines/mailing-lists
Committee: https://www.oasis-open.org/committees/virtio/
Join OASIS: https://www.oasis-open.org/join/


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [virtio-comment] [PATCH] Update VIRTIO_F_EVENT_IDX throughout
  2021-04-30 11:27 ` Cornelia Huck
@ 2021-04-30 16:27   ` Joel Nider
  2021-05-03 12:39     ` Cornelia Huck
  0 siblings, 1 reply; 4+ messages in thread
From: Joel Nider @ 2021-04-30 16:27 UTC (permalink / raw)
  To: Cornelia Huck; +Cc: virtio-comment


On 2021-04-30 4:27 a.m., Cornelia Huck wrote:
> On Thu, 29 Apr 2021 16:10:16 -0700
> Joel Nider <joel@nider.org> wrote:
>
>> This flag has been called by many names in the past
>> (VIRTIO_RING_F_EVENT_IDX, VIRTIO_F_RING_EVENT_IDX) and there are
>> just a few stragglers left to clean up.
>>
>> Signed-off-by: Joel Nider <joel@nider.org>
>> ---
>>   content.tex     | 2 +-
>>   packed-ring.tex | 4 ++--
>>   2 files changed, 3 insertions(+), 3 deletions(-)
>>
>> diff --git a/content.tex b/content.tex
>> index 9232d5c..5a803dc 100644
>> --- a/content.tex
>> +++ b/content.tex
>> @@ -6581,7 +6581,7 @@ \chapter{Reserved Feature Bits}\label{sec:Reserved Feature Bits}
>>   Descriptors}~\nameref{sec:Basic Facilities of a Virtio Device /
>>   Virtqueues / The Virtqueue Descriptor Table / Indirect
>>   Descriptors} and \ref{sec:Packed Virtqueues / Indirect Flag: Scatter-Gather Support}~\nameref{sec:Packed Virtqueues / Indirect Flag: Scatter-Gather Support}.
>> -  \item[VIRTIO_F_RING_EVENT_IDX(29)] This feature enables the \field{used_event}
>> +  \item[VIRTIO_F_EVENT_IDX(29)] This feature enables the \field{used_event}
> Hm. The VIRTIO_F_RING_ version actually matches well with
> VIRTIO_F_RING_INDIRECT_DESC and VIRTIO_F_RING_PACKED. While the latter
> is used consistently throughout the spec, we seem to use
> VIRTIO_F_INDIRECT_DESC in other places. For added variety, Linux and
> QEMU use VIRTIO_RING_F_INDIRECT_DESC and VIRTIO_RING_F_EVENT_IDX (but
> VIRTIO_F_RING_PACKED.)
Clearly all of these flags apply to the v-rings - I don't think 
including 'RING' to makes it any clearer. So in the interest of 
readability, I would opt for the shorter flag names (more likely to fit 
in a 80-char line). Linux (and the other OSes and hypervisors) will 
eventually fall in line, once the spec is consistent.
> We should be consistent within the spec, so I'd vote for using the
> VIRTIO_F_RING_ versions everywhere here. (The Linux/QEMU variants are
> still easily recognizable, so there's actually not much potential for
> confusion.) The only downside is that this would mean more changes.
I fully support being consistent everywhere in the spec - that is my 
primary concern. I noticed that over time, the flag name seems to be 
gravitating towards the VIRTIO_F_EVENT_IDX (all places in section 2 
already use this name), so that's why I just changed the last two places 
that are not consistent. Truly, I will be happy once they are all the 
same (one way or the other).
> Opinions?
>
>>     and the \field{avail_event} fields as described in
>>   \ref{sec:Basic Facilities of a Virtio Device / Virtqueues / Used Buffer Notification Suppression}, \ref{sec:Basic Facilities of a Virtio Device / Virtqueues / The Virtqueue Used Ring} and \ref{sec:Packed Virtqueues / Driver and Device Event Suppression}.
>>   
>> diff --git a/packed-ring.tex b/packed-ring.tex
>> index ea92543..a9e6c16 100644
>> --- a/packed-ring.tex
>> +++ b/packed-ring.tex
>> @@ -336,7 +336,7 @@ \subsection{Driver and Device Event Suppression}
>>   /*
>>    * Enable events for a specific descriptor
>>    * (as specified by Descriptor Ring Change Event Offset/Wrap Counter).
>> - * Only valid if VIRTIO_F_RING_EVENT_IDX has been negotiated.
>> + * Only valid if VIRTIO_F_EVENT_IDX has been negotiated.
>>    */
>>   #define RING_EVENT_FLAGS_DESC 0x2
>>   /* The value 0x3 is reserved */
>> @@ -597,7 +597,7 @@ \subsubsection{Implementation Example}\label{sec:Basic Facilities of a Virtio De
>>   
>>   Below is a driver code example. It does not attempt to reduce
>>   the number of available buffer notifications, neither does it support
>> -the VIRTIO_F_RING_EVENT_IDX feature.
>> +the VIRTIO_F_EVENT_IDX feature.
>>   
>>   \begin{lstlisting}
>>   /* Note: vq->avail_wrap_count is initialized to 1 */

This publicly archived list offers a means to provide input to the
OASIS Virtual I/O Device (VIRTIO) TC.

In order to verify user consent to the Feedback License terms and
to minimize spam in the list archive, subscription is required
before posting.

Subscribe: virtio-comment-subscribe@lists.oasis-open.org
Unsubscribe: virtio-comment-unsubscribe@lists.oasis-open.org
List help: virtio-comment-help@lists.oasis-open.org
List archive: https://lists.oasis-open.org/archives/virtio-comment/
Feedback License: https://www.oasis-open.org/who/ipr/feedback_license.pdf
List Guidelines: https://www.oasis-open.org/policies-guidelines/mailing-lists
Committee: https://www.oasis-open.org/committees/virtio/
Join OASIS: https://www.oasis-open.org/join/


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [virtio-comment] [PATCH] Update VIRTIO_F_EVENT_IDX throughout
  2021-04-30 16:27   ` Joel Nider
@ 2021-05-03 12:39     ` Cornelia Huck
  0 siblings, 0 replies; 4+ messages in thread
From: Cornelia Huck @ 2021-05-03 12:39 UTC (permalink / raw)
  To: Joel Nider; +Cc: virtio-comment

On Fri, 30 Apr 2021 09:27:55 -0700
Joel Nider <joel@nider.org> wrote:

> On 2021-04-30 4:27 a.m., Cornelia Huck wrote:
> > On Thu, 29 Apr 2021 16:10:16 -0700
> > Joel Nider <joel@nider.org> wrote:

> >> -  \item[VIRTIO_F_RING_EVENT_IDX(29)] This feature enables the \field{used_event}
> >> +  \item[VIRTIO_F_EVENT_IDX(29)] This feature enables the \field{used_event}  
> > Hm. The VIRTIO_F_RING_ version actually matches well with
> > VIRTIO_F_RING_INDIRECT_DESC and VIRTIO_F_RING_PACKED. While the latter
> > is used consistently throughout the spec, we seem to use
> > VIRTIO_F_INDIRECT_DESC in other places. For added variety, Linux and
> > QEMU use VIRTIO_RING_F_INDIRECT_DESC and VIRTIO_RING_F_EVENT_IDX (but
> > VIRTIO_F_RING_PACKED.)  
> Clearly all of these flags apply to the v-rings - I don't think 
> including 'RING' to makes it any clearer. So in the interest of 
> readability, I would opt for the shorter flag names (more likely to fit 
> in a 80-char line). Linux (and the other OSes and hypervisors) will 
> eventually fall in line, once the spec is consistent.

Not so sure about implementations changing their terms, but I don't
think it's of much consequence.

> > We should be consistent within the spec, so I'd vote for using the
> > VIRTIO_F_RING_ versions everywhere here. (The Linux/QEMU variants are
> > still easily recognizable, so there's actually not much potential for
> > confusion.) The only downside is that this would mean more changes.  
> I fully support being consistent everywhere in the spec - that is my 
> primary concern. I noticed that over time, the flag name seems to be 
> gravitating towards the VIRTIO_F_EVENT_IDX (all places in section 2 
> already use this name), so that's why I just changed the last two places 
> that are not consistent. Truly, I will be happy once they are all the 
> same (one way or the other).

I have no strong preference for keeping the 'RING' particle, the main
issue is consistency. In any case, we should also clean up
INDIRECT_DESC.


This publicly archived list offers a means to provide input to the
OASIS Virtual I/O Device (VIRTIO) TC.

In order to verify user consent to the Feedback License terms and
to minimize spam in the list archive, subscription is required
before posting.

Subscribe: virtio-comment-subscribe@lists.oasis-open.org
Unsubscribe: virtio-comment-unsubscribe@lists.oasis-open.org
List help: virtio-comment-help@lists.oasis-open.org
List archive: https://lists.oasis-open.org/archives/virtio-comment/
Feedback License: https://www.oasis-open.org/who/ipr/feedback_license.pdf
List Guidelines: https://www.oasis-open.org/policies-guidelines/mailing-lists
Committee: https://www.oasis-open.org/committees/virtio/
Join OASIS: https://www.oasis-open.org/join/


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2021-05-03 12:39 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-04-29 23:10 [virtio-comment] [PATCH] Update VIRTIO_F_EVENT_IDX throughout Joel Nider
2021-04-30 11:27 ` Cornelia Huck
2021-04-30 16:27   ` Joel Nider
2021-05-03 12:39     ` Cornelia Huck

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.