All of lore.kernel.org
 help / color / mirror / Atom feed
* [virtio-comment] [PATCH] Make global flag names consistent
@ 2021-05-04 18:21 Joel Nider
  2021-05-14  1:22 ` Joel Nider
  0 siblings, 1 reply; 4+ messages in thread
From: Joel Nider @ 2021-05-04 18:21 UTC (permalink / raw)
  To: virtio-comment; +Cc: Joel Nider

The global flags VIRTIO_F_EVENT_IDX and VIRTIO_F_INDIRECT_DESC
have inconsistent naming throughout the document. This change
removes the _RING designation from the flag names to make the
usage consistent.

Signed-off-by: Joel Nider <joel@nider.org>
---
 content.tex     | 4 ++--
 packed-ring.tex | 4 ++--
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/content.tex b/content.tex
index 9232d5c..c869cf4 100644
--- a/content.tex
+++ b/content.tex
@@ -6574,14 +6574,14 @@ \chapter{Reserved Feature Bits}\label{sec:Reserved Feature Bits}
 Currently these device-independent feature bits defined:
 
 \begin{description}
-  \item[VIRTIO_F_RING_INDIRECT_DESC (28)] Negotiating this feature indicates
+  \item[VIRTIO_F_INDIRECT_DESC (28)] Negotiating this feature indicates
   that the driver can use descriptors with the VIRTQ_DESC_F_INDIRECT
   flag set, as described in \ref{sec:Basic Facilities of a Virtio
 Device / Virtqueues / The Virtqueue Descriptor Table / Indirect
 Descriptors}~\nameref{sec:Basic Facilities of a Virtio Device /
 Virtqueues / The Virtqueue Descriptor Table / Indirect
 Descriptors} and \ref{sec:Packed Virtqueues / Indirect Flag: Scatter-Gather Support}~\nameref{sec:Packed Virtqueues / Indirect Flag: Scatter-Gather Support}.
-  \item[VIRTIO_F_RING_EVENT_IDX(29)] This feature enables the \field{used_event}
+  \item[VIRTIO_F_EVENT_IDX(29)] This feature enables the \field{used_event}
   and the \field{avail_event} fields as described in
 \ref{sec:Basic Facilities of a Virtio Device / Virtqueues / Used Buffer Notification Suppression}, \ref{sec:Basic Facilities of a Virtio Device / Virtqueues / The Virtqueue Used Ring} and \ref{sec:Packed Virtqueues / Driver and Device Event Suppression}.
 
diff --git a/packed-ring.tex b/packed-ring.tex
index ea92543..a9e6c16 100644
--- a/packed-ring.tex
+++ b/packed-ring.tex
@@ -336,7 +336,7 @@ \subsection{Driver and Device Event Suppression}
 /*
  * Enable events for a specific descriptor
  * (as specified by Descriptor Ring Change Event Offset/Wrap Counter).
- * Only valid if VIRTIO_F_RING_EVENT_IDX has been negotiated.
+ * Only valid if VIRTIO_F_EVENT_IDX has been negotiated.
  */
 #define RING_EVENT_FLAGS_DESC 0x2
 /* The value 0x3 is reserved */
@@ -597,7 +597,7 @@ \subsubsection{Implementation Example}\label{sec:Basic Facilities of a Virtio De
 
 Below is a driver code example. It does not attempt to reduce
 the number of available buffer notifications, neither does it support
-the VIRTIO_F_RING_EVENT_IDX feature.
+the VIRTIO_F_EVENT_IDX feature.
 
 \begin{lstlisting}
 /* Note: vq->avail_wrap_count is initialized to 1 */
-- 
2.25.1


This publicly archived list offers a means to provide input to the
OASIS Virtual I/O Device (VIRTIO) TC.

In order to verify user consent to the Feedback License terms and
to minimize spam in the list archive, subscription is required
before posting.

Subscribe: virtio-comment-subscribe@lists.oasis-open.org
Unsubscribe: virtio-comment-unsubscribe@lists.oasis-open.org
List help: virtio-comment-help@lists.oasis-open.org
List archive: https://lists.oasis-open.org/archives/virtio-comment/
Feedback License: https://www.oasis-open.org/who/ipr/feedback_license.pdf
List Guidelines: https://www.oasis-open.org/policies-guidelines/mailing-lists
Committee: https://www.oasis-open.org/committees/virtio/
Join OASIS: https://www.oasis-open.org/join/


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [virtio-comment] [PATCH] Make global flag names consistent
  2021-05-04 18:21 [virtio-comment] [PATCH] Make global flag names consistent Joel Nider
@ 2021-05-14  1:22 ` Joel Nider
  2021-05-17 10:17   ` Cornelia Huck
  0 siblings, 1 reply; 4+ messages in thread
From: Joel Nider @ 2021-05-14  1:22 UTC (permalink / raw)
  To: virtio-comment

Hi Cornelia,

Could you please comment on this patch - is this what you were expecting?

Thanks,

Joel

On 2021-05-04 11:21 a.m., Joel Nider wrote:
> The global flags VIRTIO_F_EVENT_IDX and VIRTIO_F_INDIRECT_DESC
> have inconsistent naming throughout the document. This change
> removes the _RING designation from the flag names to make the
> usage consistent.
>
> Signed-off-by: Joel Nider <joel@nider.org>
> ---
>   content.tex     | 4 ++--
>   packed-ring.tex | 4 ++--
>   2 files changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/content.tex b/content.tex
> index 9232d5c..c869cf4 100644
> --- a/content.tex
> +++ b/content.tex
> @@ -6574,14 +6574,14 @@ \chapter{Reserved Feature Bits}\label{sec:Reserved Feature Bits}
>   Currently these device-independent feature bits defined:
>   
>   \begin{description}
> -  \item[VIRTIO_F_RING_INDIRECT_DESC (28)] Negotiating this feature indicates
> +  \item[VIRTIO_F_INDIRECT_DESC (28)] Negotiating this feature indicates
>     that the driver can use descriptors with the VIRTQ_DESC_F_INDIRECT
>     flag set, as described in \ref{sec:Basic Facilities of a Virtio
>   Device / Virtqueues / The Virtqueue Descriptor Table / Indirect
>   Descriptors}~\nameref{sec:Basic Facilities of a Virtio Device /
>   Virtqueues / The Virtqueue Descriptor Table / Indirect
>   Descriptors} and \ref{sec:Packed Virtqueues / Indirect Flag: Scatter-Gather Support}~\nameref{sec:Packed Virtqueues / Indirect Flag: Scatter-Gather Support}.
> -  \item[VIRTIO_F_RING_EVENT_IDX(29)] This feature enables the \field{used_event}
> +  \item[VIRTIO_F_EVENT_IDX(29)] This feature enables the \field{used_event}
>     and the \field{avail_event} fields as described in
>   \ref{sec:Basic Facilities of a Virtio Device / Virtqueues / Used Buffer Notification Suppression}, \ref{sec:Basic Facilities of a Virtio Device / Virtqueues / The Virtqueue Used Ring} and \ref{sec:Packed Virtqueues / Driver and Device Event Suppression}.
>   
> diff --git a/packed-ring.tex b/packed-ring.tex
> index ea92543..a9e6c16 100644
> --- a/packed-ring.tex
> +++ b/packed-ring.tex
> @@ -336,7 +336,7 @@ \subsection{Driver and Device Event Suppression}
>   /*
>    * Enable events for a specific descriptor
>    * (as specified by Descriptor Ring Change Event Offset/Wrap Counter).
> - * Only valid if VIRTIO_F_RING_EVENT_IDX has been negotiated.
> + * Only valid if VIRTIO_F_EVENT_IDX has been negotiated.
>    */
>   #define RING_EVENT_FLAGS_DESC 0x2
>   /* The value 0x3 is reserved */
> @@ -597,7 +597,7 @@ \subsubsection{Implementation Example}\label{sec:Basic Facilities of a Virtio De
>   
>   Below is a driver code example. It does not attempt to reduce
>   the number of available buffer notifications, neither does it support
> -the VIRTIO_F_RING_EVENT_IDX feature.
> +the VIRTIO_F_EVENT_IDX feature.
>   
>   \begin{lstlisting}
>   /* Note: vq->avail_wrap_count is initialized to 1 */

This publicly archived list offers a means to provide input to the
OASIS Virtual I/O Device (VIRTIO) TC.

In order to verify user consent to the Feedback License terms and
to minimize spam in the list archive, subscription is required
before posting.

Subscribe: virtio-comment-subscribe@lists.oasis-open.org
Unsubscribe: virtio-comment-unsubscribe@lists.oasis-open.org
List help: virtio-comment-help@lists.oasis-open.org
List archive: https://lists.oasis-open.org/archives/virtio-comment/
Feedback License: https://www.oasis-open.org/who/ipr/feedback_license.pdf
List Guidelines: https://www.oasis-open.org/policies-guidelines/mailing-lists
Committee: https://www.oasis-open.org/committees/virtio/
Join OASIS: https://www.oasis-open.org/join/


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [virtio-comment] [PATCH] Make global flag names consistent
  2021-05-14  1:22 ` Joel Nider
@ 2021-05-17 10:17   ` Cornelia Huck
  2021-05-17 11:49     ` Cornelia Huck
  0 siblings, 1 reply; 4+ messages in thread
From: Cornelia Huck @ 2021-05-17 10:17 UTC (permalink / raw)
  To: Joel Nider; +Cc: virtio-comment

On Thu, 13 May 2021 18:22:23 -0700
Joel Nider <joel@nider.org> wrote:

> Hi Cornelia,
> 
> Could you please comment on this patch - is this what you were expecting?

Sorry for being late; being cc:ed usually brings stuff like this to my
attention sooner.

> 
> Thanks,
> 
> Joel
> 
> On 2021-05-04 11:21 a.m., Joel Nider wrote:
> > The global flags VIRTIO_F_EVENT_IDX and VIRTIO_F_INDIRECT_DESC
> > have inconsistent naming throughout the document. This change
> > removes the _RING designation from the flag names to make the
> > usage consistent.
> >
> > Signed-off-by: Joel Nider <joel@nider.org>
> > ---
> >   content.tex     | 4 ++--
> >   packed-ring.tex | 4 ++--
> >   2 files changed, 4 insertions(+), 4 deletions(-)

Change looks good to me.

In order to request a vote, please follow
https://github.com/oasis-tcs/virtio-spec#use-of-github-issues


This publicly archived list offers a means to provide input to the
OASIS Virtual I/O Device (VIRTIO) TC.

In order to verify user consent to the Feedback License terms and
to minimize spam in the list archive, subscription is required
before posting.

Subscribe: virtio-comment-subscribe@lists.oasis-open.org
Unsubscribe: virtio-comment-unsubscribe@lists.oasis-open.org
List help: virtio-comment-help@lists.oasis-open.org
List archive: https://lists.oasis-open.org/archives/virtio-comment/
Feedback License: https://www.oasis-open.org/who/ipr/feedback_license.pdf
List Guidelines: https://www.oasis-open.org/policies-guidelines/mailing-lists
Committee: https://www.oasis-open.org/committees/virtio/
Join OASIS: https://www.oasis-open.org/join/


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [virtio-comment] [PATCH] Make global flag names consistent
  2021-05-17 10:17   ` Cornelia Huck
@ 2021-05-17 11:49     ` Cornelia Huck
  0 siblings, 0 replies; 4+ messages in thread
From: Cornelia Huck @ 2021-05-17 11:49 UTC (permalink / raw)
  To: Joel Nider; +Cc: virtio-comment, Michael S . Tsirkin

On Mon, 17 May 2021 12:17:12 +0200
Cornelia Huck <cohuck@redhat.com> wrote:

> On Thu, 13 May 2021 18:22:23 -0700
> Joel Nider <joel@nider.org> wrote:
> 
> > Hi Cornelia,
> > 
> > Could you please comment on this patch - is this what you were expecting?  
> 
> Sorry for being late; being cc:ed usually brings stuff like this to my
> attention sooner.
> 
> > 
> > Thanks,
> > 
> > Joel
> > 
> > On 2021-05-04 11:21 a.m., Joel Nider wrote:  
> > > The global flags VIRTIO_F_EVENT_IDX and VIRTIO_F_INDIRECT_DESC
> > > have inconsistent naming throughout the document. This change
> > > removes the _RING designation from the flag names to make the
> > > usage consistent.
> > >
> > > Signed-off-by: Joel Nider <joel@nider.org>
> > > ---
> > >   content.tex     | 4 ++--
> > >   packed-ring.tex | 4 ++--
> > >   2 files changed, 4 insertions(+), 4 deletions(-)  
> 
> Change looks good to me.
> 
> In order to request a vote, please follow
> https://github.com/oasis-tcs/virtio-spec#use-of-github-issues

I now see that there's already
https://github.com/oasis-tcs/virtio-spec/issues/36 dealing with the
same problem.


This publicly archived list offers a means to provide input to the
OASIS Virtual I/O Device (VIRTIO) TC.

In order to verify user consent to the Feedback License terms and
to minimize spam in the list archive, subscription is required
before posting.

Subscribe: virtio-comment-subscribe@lists.oasis-open.org
Unsubscribe: virtio-comment-unsubscribe@lists.oasis-open.org
List help: virtio-comment-help@lists.oasis-open.org
List archive: https://lists.oasis-open.org/archives/virtio-comment/
Feedback License: https://www.oasis-open.org/who/ipr/feedback_license.pdf
List Guidelines: https://www.oasis-open.org/policies-guidelines/mailing-lists
Committee: https://www.oasis-open.org/committees/virtio/
Join OASIS: https://www.oasis-open.org/join/


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2021-05-17 11:49 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-05-04 18:21 [virtio-comment] [PATCH] Make global flag names consistent Joel Nider
2021-05-14  1:22 ` Joel Nider
2021-05-17 10:17   ` Cornelia Huck
2021-05-17 11:49     ` Cornelia Huck

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.