All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/8] configure: Change to -std=gnu11
@ 2021-06-11 23:33 Richard Henderson
  2021-06-11 23:33 ` [PATCH 1/8] configure: Use -std=gnu11 Richard Henderson
                   ` (10 more replies)
  0 siblings, 11 replies; 15+ messages in thread
From: Richard Henderson @ 2021-06-11 23:33 UTC (permalink / raw)
  To: qemu-devel; +Cc: pbonzini, thuth, ehabkost

Now that we assume gcc 7.5 as a minimum, we have the option
of changing to a newer C standard.  The two major ones that
I think apply are _Generic and _Static_assert.

While Paolo created a remarkably functional replacement for _Generic
using builtins, the error messages that you get out of the keyword
are *vastly* more intelligable, and the syntax is easier to read.

While I'd like to prefer _Static_assert over QEMU_BUILD_BUG_ON
going forward, and would like to convert existing uses, that is
a much bigger job.  Especially since the test condition is inverted.
In the meantime, can drop the configure detection.


r~


Richard Henderson (8):
  configure: Use -std=gnu11
  softfloat: Use _Generic instead of QEMU_GENERIC
  util: Use real functions for thread-posix QemuRecMutex
  util: Pass file+line to qemu_rec_mutex_unlock_impl
  util: Use unique type for QemuRecMutex in thread-posix.h
  include/qemu/lockable: Use _Generic instead of QEMU_GENERIC
  qemu/compiler: Remove QEMU_GENERIC
  configure: Remove probe for _Static_assert

 configure                   | 22 +---------
 meson.build                 |  2 +-
 include/qemu/compiler.h     | 51 ----------------------
 include/qemu/lockable.h     | 85 +++++++++++++++++++------------------
 include/qemu/thread-posix.h | 14 +++---
 include/qemu/thread-win32.h |  6 ---
 include/qemu/thread.h       | 15 ++++++-
 fpu/softfloat.c             | 16 ++++---
 util/qemu-thread-posix.c    | 24 ++++++++++-
 util/qemu-thread-win32.c    |  2 +-
 10 files changed, 100 insertions(+), 137 deletions(-)

-- 
2.25.1



^ permalink raw reply	[flat|nested] 15+ messages in thread

end of thread, other threads:[~2021-06-15  7:48 UTC | newest]

Thread overview: 15+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-06-11 23:33 [PATCH 0/8] configure: Change to -std=gnu11 Richard Henderson
2021-06-11 23:33 ` [PATCH 1/8] configure: Use -std=gnu11 Richard Henderson
2021-06-15  7:42   ` Thomas Huth
2021-06-11 23:33 ` [PATCH 2/8] softfloat: Use _Generic instead of QEMU_GENERIC Richard Henderson
2021-06-11 23:33 ` [PATCH 3/8] util: Use real functions for thread-posix QemuRecMutex Richard Henderson
2021-06-11 23:33 ` [PATCH 4/8] util: Pass file+line to qemu_rec_mutex_unlock_impl Richard Henderson
2021-06-11 23:33 ` [PATCH 5/8] util: Use unique type for QemuRecMutex in thread-posix.h Richard Henderson
2021-06-11 23:33 ` [PATCH 6/8] include/qemu/lockable: Use _Generic instead of QEMU_GENERIC Richard Henderson
2021-06-14 11:14   ` Paolo Bonzini
2021-06-14 14:47     ` Richard Henderson
2021-06-11 23:33 ` [PATCH 7/8] qemu/compiler: Remove QEMU_GENERIC Richard Henderson
2021-06-11 23:33 ` [PATCH 8/8] configure: Remove probe for _Static_assert Richard Henderson
2021-06-11 23:36 ` [PATCH 0/8] configure: Change to -std=gnu11 Richard Henderson
2021-06-14 11:15 ` Paolo Bonzini
2021-06-14 22:38 ` no-reply

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.