All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2 0/3] UFS patches for Linux kernel v5.14
@ 2021-06-24 23:29 Bart Van Assche
  2021-06-24 23:29 ` [PATCH v2 1/3] ufs: Reduce code duplication in the runtime power managment implementation Bart Van Assche
                   ` (2 more replies)
  0 siblings, 3 replies; 10+ messages in thread
From: Bart Van Assche @ 2021-06-24 23:29 UTC (permalink / raw)
  To: Martin K . Petersen; +Cc: linux-scsi, Jaegeuk Kim, Bart Van Assche


Hi Martin,

The three patches in this series are intended for kernel v5.14. These
patches have been compile tested only but should be easy to review.

Thanks,

Bart.

Changes compared to v1:
- Dropped patches 3 and 4.
- Added a new patch at the start of this series that reduces code duplication
  in the runtime power managment implementation.

Bart Van Assche (3):
  ufs: Reduce code duplication in the runtime power managment
    implementation
  ufs: Rename the second ufshcd_probe_hba() argument
  ufs: Remove ufshcd_valid_tag()

 drivers/scsi/ufs/tc-dwc-g210-pci.c | 34 ++----------
 drivers/scsi/ufs/ufshcd-pci.c      | 48 +----------------
 drivers/scsi/ufs/ufshcd-pltfrm.c   | 47 -----------------
 drivers/scsi/ufs/ufshcd.c          | 83 ++++++++++--------------------
 drivers/scsi/ufs/ufshcd.h          |  9 ++--
 5 files changed, 36 insertions(+), 185 deletions(-)


^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2021-06-25 20:39 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-06-24 23:29 [PATCH v2 0/3] UFS patches for Linux kernel v5.14 Bart Van Assche
2021-06-24 23:29 ` [PATCH v2 1/3] ufs: Reduce code duplication in the runtime power managment implementation Bart Van Assche
2021-06-25 10:27   ` Bean Huo
2021-06-25 12:36   ` Bean Huo
2021-06-25 14:27   ` kernel test robot
2021-06-25 14:27     ` kernel test robot
2021-06-25 20:39   ` kernel test robot
2021-06-24 23:29 ` [PATCH v2 2/3] ufs: Rename the second ufshcd_probe_hba() argument Bart Van Assche
2021-06-25 10:36   ` Bean Huo
2021-06-24 23:29 ` [PATCH v2 3/3] ufs: Remove ufshcd_valid_tag() Bart Van Assche

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.