All of lore.kernel.org
 help / color / mirror / Atom feed
* [dpdk-dev] [PATCH] test/crypto: rename slave to worker
@ 2021-06-30 15:29 Rebecca Troy
  2021-07-07 14:23 ` [dpdk-dev] [EXT] " Akhil Goyal
  0 siblings, 1 reply; 2+ messages in thread
From: Rebecca Troy @ 2021-06-30 15:29 UTC (permalink / raw)
  To: dev; +Cc: ciara.power, Rebecca Troy, Declan Doherty

Modifies the scheduler tests in the crypto unit test suite
to replace the usage of the word 'slave' with the more
appropriate word 'worker'.

The scheduler test functions were modified as follows:
test_scheduler_attach_slave_op is now called
test_scheduler_attach_worker_op,
test_scheduler_detach_slave_op is
test_scheduler_detach_worker_op.

Signed-off-by: Rebecca Troy <rebecca.troy@intel.com>
---
 app/test/test_cryptodev.c | 18 +++++++++---------
 1 file changed, 9 insertions(+), 9 deletions(-)

diff --git a/app/test/test_cryptodev.c b/app/test/test_cryptodev.c
index 39db52b17a..1725d6154c 100644
--- a/app/test/test_cryptodev.c
+++ b/app/test/test_cryptodev.c
@@ -13474,7 +13474,7 @@ scheduler_testsuite_setup(void)
 }
 
 static int
-test_scheduler_attach_slave_op(void)
+test_scheduler_attach_worker_op(void)
 {
 	struct crypto_testsuite_params *ts_params = &testsuite_params;
 	uint8_t sched_id = ts_params->valid_devs[0];
@@ -13584,7 +13584,7 @@ test_scheduler_attach_slave_op(void)
 }
 
 static int
-test_scheduler_detach_slave_op(void)
+test_scheduler_detach_worker_op(void)
 {
 	struct crypto_testsuite_params *ts_params = &testsuite_params;
 	uint8_t sched_id = ts_params->valid_devs[0];
@@ -13650,7 +13650,7 @@ test_scheduler_mode_pkt_size_distr_op(void)
 static int
 scheduler_multicore_testsuite_setup(void)
 {
-	if (test_scheduler_attach_slave_op() < 0)
+	if (test_scheduler_attach_worker_op() < 0)
 		return TEST_SKIPPED;
 	if (test_scheduler_mode_op(CDEV_SCHED_MODE_MULTICORE) < 0)
 		return TEST_SKIPPED;
@@ -13660,7 +13660,7 @@ scheduler_multicore_testsuite_setup(void)
 static int
 scheduler_roundrobin_testsuite_setup(void)
 {
-	if (test_scheduler_attach_slave_op() < 0)
+	if (test_scheduler_attach_worker_op() < 0)
 		return TEST_SKIPPED;
 	if (test_scheduler_mode_op(CDEV_SCHED_MODE_ROUNDROBIN) < 0)
 		return TEST_SKIPPED;
@@ -13670,7 +13670,7 @@ scheduler_roundrobin_testsuite_setup(void)
 static int
 scheduler_failover_testsuite_setup(void)
 {
-	if (test_scheduler_attach_slave_op() < 0)
+	if (test_scheduler_attach_worker_op() < 0)
 		return TEST_SKIPPED;
 	if (test_scheduler_mode_op(CDEV_SCHED_MODE_FAILOVER) < 0)
 		return TEST_SKIPPED;
@@ -13680,7 +13680,7 @@ scheduler_failover_testsuite_setup(void)
 static int
 scheduler_pkt_size_distr_testsuite_setup(void)
 {
-	if (test_scheduler_attach_slave_op() < 0)
+	if (test_scheduler_attach_worker_op() < 0)
 		return TEST_SKIPPED;
 	if (test_scheduler_mode_op(CDEV_SCHED_MODE_PKT_SIZE_DISTR) < 0)
 		return TEST_SKIPPED;
@@ -13690,7 +13690,7 @@ scheduler_pkt_size_distr_testsuite_setup(void)
 static void
 scheduler_mode_testsuite_teardown(void)
 {
-	test_scheduler_detach_slave_op();
+	test_scheduler_detach_worker_op();
 }
 
 #endif /* RTE_CRYPTO_SCHEDULER */
@@ -14652,12 +14652,12 @@ test_cryptodev_scheduler(void /*argv __rte_unused, int argc __rte_unused*/)
 	static struct unit_test_suite scheduler_config = {
 		.suite_name = "Crypto Device Scheduler Config Unit Test Suite",
 		.unit_test_cases = {
-			TEST_CASE(test_scheduler_attach_slave_op),
+			TEST_CASE(test_scheduler_attach_worker_op),
 			TEST_CASE(test_scheduler_mode_multicore_op),
 			TEST_CASE(test_scheduler_mode_roundrobin_op),
 			TEST_CASE(test_scheduler_mode_failover_op),
 			TEST_CASE(test_scheduler_mode_pkt_size_distr_op),
-			TEST_CASE(test_scheduler_detach_slave_op),
+			TEST_CASE(test_scheduler_detach_worker_op),
 
 			TEST_CASES_END() /**< NULL terminate array */
 		}
-- 
2.25.1


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [dpdk-dev] [EXT]  [PATCH] test/crypto: rename slave to worker
  2021-06-30 15:29 [dpdk-dev] [PATCH] test/crypto: rename slave to worker Rebecca Troy
@ 2021-07-07 14:23 ` Akhil Goyal
  0 siblings, 0 replies; 2+ messages in thread
From: Akhil Goyal @ 2021-07-07 14:23 UTC (permalink / raw)
  To: Rebecca Troy, dev; +Cc: ciara.power, Declan Doherty


> Modifies the scheduler tests in the crypto unit test suite
> to replace the usage of the word 'slave' with the more
> appropriate word 'worker'.
> 
> The scheduler test functions were modified as follows:
> test_scheduler_attach_slave_op is now called
> test_scheduler_attach_worker_op,
> test_scheduler_detach_slave_op is
> test_scheduler_detach_worker_op.
> 
> Signed-off-by: Rebecca Troy <rebecca.troy@intel.com>
> ---
Acked-by: Akhil Goyal <gakhil@marvell.com>

Applied to dpdk-next-crypto


^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-07-07 14:23 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-06-30 15:29 [dpdk-dev] [PATCH] test/crypto: rename slave to worker Rebecca Troy
2021-07-07 14:23 ` [dpdk-dev] [EXT] " Akhil Goyal

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.