All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 1/2] remoteproc: fix an typo in fw_elf_get_class code comments
@ 2021-07-06 14:21 ` Dong Aisheng
  0 siblings, 0 replies; 9+ messages in thread
From: Dong Aisheng @ 2021-07-06 14:21 UTC (permalink / raw)
  To: linux-remoteproc
  Cc: linux-arm-kernel, ohad, dongas86, bjorn.andersson,
	mathieu.poirier, cleger, Dong Aisheng

Drop 'and' which looks like unnecessary.

Fixes: 73516a33588c ("remoteproc: Add elf helpers to access elf64 and elf32 fields")
Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
---
 drivers/remoteproc/remoteproc_elf_helpers.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/remoteproc/remoteproc_elf_helpers.h b/drivers/remoteproc/remoteproc_elf_helpers.h
index 26404e68e17a..e6de53a5000c 100644
--- a/drivers/remoteproc/remoteproc_elf_helpers.h
+++ b/drivers/remoteproc/remoteproc_elf_helpers.h
@@ -15,7 +15,7 @@
  * fw_elf_get_class - Get elf class
  * @fw: the ELF firmware image
  *
- * Note that we use and elf32_hdr to access the class since the start of the
+ * Note that we use elf32_hdr to access the class since the start of the
  * struct is the same for both elf class
  *
  * Return: elf class of the firmware
-- 
2.25.1


^ permalink raw reply related	[flat|nested] 9+ messages in thread

* [PATCH 1/2] remoteproc: fix an typo in fw_elf_get_class code comments
@ 2021-07-06 14:21 ` Dong Aisheng
  0 siblings, 0 replies; 9+ messages in thread
From: Dong Aisheng @ 2021-07-06 14:21 UTC (permalink / raw)
  To: linux-remoteproc
  Cc: linux-arm-kernel, ohad, dongas86, bjorn.andersson,
	mathieu.poirier, cleger, Dong Aisheng

Drop 'and' which looks like unnecessary.

Fixes: 73516a33588c ("remoteproc: Add elf helpers to access elf64 and elf32 fields")
Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
---
 drivers/remoteproc/remoteproc_elf_helpers.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/remoteproc/remoteproc_elf_helpers.h b/drivers/remoteproc/remoteproc_elf_helpers.h
index 26404e68e17a..e6de53a5000c 100644
--- a/drivers/remoteproc/remoteproc_elf_helpers.h
+++ b/drivers/remoteproc/remoteproc_elf_helpers.h
@@ -15,7 +15,7 @@
  * fw_elf_get_class - Get elf class
  * @fw: the ELF firmware image
  *
- * Note that we use and elf32_hdr to access the class since the start of the
+ * Note that we use elf32_hdr to access the class since the start of the
  * struct is the same for both elf class
  *
  * Return: elf class of the firmware
-- 
2.25.1


_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

^ permalink raw reply related	[flat|nested] 9+ messages in thread

* [PATCH 2/2] remoteproc: fix kernel doc for struct rproc_ops
  2021-07-06 14:21 ` Dong Aisheng
@ 2021-07-06 14:21   ` Dong Aisheng
  -1 siblings, 0 replies; 9+ messages in thread
From: Dong Aisheng @ 2021-07-06 14:21 UTC (permalink / raw)
  To: linux-remoteproc
  Cc: linux-arm-kernel, ohad, dongas86, bjorn.andersson,
	mathieu.poirier, cleger, Dong Aisheng

The load_rsc_table was removed since the
commit c1d35c1ab424 ("remoteproc: Rename "load_rsc_table" to "parse_fw"")
but got added back again by mistake in the below commit:
commit b1a17513a2d6 ("remoteproc: add vendor resources handling").

The patch fixed a small code indent issue which not worth
a separate patch.

Fixes: b1a17513a2d6 ("remoteproc: add vendor resources handling")
Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
---
 include/linux/remoteproc.h | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/include/linux/remoteproc.h b/include/linux/remoteproc.h
index a5b37bc10865..83c09ac36b13 100644
--- a/include/linux/remoteproc.h
+++ b/include/linux/remoteproc.h
@@ -369,9 +369,8 @@ enum rsc_handling_status {
  * @da_to_va:	optional platform hook to perform address translations
  * @parse_fw:	parse firmware to extract information (e.g. resource table)
  * @handle_rsc:	optional platform hook to handle vendor resources. Should return
- * RSC_HANDLED if resource was handled, RSC_IGNORED if not handled and a
- * negative value on error
- * @load_rsc_table:	load resource table from firmware image
+ *		RSC_HANDLED if resource was handled, RSC_IGNORED if not handled
+ *		and a negative value on error
  * @find_loaded_rsc_table: find the loaded resource table from firmware image
  * @get_loaded_rsc_table: get resource table installed in memory
  *			  by external entity
-- 
2.25.1


^ permalink raw reply related	[flat|nested] 9+ messages in thread

* [PATCH 2/2] remoteproc: fix kernel doc for struct rproc_ops
@ 2021-07-06 14:21   ` Dong Aisheng
  0 siblings, 0 replies; 9+ messages in thread
From: Dong Aisheng @ 2021-07-06 14:21 UTC (permalink / raw)
  To: linux-remoteproc
  Cc: linux-arm-kernel, ohad, dongas86, bjorn.andersson,
	mathieu.poirier, cleger, Dong Aisheng

The load_rsc_table was removed since the
commit c1d35c1ab424 ("remoteproc: Rename "load_rsc_table" to "parse_fw"")
but got added back again by mistake in the below commit:
commit b1a17513a2d6 ("remoteproc: add vendor resources handling").

The patch fixed a small code indent issue which not worth
a separate patch.

Fixes: b1a17513a2d6 ("remoteproc: add vendor resources handling")
Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
---
 include/linux/remoteproc.h | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/include/linux/remoteproc.h b/include/linux/remoteproc.h
index a5b37bc10865..83c09ac36b13 100644
--- a/include/linux/remoteproc.h
+++ b/include/linux/remoteproc.h
@@ -369,9 +369,8 @@ enum rsc_handling_status {
  * @da_to_va:	optional platform hook to perform address translations
  * @parse_fw:	parse firmware to extract information (e.g. resource table)
  * @handle_rsc:	optional platform hook to handle vendor resources. Should return
- * RSC_HANDLED if resource was handled, RSC_IGNORED if not handled and a
- * negative value on error
- * @load_rsc_table:	load resource table from firmware image
+ *		RSC_HANDLED if resource was handled, RSC_IGNORED if not handled
+ *		and a negative value on error
  * @find_loaded_rsc_table: find the loaded resource table from firmware image
  * @get_loaded_rsc_table: get resource table installed in memory
  *			  by external entity
-- 
2.25.1


_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

^ permalink raw reply related	[flat|nested] 9+ messages in thread

* Re: [PATCH 1/2] remoteproc: fix an typo in fw_elf_get_class code comments
  2021-07-06 14:21 ` Dong Aisheng
@ 2021-07-12 17:29   ` Mathieu Poirier
  -1 siblings, 0 replies; 9+ messages in thread
From: Mathieu Poirier @ 2021-07-12 17:29 UTC (permalink / raw)
  To: Dong Aisheng
  Cc: linux-remoteproc, linux-arm-kernel, ohad, dongas86,
	bjorn.andersson, cleger

On Tue, Jul 06, 2021 at 10:21:55PM +0800, Dong Aisheng wrote:
> Drop 'and' which looks like unnecessary.
> 
> Fixes: 73516a33588c ("remoteproc: Add elf helpers to access elf64 and elf32 fields")
> Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
> ---
>  drivers/remoteproc/remoteproc_elf_helpers.h | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/remoteproc/remoteproc_elf_helpers.h b/drivers/remoteproc/remoteproc_elf_helpers.h
> index 26404e68e17a..e6de53a5000c 100644
> --- a/drivers/remoteproc/remoteproc_elf_helpers.h
> +++ b/drivers/remoteproc/remoteproc_elf_helpers.h
> @@ -15,7 +15,7 @@
>   * fw_elf_get_class - Get elf class
>   * @fw: the ELF firmware image
>   *
> - * Note that we use and elf32_hdr to access the class since the start of the
> + * Note that we use elf32_hdr to access the class since the start of the
>   * struct is the same for both elf class

The sentence should read:

"Note that we use an elf32_hdr..."

With the above:

Reviewed-by: Mathieu Poirier <mathieu.poirier@linaro.org>

>   *
>   * Return: elf class of the firmware
> -- 
> 2.25.1
> 

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PATCH 1/2] remoteproc: fix an typo in fw_elf_get_class code comments
@ 2021-07-12 17:29   ` Mathieu Poirier
  0 siblings, 0 replies; 9+ messages in thread
From: Mathieu Poirier @ 2021-07-12 17:29 UTC (permalink / raw)
  To: Dong Aisheng
  Cc: linux-remoteproc, linux-arm-kernel, ohad, dongas86,
	bjorn.andersson, cleger

On Tue, Jul 06, 2021 at 10:21:55PM +0800, Dong Aisheng wrote:
> Drop 'and' which looks like unnecessary.
> 
> Fixes: 73516a33588c ("remoteproc: Add elf helpers to access elf64 and elf32 fields")
> Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
> ---
>  drivers/remoteproc/remoteproc_elf_helpers.h | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/remoteproc/remoteproc_elf_helpers.h b/drivers/remoteproc/remoteproc_elf_helpers.h
> index 26404e68e17a..e6de53a5000c 100644
> --- a/drivers/remoteproc/remoteproc_elf_helpers.h
> +++ b/drivers/remoteproc/remoteproc_elf_helpers.h
> @@ -15,7 +15,7 @@
>   * fw_elf_get_class - Get elf class
>   * @fw: the ELF firmware image
>   *
> - * Note that we use and elf32_hdr to access the class since the start of the
> + * Note that we use elf32_hdr to access the class since the start of the
>   * struct is the same for both elf class

The sentence should read:

"Note that we use an elf32_hdr..."

With the above:

Reviewed-by: Mathieu Poirier <mathieu.poirier@linaro.org>

>   *
>   * Return: elf class of the firmware
> -- 
> 2.25.1
> 

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PATCH 2/2] remoteproc: fix kernel doc for struct rproc_ops
  2021-07-06 14:21   ` Dong Aisheng
@ 2021-07-12 17:41     ` Mathieu Poirier
  -1 siblings, 0 replies; 9+ messages in thread
From: Mathieu Poirier @ 2021-07-12 17:41 UTC (permalink / raw)
  To: Dong Aisheng
  Cc: linux-remoteproc, linux-arm-kernel, ohad, dongas86,
	bjorn.andersson, cleger

On Tue, Jul 06, 2021 at 10:21:56PM +0800, Dong Aisheng wrote:
> The load_rsc_table was removed since the
> commit c1d35c1ab424 ("remoteproc: Rename "load_rsc_table" to "parse_fw"")
> but got added back again by mistake in the below commit:
> commit b1a17513a2d6 ("remoteproc: add vendor resources handling").
> 
> The patch fixed a small code indent issue which not worth
> a separate patch.
> 
> Fixes: b1a17513a2d6 ("remoteproc: add vendor resources handling")
> Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
> ---
>  include/linux/remoteproc.h | 5 ++---
>  1 file changed, 2 insertions(+), 3 deletions(-)
>

Reviewed-by: Mathieu Poirier <mathieu.poirier@linaro.org>

Bjorn - checkpatch gets confused with the two double quotes in the changelog.  I
checked the syntax and everything is conformant to the guidelines.

> diff --git a/include/linux/remoteproc.h b/include/linux/remoteproc.h
> index a5b37bc10865..83c09ac36b13 100644
> --- a/include/linux/remoteproc.h
> +++ b/include/linux/remoteproc.h
> @@ -369,9 +369,8 @@ enum rsc_handling_status {
>   * @da_to_va:	optional platform hook to perform address translations
>   * @parse_fw:	parse firmware to extract information (e.g. resource table)
>   * @handle_rsc:	optional platform hook to handle vendor resources. Should return
> - * RSC_HANDLED if resource was handled, RSC_IGNORED if not handled and a
> - * negative value on error
> - * @load_rsc_table:	load resource table from firmware image
> + *		RSC_HANDLED if resource was handled, RSC_IGNORED if not handled
> + *		and a negative value on error
>   * @find_loaded_rsc_table: find the loaded resource table from firmware image
>   * @get_loaded_rsc_table: get resource table installed in memory
>   *			  by external entity
> -- 
> 2.25.1
> 

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PATCH 2/2] remoteproc: fix kernel doc for struct rproc_ops
@ 2021-07-12 17:41     ` Mathieu Poirier
  0 siblings, 0 replies; 9+ messages in thread
From: Mathieu Poirier @ 2021-07-12 17:41 UTC (permalink / raw)
  To: Dong Aisheng
  Cc: linux-remoteproc, linux-arm-kernel, ohad, dongas86,
	bjorn.andersson, cleger

On Tue, Jul 06, 2021 at 10:21:56PM +0800, Dong Aisheng wrote:
> The load_rsc_table was removed since the
> commit c1d35c1ab424 ("remoteproc: Rename "load_rsc_table" to "parse_fw"")
> but got added back again by mistake in the below commit:
> commit b1a17513a2d6 ("remoteproc: add vendor resources handling").
> 
> The patch fixed a small code indent issue which not worth
> a separate patch.
> 
> Fixes: b1a17513a2d6 ("remoteproc: add vendor resources handling")
> Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
> ---
>  include/linux/remoteproc.h | 5 ++---
>  1 file changed, 2 insertions(+), 3 deletions(-)
>

Reviewed-by: Mathieu Poirier <mathieu.poirier@linaro.org>

Bjorn - checkpatch gets confused with the two double quotes in the changelog.  I
checked the syntax and everything is conformant to the guidelines.

> diff --git a/include/linux/remoteproc.h b/include/linux/remoteproc.h
> index a5b37bc10865..83c09ac36b13 100644
> --- a/include/linux/remoteproc.h
> +++ b/include/linux/remoteproc.h
> @@ -369,9 +369,8 @@ enum rsc_handling_status {
>   * @da_to_va:	optional platform hook to perform address translations
>   * @parse_fw:	parse firmware to extract information (e.g. resource table)
>   * @handle_rsc:	optional platform hook to handle vendor resources. Should return
> - * RSC_HANDLED if resource was handled, RSC_IGNORED if not handled and a
> - * negative value on error
> - * @load_rsc_table:	load resource table from firmware image
> + *		RSC_HANDLED if resource was handled, RSC_IGNORED if not handled
> + *		and a negative value on error
>   * @find_loaded_rsc_table: find the loaded resource table from firmware image
>   * @get_loaded_rsc_table: get resource table installed in memory
>   *			  by external entity
> -- 
> 2.25.1
> 

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [PATCH 1/2] remoteproc: fix an typo in fw_elf_get_class code comments
  2021-07-06 14:21 ` Dong Aisheng
                   ` (2 preceding siblings ...)
  (?)
@ 2021-08-04 19:31 ` patchwork-bot+linux-remoteproc
  -1 siblings, 0 replies; 9+ messages in thread
From: patchwork-bot+linux-remoteproc @ 2021-08-04 19:31 UTC (permalink / raw)
  To: Dong Aisheng; +Cc: linux-remoteproc

Hello:

This series was applied to andersson/remoteproc.git (refs/heads/for-next):

On Tue,  6 Jul 2021 22:21:55 +0800 you wrote:
> Drop 'and' which looks like unnecessary.
> 
> Fixes: 73516a33588c ("remoteproc: Add elf helpers to access elf64 and elf32 fields")
> Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
> ---
>  drivers/remoteproc/remoteproc_elf_helpers.h | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Here is the summary with links:
  - [1/2] remoteproc: fix an typo in fw_elf_get_class code comments
    https://git.kernel.org/andersson/remoteproc/c/c080128b6f05
  - [2/2] remoteproc: fix kernel doc for struct rproc_ops
    https://git.kernel.org/andersson/remoteproc/c/147b589c5f44

You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html



^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2021-08-04 19:31 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-07-06 14:21 [PATCH 1/2] remoteproc: fix an typo in fw_elf_get_class code comments Dong Aisheng
2021-07-06 14:21 ` Dong Aisheng
2021-07-06 14:21 ` [PATCH 2/2] remoteproc: fix kernel doc for struct rproc_ops Dong Aisheng
2021-07-06 14:21   ` Dong Aisheng
2021-07-12 17:41   ` Mathieu Poirier
2021-07-12 17:41     ` Mathieu Poirier
2021-07-12 17:29 ` [PATCH 1/2] remoteproc: fix an typo in fw_elf_get_class code comments Mathieu Poirier
2021-07-12 17:29   ` Mathieu Poirier
2021-08-04 19:31 ` patchwork-bot+linux-remoteproc

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.