All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2 0/3] btrfs: btrfs_bio and btrfs_io_bio rename
@ 2021-09-14  1:25 Qu Wenruo
  2021-09-14  1:25 ` [PATCH v2 1/3] btrfs: rename btrfs_bio to btrfs_io_context Qu Wenruo
                   ` (3 more replies)
  0 siblings, 4 replies; 10+ messages in thread
From: Qu Wenruo @ 2021-09-14  1:25 UTC (permalink / raw)
  To: linux-btrfs

The branch can be fetched from github, and is the preferred way to grab
the code, as this patchset changed quite a lot of code.
https://github.com/adam900710/linux/tree/chunk_refactor

There are two structure, btrfs_io_bio and btrfs_bio, which have very
similar names but completely different meanings.

Btrfs_io_bio mostly works at logical bytenr layer (its
bio->bi_iter.bi_sector points to btrfs logical bytenr), and just
contains extra info like csum and mirror_num.

And btrfs_io_bio is in fact the most utilized bio, as all data/metadata
IO is using btrfs_io_bio.

While btrfs_bio is completely a helper structure for stripe IO
submission (RAID56 doesn't utilize it for IO submission).

Such naming is completely anti-human.

So this patchset will do the following renaming:

- btrfs_bio -> btrfs_io_context
  Since it's not really used by all bios (only mirrored profiles utilize
  it), and it contains extra info for RAID56, it's not proper to name it
  with _bio suffix.

  Later we can integrate btrfs_io_context pointer into the new
  btrfs_bio.

- btrfs_io_bio -> btrfs_bio
  I originally plan to rename it to btrfs_logical_bio, but it's a little
  too long for a lot of functions.

Changelog:
v2:
- Rename btrfs_bio to btrfs_io_context (bioc)
- Rename btrfs_io_bio to btrfs_bio
  Both suggested by Nikolay


Qu Wenruo (3):
  btrfs: rename btrfs_bio to btrfs_io_context
  btrfs: remove btrfs_bio_alloc() helper
  btrfs: rename struct btrfs_io_bio to btrfs_bio

 fs/btrfs/check-integrity.c |   4 +-
 fs/btrfs/compression.c     |  20 +--
 fs/btrfs/ctree.h           |   3 +-
 fs/btrfs/disk-io.c         |   2 +-
 fs/btrfs/disk-io.h         |   2 +-
 fs/btrfs/extent-tree.c     |  18 +--
 fs/btrfs/extent_io.c       | 108 ++++++++-------
 fs/btrfs/extent_io.h       |   3 +-
 fs/btrfs/extent_map.c      |   4 +-
 fs/btrfs/file-item.c       |  12 +-
 fs/btrfs/inode.c           |  42 +++---
 fs/btrfs/raid56.c          | 130 +++++++++----------
 fs/btrfs/raid56.h          |   8 +-
 fs/btrfs/reada.c           |  26 ++--
 fs/btrfs/scrub.c           | 130 +++++++++----------
 fs/btrfs/volumes.c         | 260 ++++++++++++++++++-------------------
 fs/btrfs/volumes.h         |  48 +++----
 fs/btrfs/zoned.c           |  16 +--
 18 files changed, 416 insertions(+), 420 deletions(-)

-- 
2.33.0


^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2021-09-15  6:02 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-14  1:25 [PATCH v2 0/3] btrfs: btrfs_bio and btrfs_io_bio rename Qu Wenruo
2021-09-14  1:25 ` [PATCH v2 1/3] btrfs: rename btrfs_bio to btrfs_io_context Qu Wenruo
2021-09-14 16:42   ` David Sterba
2021-09-15  6:02     ` Qu Wenruo
2021-09-14  1:25 ` [PATCH v2 2/3] btrfs: remove btrfs_bio_alloc() helper Qu Wenruo
2021-09-14 16:45   ` David Sterba
2021-09-14  1:25 ` [PATCH v2 3/3] btrfs: rename struct btrfs_io_bio to btrfs_bio Qu Wenruo
2021-09-14 16:49   ` David Sterba
2021-09-14 16:25 ` [PATCH v2 0/3] btrfs: btrfs_bio and btrfs_io_bio rename David Sterba
2021-09-14 22:20   ` Qu Wenruo

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.