All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] nl80211: prefer struct_size over open coded arithmetic
@ 2021-09-19 11:40 Len Baker
  2021-09-21 18:51 ` Gustavo A. R. Silva
  0 siblings, 1 reply; 2+ messages in thread
From: Len Baker @ 2021-09-19 11:40 UTC (permalink / raw)
  To: Johannes Berg, David S. Miller, Jakub Kicinski
  Cc: Len Baker, Kees Cook, Gustavo A. R. Silva, linux-wireless,
	netdev, linux-hardening, linux-kernel

As noted in the "Deprecated Interfaces, Language Features, Attributes,
and Conventions" documentation [1], size calculations (especially
multiplication) should not be performed in memory allocator (or similar)
function arguments due to the risk of them overflowing. This could lead
to values wrapping around and a smaller allocation being made than the
caller was expecting. Using those allocations could lead to linear
overflows of heap memory and other misbehaviors.

So, use the struct_size() helper to do the arithmetic instead of the
argument "size + count * size" in the kzalloc() functions.

Also, take the opportunity to refactor the memcpy() call to use the
flex_array_size() helper.

[1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments

Signed-off-by: Len Baker <len.baker@gmx.com>
---
 net/wireless/nl80211.c | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/net/wireless/nl80211.c b/net/wireless/nl80211.c
index bf7cd4752547..b56856349ced 100644
--- a/net/wireless/nl80211.c
+++ b/net/wireless/nl80211.c
@@ -11766,9 +11766,10 @@ static int nl80211_set_cqm_rssi(struct genl_info *info,
 	wdev_lock(wdev);
 	if (n_thresholds) {
 		struct cfg80211_cqm_config *cqm_config;
+		size_t size = struct_size(cqm_config, rssi_thresholds,
+					  n_thresholds);

-		cqm_config = kzalloc(sizeof(struct cfg80211_cqm_config) +
-				     n_thresholds * sizeof(s32), GFP_KERNEL);
+		cqm_config = kzalloc(size, GFP_KERNEL);
 		if (!cqm_config) {
 			err = -ENOMEM;
 			goto unlock;
@@ -11777,7 +11778,8 @@ static int nl80211_set_cqm_rssi(struct genl_info *info,
 		cqm_config->rssi_hyst = hysteresis;
 		cqm_config->n_rssi_thresholds = n_thresholds;
 		memcpy(cqm_config->rssi_thresholds, thresholds,
-		       n_thresholds * sizeof(s32));
+		       flex_array_size(cqm_config, rssi_thresholds,
+				       n_thresholds));

 		wdev->cqm_config = cqm_config;
 	}
@@ -15081,9 +15083,7 @@ static int nl80211_set_sar_specs(struct sk_buff *skb, struct genl_info *info)
 	if (specs > rdev->wiphy.sar_capa->num_freq_ranges)
 		return -EINVAL;

-	sar_spec = kzalloc(sizeof(*sar_spec) +
-			   specs * sizeof(struct cfg80211_sar_sub_specs),
-			   GFP_KERNEL);
+	sar_spec = kzalloc(struct_size(sar_spec, sub_specs, specs), GFP_KERNEL);
 	if (!sar_spec)
 		return -ENOMEM;

--
2.25.1


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] nl80211: prefer struct_size over open coded arithmetic
  2021-09-19 11:40 [PATCH] nl80211: prefer struct_size over open coded arithmetic Len Baker
@ 2021-09-21 18:51 ` Gustavo A. R. Silva
  0 siblings, 0 replies; 2+ messages in thread
From: Gustavo A. R. Silva @ 2021-09-21 18:51 UTC (permalink / raw)
  To: Len Baker, Johannes Berg, David S. Miller, Jakub Kicinski
  Cc: Kees Cook, Gustavo A. R. Silva, linux-wireless, netdev,
	linux-hardening, linux-kernel



On 9/19/21 06:40, Len Baker wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
> 
> So, use the struct_size() helper to do the arithmetic instead of the
> argument "size + count * size" in the kzalloc() functions.
> 
> Also, take the opportunity to refactor the memcpy() call to use the
> flex_array_size() helper.
> 
> [1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
> 
> Signed-off-by: Len Baker <len.baker@gmx.com>
> ---
>  net/wireless/nl80211.c | 12 ++++++------
>  1 file changed, 6 insertions(+), 6 deletions(-)
> 
> diff --git a/net/wireless/nl80211.c b/net/wireless/nl80211.c
> index bf7cd4752547..b56856349ced 100644
> --- a/net/wireless/nl80211.c
> +++ b/net/wireless/nl80211.c
> @@ -11766,9 +11766,10 @@ static int nl80211_set_cqm_rssi(struct genl_info *info,
>  	wdev_lock(wdev);
>  	if (n_thresholds) {
>  		struct cfg80211_cqm_config *cqm_config;
> +		size_t size = struct_size(cqm_config, rssi_thresholds,
> +					  n_thresholds);
> 
> -		cqm_config = kzalloc(sizeof(struct cfg80211_cqm_config) +
> -				     n_thresholds * sizeof(s32), GFP_KERNEL);
> +		cqm_config = kzalloc(size, GFP_KERNEL);

I don't think variable _size_ is needed here; this is just fine:

-               cqm_config = kzalloc(sizeof(struct cfg80211_cqm_config) +
-                                    n_thresholds * sizeof(s32), GFP_KERNEL);
+               cqm_config = kzalloc(struct_size(cqm_config, rssi_thresholds,
+                                                n_thresholds), GFP_KERNEL);

Thanks
--
Gustavo

>  		if (!cqm_config) {
>  			err = -ENOMEM;
>  			goto unlock;
> @@ -11777,7 +11778,8 @@ static int nl80211_set_cqm_rssi(struct genl_info *info,
>  		cqm_config->rssi_hyst = hysteresis;
>  		cqm_config->n_rssi_thresholds = n_thresholds;
>  		memcpy(cqm_config->rssi_thresholds, thresholds,
> -		       n_thresholds * sizeof(s32));
> +		       flex_array_size(cqm_config, rssi_thresholds,
> +				       n_thresholds));
> 
>  		wdev->cqm_config = cqm_config;
>  	}
> @@ -15081,9 +15083,7 @@ static int nl80211_set_sar_specs(struct sk_buff *skb, struct genl_info *info)
>  	if (specs > rdev->wiphy.sar_capa->num_freq_ranges)
>  		return -EINVAL;
> 
> -	sar_spec = kzalloc(sizeof(*sar_spec) +
> -			   specs * sizeof(struct cfg80211_sar_sub_specs),
> -			   GFP_KERNEL);
> +	sar_spec = kzalloc(struct_size(sar_spec, sub_specs, specs), GFP_KERNEL);
>  	if (!sar_spec)
>  		return -ENOMEM;
> 
> --
> 2.25.1
> 

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-09-21 19:12 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-19 11:40 [PATCH] nl80211: prefer struct_size over open coded arithmetic Len Baker
2021-09-21 18:51 ` Gustavo A. R. Silva

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.