All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2] scsi: advansys: Prefer struct_size over open coded arithmetic
@ 2021-09-25 11:42 Len Baker
  2021-09-27 14:48 ` Gustavo A. R. Silva
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: Len Baker @ 2021-09-25 11:42 UTC (permalink / raw)
  To: Matthew Wilcox, Hannes Reinecke, James E.J. Bottomley,
	Martin K. Petersen
  Cc: Len Baker, Gustavo A. R. Silva, Kees Cook, linux-hardening,
	linux-scsi, linux-kernel

As noted in the "Deprecated Interfaces, Language Features, Attributes,
and Conventions" documentation [1], size calculations (especially
multiplication) should not be performed in memory allocator (or similar)
function arguments due to the risk of them overflowing. This could lead
to values wrapping around and a smaller allocation being made than the
caller was expecting. Using those allocations could lead to linear
overflows of heap memory and other misbehaviors.

So, use the struct_size() helper to do the arithmetic instead of the
argument "size + count * size" in the kzalloc() function.

This code was detected with the help of Coccinelle and audited and fixed
manually.

[1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments

Signed-off-by: Len Baker <len.baker@gmx.com>
---
Changelog v1 -> v2
- Rebase against v5.15-rc2
- Remove the unnecessary "size" variable (Gustavo A. R. Silva).
- Update the commit changelog to inform that this code was detected
  using a Coccinelle script (Gustavo A. R. Silva).

 drivers/scsi/advansys.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/scsi/advansys.c b/drivers/scsi/advansys.c
index ffb391967573..e341b3372482 100644
--- a/drivers/scsi/advansys.c
+++ b/drivers/scsi/advansys.c
@@ -7477,8 +7477,8 @@ static int asc_build_req(struct asc_board *boardp, struct scsi_cmnd *scp,
 			return ASC_ERROR;
 		}

-		asc_sg_head = kzalloc(sizeof(asc_scsi_q->sg_head) +
-			use_sg * sizeof(struct asc_sg_list), GFP_ATOMIC);
+		asc_sg_head = kzalloc(struct_size(asc_sg_head, sg_list, use_sg),
+				      GFP_ATOMIC);
 		if (!asc_sg_head) {
 			scsi_dma_unmap(scp);
 			set_host_byte(scp, DID_SOFT_ERROR);
--
2.25.1


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH v2] scsi: advansys: Prefer struct_size over open coded arithmetic
  2021-09-25 11:42 [PATCH v2] scsi: advansys: Prefer struct_size over open coded arithmetic Len Baker
@ 2021-09-27 14:48 ` Gustavo A. R. Silva
  2021-09-29  2:55 ` Martin K. Petersen
  2021-10-05  4:34 ` Martin K. Petersen
  2 siblings, 0 replies; 4+ messages in thread
From: Gustavo A. R. Silva @ 2021-09-27 14:48 UTC (permalink / raw)
  To: Len Baker
  Cc: Matthew Wilcox, Hannes Reinecke, James E.J. Bottomley,
	Martin K. Petersen, Kees Cook, linux-hardening, linux-scsi,
	linux-kernel

On Sat, Sep 25, 2021 at 01:42:05PM +0200, Len Baker wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
> 
> So, use the struct_size() helper to do the arithmetic instead of the
> argument "size + count * size" in the kzalloc() function.
> 
> This code was detected with the help of Coccinelle and audited and fixed
> manually.
> 
> [1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
> 
> Signed-off-by: Len Baker <len.baker@gmx.com>

Reviewed-by: Gustavo A. R. Silva <gustavoars@kernel.org>

> ---
> Changelog v1 -> v2
> - Rebase against v5.15-rc2

Don't use mainline for these sorts of patches . Use linux-next instead:

https://www.kernel.org/doc/man-pages/linux-next.html

Thanks
--
Gustavo

> - Remove the unnecessary "size" variable (Gustavo A. R. Silva).
> - Update the commit changelog to inform that this code was detected
>   using a Coccinelle script (Gustavo A. R. Silva).
> 
>  drivers/scsi/advansys.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/scsi/advansys.c b/drivers/scsi/advansys.c
> index ffb391967573..e341b3372482 100644
> --- a/drivers/scsi/advansys.c
> +++ b/drivers/scsi/advansys.c
> @@ -7477,8 +7477,8 @@ static int asc_build_req(struct asc_board *boardp, struct scsi_cmnd *scp,
>  			return ASC_ERROR;
>  		}
> 
> -		asc_sg_head = kzalloc(sizeof(asc_scsi_q->sg_head) +
> -			use_sg * sizeof(struct asc_sg_list), GFP_ATOMIC);
> +		asc_sg_head = kzalloc(struct_size(asc_sg_head, sg_list, use_sg),
> +				      GFP_ATOMIC);
>  		if (!asc_sg_head) {
>  			scsi_dma_unmap(scp);
>  			set_host_byte(scp, DID_SOFT_ERROR);
> --
> 2.25.1
> 

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH v2] scsi: advansys: Prefer struct_size over open coded arithmetic
  2021-09-25 11:42 [PATCH v2] scsi: advansys: Prefer struct_size over open coded arithmetic Len Baker
  2021-09-27 14:48 ` Gustavo A. R. Silva
@ 2021-09-29  2:55 ` Martin K. Petersen
  2021-10-05  4:34 ` Martin K. Petersen
  2 siblings, 0 replies; 4+ messages in thread
From: Martin K. Petersen @ 2021-09-29  2:55 UTC (permalink / raw)
  To: Len Baker
  Cc: Matthew Wilcox, Hannes Reinecke, James E.J. Bottomley,
	Martin K. Petersen, Gustavo A. R. Silva, Kees Cook,
	linux-hardening, linux-scsi, linux-kernel


Len,

> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or
> similar) function arguments due to the risk of them overflowing. This
> could lead to values wrapping around and a smaller allocation being
> made than the caller was expecting. Using those allocations could lead
> to linear overflows of heap memory and other misbehaviors.

Applied to 5.16/scsi-staging, thanks!

-- 
Martin K. Petersen	Oracle Linux Engineering

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH v2] scsi: advansys: Prefer struct_size over open coded arithmetic
  2021-09-25 11:42 [PATCH v2] scsi: advansys: Prefer struct_size over open coded arithmetic Len Baker
  2021-09-27 14:48 ` Gustavo A. R. Silva
  2021-09-29  2:55 ` Martin K. Petersen
@ 2021-10-05  4:34 ` Martin K. Petersen
  2 siblings, 0 replies; 4+ messages in thread
From: Martin K. Petersen @ 2021-10-05  4:34 UTC (permalink / raw)
  To: Matthew Wilcox, James E.J. Bottomley, Len Baker, Hannes Reinecke
  Cc: Martin K . Petersen, linux-scsi, Gustavo A. R. Silva,
	linux-hardening, Kees Cook, linux-kernel

On Sat, 25 Sep 2021 13:42:05 +0200, Len Baker wrote:

> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
> 
> [...]

Applied to 5.16/scsi-queue, thanks!

[1/1] scsi: advansys: Prefer struct_size over open coded arithmetic
      https://git.kernel.org/mkp/scsi/c/568778f5572a

-- 
Martin K. Petersen	Oracle Linux Engineering

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2021-10-05  4:35 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-25 11:42 [PATCH v2] scsi: advansys: Prefer struct_size over open coded arithmetic Len Baker
2021-09-27 14:48 ` Gustavo A. R. Silva
2021-09-29  2:55 ` Martin K. Petersen
2021-10-05  4:34 ` Martin K. Petersen

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.