All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2 0/8] cmdprio cleanup series
@ 2021-11-09 23:38 Niklas Cassel
  2021-11-09 23:38 ` [PATCH v2 1/8] docs: update cmdprio_percentage documentation Niklas Cassel
                   ` (7 more replies)
  0 siblings, 8 replies; 13+ messages in thread
From: Niklas Cassel @ 2021-11-09 23:38 UTC (permalink / raw)
  To: axboe; +Cc: fio, damien.lemoal, Niklas Cassel

From: Niklas Cassel <niklas.cassel@wdc.com>

Hello Jens,

Here is a cleanup series that improves the cmdprio_percentage and
cmdprio_bssplit options in libaio and io_uring ioengines.

I'm currently working on adding support for multiple priority class +
priority level combinations, however that series is not quite ready yet.

Getting this cleanup series merged would make it easier to get multiple
priority class + priority level combinations added.
(Because AFAICT we wouldn't need any further changes to engines/io_uring.c
or engines/libaio.c after this. Most changes will be to cmdprio.c and
stat.c.)


Changes since v1:
-Incorporated review comments by Damien.


Kind regards,
Niklas

Niklas Cassel (8):
  docs: update cmdprio_percentage documentation
  cmdprio: move cmdprio function definitions to a new cmdprio.c file
  cmdprio: do not allocate memory for unused data direction
  io_uring: set async IO priority to td->ioprio in fio_ioring_prep()
  libaio,io_uring: rename prio_prep() to include cmdprio in the name
  libaio,io_uring: move common cmdprio_prep() code to cmdprio
  cmdprio: add mode to make the logic easier to reason about
  libaio,io_uring: make it possible to cleanup cmdprio malloced data

 HOWTO              |   5 +-
 Makefile           |   6 ++
 engines/cmdprio.c  | 236 +++++++++++++++++++++++++++++++++++++++++++++
 engines/cmdprio.h  | 150 +++++-----------------------
 engines/io_uring.c | 100 +++++++------------
 engines/libaio.c   |  72 +++++---------
 fio.1              |   3 +-
 7 files changed, 325 insertions(+), 247 deletions(-)
 create mode 100644 engines/cmdprio.c

-- 
2.33.1

^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2021-11-12  1:13 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-11-09 23:38 [PATCH v2 0/8] cmdprio cleanup series Niklas Cassel
2021-11-09 23:38 ` [PATCH v2 1/8] docs: update cmdprio_percentage documentation Niklas Cassel
2021-11-09 23:38 ` [PATCH v2 2/8] cmdprio: move cmdprio function definitions to a new cmdprio.c file Niklas Cassel
2021-11-09 23:38 ` [PATCH v2 3/8] cmdprio: do not allocate memory for unused data direction Niklas Cassel
2021-11-09 23:38 ` [PATCH v2 4/8] io_uring: set async IO priority to td->ioprio in fio_ioring_prep() Niklas Cassel
2021-11-12  0:41   ` Damien Le Moal
2021-11-09 23:38 ` [PATCH v2 5/8] libaio,io_uring: rename prio_prep() to include cmdprio in the name Niklas Cassel
2021-11-09 23:38 ` [PATCH v2 7/8] cmdprio: add mode to make the logic easier to reason about Niklas Cassel
2021-11-12  0:58   ` Damien Le Moal
2021-11-09 23:38 ` [PATCH v2 6/8] libaio,io_uring: move common cmdprio_prep() code to cmdprio Niklas Cassel
2021-11-12  0:52   ` Damien Le Moal
2021-11-09 23:38 ` [PATCH v2 8/8] libaio,io_uring: make it possible to cleanup cmdprio malloced data Niklas Cassel
2021-11-12  1:12   ` Damien Le Moal

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.