All of lore.kernel.org
 help / color / mirror / Atom feed
From: Bjorn Helgaas <helgaas@kernel.org>
To: Shuai Xue <xueshuai@linux.alibaba.com>
Cc: rafael@kernel.org, bp@alien8.de, tony.luck@intel.com,
	james.morse@arm.com, lenb@kernel.org, rjw@rjwysocki.net,
	bhelgaas@google.com, zhangliguang@linux.alibaba.com,
	zhuo.song@linux.alibaba.com, linux-kernel@vger.kernel.org,
	linux-acpi@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
	linux-pci@vger.kernel.org
Subject: Re: [PATCH v6] ACPI: explicit init HEST, SDEI and GHES in apci_init
Date: Fri, 21 Jan 2022 13:46:07 -0600	[thread overview]
Message-ID: <20220121194607.GA1146355@bhelgaas> (raw)
In-Reply-To: <4c34906a-244e-3956-0ca7-7131b268cf60@linux.alibaba.com>

On Fri, Jan 21, 2022 at 11:43:25AM +0800, Shuai Xue wrote:
> 在 2022/1/21 AM12:22, Bjorn Helgaas 写道:
> > On Thu, Jan 20, 2022 at 01:05:22PM +0800, Shuai Xue wrote:
> >> From commit e147133a42cb ("ACPI / APEI: Make hest.c manage the estatus
> >> memory pool") was merged, ghes_init() relies on acpi_hest_init() to manage
> >> the estatus memory pool. On the other hand, ghes_init() relies on
> >> sdei_init() to detect the SDEI version and (un)register events. The
> >> dependencies are as follows:
> >>
> >>     ghes_init() => acpi_hest_init() => acpi_bus_init() => acpi_init()
> >>     ghes_init() => sdei_init()
> >>
> >> HEST is not PCI-specific and initcall ordering is implicit and not
> >> well-defined within a level.
> >>
> >> Based on above, remove acpi_hest_init() from acpi_pci_root_init() and
> >> convert ghes_init() and sdei_init() from initcalls to explicit calls in the
> >> following order:
> >>
> >>     acpi_hest_init()
> >>     sdei_init()
> >>     ghes_init()

> >> --- a/drivers/acpi/bus.c
> >> +++ b/drivers/acpi/bus.c
> >> @@ -30,6 +30,7 @@
> >>  #include <linux/acpi_viot.h>
> >>  #include <linux/pci.h>
> >>  #include <acpi/apei.h>
> >> +#include <linux/arm_sdei.h>
> > 
> > This "arm" looks a little out of place in this supposedly arch-generic
> > code.  Not really a new thing with this patch, since this #include
> > already appears in drivers/acpi/apei/ghes.c.  Maybe it's unavoidable.
> 
> Yep, should we move sdei_init() into the beginning of ghes_init()?
> ...

> > Software Delegated Exception Interface (|SDEI|) is an Arm specification for
> > Non-secure world to register handlers with firmware to receive notifications
> > about system events.
> > LINK: https://github.com/ARM-software/arm-trusted-firmware/blob/master/docs/components/sdei.rst
> 
> I think SDEI is not a ACPI Specification but Arm specification so we should
> not rename sdei_init() with an "acpi_" prefix.  If we move sdei_init() into
> ghes_init(), and rename ghes_init() to acpi_ghes_init(), then all looks
> fine? What's your opinion, Bjorn?

Makes sense to me, especially since drivers/acpi/apei/ghes.c already
includes linux/arm_sdei.h.  This is Rafael's area.

Bjorn

WARNING: multiple messages have this Message-ID (diff)
From: Bjorn Helgaas <helgaas@kernel.org>
To: Shuai Xue <xueshuai@linux.alibaba.com>
Cc: rafael@kernel.org, bp@alien8.de, tony.luck@intel.com,
	james.morse@arm.com, lenb@kernel.org, rjw@rjwysocki.net,
	bhelgaas@google.com, zhangliguang@linux.alibaba.com,
	zhuo.song@linux.alibaba.com, linux-kernel@vger.kernel.org,
	linux-acpi@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
	linux-pci@vger.kernel.org
Subject: Re: [PATCH v6] ACPI: explicit init HEST, SDEI and GHES in apci_init
Date: Fri, 21 Jan 2022 13:46:07 -0600	[thread overview]
Message-ID: <20220121194607.GA1146355@bhelgaas> (raw)
In-Reply-To: <4c34906a-244e-3956-0ca7-7131b268cf60@linux.alibaba.com>

On Fri, Jan 21, 2022 at 11:43:25AM +0800, Shuai Xue wrote:
> 在 2022/1/21 AM12:22, Bjorn Helgaas 写道:
> > On Thu, Jan 20, 2022 at 01:05:22PM +0800, Shuai Xue wrote:
> >> From commit e147133a42cb ("ACPI / APEI: Make hest.c manage the estatus
> >> memory pool") was merged, ghes_init() relies on acpi_hest_init() to manage
> >> the estatus memory pool. On the other hand, ghes_init() relies on
> >> sdei_init() to detect the SDEI version and (un)register events. The
> >> dependencies are as follows:
> >>
> >>     ghes_init() => acpi_hest_init() => acpi_bus_init() => acpi_init()
> >>     ghes_init() => sdei_init()
> >>
> >> HEST is not PCI-specific and initcall ordering is implicit and not
> >> well-defined within a level.
> >>
> >> Based on above, remove acpi_hest_init() from acpi_pci_root_init() and
> >> convert ghes_init() and sdei_init() from initcalls to explicit calls in the
> >> following order:
> >>
> >>     acpi_hest_init()
> >>     sdei_init()
> >>     ghes_init()

> >> --- a/drivers/acpi/bus.c
> >> +++ b/drivers/acpi/bus.c
> >> @@ -30,6 +30,7 @@
> >>  #include <linux/acpi_viot.h>
> >>  #include <linux/pci.h>
> >>  #include <acpi/apei.h>
> >> +#include <linux/arm_sdei.h>
> > 
> > This "arm" looks a little out of place in this supposedly arch-generic
> > code.  Not really a new thing with this patch, since this #include
> > already appears in drivers/acpi/apei/ghes.c.  Maybe it's unavoidable.
> 
> Yep, should we move sdei_init() into the beginning of ghes_init()?
> ...

> > Software Delegated Exception Interface (|SDEI|) is an Arm specification for
> > Non-secure world to register handlers with firmware to receive notifications
> > about system events.
> > LINK: https://github.com/ARM-software/arm-trusted-firmware/blob/master/docs/components/sdei.rst
> 
> I think SDEI is not a ACPI Specification but Arm specification so we should
> not rename sdei_init() with an "acpi_" prefix.  If we move sdei_init() into
> ghes_init(), and rename ghes_init() to acpi_ghes_init(), then all looks
> fine? What's your opinion, Bjorn?

Makes sense to me, especially since drivers/acpi/apei/ghes.c already
includes linux/arm_sdei.h.  This is Rafael's area.

Bjorn

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2022-01-21 19:46 UTC|newest]

Thread overview: 60+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-11-26  7:04 [RFC PATCH v4] ACPI: Move sdei_init and ghes_init ahead to handle platform errors earlier Shuai Xue
2021-11-26  7:04 ` Shuai Xue
2021-12-02 12:50 ` Shuai Xue
2021-12-02 12:50   ` Shuai Xue
2021-12-16 13:34 ` [RESEND " Shuai Xue
2021-12-16 13:34   ` Shuai Xue
2021-12-17 18:17   ` Rafael J. Wysocki
2021-12-17 18:17     ` Rafael J. Wysocki
2021-12-19  4:04     ` Shuai Xue
2021-12-19  4:04       ` Shuai Xue
2021-12-21 23:17   ` Bjorn Helgaas
2021-12-21 23:17     ` Bjorn Helgaas
2021-12-23  8:11     ` Shuai Xue
2021-12-23  8:11       ` Shuai Xue
2021-12-24  0:17       ` Bjorn Helgaas
2021-12-24  0:17         ` Bjorn Helgaas
2021-12-24  8:55         ` Shuai Xue
2021-12-24  8:55           ` Shuai Xue
2022-01-13 13:38           ` Shuai Xue
2022-01-13 13:38             ` Shuai Xue
2022-01-16  8:43 ` [PATCH v5] " Shuai Xue
2022-01-16  8:43   ` Shuai Xue
2022-01-18 22:49   ` Bjorn Helgaas
2022-01-18 22:49     ` Bjorn Helgaas
2022-01-19  6:40     ` Shuai Xue
2022-01-19  6:40       ` Shuai Xue
2022-01-19 20:42       ` Bjorn Helgaas
2022-01-19 20:42         ` Bjorn Helgaas
2022-01-20  2:40         ` Shuai Xue
2022-01-20  2:40           ` Shuai Xue
2022-01-20 16:24         ` Rafael J. Wysocki
2022-01-20 16:24           ` Rafael J. Wysocki
2022-01-20  5:05 ` [PATCH v6] ACPI: explicit init HEST, SDEI and GHES in apci_init Shuai Xue
2022-01-20  5:05   ` Shuai Xue
2022-01-20 16:22   ` Bjorn Helgaas
2022-01-20 16:22     ` Bjorn Helgaas
2022-01-21  3:43     ` Shuai Xue
2022-01-21  3:43       ` Shuai Xue
2022-01-21 19:46       ` Bjorn Helgaas [this message]
2022-01-21 19:46         ` Bjorn Helgaas
2022-01-22  5:26 ` [PATCH v7 1/2] ACPI: APEI: explicit init HEST " Shuai Xue
2022-01-22  5:26   ` Shuai Xue
2022-02-10  9:39   ` Shuai Xue
2022-02-10  9:39     ` Shuai Xue
2022-02-14 18:51     ` Rafael J. Wysocki
2022-02-14 18:51       ` Rafael J. Wysocki
2022-02-21 18:18   ` Nathan Chancellor
2022-02-21 18:18     ` Nathan Chancellor
2022-02-21 18:25     ` Rafael J. Wysocki
2022-02-21 18:25       ` Rafael J. Wysocki
2022-02-22  6:03     ` Shuai Xue
2022-02-22  6:03       ` Shuai Xue
2022-01-22  5:26 ` [PATCH v7 2/2] ACPI: APEI: rename ghes_init with an "acpi_" prefix Shuai Xue
2022-01-22  5:26   ` Shuai Xue
2022-02-27 12:25 ` [PATCH v8 1/2] ACPI: APEI: explicit init HEST and GHES in apci_init Shuai Xue
2022-02-27 12:25   ` Shuai Xue
2022-03-03 19:27   ` Rafael J. Wysocki
2022-03-03 19:27     ` Rafael J. Wysocki
2022-02-27 12:25 ` [PATCH v8 2/2] ACPI: APEI: rename ghes_init with an "acpi_" prefix Shuai Xue
2022-02-27 12:25   ` Shuai Xue

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20220121194607.GA1146355@bhelgaas \
    --to=helgaas@kernel.org \
    --cc=bhelgaas@google.com \
    --cc=bp@alien8.de \
    --cc=james.morse@arm.com \
    --cc=lenb@kernel.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=rafael@kernel.org \
    --cc=rjw@rjwysocki.net \
    --cc=tony.luck@intel.com \
    --cc=xueshuai@linux.alibaba.com \
    --cc=zhangliguang@linux.alibaba.com \
    --cc=zhuo.song@linux.alibaba.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.