All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2 0/6] pwm: renesas-tpu: Various improvements
@ 2022-04-20 12:12 Uwe Kleine-König
  2022-04-20 12:12 ` [PATCH v2 1/6] pwm: renesas-tpu: Make use of dev_err_probe() Uwe Kleine-König
                   ` (7 more replies)
  0 siblings, 8 replies; 14+ messages in thread
From: Uwe Kleine-König @ 2022-04-20 12:12 UTC (permalink / raw)
  To: Laurent Pinchart, Simon Horman, Geert Uytterhoeven, Magnus Damm,
	Thierry Reding, Lee Jones
  Cc: linux-renesas-soc, linux-pwm, kernel

Hello,

I reworked the series to improve the renesas-tpu PWM driver after
feedback I got from Geert. The changes are:

 - Add Geert's tags for the first two patches
   (I didn't add them for the other patches as I changed these enough to
   not carry the tags forward.)
 - Use tpu_pwm_disable instead chip->ops->disable (which is NULL now)
   fixing a crash in v1.
 - The calculation now uses a switch instead of ilog2.
   Looking at the compiled code for ARM this is more effective and I
   assume the same holds true for other platforms.

Thanks again to Geert for his valuable feedback and testing.

Best regards
Uwe

Uwe Kleine-König (6):
  pwm: renesas-tpu: Make use of dev_err_probe()
  pwm: renesas-tpu: Make use of devm functions
  pwm: renesas-tpu: Implement .apply() callback
  pwm: renesas-tpu: Rename variables to match the usual naming
  pwm: renesas-tpu: Improve maths to compute register settings
  pwm: renesas-tpu: Improve precision of period and duty_cycle
    calculation

 drivers/pwm/pwm-renesas-tpu.c | 317 +++++++++++++++++++---------------
 1 file changed, 180 insertions(+), 137 deletions(-)


base-commit: 3123109284176b1532874591f7c81f3837bbdc17
-- 
2.35.1


^ permalink raw reply	[flat|nested] 14+ messages in thread

end of thread, other threads:[~2022-06-19 20:03 UTC | newest]

Thread overview: 14+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-04-20 12:12 [PATCH v2 0/6] pwm: renesas-tpu: Various improvements Uwe Kleine-König
2022-04-20 12:12 ` [PATCH v2 1/6] pwm: renesas-tpu: Make use of dev_err_probe() Uwe Kleine-König
2022-04-20 12:12 ` [PATCH v2 2/6] pwm: renesas-tpu: Make use of devm functions Uwe Kleine-König
2022-04-20 12:12 ` [PATCH v2 3/6] pwm: renesas-tpu: Implement .apply() callback Uwe Kleine-König
2022-04-20 18:07   ` Geert Uytterhoeven
2022-04-20 12:12 ` [PATCH v2 4/6] pwm: renesas-tpu: Rename variables to match the usual naming Uwe Kleine-König
2022-04-20 12:25   ` Geert Uytterhoeven
2022-04-20 12:12 ` [PATCH v2 5/6] pwm: renesas-tpu: Improve maths to compute register settings Uwe Kleine-König
2022-04-20 18:08   ` Geert Uytterhoeven
2022-06-19 20:03     ` Uwe Kleine-König
2022-04-20 12:12 ` [PATCH v2 6/6] pwm: renesas-tpu: Improve precision of period and duty_cycle calculation Uwe Kleine-König
2022-04-20 18:10   ` Geert Uytterhoeven
2022-04-20 18:12 ` [PATCH v2 0/6] pwm: renesas-tpu: Various improvements Geert Uytterhoeven
2022-05-20 14:19 ` Thierry Reding

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.