All of lore.kernel.org
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@lst.de>
To: Eric Biggers <ebiggers@kernel.org>
Cc: Christoph Hellwig <hch@lst.de>, Jens Axboe <axboe@kernel.dk>,
	Mike Snitzer <snitzer@kernel.org>,
	"Theodore Y. Ts'o" <tytso@mit.edu>,
	Jaegeuk Kim <jaegeuk@kernel.org>,
	dm-devel@redhat.com, linux-block@vger.kernel.org,
	linux-fscrypt@vger.kernel.org
Subject: Re: [PATCH 2/2] blk-crypto: add a blk_crypto_cfg_supported helper
Date: Fri, 4 Nov 2022 08:32:49 +0100	[thread overview]
Message-ID: <20221104073249.GB18231@lst.de> (raw)
In-Reply-To: <Y2S927PXuEYM7xwJ@sol.localdomain>

On Fri, Nov 04, 2022 at 12:23:07AM -0700, Eric Biggers wrote:
> > +bool blk_crypto_cfg_supported(struct block_device *bdev,
> > +			      const struct blk_crypto_config *cfg)
> > +{
> > +	return __blk_crypto_cfg_supported(bdev_get_queue(bdev)->crypto_profile,
> > +					  cfg);
> > +}
> 
> I think this part is too confusing, because there's already a function
> blk_crypto_config_supported() which does something slightly different.
> 
> How about calling this blk_crypto_config_supported_natively() instead?  It's
> kind of long, but it's much clearer.

Fine with me.

> Also, it should be defined in blk-crypto.c, next to
> blk_crypto_config_supported(), and not in blk-crypto-profile.c.
> (And declared in blk-crypto.h, not blk-crypto-profile.h.)

Ok.

WARNING: multiple messages have this Message-ID (diff)
From: Christoph Hellwig <hch@lst.de>
To: Eric Biggers <ebiggers@kernel.org>
Cc: Jens Axboe <axboe@kernel.dk>, "Theodore Y. Ts'o" <tytso@mit.edu>,
	Mike Snitzer <snitzer@kernel.org>,
	linux-fscrypt@vger.kernel.org, linux-block@vger.kernel.org,
	dm-devel@redhat.com, Jaegeuk Kim <jaegeuk@kernel.org>,
	Christoph Hellwig <hch@lst.de>
Subject: Re: [dm-devel] [PATCH 2/2] blk-crypto: add a blk_crypto_cfg_supported helper
Date: Fri, 4 Nov 2022 08:32:49 +0100	[thread overview]
Message-ID: <20221104073249.GB18231@lst.de> (raw)
In-Reply-To: <Y2S927PXuEYM7xwJ@sol.localdomain>

On Fri, Nov 04, 2022 at 12:23:07AM -0700, Eric Biggers wrote:
> > +bool blk_crypto_cfg_supported(struct block_device *bdev,
> > +			      const struct blk_crypto_config *cfg)
> > +{
> > +	return __blk_crypto_cfg_supported(bdev_get_queue(bdev)->crypto_profile,
> > +					  cfg);
> > +}
> 
> I think this part is too confusing, because there's already a function
> blk_crypto_config_supported() which does something slightly different.
> 
> How about calling this blk_crypto_config_supported_natively() instead?  It's
> kind of long, but it's much clearer.

Fine with me.

> Also, it should be defined in blk-crypto.c, next to
> blk_crypto_config_supported(), and not in blk-crypto-profile.c.
> (And declared in blk-crypto.h, not blk-crypto-profile.h.)

Ok.

--
dm-devel mailing list
dm-devel@redhat.com
https://listman.redhat.com/mailman/listinfo/dm-devel


  reply	other threads:[~2022-11-04  7:32 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-11-04  5:46 pass a struct block_device to the blk-crypto interfaces Christoph Hellwig
2022-11-04  5:46 ` [dm-devel] " Christoph Hellwig
2022-11-04  5:46 ` [PATCH 1/2] blk-crypto: don't use struct request_queue for public interfaces Christoph Hellwig
2022-11-04  5:46   ` [dm-devel] " Christoph Hellwig
2022-11-04  7:28   ` Eric Biggers
2022-11-04  7:28     ` [dm-devel] " Eric Biggers
2022-11-04  7:32     ` Christoph Hellwig
2022-11-04  7:32       ` [dm-devel] " Christoph Hellwig
2022-11-04  5:46 ` [PATCH 2/2] blk-crypto: add a blk_crypto_cfg_supported helper Christoph Hellwig
2022-11-04  5:46   ` [dm-devel] " Christoph Hellwig
2022-11-04  7:23   ` Eric Biggers
2022-11-04  7:23     ` [dm-devel] " Eric Biggers
2022-11-04  7:32     ` Christoph Hellwig [this message]
2022-11-04  7:32       ` Christoph Hellwig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20221104073249.GB18231@lst.de \
    --to=hch@lst.de \
    --cc=axboe@kernel.dk \
    --cc=dm-devel@redhat.com \
    --cc=ebiggers@kernel.org \
    --cc=jaegeuk@kernel.org \
    --cc=linux-block@vger.kernel.org \
    --cc=linux-fscrypt@vger.kernel.org \
    --cc=snitzer@kernel.org \
    --cc=tytso@mit.edu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.