All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jan Kara <jack@suse.cz>
To: Kemeng Shi <shikemeng@huaweicloud.com>
Cc: axboe@kernel.dk, linux-block@vger.kernel.org,
	linux-kernel@vger.kernel.org, jack@suse.cz, kbusch@kernel.org
Subject: Re: [PATCH RESEND v2 3/5] sbitmap: rewrite sbitmap_find_bit_in_index to reduce repeat code
Date: Thu, 22 Dec 2022 13:23:24 +0100	[thread overview]
Message-ID: <20221222122324.z3sueeqwc26pqeh5@quack3> (raw)
In-Reply-To: <20221222143353.598042-4-shikemeng@huaweicloud.com>

On Thu 22-12-22 22:33:51, Kemeng Shi wrote:
> Rewrite sbitmap_find_bit_in_index as following:
> 1. Rename sbitmap_find_bit_in_index to sbitmap_find_bit_in_word
> 2. Accept "struct sbitmap_word *" directly instead of accepting
> "struct sbitmap *" and "int index" to get "struct sbitmap_word *".
> 3. Accept depth/shallow_depth and wrap for __sbitmap_get_word from caller
> to support need of both __sbitmap_get_shallow and __sbitmap_get.
> 
> With helper function sbitmap_find_bit_in_word, we can remove repeat
> code in __sbitmap_get_shallow to find bit considring deferred clear.
> 
> Signed-off-by: Kemeng Shi <shikemeng@huaweicloud.com>
> ---
>  lib/sbitmap.c | 29 ++++++++++++++---------------
>  1 file changed, 14 insertions(+), 15 deletions(-)

Just one style nit below. Please fix that up. Otherwise feel free to add:

Reviewed-by: Jan Kara <jack@suse.cz>

> diff --git a/lib/sbitmap.c b/lib/sbitmap.c
> index 11e75f4040fb..3f7e276a427d 100644
> --- a/lib/sbitmap.c
> +++ b/lib/sbitmap.c
> @@ -167,15 +167,16 @@ static int __sbitmap_get_word(unsigned long *word, unsigned long depth,
>  	return nr;
>  }
>  
> -static int sbitmap_find_bit_in_index(struct sbitmap *sb, int index,
> -				     unsigned int alloc_hint)
> +static int sbitmap_find_bit_in_word(struct sbitmap_word *map,
> +				    unsigned int depth,
> +				    unsigned int alloc_hint,
> +				    bool wrap)
>  {
> -	struct sbitmap_word *map = &sb->map[index];
>  	int nr;
>  
>  	do {
> -		nr = __sbitmap_get_word(&map->word, __map_depth(sb, index),
> -					alloc_hint, !sb->round_robin);
> +		nr = __sbitmap_get_word(&map->word, depth,
> +					alloc_hint, wrap);
>  		if (nr != -1)
>  			break;
>  		if (!sbitmap_deferred_clear(map))
> @@ -203,7 +204,8 @@ static int __sbitmap_get(struct sbitmap *sb, unsigned int alloc_hint)
>  		alloc_hint = 0;
>  
>  	for (i = 0; i < sb->map_nr; i++) {
> -		nr = sbitmap_find_bit_in_index(sb, index, alloc_hint);
> +		nr = sbitmap_find_bit_in_word(&sb->map[index], __map_depth(sb, index),

Please avoid lines over 80 characters.

> +					      alloc_hint, !sb->round_robin);
>  		if (nr != -1) {
>  			nr += index << sb->shift;
>  			break;

								Honza
-- 
Jan Kara <jack@suse.com>
SUSE Labs, CR

  reply	other threads:[~2022-12-22 12:23 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-12-22 14:33 [PATCH RESEND v2 0/5] A few bugfix and cleanup patches for sbitmap Kemeng Shi
2022-12-22 14:33 ` [PATCH RESEND v2 1/5] sbitmap: remove unnecessary calculation of alloc_hint in __sbitmap_get_shallow Kemeng Shi
2022-12-22 11:01   ` Jan Kara
2022-12-22 14:33 ` [PATCH RESEND v2 2/5] sbitmap: remove redundant check in __sbitmap_queue_get_batch Kemeng Shi
2022-12-22 11:23   ` Jan Kara
2022-12-22 11:49     ` Kemeng Shi
2022-12-22 12:16       ` Jan Kara
2022-12-22 14:33 ` [PATCH RESEND v2 3/5] sbitmap: rewrite sbitmap_find_bit_in_index to reduce repeat code Kemeng Shi
2022-12-22 12:23   ` Jan Kara [this message]
2022-12-22 14:33 ` [PATCH RESEND v2 4/5] sbitmap: add sbitmap_find_bit to remove repeat code in __sbitmap_get/__sbitmap_get_shallow Kemeng Shi
2022-12-22 12:42   ` Jan Kara
2022-12-22 14:33 ` [PATCH RESEND v2 5/5] sbitmap: correct wake_batch recalculation to avoid potential IO hung Kemeng Shi
2022-12-22 13:41   ` Jan Kara
2022-12-26  7:50     ` Yu Kuai
2022-12-26  8:57       ` Yu Kuai
2023-01-03  2:12         ` Kemeng Shi
2023-01-16  2:15           ` Kemeng Shi
2023-01-16  9:54             ` Jan Kara

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20221222122324.z3sueeqwc26pqeh5@quack3 \
    --to=jack@suse.cz \
    --cc=axboe@kernel.dk \
    --cc=kbusch@kernel.org \
    --cc=linux-block@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=shikemeng@huaweicloud.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.