All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] block: fix kernel-doc for disk_force_media_change()
@ 2023-09-26  0:52 Randy Dunlap
  2023-09-26  6:04 ` Christoph Hellwig
  2023-09-26  6:43 ` Jens Axboe
  0 siblings, 2 replies; 3+ messages in thread
From: Randy Dunlap @ 2023-09-26  0:52 UTC (permalink / raw)
  To: linux-kernel
  Cc: Randy Dunlap, kernel test robot, Christoph Hellwig, Jens Axboe,
	linux-block

Drop one function parameter's kernel-doc comment since the parameter
was removed. This prevents a kernel-doc warning:

block/disk-events.c:300: warning: Excess function parameter 'events' description in 'disk_force_media_change'

Fixes: ab6860f62bfe ("block: simplify the disk_force_media_change interface")
Signed-off-by: Randy Dunlap <rdunlap@infradead.org>
Reported-by: kernel test robot <lkp@intel.com>
Closes: lore.kernel.org/r/202309060957.vfl0mUur-lkp@intel.com
Cc: Christoph Hellwig <hch@lst.de>
Cc: Jens Axboe <axboe@kernel.dk>
Cc: linux-block@vger.kernel.org
---
 block/disk-events.c |    1 -
 1 file changed, 1 deletion(-)

diff -- a/block/disk-events.c b/block/disk-events.c
--- a/block/disk-events.c
+++ b/block/disk-events.c
@@ -290,7 +290,6 @@ EXPORT_SYMBOL(disk_check_media_change);
 /**
  * disk_force_media_change - force a media change event
  * @disk: the disk which will raise the event
- * @events: the events to raise
  *
  * Should be called when the media changes for @disk.  Generates a uevent
  * and attempts to free all dentries and inodes and invalidates all block

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] block: fix kernel-doc for disk_force_media_change()
  2023-09-26  0:52 [PATCH] block: fix kernel-doc for disk_force_media_change() Randy Dunlap
@ 2023-09-26  6:04 ` Christoph Hellwig
  2023-09-26  6:43 ` Jens Axboe
  1 sibling, 0 replies; 3+ messages in thread
From: Christoph Hellwig @ 2023-09-26  6:04 UTC (permalink / raw)
  To: Randy Dunlap
  Cc: linux-kernel, kernel test robot, Christoph Hellwig, Jens Axboe,
	linux-block

Looks good:

Reviewed-by: Christoph Hellwig <hch@lst.de>

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] block: fix kernel-doc for disk_force_media_change()
  2023-09-26  0:52 [PATCH] block: fix kernel-doc for disk_force_media_change() Randy Dunlap
  2023-09-26  6:04 ` Christoph Hellwig
@ 2023-09-26  6:43 ` Jens Axboe
  1 sibling, 0 replies; 3+ messages in thread
From: Jens Axboe @ 2023-09-26  6:43 UTC (permalink / raw)
  To: linux-kernel, Randy Dunlap
  Cc: kernel test robot, Christoph Hellwig, linux-block


On Mon, 25 Sep 2023 17:52:32 -0700, Randy Dunlap wrote:
> Drop one function parameter's kernel-doc comment since the parameter
> was removed. This prevents a kernel-doc warning:
> 
> block/disk-events.c:300: warning: Excess function parameter 'events' description in 'disk_force_media_change'
> 
> 

Applied, thanks!

[1/1] block: fix kernel-doc for disk_force_media_change()
      commit: a578a25339aca38e23bb5af6e3fc6c2c51f0215c

Best regards,
-- 
Jens Axboe




^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2023-09-26  6:43 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2023-09-26  0:52 [PATCH] block: fix kernel-doc for disk_force_media_change() Randy Dunlap
2023-09-26  6:04 ` Christoph Hellwig
2023-09-26  6:43 ` Jens Axboe

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.