All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Rafael J. Wysocki" <rjw@rjwysocki.net>
To: Suravee Suthikulpanit <Suravee.Suthikulpanit@amd.com>
Cc: lenb@kernel.org, hdegoede@redhat.com, tj@kernel.org,
	arnd@arndb.de, mjg59@srcf.ucam.org, grant.likely@linaro.org,
	hanjun.guo@linaro.org, al.stone@linaro.org,
	graeme.gregory@linaro.org, leo.duran@amd.com,
	linux-ide@vger.kernel.org, linux-acpi@vger.kernel.org,
	linux-kernel@vger.kernel.org, linaro-acpi@lists.linaro.org
Subject: Re: [V2 PATCH 0/2] Introduce ACPI support for ahci_platform driver
Date: Tue, 06 Jan 2015 00:24:01 +0100	[thread overview]
Message-ID: <2457489.S2ztcy2W3i@vostro.rjw.lan> (raw)
In-Reply-To: <1420492275-6878-1-git-send-email-Suravee.Suthikulpanit@amd.com>

On Monday, January 05, 2015 03:11:13 PM Suravee Suthikulpanit wrote:
> This patch series introduce ACPI support for non-PCI AHCI platform driver.
> Existing ACPI support for AHCI assumes the device controller is a PCI device.
> 
> Also, since there is no ACPI _HID/_CID for generic AHCI controller, the driver
> could not use them for matching devices. Therefore, this patch introduces
> a mechanism for drivers to match devices using ACPI _CLS method.
> 
> This patch series is rebased from and tested with:
> 
>     http://git.linaro.org/leg/acpi/acpi.git acpi-5.1-v7
> 
> This topic was discussed earlier here (as part of introducing support for
> AMD Seattle SATA controller):
> 
>     http://marc.info/?l=linux-arm-kernel&m=141083492521584&w=2
> 
> NOTE:
> 	* PATCH 2/2 has already been Acked-by Tejun Heo in V1. I only made
> 	  a minor renaming of the acpi_cls to acpi_match_cls for clarity
> 	  in V2. It probably should be routed together with the PATCH 1/2
> 	  (once acked) since it defines the new member in the struct.
> 
> Changes V1 (https://lkml.org/lkml/2014/12/19/345)
> 	* Rebased to 3.19.0-rc2
> 	* Change from acpi_cls in device_driver to acpi_match_cls (Hanjun comment)
> 	* Change the matching logic in acpi_driver_match_device() due to the new
> 	  special PRP0001 _HID.
> 	* Simplify the return type of acpi_match_device_cls() to boolean.
> 
> Changes from RFC (https://lkml.org/lkml/2014/12/17/446)
> 	* Remove #ifdef and make non-ACPI version of the acpi_match_device_cls
> 	  as inline. (per Arnd)
> 	* Simplify logic to retrieve and evaluate _CLS handle. (per Hanjun)
> 
> Suravee Suthikulpanit (2):
>   ACPI / scan: Add support for ACPI _CLS device matching
>   ata: ahci_platform: Add ACPI _CLS matching
> 
>  drivers/acpi/scan.c             | 79 +++++++++++++++++++++++++++++++++++++++--
>  drivers/ata/Kconfig             |  2 +-
>  drivers/ata/ahci_platform.c     |  3 ++
>  include/acpi/acnames.h          |  1 +
>  include/linux/acpi.h            | 10 ++++++
>  include/linux/device.h          |  1 +
>  include/linux/mod_devicetable.h |  6 ++++
>  7 files changed, 98 insertions(+), 4 deletions(-)

I'll take care of this when I'm back from travels later this month.  Thanks!

-- 
I speak only for myself.
Rafael J. Wysocki, Intel Open Source Technology Center.

  parent reply	other threads:[~2015-01-05 23:24 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-01-05 21:11 [V2 PATCH 0/2] Introduce ACPI support for ahci_platform driver Suravee Suthikulpanit
2015-01-05 21:11 ` Suravee Suthikulpanit
2015-01-05 21:11 ` [V2 PATCH 1/2] ACPI / scan: Add support for ACPI _CLS device matching Suravee Suthikulpanit
2015-01-05 21:11   ` Suravee Suthikulpanit
2015-01-21 22:40   ` Rafael J. Wysocki
2015-02-08 16:18     ` Suravee Suthikulpanit
2015-02-08 16:18       ` Suravee Suthikulpanit
2015-01-05 21:11 ` [V2 PATCH 2/2] ata: ahci_platform: Add ACPI _CLS matching Suravee Suthikulpanit
2015-01-05 21:11   ` Suravee Suthikulpanit
2015-01-05 23:24 ` Rafael J. Wysocki [this message]
2015-01-07 21:40   ` [V2 PATCH 0/2] Introduce ACPI support for ahci_platform driver Suravee Suthikulanit
2015-01-07 21:40     ` Suravee Suthikulanit

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2457489.S2ztcy2W3i@vostro.rjw.lan \
    --to=rjw@rjwysocki.net \
    --cc=Suravee.Suthikulpanit@amd.com \
    --cc=al.stone@linaro.org \
    --cc=arnd@arndb.de \
    --cc=graeme.gregory@linaro.org \
    --cc=grant.likely@linaro.org \
    --cc=hanjun.guo@linaro.org \
    --cc=hdegoede@redhat.com \
    --cc=lenb@kernel.org \
    --cc=leo.duran@amd.com \
    --cc=linaro-acpi@lists.linaro.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-ide@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mjg59@srcf.ucam.org \
    --cc=tj@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.