All of lore.kernel.org
 help / color / mirror / Atom feed
From: Dmitry Safonov <dsafonov@virtuozzo.com>
To: Thomas Gleixner <tglx@linutronix.de>,
	Dmitry Safonov <0x7f454c46@gmail.com>
Cc: Borislav Petkov <bp@alien8.de>,
	open list <linux-kernel@vger.kernel.org>,
	Ingo Molnar <mingo@redhat.com>, "H. Peter Anvin" <hpa@zytor.com>,
	Andy Lutomirski <luto@kernel.org>, Borislav Petkov <bp@suse.de>,
	X86 ML <x86@kernel.org>, <linux-mm@kvack.org>
Subject: Re: [PATCHv4 1/5] x86/mm: split arch_mmap_rnd() on compat/native versions
Date: Mon, 13 Feb 2017 14:12:55 +0300	[thread overview]
Message-ID: <3a275384-0c4a-5334-f31b-5fadda9d8ee9@virtuozzo.com> (raw)
In-Reply-To: <alpine.DEB.2.20.1702110919370.3734@nanos>

On 02/11/2017 11:23 AM, Thomas Gleixner wrote:
> On Sat, 11 Feb 2017, Dmitry Safonov wrote:
>
>> 2017-02-10 23:10 GMT+03:00 Thomas Gleixner <tglx@linutronix.de>:
>>> On Thu, 9 Feb 2017, Borislav Petkov wrote:
>>>> I can't say that I'm thrilled about the ifdeffery this is adding.
>>>>
>>>> But I can't think of a cleaner approach at a quick glance, though -
>>>> that's generic and arch-specific code intertwined muck. Sad face.
>>>
>>> It's trivial enough to do ....
>>>
>>> Thanks,
>>>
>>>         tglx
>>>
>>> ---
>>>  arch/x86/mm/mmap.c |   22 ++++++++++------------
>>>  1 file changed, 10 insertions(+), 12 deletions(-)
>>>
>>> --- a/arch/x86/mm/mmap.c
>>> +++ b/arch/x86/mm/mmap.c
>>> @@ -55,6 +55,10 @@ static unsigned long stack_maxrandom_siz
>>>  #define MIN_GAP (128*1024*1024UL + stack_maxrandom_size())
>>>  #define MAX_GAP (TASK_SIZE/6*5)
>>>
>>> +#ifndef CONFIG_COMPAT
>>> +# define mmap_rnd_compat_bits  mmap_rnd_bits
>>> +#endif
>>> +
>>
>> >From my POV, I can't say that it's clearer to shadow mmap_compat_bits
>> like that then to have two functions with native/compat names.
>> But if you insist, I'll resend patches set with your version.
>
> You can make that
>
> #ifdef CONFIG_64BIT
> # define mmap32_rnd_bits  mmap_compat_rnd_bits
> # define mmap64_rnd_bits  mmap_rnd_bits
> #else
> # define mmap32_rnd_bits  mmap_rnd_bits
> # define mmap64_rnd_bits  mmap_rnd_bits
> #endif
>
> and use that. That's still way more readable than the unholy ifdef mess.

Ok, will send this version in v5.
Ping me if you mind me using your SOB for this patch.

>
> Thanks,
>
> 	tglx
>


-- 
              Dmitry

WARNING: multiple messages have this Message-ID (diff)
From: Dmitry Safonov <dsafonov@virtuozzo.com>
To: Thomas Gleixner <tglx@linutronix.de>,
	Dmitry Safonov <0x7f454c46@gmail.com>
Cc: Borislav Petkov <bp@alien8.de>,
	open list <linux-kernel@vger.kernel.org>,
	Ingo Molnar <mingo@redhat.com>, "H. Peter Anvin" <hpa@zytor.com>,
	Andy Lutomirski <luto@kernel.org>, Borislav Petkov <bp@suse.de>,
	X86 ML <x86@kernel.org>,
	linux-mm@kvack.org
Subject: Re: [PATCHv4 1/5] x86/mm: split arch_mmap_rnd() on compat/native versions
Date: Mon, 13 Feb 2017 14:12:55 +0300	[thread overview]
Message-ID: <3a275384-0c4a-5334-f31b-5fadda9d8ee9@virtuozzo.com> (raw)
In-Reply-To: <alpine.DEB.2.20.1702110919370.3734@nanos>

On 02/11/2017 11:23 AM, Thomas Gleixner wrote:
> On Sat, 11 Feb 2017, Dmitry Safonov wrote:
>
>> 2017-02-10 23:10 GMT+03:00 Thomas Gleixner <tglx@linutronix.de>:
>>> On Thu, 9 Feb 2017, Borislav Petkov wrote:
>>>> I can't say that I'm thrilled about the ifdeffery this is adding.
>>>>
>>>> But I can't think of a cleaner approach at a quick glance, though -
>>>> that's generic and arch-specific code intertwined muck. Sad face.
>>>
>>> It's trivial enough to do ....
>>>
>>> Thanks,
>>>
>>>         tglx
>>>
>>> ---
>>>  arch/x86/mm/mmap.c |   22 ++++++++++------------
>>>  1 file changed, 10 insertions(+), 12 deletions(-)
>>>
>>> --- a/arch/x86/mm/mmap.c
>>> +++ b/arch/x86/mm/mmap.c
>>> @@ -55,6 +55,10 @@ static unsigned long stack_maxrandom_siz
>>>  #define MIN_GAP (128*1024*1024UL + stack_maxrandom_size())
>>>  #define MAX_GAP (TASK_SIZE/6*5)
>>>
>>> +#ifndef CONFIG_COMPAT
>>> +# define mmap_rnd_compat_bits  mmap_rnd_bits
>>> +#endif
>>> +
>>
>> >From my POV, I can't say that it's clearer to shadow mmap_compat_bits
>> like that then to have two functions with native/compat names.
>> But if you insist, I'll resend patches set with your version.
>
> You can make that
>
> #ifdef CONFIG_64BIT
> # define mmap32_rnd_bits  mmap_compat_rnd_bits
> # define mmap64_rnd_bits  mmap_rnd_bits
> #else
> # define mmap32_rnd_bits  mmap_rnd_bits
> # define mmap64_rnd_bits  mmap_rnd_bits
> #endif
>
> and use that. That's still way more readable than the unholy ifdef mess.

Ok, will send this version in v5.
Ping me if you mind me using your SOB for this patch.

>
> Thanks,
>
> 	tglx
>


-- 
              Dmitry

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>

  reply	other threads:[~2017-02-13 11:16 UTC|newest]

Thread overview: 49+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-01-30 12:04 [PATCHv4 0/5] Fix compatible mmap() return pointer over 4Gb Dmitry Safonov
2017-01-30 12:04 ` Dmitry Safonov
2017-01-30 12:04 ` [PATCHv4 1/5] x86/mm: split arch_mmap_rnd() on compat/native versions Dmitry Safonov
2017-01-30 12:04   ` Dmitry Safonov
2017-02-09 13:55   ` Borislav Petkov
2017-02-09 23:06     ` Andy Lutomirski
2017-02-09 23:06       ` Andy Lutomirski
2017-02-10 20:10     ` Thomas Gleixner
2017-02-10 20:10       ` Thomas Gleixner
2017-02-10 20:25       ` Borislav Petkov
2017-02-10 20:25         ` Borislav Petkov
2017-02-10 21:28       ` Dmitry Safonov
2017-02-10 21:28         ` Dmitry Safonov
2017-02-11  8:23         ` Thomas Gleixner
2017-02-11  8:23           ` Thomas Gleixner
2017-02-13 11:12           ` Dmitry Safonov [this message]
2017-02-13 11:12             ` Dmitry Safonov
2017-02-13 11:22             ` Thomas Gleixner
2017-02-13 11:22               ` Thomas Gleixner
2017-01-30 12:04 ` [PATCHv4 2/5] x86/mm: introduce mmap{,_legacy}_base Dmitry Safonov
2017-01-30 12:04   ` Dmitry Safonov
2017-02-11 14:13   ` Thomas Gleixner
2017-02-11 14:13     ` Thomas Gleixner
2017-02-13 13:02     ` Dmitry Safonov
2017-02-13 13:02       ` Dmitry Safonov
2017-02-13 13:13       ` Thomas Gleixner
2017-02-13 13:13         ` Thomas Gleixner
2017-02-13 14:37     ` Dmitry Safonov
2017-02-13 14:37       ` Dmitry Safonov
2017-02-13 15:35       ` Thomas Gleixner
2017-02-13 15:35         ` Thomas Gleixner
2017-01-30 12:04 ` [PATCHv4 3/5] x86/mm: fix 32-bit mmap() for 64-bit ELF Dmitry Safonov
2017-01-30 12:04   ` Dmitry Safonov
2017-02-11 19:49   ` Thomas Gleixner
2017-02-11 19:49     ` Thomas Gleixner
2017-02-14 15:24     ` Dmitry Safonov
2017-02-14 15:24       ` Dmitry Safonov
2017-01-30 12:04 ` [PATCHv4 4/5] x86/mm: check in_compat_syscall() instead TIF_ADDR32 for mmap(MAP_32BIT) Dmitry Safonov
2017-01-30 12:04   ` Dmitry Safonov
2017-02-11 20:13   ` Thomas Gleixner
2017-02-11 20:13     ` Thomas Gleixner
2017-02-14 16:11     ` Dmitry Safonov
2017-02-14 16:11       ` Dmitry Safonov
2017-02-14 16:14       ` Dmitry Safonov
2017-02-14 16:14         ` Dmitry Safonov
2017-01-30 12:04 ` [PATCHv4 5/5] selftests/x86: add test to check compat mmap() return addr Dmitry Safonov
2017-01-30 12:04   ` Dmitry Safonov
2017-02-06 16:46 ` [PATCHv4 0/5] Fix compatible mmap() return pointer over 4Gb Dmitry Safonov
2017-02-06 16:46   ` Dmitry Safonov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=3a275384-0c4a-5334-f31b-5fadda9d8ee9@virtuozzo.com \
    --to=dsafonov@virtuozzo.com \
    --cc=0x7f454c46@gmail.com \
    --cc=bp@alien8.de \
    --cc=bp@suse.de \
    --cc=hpa@zytor.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=luto@kernel.org \
    --cc=mingo@redhat.com \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.