All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jacek Anaszewski <jacek.anaszewski@gmail.com>
To: Simon Shields <simon@lineageos.org>, linux-leds@vger.kernel.org
Cc: Pavel Machek <pavel@ucw.cz>, Rob Herring <robh+dt@kernel.org>,
	Mark Rutland <mark.rutland@arm.com>,
	"open list:OPEN FIRMWARE AND FLATTENED DEVICE TREE BINDINGS"
	<devicetree@vger.kernel.org>,
	open list <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v5 0/2] Panasonic AN30259A support
Date: Mon, 10 Sep 2018 21:33:53 +0200	[thread overview]
Message-ID: <3bafc642-db6c-e872-cca5-8f654f38224a@gmail.com> (raw)
In-Reply-To: <20180909103826.17793-1-simon@lineageos.org>

Hi Simon,

Thank you for the updated set.

On 09/09/2018 12:38 PM, Simon Shields wrote:
> Hi,
> 
> This patch series adds DT bindings (patch #1) and the corresponding driver
> (patch #2) for the Panasonic AN30259A 3-channel LED driver. AN30259A
> uses an internal clock for controlling brightness/on-off cycles, but
> also supports using an external PWM/clock input. This patch series only
> implements support for the former.
> 
> The AN30259A is connected using I2C, and the datasheet is freely
> available[0].
> 
> Changes since v4 (mistakenly sent as v3):
> * Rebased on v4.19-rc2
> * Namespace all macros with AN30259A_ prefix
> * Fix trivial compiler/checkpatch --strict warnings
> 
> Changes since v3:
> * Rebased on v4.18-rc3.
> * Drop unnecessary DUTYMAX/MID calculations when blinking:
>  previously I'd thought that the PWM duty values were expressed
>  as a percentage of the maximum current output, but in reality
>  they're a percentage of the current set in the LEDxCC registers.
> This simplifies the code quite a bit.
> * Corrected MODULE_LICENSE declaration.
> * Return -EINVAL from set_blink if the blink rate is unsupported in
>  hardware.
> * Fix more checkpatch --strict issues.
> 
> Changes since v2:
> * Drop "an30259a:" prefix from bindings and add it in the device driver
>  instead.
> * Use led-controller instead of leds for sample DT binding.
> * Use ":indicator" instead of ":notification" in sample DT binding.
> * Merge an30259a_led_set and an30259a_brightness to
>  an30259a_brightness_set (and same for blink functions).
> * Explain the range limitations of the AN30259A's sloping mode
>  in the code - the AN30259A only has a 7-bit PWM range in slope mode,
>  and the bottom 3 bits are always set.
> 
> Changes since v1:
> * Documentation formatting/grammar fixes.
> * Use reg property instead of led-sources for leds.
> * Add default-state support.
> * Fix auto-probing when built as a module.
> * Simplified DT parsing code.
> * Use devm version of led_class_register().
> * Fix LED naming scheme.
> * Fixed checkpatch --strict issues.
> 
> Cheers,
> Simon
> 
> [0]: https://www.alliedelec.com/m/d/a9d2b3ee87c2d1a535a41dd747b1c247.pdf
> 
> Simon Shields (2):
>   dt-bindings: leds: document Panasonic AN30259A bindings
>   leds: add Panasonic AN30259A support
> 
>  .../bindings/leds/leds-an30259a.txt           |  43 ++
>  drivers/leds/Kconfig                          |  10 +
>  drivers/leds/Makefile                         |   1 +
>  drivers/leds/leds-an30259a.c                  | 368 ++++++++++++++++++
>  4 files changed, 422 insertions(+)
>  create mode 100644 Documentation/devicetree/bindings/leds/leds-an30259a.txt
>  create mode 100644 drivers/leds/leds-an30259a.c
> 

Applied to the for-next branch of linux-leds.git.

-- 
Best regards,
Jacek Anaszewski

  parent reply	other threads:[~2018-09-10 19:33 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-09-09 10:38 [PATCH v5 0/2] Panasonic AN30259A support Simon Shields
2018-09-09 10:38 ` Simon Shields
2018-09-09 10:38 ` [PATCH v5 1/2] dt-bindings: leds: document Panasonic AN30259A bindings Simon Shields
2018-09-09 10:38   ` Simon Shields
2018-09-09 10:38 ` [PATCH v5 2/2] leds: add Panasonic AN30259A support Simon Shields
2018-09-09 10:38   ` Simon Shields
2018-09-10 19:33 ` Jacek Anaszewski [this message]
2018-09-10 19:33   ` [PATCH v5 0/2] " Jacek Anaszewski

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=3bafc642-db6c-e872-cca5-8f654f38224a@gmail.com \
    --to=jacek.anaszewski@gmail.com \
    --cc=devicetree@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-leds@vger.kernel.org \
    --cc=mark.rutland@arm.com \
    --cc=pavel@ucw.cz \
    --cc=robh+dt@kernel.org \
    --cc=simon@lineageos.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.