All of lore.kernel.org
 help / color / mirror / Atom feed
From: Khalid Aziz <khalid.aziz@oracle.com>
To: Christoph Hellwig <hch@lst.de>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Paul Burton <paul.burton@mips.com>,
	James Hogan <jhogan@kernel.org>,
	Yoshinori Sato <ysato@users.sourceforge.jp>,
	Rich Felker <dalias@libc.org>,
	"David S. Miller" <davem@davemloft.net>,
	Andrey Konovalov <andreyknvl@google.com>
Cc: Nicholas Piggin <npiggin@gmail.com>,
	Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Paul Mackerras <paulus@samba.org>,
	Michael Ellerman <mpe@ellerman.id.au>,
	linux-mips@vger.kernel.org, linux-sh@vger.kernel.org,
	sparclinux@vger.kernel.org, linuxppc-dev@lists.ozlabs.org,
	linux-mm@kvack.org, x86@kernel.org, linux-kernel@vger.kernel.org,
	Catalin Marinas <catalin.marinas@arm.com>
Subject: Re: [PATCH 01/16] uaccess: add untagged_addr definition for other arches
Date: Mon, 03 Jun 2019 15:16:08 +0000	[thread overview]
Message-ID: <431c7395-2327-2f7c-cc8f-b01412b74e10@oracle.com> (raw)
In-Reply-To: <20190601074959.14036-2-hch@lst.de>

On 6/1/19 1:49 AM, Christoph Hellwig wrote:
> From: Andrey Konovalov <andreyknvl@google.com>
> 
> To allow arm64 syscalls to accept tagged pointers from userspace, we must
> untag them when they are passed to the kernel. Since untagging is done in
> generic parts of the kernel, the untagged_addr macro needs to be defined
> for all architectures.
> 
> Define it as a noop for architectures other than arm64.

Could you reword above sentence? We are already starting off with
untagged_addr() not being no-op for arm64 and sparc64. It will expand
further potentially. So something more along the lines of "Define it as
noop for architectures that do not support memory tagging". The first
paragraph in the log can also be rewritten to be not specific to arm64.

--
Khalid

> 
> Acked-by: Catalin Marinas <catalin.marinas@arm.com>
> Signed-off-by: Andrey Konovalov <andreyknvl@google.com>
> Signed-off-by: Christoph Hellwig <hch@lst.de>
> ---
>  include/linux/mm.h | 4 ++++
>  1 file changed, 4 insertions(+)
> 
> diff --git a/include/linux/mm.h b/include/linux/mm.h
> index 0e8834ac32b7..949d43e9c0b6 100644
> --- a/include/linux/mm.h
> +++ b/include/linux/mm.h
> @@ -99,6 +99,10 @@ extern int mmap_rnd_compat_bits __read_mostly;
>  #include <asm/pgtable.h>
>  #include <asm/processor.h>
>  
> +#ifndef untagged_addr
> +#define untagged_addr(addr) (addr)
> +#endif
> +
>  #ifndef __pa_symbol
>  #define __pa_symbol(x)  __pa(RELOC_HIDE((unsigned long)(x), 0))
>  #endif
> 

WARNING: multiple messages have this Message-ID (diff)
From: Khalid Aziz <khalid.aziz@oracle.com>
To: Christoph Hellwig <hch@lst.de>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Paul Burton <paul.burton@mips.com>,
	James Hogan <jhogan@kernel.org>,
	Yoshinori Sato <ysato@users.sourceforge.jp>,
	Rich Felker <dalias@libc.org>,
	"David S. Miller" <davem@davemloft.net>,
	Andrey Konovalov <andreyknvl@google.com>
Cc: Nicholas Piggin <npiggin@gmail.com>,
	Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Paul Mackerras <paulus@samba.org>,
	Michael Ellerman <mpe@ellerman.id.au>,
	linux-mips@vger.kernel.org, linux-sh@vger.kernel.org,
	sparclinux@vger.kernel.org, linuxppc-dev@lists.ozlabs.org,
	linux-mm@kvack.org, x86@kernel.org, linux-kernel@vger.kernel.org,
	Catalin Marinas <catalin.marinas@arm.com>
Subject: Re: [PATCH 01/16] uaccess: add untagged_addr definition for other arches
Date: Mon, 3 Jun 2019 09:16:08 -0600	[thread overview]
Message-ID: <431c7395-2327-2f7c-cc8f-b01412b74e10@oracle.com> (raw)
In-Reply-To: <20190601074959.14036-2-hch@lst.de>

On 6/1/19 1:49 AM, Christoph Hellwig wrote:
> From: Andrey Konovalov <andreyknvl@google.com>
> 
> To allow arm64 syscalls to accept tagged pointers from userspace, we must
> untag them when they are passed to the kernel. Since untagging is done in
> generic parts of the kernel, the untagged_addr macro needs to be defined
> for all architectures.
> 
> Define it as a noop for architectures other than arm64.

Could you reword above sentence? We are already starting off with
untagged_addr() not being no-op for arm64 and sparc64. It will expand
further potentially. So something more along the lines of "Define it as
noop for architectures that do not support memory tagging". The first
paragraph in the log can also be rewritten to be not specific to arm64.

--
Khalid

> 
> Acked-by: Catalin Marinas <catalin.marinas@arm.com>
> Signed-off-by: Andrey Konovalov <andreyknvl@google.com>
> Signed-off-by: Christoph Hellwig <hch@lst.de>
> ---
>  include/linux/mm.h | 4 ++++
>  1 file changed, 4 insertions(+)
> 
> diff --git a/include/linux/mm.h b/include/linux/mm.h
> index 0e8834ac32b7..949d43e9c0b6 100644
> --- a/include/linux/mm.h
> +++ b/include/linux/mm.h
> @@ -99,6 +99,10 @@ extern int mmap_rnd_compat_bits __read_mostly;
>  #include <asm/pgtable.h>
>  #include <asm/processor.h>
>  
> +#ifndef untagged_addr
> +#define untagged_addr(addr) (addr)
> +#endif
> +
>  #ifndef __pa_symbol
>  #define __pa_symbol(x)  __pa(RELOC_HIDE((unsigned long)(x), 0))
>  #endif
> 


WARNING: multiple messages have this Message-ID (diff)
From: Khalid Aziz <khalid.aziz@oracle.com>
To: Christoph Hellwig <hch@lst.de>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Paul Burton <paul.burton@mips.com>,
	James Hogan <jhogan@kernel.org>,
	Yoshinori Sato <ysato@users.sourceforge.jp>,
	Rich Felker <dalias@libc.org>,
	"David S. Miller" <davem@davemloft.net>,
	Andrey Konovalov <andreyknvl@google.com>
Cc: Catalin Marinas <catalin.marinas@arm.com>,
	linux-sh@vger.kernel.org, x86@kernel.org,
	linux-mips@vger.kernel.org, Nicholas Piggin <npiggin@gmail.com>,
	linux-kernel@vger.kernel.org, linux-mm@kvack.org,
	Paul Mackerras <paulus@samba.org>,
	sparclinux@vger.kernel.org, linuxppc-dev@lists.ozlabs.org
Subject: Re: [PATCH 01/16] uaccess: add untagged_addr definition for other arches
Date: Mon, 3 Jun 2019 09:16:08 -0600	[thread overview]
Message-ID: <431c7395-2327-2f7c-cc8f-b01412b74e10@oracle.com> (raw)
In-Reply-To: <20190601074959.14036-2-hch@lst.de>

On 6/1/19 1:49 AM, Christoph Hellwig wrote:
> From: Andrey Konovalov <andreyknvl@google.com>
> 
> To allow arm64 syscalls to accept tagged pointers from userspace, we must
> untag them when they are passed to the kernel. Since untagging is done in
> generic parts of the kernel, the untagged_addr macro needs to be defined
> for all architectures.
> 
> Define it as a noop for architectures other than arm64.

Could you reword above sentence? We are already starting off with
untagged_addr() not being no-op for arm64 and sparc64. It will expand
further potentially. So something more along the lines of "Define it as
noop for architectures that do not support memory tagging". The first
paragraph in the log can also be rewritten to be not specific to arm64.

--
Khalid

> 
> Acked-by: Catalin Marinas <catalin.marinas@arm.com>
> Signed-off-by: Andrey Konovalov <andreyknvl@google.com>
> Signed-off-by: Christoph Hellwig <hch@lst.de>
> ---
>  include/linux/mm.h | 4 ++++
>  1 file changed, 4 insertions(+)
> 
> diff --git a/include/linux/mm.h b/include/linux/mm.h
> index 0e8834ac32b7..949d43e9c0b6 100644
> --- a/include/linux/mm.h
> +++ b/include/linux/mm.h
> @@ -99,6 +99,10 @@ extern int mmap_rnd_compat_bits __read_mostly;
>  #include <asm/pgtable.h>
>  #include <asm/processor.h>
>  
> +#ifndef untagged_addr
> +#define untagged_addr(addr) (addr)
> +#endif
> +
>  #ifndef __pa_symbol
>  #define __pa_symbol(x)  __pa(RELOC_HIDE((unsigned long)(x), 0))
>  #endif
> 


  reply	other threads:[~2019-06-03 15:16 UTC|newest]

Thread overview: 133+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-05-25 13:31 RFC: switch the remaining architectures to use generic GUP Christoph Hellwig
2019-05-25 13:31 ` Christoph Hellwig
2019-05-25 13:31 ` [PATCH 1/6] MIPS: use the generic get_user_pages_fast code Christoph Hellwig
2019-05-25 13:31   ` Christoph Hellwig
2019-05-25 13:31 ` [PATCH 2/6] sh: add a missing pud_page definition Christoph Hellwig
2019-05-25 13:31   ` Christoph Hellwig
2019-05-25 13:32 ` [PATCH 3/6] sh: use the generic get_user_pages_fast code Christoph Hellwig
2019-05-25 13:32   ` Christoph Hellwig
2019-05-25 13:32 ` [PATCH 4/6] mm: add a gup_fixup_start_addr hook Christoph Hellwig
2019-05-25 13:32   ` Christoph Hellwig
2019-05-25 17:05   ` Linus Torvalds
2019-05-25 17:05     ` Linus Torvalds
2019-05-25 17:05     ` Linus Torvalds
2019-05-28 15:57     ` Khalid Aziz
2019-05-28 15:57       ` Khalid Aziz
2019-05-29  7:26       ` Christoph Hellwig
2019-05-29  7:26         ` Christoph Hellwig
2019-05-29  8:19   ` Catalin Marinas
2019-05-29  8:19     ` Catalin Marinas
2019-05-29  8:19     ` Catalin Marinas
2019-05-25 13:32 ` [PATCH 5/6] sparc64: use the generic get_user_pages_fast code Christoph Hellwig
2019-05-25 13:32   ` Christoph Hellwig
2019-05-25 16:55   ` David Miller
2019-05-25 16:55     ` David Miller
2019-05-25 13:32 ` [PATCH 6/6] mm: don't allow non-generic get_user_pages_fast implementations Christoph Hellwig
2019-05-25 13:32   ` Christoph Hellwig
2019-05-25 17:07 ` RFC: switch the remaining architectures to use generic GUP Linus Torvalds
2019-05-25 17:07   ` Linus Torvalds
2019-05-25 17:07   ` Linus Torvalds
2019-05-25 17:39   ` Christoph Hellwig
2019-05-25 17:39     ` Christoph Hellwig
2019-06-01  7:49 ` RFC: switch the remaining architectures to use generic GUP v2 Christoph Hellwig
2019-06-01  7:49   ` Christoph Hellwig
2019-06-01  7:49   ` Christoph Hellwig
2019-06-01  7:49   ` [PATCH 01/16] uaccess: add untagged_addr definition for other arches Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-03 15:16     ` Khalid Aziz [this message]
2019-06-03 15:16       ` Khalid Aziz
2019-06-03 15:16       ` Khalid Aziz
2019-06-04  7:27       ` Christoph Hellwig
2019-06-04  7:27         ` Christoph Hellwig
2019-06-04  7:27         ` Christoph Hellwig
2019-06-04 11:46         ` Andrey Konovalov
2019-06-04 11:46           ` Andrey Konovalov
2019-06-04 11:46           ` Andrey Konovalov
2019-06-04 11:46           ` Andrey Konovalov
2019-06-01  7:49   ` [PATCH 02/16] mm: use untagged_addr() for get_user_pages_fast addresses Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49   ` [PATCH 03/16] mm: simplify gup_fast_permitted Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01 16:14     ` Linus Torvalds
2019-06-01 16:14       ` Linus Torvalds
2019-06-01 16:14       ` Linus Torvalds
2019-06-01 16:14       ` Linus Torvalds
2019-06-03  7:41       ` Christoph Hellwig
2019-06-03  7:41         ` Christoph Hellwig
2019-06-03  7:41         ` Christoph Hellwig
2019-06-03 16:08         ` Linus Torvalds
2019-06-03 16:08           ` Linus Torvalds
2019-06-03 16:08           ` Linus Torvalds
2019-06-03 16:08           ` Linus Torvalds
2019-06-03 17:02           ` Linus Torvalds
2019-06-03 17:02             ` Linus Torvalds
2019-06-03 17:02             ` Linus Torvalds
2019-06-03 17:02             ` Linus Torvalds
2019-06-04  7:26             ` Christoph Hellwig
2019-06-04  7:26               ` Christoph Hellwig
2019-06-04  7:26               ` Christoph Hellwig
2019-06-01  7:49   ` [PATCH 04/16] mm: lift the x86_32 PAE version of gup_get_pte to common code Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49   ` [PATCH 05/16] MIPS: use the generic get_user_pages_fast code Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49   ` [PATCH 06/16] sh: add the missing pud_page definition Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49   ` [PATCH 07/16] sh: use the generic get_user_pages_fast code Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49   ` [PATCH 08/16] sparc64: add the missing pgd_page definition Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01 16:28     ` Linus Torvalds
2019-06-01 16:28       ` Linus Torvalds
2019-06-01 16:28       ` Linus Torvalds
2019-06-01 16:28       ` Linus Torvalds
2019-06-03  7:44       ` Christoph Hellwig
2019-06-03  7:44         ` Christoph Hellwig
2019-06-03  7:44         ` Christoph Hellwig
2019-06-01  7:49   ` [PATCH 09/16] sparc64: define untagged_addr() Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49   ` [PATCH 10/16] sparc64: use the generic get_user_pages_fast code Christoph Hellwig
2019-06-02  7:39     ` Hillf Danton
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-03  7:44     ` Christoph Hellwig
2019-06-03  7:44       ` Christoph Hellwig
2019-06-03  7:44       ` Christoph Hellwig
2019-06-01  7:49   ` [PATCH 11/16] mm: rename CONFIG_HAVE_GENERIC_GUP to CONFIG_HAVE_FAST_GUP Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49   ` [PATCH 12/16] mm: consolidate the get_user_pages* implementations Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-06  6:01     ` John Hubbard
2019-06-06  6:01       ` John Hubbard
2019-06-06  6:01       ` John Hubbard
2019-06-06  6:20       ` Christoph Hellwig
2019-06-06  6:20         ` Christoph Hellwig
2019-06-06  6:20         ` Christoph Hellwig
2019-06-06  7:44         ` John Hubbard
2019-06-06  7:44           ` John Hubbard
2019-06-06  7:44           ` John Hubbard
2019-06-01  7:49   ` [PATCH 13/16] mm: validate get_user_pages_fast flags Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49   ` [PATCH 14/16] mm: move the powerpc hugepd code to mm/gup.c Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49   ` [PATCH 15/16] mm: switch gup_hugepte to use try_get_compound_head Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49   ` [PATCH 16/16] mm: mark the page referenced in gup_hugepte Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01  7:49     ` Christoph Hellwig
2019-06-01 23:46   ` RFC: switch the remaining architectures to use generic GUP v2 David Miller
2019-06-01 23:46     ` David Miller
2019-06-01 23:46     ` David Miller

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=431c7395-2327-2f7c-cc8f-b01412b74e10@oracle.com \
    --to=khalid.aziz@oracle.com \
    --cc=andreyknvl@google.com \
    --cc=benh@kernel.crashing.org \
    --cc=catalin.marinas@arm.com \
    --cc=dalias@libc.org \
    --cc=davem@davemloft.net \
    --cc=hch@lst.de \
    --cc=jhogan@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mips@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-sh@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=mpe@ellerman.id.au \
    --cc=npiggin@gmail.com \
    --cc=paul.burton@mips.com \
    --cc=paulus@samba.org \
    --cc=sparclinux@vger.kernel.org \
    --cc=torvalds@linux-foundation.org \
    --cc=x86@kernel.org \
    --cc=ysato@users.sourceforge.jp \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.