All of lore.kernel.org
 help / color / mirror / Atom feed
* [Qemu-devel] [PATCH v4 00/15] pflash: Fixes and cleanups
@ 2019-03-08  9:45 Markus Armbruster
  2019-03-08  9:45 ` [Qemu-devel] [PATCH v4 01/15] pflash: Rename pflash_t to PFlashCFI01, PFlashCFI02 Markus Armbruster
                   ` (14 more replies)
  0 siblings, 15 replies; 22+ messages in thread
From: Markus Armbruster @ 2019-03-08  9:45 UTC (permalink / raw)
  To: qemu-devel
  Cc: alex.bennee, lersek, kwolf, mreitz, qemu-block, qemu-ppc, philmd,
	balaton

Alex Bennée posted this patch to address an XXX comment in
pflash_cfi01_realize() the other day:

Subject: [PATCH v2] hw/block: report when pflash backing file isn't aligned
Message-Id: <20190215122808.22301-1-alex.bennee@linaro.org>
https://lists.nongnu.org/archive/html/qemu-devel/2019-02/msg04166.html

Review led me to look into its callers.  Most of them are pleasantly
boring: they create flash memory of some fixed size at some fixed
address.  A few are more creative, and some of the creative ones look
quite broken to me.  Fix them, and clean up some along the way.

v4:
* PATCH 01+04: Semantic rebase conflicts in pflash_cfi02_unrealize()
  resolved
* PATCH 07: New [David]
* PATCH 10: Replaces old PATCH 09
* PATCH 11,13-15: Straightforward rebase onto PATCH 10

v3:
* PATCH 07,13: Commit message typo
* PATCH 08: Replaced [Philippe, Magnus]
* PATCH 09-11: New [Philippe]
* PATCH 12: Straightforward rebase onto new patches
* PATCH 14: Commit message improved [Philippe], lines joined [Zoltan]

v2:
* PATCH 01+10: Style cleanups [checkpatch]
* PATCH 02: Rewritten [Peter, Philippe]
* PATCH 03+04: New [Philippe]
* PATCH 06: Commit message improved, FIXME added, accidental
  replacement of 64 * KiB by 65536 backed out [Zoltan]
* PATCH 07: Style tweak [Alex, David]
* PATCH 08: Commit message typo [Philippe]
* PATCH 11: Commit message typo [László]
* Old PATCH 10 dropped [Max, Peter]

Markus Armbruster (13):
  pflash: Rename pflash_t to PFlashCFI01, PFlashCFI02
  pflash_cfi01: Do not exit() on guest aborting "write to buffer"
  pflash_cfi01: Log use of flawed "write to buffer"
  pflash: Rename *CFI_PFLASH* to *PFLASH_CFI*
  hw: Use PFLASH_CFI0{1,2} and TYPE_PFLASH_CFI0{1,2}
  sam460ex: Don't size flash memory to match backing image
  ppc405_boards: Delete stale, disabled DEBUG_BOARD_INIT code
  ppc405_boards: Don't size flash memory to match backing image
  r2d: Fix flash memory size, sector size, width, device ID
  mips_malta: Delete disabled, broken DEBUG_BOARD_INIT code
  mips_malta: Clean up definition of flash memory size somewhat
  pflash: Clean up after commit 368a354f02b, part 1
  pflash: Clean up after commit 368a354f02b, part 2

Philippe Mathieu-Daudé (2):
  hw/mips/malta: Remove fl_sectors variable
  hw/mips/malta: Restrict 'bios_size' variable scope

 hw/arm/collie.c                          |   9 +-
 hw/arm/digic_boards.c                    |   3 +-
 hw/arm/gumstix.c                         |  10 +-
 hw/arm/mainstone.c                       |   5 +-
 hw/arm/musicpal.c                        |   8 +-
 hw/arm/omap_sx1.c                        |  10 +-
 hw/arm/versatilepb.c                     |   3 +-
 hw/arm/vexpress.c                        |  10 +-
 hw/arm/virt.c                            |   3 +-
 hw/arm/xilinx_zynq.c                     |   7 +-
 hw/arm/z2.c                              |   6 +-
 hw/block/pflash_cfi01.c                  | 123 ++++++++++++-----------
 hw/block/pflash_cfi02.c                  |  81 +++++++--------
 hw/i386/pc_sysfw.c                       |  10 +-
 hw/lm32/lm32_boards.c                    |   8 +-
 hw/lm32/milkymist.c                      |   5 +-
 hw/microblaze/petalogix_ml605_mmu.c      |   6 +-
 hw/microblaze/petalogix_s3adsp1800_mmu.c |   5 +-
 hw/mips/mips_malta.c                     |  21 +---
 hw/mips/mips_r4k.c                       |   5 +-
 hw/ppc/ppc405_boards.c                   | 102 +++----------------
 hw/ppc/sam460ex.c                        |  42 +++++---
 hw/ppc/virtex_ml507.c                    |   5 +-
 hw/sh4/r2d.c                             |  17 +++-
 hw/xtensa/xtfpga.c                       |  12 +--
 include/hw/block/flash.h                 |  57 +++++++----
 26 files changed, 257 insertions(+), 316 deletions(-)

-- 
2.17.2

^ permalink raw reply	[flat|nested] 22+ messages in thread

end of thread, other threads:[~2019-03-08 13:04 UTC | newest]

Thread overview: 22+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-03-08  9:45 [Qemu-devel] [PATCH v4 00/15] pflash: Fixes and cleanups Markus Armbruster
2019-03-08  9:45 ` [Qemu-devel] [PATCH v4 01/15] pflash: Rename pflash_t to PFlashCFI01, PFlashCFI02 Markus Armbruster
2019-03-08  9:45 ` [Qemu-devel] [PATCH v4 02/15] pflash_cfi01: Do not exit() on guest aborting "write to buffer" Markus Armbruster
2019-03-08  9:45 ` [Qemu-devel] [PATCH v4 03/15] pflash_cfi01: Log use of flawed " Markus Armbruster
2019-03-08  9:45 ` [Qemu-devel] [PATCH v4 04/15] pflash: Rename *CFI_PFLASH* to *PFLASH_CFI* Markus Armbruster
2019-03-08  9:46 ` [Qemu-devel] [PATCH v4 05/15] hw: Use PFLASH_CFI0{1, 2} and TYPE_PFLASH_CFI0{1, 2} Markus Armbruster
2019-03-08  9:46 ` [Qemu-devel] [PATCH v4 06/15] sam460ex: Don't size flash memory to match backing image Markus Armbruster
2019-03-08  9:46 ` [Qemu-devel] [PATCH v4 07/15] ppc405_boards: Delete stale, disabled DEBUG_BOARD_INIT code Markus Armbruster
2019-03-08 10:45   ` Alex Bennée
2019-03-08  9:46 ` [Qemu-devel] [PATCH v4 08/15] ppc405_boards: Don't size flash memory to match backing image Markus Armbruster
2019-03-08  9:46 ` [Qemu-devel] [PATCH v4 09/15] r2d: Fix flash memory size, sector size, width, device ID Markus Armbruster
2019-03-08 13:01   ` Philippe Mathieu-Daudé
2019-03-08  9:46 ` [Qemu-devel] [PATCH v4 10/15] mips_malta: Delete disabled, broken DEBUG_BOARD_INIT code Markus Armbruster
2019-03-08 10:47   ` Alex Bennée
2019-03-08 13:03   ` Philippe Mathieu-Daudé
2019-03-08  9:46 ` [Qemu-devel] [PATCH v4 11/15] hw/mips/malta: Remove fl_sectors variable Markus Armbruster
2019-03-08  9:46 ` [Qemu-devel] [PATCH v4 12/15] hw/mips/malta: Restrict 'bios_size' variable scope Markus Armbruster
2019-03-08  9:46 ` [Qemu-devel] [PATCH v4 13/15] mips_malta: Clean up definition of flash memory size somewhat Markus Armbruster
2019-03-08 12:32   ` Philippe Mathieu-Daudé
2019-03-08 13:04     ` Philippe Mathieu-Daudé
2019-03-08  9:46 ` [Qemu-devel] [PATCH v4 14/15] pflash: Clean up after commit 368a354f02b, part 1 Markus Armbruster
2019-03-08  9:46 ` [Qemu-devel] [PATCH v4 15/15] pflash: Clean up after commit 368a354f02b, part 2 Markus Armbruster

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.