All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] hugetlbfs: correct obsolete function name hugetlbfs_read_iter()
@ 2021-01-16  9:32 Miaohe Lin
  2021-01-16  9:36   ` Souptick Joarder
  0 siblings, 1 reply; 4+ messages in thread
From: Miaohe Lin @ 2021-01-16  9:32 UTC (permalink / raw)
  To: mike.kravetz; +Cc: linux-mm, linux-kernel, linmiaohe

The func do_generic_mapping_read() is killed by commit 36e789144267 ("kill
do_generic_mapping_read"). So replace it with do_generic_mapping_read to
keep comment uptodate.

Signed-off-by: Miaohe Lin <linmiaohe@huawei.com>
---
 fs/hugetlbfs/inode.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/fs/hugetlbfs/inode.c b/fs/hugetlbfs/inode.c
index 23ad6ed8b75f..d02616513b43 100644
--- a/fs/hugetlbfs/inode.c
+++ b/fs/hugetlbfs/inode.c
@@ -310,7 +310,7 @@ hugetlbfs_read_actor(struct page *page, unsigned long offset,
 
 /*
  * Support for read() - Find the page attached to f_mapping and copy out the
- * data. Its *very* similar to do_generic_mapping_read(), we can't use that
+ * data. Its *very* similar to generic_file_buffered_read(), we can't use that
  * since it has PAGE_SIZE assumptions.
  */
 static ssize_t hugetlbfs_read_iter(struct kiocb *iocb, struct iov_iter *to)
-- 
2.19.1


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH] hugetlbfs: correct obsolete function name hugetlbfs_read_iter()
  2021-01-16  9:32 [PATCH] hugetlbfs: correct obsolete function name hugetlbfs_read_iter() Miaohe Lin
@ 2021-01-16  9:36   ` Souptick Joarder
  0 siblings, 0 replies; 4+ messages in thread
From: Souptick Joarder @ 2021-01-16  9:36 UTC (permalink / raw)
  To: Miaohe Lin; +Cc: Mike Kravetz, Linux-MM, linux-kernel

On Sat, Jan 16, 2021 at 3:03 PM Miaohe Lin <linmiaohe@huawei.com> wrote:
>
> The func do_generic_mapping_read() is killed by commit 36e789144267 ("kill
> do_generic_mapping_read"). So replace it with do_generic_mapping_read to
> keep comment uptodate.

s/func/function

replace it with generic_file_buffered_read()  ?

>
> Signed-off-by: Miaohe Lin <linmiaohe@huawei.com>
> ---
>  fs/hugetlbfs/inode.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/fs/hugetlbfs/inode.c b/fs/hugetlbfs/inode.c
> index 23ad6ed8b75f..d02616513b43 100644
> --- a/fs/hugetlbfs/inode.c
> +++ b/fs/hugetlbfs/inode.c
> @@ -310,7 +310,7 @@ hugetlbfs_read_actor(struct page *page, unsigned long offset,
>
>  /*
>   * Support for read() - Find the page attached to f_mapping and copy out the
> - * data. Its *very* similar to do_generic_mapping_read(), we can't use that
> + * data. Its *very* similar to generic_file_buffered_read(), we can't use that
>   * since it has PAGE_SIZE assumptions.
>   */
>  static ssize_t hugetlbfs_read_iter(struct kiocb *iocb, struct iov_iter *to)
> --
> 2.19.1
>
>

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] hugetlbfs: correct obsolete function name hugetlbfs_read_iter()
@ 2021-01-16  9:36   ` Souptick Joarder
  0 siblings, 0 replies; 4+ messages in thread
From: Souptick Joarder @ 2021-01-16  9:36 UTC (permalink / raw)
  To: Miaohe Lin; +Cc: Mike Kravetz, Linux-MM, linux-kernel

On Sat, Jan 16, 2021 at 3:03 PM Miaohe Lin <linmiaohe@huawei.com> wrote:
>
> The func do_generic_mapping_read() is killed by commit 36e789144267 ("kill
> do_generic_mapping_read"). So replace it with do_generic_mapping_read to
> keep comment uptodate.

s/func/function

replace it with generic_file_buffered_read()  ?

>
> Signed-off-by: Miaohe Lin <linmiaohe@huawei.com>
> ---
>  fs/hugetlbfs/inode.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/fs/hugetlbfs/inode.c b/fs/hugetlbfs/inode.c
> index 23ad6ed8b75f..d02616513b43 100644
> --- a/fs/hugetlbfs/inode.c
> +++ b/fs/hugetlbfs/inode.c
> @@ -310,7 +310,7 @@ hugetlbfs_read_actor(struct page *page, unsigned long offset,
>
>  /*
>   * Support for read() - Find the page attached to f_mapping and copy out the
> - * data. Its *very* similar to do_generic_mapping_read(), we can't use that
> + * data. Its *very* similar to generic_file_buffered_read(), we can't use that
>   * since it has PAGE_SIZE assumptions.
>   */
>  static ssize_t hugetlbfs_read_iter(struct kiocb *iocb, struct iov_iter *to)
> --
> 2.19.1
>
>


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] hugetlbfs: correct obsolete function name hugetlbfs_read_iter()
  2021-01-16  9:36   ` Souptick Joarder
  (?)
@ 2021-01-16  9:44   ` Miaohe Lin
  -1 siblings, 0 replies; 4+ messages in thread
From: Miaohe Lin @ 2021-01-16  9:44 UTC (permalink / raw)
  To: Souptick Joarder; +Cc: Mike Kravetz, Linux-MM, linux-kernel

Hi:

On 2021/1/16 17:36, Souptick Joarder wrote:
> On Sat, Jan 16, 2021 at 3:03 PM Miaohe Lin <linmiaohe@huawei.com> wrote:
>>
>> The func do_generic_mapping_read() is killed by commit 36e789144267 ("kill
>> do_generic_mapping_read"). So replace it with do_generic_mapping_read to
>> keep comment uptodate.
> 
> s/func/function
> 
> replace it with generic_file_buffered_read()  ?
> 

Many thanks for your review. I'am going to resend this patch as I forgot to mention the
second commit that rename do_generic_file_read to generic_file_buffered_read. But it looks
I should send a v2 now to fix above comment.

Thanks again.

>>
>> Signed-off-by: Miaohe Lin <linmiaohe@huawei.com>
>> ---
>>  fs/hugetlbfs/inode.c | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/fs/hugetlbfs/inode.c b/fs/hugetlbfs/inode.c
>> index 23ad6ed8b75f..d02616513b43 100644
>> --- a/fs/hugetlbfs/inode.c
>> +++ b/fs/hugetlbfs/inode.c
>> @@ -310,7 +310,7 @@ hugetlbfs_read_actor(struct page *page, unsigned long offset,
>>
>>  /*
>>   * Support for read() - Find the page attached to f_mapping and copy out the
>> - * data. Its *very* similar to do_generic_mapping_read(), we can't use that
>> + * data. Its *very* similar to generic_file_buffered_read(), we can't use that
>>   * since it has PAGE_SIZE assumptions.
>>   */
>>  static ssize_t hugetlbfs_read_iter(struct kiocb *iocb, struct iov_iter *to)
>> --
>> 2.19.1
>>
>>
> .
> 

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2021-01-16  9:45 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-01-16  9:32 [PATCH] hugetlbfs: correct obsolete function name hugetlbfs_read_iter() Miaohe Lin
2021-01-16  9:36 ` Souptick Joarder
2021-01-16  9:36   ` Souptick Joarder
2021-01-16  9:44   ` Miaohe Lin

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.