All of lore.kernel.org
 help / color / mirror / Atom feed
From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
To: Mike Snitzer <snitzer@redhat.com>
Cc: Alasdair Kergon <agk@redhat.com>,
	dm-devel@redhat.com, Shaohua Li <shli@kernel.org>,
	linux-raid@vger.kernel.org,
	Dmitry Torokhov <dmitry.torokhov@gmail.com>,
	linux-input@vger.kernel.org,
	Andrew Morton <akpm@linux-foundation.org>,
	Yury Norov <ynorov@caviumnetworks.com>,
	linux-kernel@vger.kernel.org, mika.westerberg@linux.intel.com,
	Joe Perches <joe@perches.com>
Subject: Re: [PATCH v3 1/5] md: Avoid namespace collision with bitmap API
Date: Mon, 18 Jun 2018 16:57:41 +0300	[thread overview]
Message-ID: <49e96a4ecb3566139bef0b36093143077ceafd3f.camel@linux.intel.com> (raw)
In-Reply-To: <20180618134454.GA25547@redhat.com>

On Mon, 2018-06-18 at 09:44 -0400, Mike Snitzer wrote:
> On Mon, Jun 18 2018 at  9:09am -0400,
> Andy Shevchenko <andriy.shevchenko@linux.intel.com> wrote:
> 
> > bitmap API (include/linux/bitmap.h) has 'bitmap' prefix for its
> > methods.
> > 
> > On the other hand MD bitmap API is special case.
> > Adding 'md' prefix to it to avoid name space collision.
> > 
> > No functional changes intended.
> > 
> > Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> > ---
> >  drivers/md/dm-raid.c                          |   6 +-
> >  drivers/md/md-bitmap.c                        | 301 +++++++++----
> > -----
> >  drivers/md/md-bitmap.h                        |  46 +--
> >  drivers/md/md-cluster.c                       |  16 +-
> >  drivers/md/md.c                               |  44 +--
> >  .../md/persistent-data/dm-space-map-common.c  |  12 +-
> >  drivers/md/raid1.c                            |  20 +-
> >  drivers/md/raid10.c                           |  26 +-
> >  drivers/md/raid5-cache.c                      |   2 +-
> >  drivers/md/raid5.c                            |  24 +-
> >  10 files changed, 244 insertions(+), 253 deletions(-)
> 
> Seems my previous mail just missed your v3 cutoff but...
> 
> <snip>
> 
> All of these drivers/md/persistent-data/dm-space-map-common.c renames
> are wrong.

So, let me understand this clear, the naming problem appears in one file
only. The rest is fine. Correct?

>   DM is the only consumer (it is confusing because all DM and
> MD code lives in drivers/md/ despite only sharing a bit of MD code).
> 
> Anyway, please rename bitmap methods in this file to have a
> "dm_bitmap"
> prefix instead.  Thanks.

Ah, okay, will do this in v4 later this week.

Thanks for review!

-- 
Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Intel Finland Oy

  reply	other threads:[~2018-06-18 13:57 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-06-18 13:09 [PATCH v3 0/5] bitmap: Introduce alloc/free helpers Andy Shevchenko
2018-06-18 13:09 ` [PATCH v3 1/5] md: Avoid namespace collision with bitmap API Andy Shevchenko
2018-06-18 13:44   ` Mike Snitzer
2018-06-18 13:57     ` Andy Shevchenko [this message]
2018-06-18 13:10 ` [PATCH v3 2/5] bitmap: Drop unnecessary 0 check for u32 array operations Andy Shevchenko
2018-06-18 13:10 ` [PATCH v3 3/5] bitmap: Add bitmap_alloc(), bitmap_zalloc() and bitmap_free() Andy Shevchenko
2018-06-18 21:14   ` Andrew Morton
2018-06-18 22:01     ` Dmitry Torokhov
2018-06-18 22:52       ` Andy Shevchenko
2018-06-18 23:10       ` Andrew Morton
2018-06-18 23:18         ` Andy Shevchenko
2018-06-21  2:13         ` Andy Shevchenko
2018-06-22 18:46           ` Dmitry Torokhov
2018-06-26 11:13             ` Andy Shevchenko
2018-06-18 13:10 ` [PATCH v3 4/5] Input: gpio-keys - Switch to bitmap_zalloc() Andy Shevchenko
2018-06-18 13:10 ` [PATCH v3 5/5] Input: evdev - Switch to bitmap API Andy Shevchenko
2018-06-20  7:33 ` [PATCH v3 0/5] bitmap: Introduce alloc/free helpers Yury Norov
2018-06-20  7:33   ` Yury Norov
2018-06-20 10:16   ` Andy Shevchenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=49e96a4ecb3566139bef0b36093143077ceafd3f.camel@linux.intel.com \
    --to=andriy.shevchenko@linux.intel.com \
    --cc=agk@redhat.com \
    --cc=akpm@linux-foundation.org \
    --cc=dm-devel@redhat.com \
    --cc=dmitry.torokhov@gmail.com \
    --cc=joe@perches.com \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-raid@vger.kernel.org \
    --cc=mika.westerberg@linux.intel.com \
    --cc=shli@kernel.org \
    --cc=snitzer@redhat.com \
    --cc=ynorov@caviumnetworks.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.