All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] xt_helper: use sizeof()
@ 2010-07-23  8:22 Changli Gao
  2010-07-23 11:53 ` Patrick McHardy
  0 siblings, 1 reply; 3+ messages in thread
From: Changli Gao @ 2010-07-23  8:22 UTC (permalink / raw)
  To: Patrick McHardy; +Cc: David S. Miller, netfilter-devel, netdev, Changli Gao

use sizeof() to improve the readability.

Signed-off-by: Changli Gao <xiaosuo@gmail.com>
----
 net/netfilter/xt_helper.c |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/net/netfilter/xt_helper.c b/net/netfilter/xt_helper.c
index 9f4ab00..805c9f6 100644
--- a/net/netfilter/xt_helper.c
+++ b/net/netfilter/xt_helper.c
@@ -65,7 +65,7 @@ static int helper_mt_check(const struct xt_mtchk_param *par)
 			par->family);
 		return ret;
 	}
-	info->name[29] = '\0';
+	info->name[sizeof(info->name) - 1] = '\0';
 	return 0;
 }
 

^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH] xt_helper: use sizeof()
  2010-07-23  8:22 [PATCH] xt_helper: use sizeof() Changli Gao
@ 2010-07-23 11:53 ` Patrick McHardy
  2010-07-23 11:56   ` Patrick McHardy
  0 siblings, 1 reply; 3+ messages in thread
From: Patrick McHardy @ 2010-07-23 11:53 UTC (permalink / raw)
  To: Changli Gao; +Cc: David S. Miller, netfilter-devel, netdev

On 23.07.2010 10:22, Changli Gao wrote:
> use sizeof() to improve the readability.
> 

Applied, thanks.

One more request about your changelogs though: please use capital
letters at the beginning of new sentences in the patch description.

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] xt_helper: use sizeof()
  2010-07-23 11:53 ` Patrick McHardy
@ 2010-07-23 11:56   ` Patrick McHardy
  0 siblings, 0 replies; 3+ messages in thread
From: Patrick McHardy @ 2010-07-23 11:56 UTC (permalink / raw)
  To: Changli Gao; +Cc: David S. Miller, netfilter-devel, netdev

On 23.07.2010 13:53, Patrick McHardy wrote:
> On 23.07.2010 10:22, Changli Gao wrote:
>> use sizeof() to improve the readability.
>>
> 
> Applied, thanks.

I see that you sent another patch for this using a different
subject. Please state it clearly when you wish to withdraw
a patch. I've backed it out again.

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2010-07-23 11:56 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2010-07-23  8:22 [PATCH] xt_helper: use sizeof() Changli Gao
2010-07-23 11:53 ` Patrick McHardy
2010-07-23 11:56   ` Patrick McHardy

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.