All of lore.kernel.org
 help / color / mirror / Atom feed
From: Glauber Costa <glommer@parallels.com>
To: "Kirill A. Shutemov" <kirill@shutemov.name>
Cc: Cyrill Gorcunov <gorcunov@gmail.com>,
	<linux-kernel@vger.kernel.org>, <paul@paulmenage.org>,
	<lizf@cn.fujitsu.com>, <kamezawa.hiroyu@jp.fujitsu.com>,
	<ebiederm@xmission.com>, <davem@davemloft.net>,
	<gthelen@google.com>, <netdev@vger.kernel.org>,
	<linux-mm@kvack.org>
Subject: Re: [PATCH v2 4/7] per-cgroup tcp buffers control
Date: Sun, 18 Sep 2011 16:42:34 -0300	[thread overview]
Message-ID: <4E7649AA.40305@parallels.com> (raw)
In-Reply-To: <20110918185806.GA28057@shutemov.name>

On 09/18/2011 03:58 PM, Kirill A. Shutemov wrote:
> On Sat, Sep 17, 2011 at 10:33:58PM +0400, Cyrill Gorcunov wrote:
>> On Sat, Sep 17, 2011 at 09:11:32PM +0300, Kirill A. Shutemov wrote:
>>> On Wed, Sep 14, 2011 at 10:46:12PM -0300, Glauber Costa wrote:
>>>> +int tcp_init_cgroup_fill(struct proto *prot, struct cgroup *cgrp,
>>>> +			 struct cgroup_subsys *ss)
>>>> +{
>>>> +	prot->enter_memory_pressure	= tcp_enter_memory_pressure;
>>>> +	prot->memory_allocated		= memory_allocated_tcp;
>>>> +	prot->prot_mem			= tcp_sysctl_mem;
>>>> +	prot->sockets_allocated		= sockets_allocated_tcp;
>>>> +	prot->memory_pressure		= memory_pressure_tcp;
>>>
>>> No fancy formatting, please.
>>>
>>
>> What's wrong with having fancy formatting? It's indeed easier to read
>> when members are assigned this way. It's always up to maintainer to
>> choose what he prefers, but I see nothing wrong in such style (if only it
>> doesn't break the style of the whole file).
>
> You have to remove this indenting if you'll reorganize code (e.g. move
> part under if(...)).
> IMO, it reduces code maintainability.
>
As I said, I don't care, so I'll change. But I have to say I disagree 
with your statement.

It is a pack of assignments, so if you reorganize this code, two things 
can happen:
1) It is not moved to a new ident level -> It keeps being a pack of 
assignments, and you don't really need to change it.
2) It is moved to a new ident level -> You have to touch it anyway...


WARNING: multiple messages have this Message-ID (diff)
From: Glauber Costa <glommer@parallels.com>
To: "Kirill A. Shutemov" <kirill@shutemov.name>
Cc: Cyrill Gorcunov <gorcunov@gmail.com>,
	<linux-kernel@vger.kernel.org>, <paul@paulmenage.org>,
	<lizf@cn.fujitsu.com>, <kamezawa.hiroyu@jp.fujitsu.com>,
	<ebiederm@xmission.com>, <davem@davemloft.net>,
	<gthelen@google.com>, <netdev@vger.kernel.org>,
	<linux-mm@kvack.org>
Subject: Re: [PATCH v2 4/7] per-cgroup tcp buffers control
Date: Sun, 18 Sep 2011 16:42:34 -0300	[thread overview]
Message-ID: <4E7649AA.40305@parallels.com> (raw)
In-Reply-To: <20110918185806.GA28057@shutemov.name>

On 09/18/2011 03:58 PM, Kirill A. Shutemov wrote:
> On Sat, Sep 17, 2011 at 10:33:58PM +0400, Cyrill Gorcunov wrote:
>> On Sat, Sep 17, 2011 at 09:11:32PM +0300, Kirill A. Shutemov wrote:
>>> On Wed, Sep 14, 2011 at 10:46:12PM -0300, Glauber Costa wrote:
>>>> +int tcp_init_cgroup_fill(struct proto *prot, struct cgroup *cgrp,
>>>> +			 struct cgroup_subsys *ss)
>>>> +{
>>>> +	prot->enter_memory_pressure	= tcp_enter_memory_pressure;
>>>> +	prot->memory_allocated		= memory_allocated_tcp;
>>>> +	prot->prot_mem			= tcp_sysctl_mem;
>>>> +	prot->sockets_allocated		= sockets_allocated_tcp;
>>>> +	prot->memory_pressure		= memory_pressure_tcp;
>>>
>>> No fancy formatting, please.
>>>
>>
>> What's wrong with having fancy formatting? It's indeed easier to read
>> when members are assigned this way. It's always up to maintainer to
>> choose what he prefers, but I see nothing wrong in such style (if only it
>> doesn't break the style of the whole file).
>
> You have to remove this indenting if you'll reorganize code (e.g. move
> part under if(...)).
> IMO, it reduces code maintainability.
>
As I said, I don't care, so I'll change. But I have to say I disagree 
with your statement.

It is a pack of assignments, so if you reorganize this code, two things 
can happen:
1) It is not moved to a new ident level -> It keeps being a pack of 
assignments, and you don't really need to change it.
2) It is moved to a new ident level -> You have to touch it anyway...

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>

WARNING: multiple messages have this Message-ID (diff)
From: Glauber Costa <glommer@parallels.com>
To: "Kirill A. Shutemov" <kirill@shutemov.name>
Cc: Cyrill Gorcunov <gorcunov@gmail.com>,
	linux-kernel@vger.kernel.org, paul@paulmenage.org,
	lizf@cn.fujitsu.com, kamezawa.hiroyu@jp.fujitsu.com,
	ebiederm@xmission.com, davem@davemloft.net, gthelen@google.com,
	netdev@vger.kernel.org, linux-mm@kvack.org
Subject: Re: [PATCH v2 4/7] per-cgroup tcp buffers control
Date: Sun, 18 Sep 2011 16:42:34 -0300	[thread overview]
Message-ID: <4E7649AA.40305@parallels.com> (raw)
In-Reply-To: <20110918185806.GA28057@shutemov.name>

On 09/18/2011 03:58 PM, Kirill A. Shutemov wrote:
> On Sat, Sep 17, 2011 at 10:33:58PM +0400, Cyrill Gorcunov wrote:
>> On Sat, Sep 17, 2011 at 09:11:32PM +0300, Kirill A. Shutemov wrote:
>>> On Wed, Sep 14, 2011 at 10:46:12PM -0300, Glauber Costa wrote:
>>>> +int tcp_init_cgroup_fill(struct proto *prot, struct cgroup *cgrp,
>>>> +			 struct cgroup_subsys *ss)
>>>> +{
>>>> +	prot->enter_memory_pressure	= tcp_enter_memory_pressure;
>>>> +	prot->memory_allocated		= memory_allocated_tcp;
>>>> +	prot->prot_mem			= tcp_sysctl_mem;
>>>> +	prot->sockets_allocated		= sockets_allocated_tcp;
>>>> +	prot->memory_pressure		= memory_pressure_tcp;
>>>
>>> No fancy formatting, please.
>>>
>>
>> What's wrong with having fancy formatting? It's indeed easier to read
>> when members are assigned this way. It's always up to maintainer to
>> choose what he prefers, but I see nothing wrong in such style (if only it
>> doesn't break the style of the whole file).
>
> You have to remove this indenting if you'll reorganize code (e.g. move
> part under if(...)).
> IMO, it reduces code maintainability.
>
As I said, I don't care, so I'll change. But I have to say I disagree 
with your statement.

It is a pack of assignments, so if you reorganize this code, two things 
can happen:
1) It is not moved to a new ident level -> It keeps being a pack of 
assignments, and you don't really need to change it.
2) It is moved to a new ident level -> You have to touch it anyway...

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>

  reply	other threads:[~2011-09-18 19:43 UTC|newest]

Thread overview: 59+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-09-15  1:46 [PATCH v2 0/7] per-cgroup tcp buffer pressure settings Glauber Costa
2011-09-15  1:46 ` Glauber Costa
2011-09-15  1:46 ` [PATCH v2 1/7] Basic kernel memory functionality for the Memory Controller Glauber Costa
2011-09-15  1:46   ` Glauber Costa
2011-09-17 17:45   ` Kirill A. Shutemov
2011-09-17 17:45     ` Kirill A. Shutemov
2011-09-18  3:39     ` Glauber Costa
2011-09-18  3:39       ` Glauber Costa
2011-09-18  3:39       ` Glauber Costa
2011-09-18 19:05       ` Kirill A. Shutemov
2011-09-18 19:05         ` Kirill A. Shutemov
2011-09-18 19:11         ` Glauber Costa
2011-09-18 19:11           ` Glauber Costa
2011-09-18 19:11           ` Glauber Costa
2011-09-18 20:39           ` Kirill A. Shutemov
2011-09-18 20:39             ` Kirill A. Shutemov
2011-09-18 20:40             ` Glauber Costa
2011-09-18 20:40               ` Glauber Costa
2011-09-18 20:40               ` Glauber Costa
2011-09-18 20:43               ` Kirill A. Shutemov
2011-09-18 20:43                 ` Kirill A. Shutemov
2011-09-15  1:46 ` [PATCH v2 2/7] socket: initial cgroup code Glauber Costa
2011-09-15  1:46   ` Glauber Costa
2011-09-17 17:52   ` Kirill A. Shutemov
2011-09-17 17:52     ` Kirill A. Shutemov
2011-09-18  3:32     ` Glauber Costa
2011-09-18  3:32       ` Glauber Costa
2011-09-18  3:32       ` Glauber Costa
2011-09-18 18:58       ` Kirill A. Shutemov
2011-09-18 18:58         ` Kirill A. Shutemov
2011-09-15  1:46 ` [PATCH v2 3/7] foundations of per-cgroup memory pressure controlling Glauber Costa
2011-09-15  1:46   ` Glauber Costa
2011-09-15  1:46 ` [PATCH v2 4/7] per-cgroup tcp buffers control Glauber Costa
2011-09-15  1:46   ` Glauber Costa
2011-09-17 18:11   ` Kirill A. Shutemov
2011-09-17 18:11     ` Kirill A. Shutemov
2011-09-17 18:33     ` Cyrill Gorcunov
2011-09-17 18:33       ` Cyrill Gorcunov
2011-09-18  3:32       ` Glauber Costa
2011-09-18  3:32         ` Glauber Costa
2011-09-18  3:32         ` Glauber Costa
2011-09-18 18:58       ` Kirill A. Shutemov
2011-09-18 18:58         ` Kirill A. Shutemov
2011-09-18 19:42         ` Glauber Costa [this message]
2011-09-18 19:42           ` Glauber Costa
2011-09-18 19:42           ` Glauber Costa
2011-09-28 11:58   ` Andrew Wagin
2011-09-28 11:58     ` Andrew Wagin
2011-09-28 12:11     ` Glauber Costa
2011-09-28 12:11       ` Glauber Costa
2011-09-28 12:11       ` Glauber Costa
2011-09-15  1:46 ` [PATCH v2 5/7] per-netns ipv4 sysctl_tcp_mem Glauber Costa
2011-09-15  1:46   ` Glauber Costa
2011-09-15  1:46 ` [PATCH v2 6/7] tcp buffer limitation: per-cgroup limit Glauber Costa
2011-09-15  1:46   ` Glauber Costa
2011-09-17 12:12   ` Glauber Costa
2011-09-17 12:12     ` Glauber Costa
2011-09-15  1:46 ` [PATCH v2 7/7] Display current tcp memory allocation in kmem cgroup Glauber Costa
2011-09-15  1:46   ` Glauber Costa

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4E7649AA.40305@parallels.com \
    --to=glommer@parallels.com \
    --cc=davem@davemloft.net \
    --cc=ebiederm@xmission.com \
    --cc=gorcunov@gmail.com \
    --cc=gthelen@google.com \
    --cc=kamezawa.hiroyu@jp.fujitsu.com \
    --cc=kirill@shutemov.name \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=lizf@cn.fujitsu.com \
    --cc=netdev@vger.kernel.org \
    --cc=paul@paulmenage.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.