All of lore.kernel.org
 help / color / mirror / Atom feed
From: Sergei Shtylyov <sshtylyov@mvista.com>
To: Dong Aisheng <dong.aisheng@linaro.org>
Cc: devicetree-discuss@lists.ozlabs.org, grant.likely@secretlab.ca,
	rob.herring@calxeda.com, linux-kernel@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH V3 1/1] dt: add of_get_child_count helper function
Date: Sun, 12 Feb 2012 00:37:46 +0400	[thread overview]
Message-ID: <4F36D19A.8050409@mvista.com> (raw)
In-Reply-To: <1328980929-5423-1-git-send-email-dong.aisheng@linaro.org>

Hello.

On 11-02-2012 21:22, Dong Aisheng wrote:

> Currently most code to get child count in kernel are almost same,
> add a helper to implement this function for dt to use.

> Signed-off-by: Dong Aisheng<dong.aisheng@linaro.org>
> Cc: Grant Likely<grant.likely@secretlab.ca>
> Cc: Rob Herring<rob.herring@calxeda.com>

> ---
> Hi Rob,

> Since my imx pinctrl driver series still depends on the pinctrl core dt
> binding patch which is still not in mainline, i'd like this pure dt patch
> go separately first in case others want to use.

> changes v2->v3:
>   Addressed some people's comments:
>   * do not use assignment as expression
>   * return 0 for non-dt case

> Changes v1->v2:
>   * change the name from of_get_child_number to of_get_child_count
> ---
>   include/linux/of.h |   16 ++++++++++++++++
>   1 files changed, 16 insertions(+), 0 deletions(-)

> diff --git a/include/linux/of.h b/include/linux/of.h
> index a75a831..ae242ef 100644
> --- a/include/linux/of.h
> +++ b/include/linux/of.h
> @@ -195,6 +195,17 @@ extern struct device_node *of_get_next_child(const struct device_node *node,
>   	for (child = of_get_next_child(parent, NULL); child != NULL; \
>   	     child = of_get_next_child(parent, child))
>
> +static inline int of_get_child_count(const struct device_node *np)
> +{
> +	struct device_node *child = NULL;
> +	int num = 0;
> +
> +	while ((child = of_get_next_child(np, child)) != NULL)

    Doesn't scripts/checkpatch.pl complain here?

> +		num++;
> +
> +	return num;
> +}
> +

WBR, Sergei

WARNING: multiple messages have this Message-ID (diff)
From: sshtylyov@mvista.com (Sergei Shtylyov)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH V3 1/1] dt: add of_get_child_count helper function
Date: Sun, 12 Feb 2012 00:37:46 +0400	[thread overview]
Message-ID: <4F36D19A.8050409@mvista.com> (raw)
In-Reply-To: <1328980929-5423-1-git-send-email-dong.aisheng@linaro.org>

Hello.

On 11-02-2012 21:22, Dong Aisheng wrote:

> Currently most code to get child count in kernel are almost same,
> add a helper to implement this function for dt to use.

> Signed-off-by: Dong Aisheng<dong.aisheng@linaro.org>
> Cc: Grant Likely<grant.likely@secretlab.ca>
> Cc: Rob Herring<rob.herring@calxeda.com>

> ---
> Hi Rob,

> Since my imx pinctrl driver series still depends on the pinctrl core dt
> binding patch which is still not in mainline, i'd like this pure dt patch
> go separately first in case others want to use.

> changes v2->v3:
>   Addressed some people's comments:
>   * do not use assignment as expression
>   * return 0 for non-dt case

> Changes v1->v2:
>   * change the name from of_get_child_number to of_get_child_count
> ---
>   include/linux/of.h |   16 ++++++++++++++++
>   1 files changed, 16 insertions(+), 0 deletions(-)

> diff --git a/include/linux/of.h b/include/linux/of.h
> index a75a831..ae242ef 100644
> --- a/include/linux/of.h
> +++ b/include/linux/of.h
> @@ -195,6 +195,17 @@ extern struct device_node *of_get_next_child(const struct device_node *node,
>   	for (child = of_get_next_child(parent, NULL); child != NULL; \
>   	     child = of_get_next_child(parent, child))
>
> +static inline int of_get_child_count(const struct device_node *np)
> +{
> +	struct device_node *child = NULL;
> +	int num = 0;
> +
> +	while ((child = of_get_next_child(np, child)) != NULL)

    Doesn't scripts/checkpatch.pl complain here?

> +		num++;
> +
> +	return num;
> +}
> +

WBR, Sergei

  reply	other threads:[~2012-02-11 20:39 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-02-11 17:22 [PATCH V3 1/1] dt: add of_get_child_count helper function Dong Aisheng
2012-02-11 17:22 ` Dong Aisheng
2012-02-11 20:37 ` Sergei Shtylyov [this message]
2012-02-11 20:37   ` Sergei Shtylyov
2012-02-12  6:50   ` Dong Aisheng
2012-02-12  6:50     ` Dong Aisheng
2012-02-12 20:22 ` Rob Herring
2012-02-12 20:22   ` Rob Herring
2012-04-13 18:07   ` Dong Aisheng
2012-04-13 18:07     ` Dong Aisheng
2012-04-15  3:15     ` Rob Herring
2012-04-15  3:15       ` Rob Herring
2012-04-15  3:51       ` Dong Aisheng
2012-04-15  3:51         ` Dong Aisheng
2012-02-13  0:04 ` Grant Likely
2012-02-13  0:04   ` Grant Likely

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4F36D19A.8050409@mvista.com \
    --to=sshtylyov@mvista.com \
    --cc=devicetree-discuss@lists.ozlabs.org \
    --cc=dong.aisheng@linaro.org \
    --cc=grant.likely@secretlab.ca \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rob.herring@calxeda.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.