All of lore.kernel.org
 help / color / mirror / Atom feed
From: Nicolas Saenz Julienne <nsaenzjulienne@suse.de>
To: Christoph Hellwig <hch@lst.de>
Cc: catalin.marinas@arm.com, wahrenst@gmx.net, marc.zyngier@arm.com,
	robh+dt@kernel.org, Robin Murphy <robin.murphy@arm.com>,
	linux-arm-kernel@lists.infradead.org, devicetree@vger.kernel.org,
	linux-arch@vger.kernel.org, iommu@lists.linux-foundation.org,
	linux-mm@kvack.org, linux-riscv@lists.infradead.org,
	linux-kernel@vger.kernel.org, phill@raspberryi.org,
	f.fainelli@gmail.com, will@kernel.org, eric@anholt.net,
	mbrugger@suse.com, linux-rpi-kernel@lists.infradead.org,
	akpm@linux-foundation.org, frowand.list@gmail.com,
	m.szyprowski@samsung.com
Subject: Re: [PATCH v2 10/11] arm64: edit zone_dma_bits to fine tune dma-direct min mask
Date: Mon, 26 Aug 2019 13:08:50 +0200	[thread overview]
Message-ID: <4d8d18af22d6dcd122bc9b4d9c2bd49e8443c746.camel@suse.de> (raw)
In-Reply-To: <20190826070633.GB11331@lst.de>

[-- Attachment #1: Type: text/plain, Size: 821 bytes --]

On Mon, 2019-08-26 at 09:06 +0200, Christoph Hellwig wrote:
> On Tue, Aug 20, 2019 at 04:58:18PM +0200, Nicolas Saenz Julienne wrote:
> > -	if (IS_ENABLED(CONFIG_ZONE_DMA))
> > +	if (IS_ENABLED(CONFIG_ZONE_DMA)) {
> >  		arm64_dma_phys_limit = max_zone_dma_phys();
> > +		zone_dma_bits = ilog2((arm64_dma_phys_limit - 1) &
> > GENMASK_ULL(31, 0)) + 1;
>
Hi Christoph,
thanks for the rewiews.

> This adds a way too long line.

I know, I couldn't find a way to split the operation without making it even
harder to read. I'll find a solution.

> I also find the use of GENMASK_ULL
> horribly obsfucating, but I know that opinion is't shared by everyone.

Don't have any preference so I'll happily change it. Any suggestions? Using the
explicit 0xffffffffULL seems hard to read, how about SZ_4GB - 1?


[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 488 bytes --]

WARNING: multiple messages have this Message-ID (diff)
From: Nicolas Saenz Julienne <nsaenzjulienne@suse.de>
To: Christoph Hellwig <hch@lst.de>
Cc: linux-arch@vger.kernel.org, devicetree@vger.kernel.org,
	linux-rpi-kernel@lists.infradead.org, f.fainelli@gmail.com,
	will@kernel.org, eric@anholt.net, marc.zyngier@arm.com,
	catalin.marinas@arm.com, frowand.list@gmail.com,
	linux-kernel@vger.kernel.org, linux-mm@kvack.org,
	iommu@lists.linux-foundation.org, robh+dt@kernel.org,
	wahrenst@gmx.net, mbrugger@suse.com,
	linux-riscv@lists.infradead.org, m.szyprowski@samsung.com,
	Robin Murphy <robin.murphy@arm.com>,
	akpm@linux-foundation.org, linux-arm-kernel@lists.infradead.org,
	phill@raspberryi.org
Subject: Re: [PATCH v2 10/11] arm64: edit zone_dma_bits to fine tune dma-direct min mask
Date: Mon, 26 Aug 2019 13:08:50 +0200	[thread overview]
Message-ID: <4d8d18af22d6dcd122bc9b4d9c2bd49e8443c746.camel@suse.de> (raw)
In-Reply-To: <20190826070633.GB11331@lst.de>


[-- Attachment #1.1: Type: text/plain, Size: 821 bytes --]

On Mon, 2019-08-26 at 09:06 +0200, Christoph Hellwig wrote:
> On Tue, Aug 20, 2019 at 04:58:18PM +0200, Nicolas Saenz Julienne wrote:
> > -	if (IS_ENABLED(CONFIG_ZONE_DMA))
> > +	if (IS_ENABLED(CONFIG_ZONE_DMA)) {
> >  		arm64_dma_phys_limit = max_zone_dma_phys();
> > +		zone_dma_bits = ilog2((arm64_dma_phys_limit - 1) &
> > GENMASK_ULL(31, 0)) + 1;
>
Hi Christoph,
thanks for the rewiews.

> This adds a way too long line.

I know, I couldn't find a way to split the operation without making it even
harder to read. I'll find a solution.

> I also find the use of GENMASK_ULL
> horribly obsfucating, but I know that opinion is't shared by everyone.

Don't have any preference so I'll happily change it. Any suggestions? Using the
explicit 0xffffffffULL seems hard to read, how about SZ_4GB - 1?


[-- Attachment #1.2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 488 bytes --]

[-- Attachment #2: Type: text/plain, Size: 161 bytes --]

_______________________________________________
linux-riscv mailing list
linux-riscv@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-riscv

WARNING: multiple messages have this Message-ID (diff)
From: Nicolas Saenz Julienne <nsaenzjulienne@suse.de>
To: Christoph Hellwig <hch@lst.de>
Cc: linux-arch@vger.kernel.org, devicetree@vger.kernel.org,
	linux-rpi-kernel@lists.infradead.org, f.fainelli@gmail.com,
	will@kernel.org, eric@anholt.net, marc.zyngier@arm.com,
	catalin.marinas@arm.com, frowand.list@gmail.com,
	linux-kernel@vger.kernel.org, linux-mm@kvack.org,
	iommu@lists.linux-foundation.org, robh+dt@kernel.org,
	wahrenst@gmx.net, mbrugger@suse.com,
	linux-riscv@lists.infradead.org,
	Robin Murphy <robin.murphy@arm.com>,
	akpm@linux-foundation.org, linux-arm-kernel@lists.infradead.org,
	phill@raspberryi.org
Subject: Re: [PATCH v2 10/11] arm64: edit zone_dma_bits to fine tune dma-direct min mask
Date: Mon, 26 Aug 2019 13:08:50 +0200	[thread overview]
Message-ID: <4d8d18af22d6dcd122bc9b4d9c2bd49e8443c746.camel@suse.de> (raw)
In-Reply-To: <20190826070633.GB11331@lst.de>


[-- Attachment #1.1: Type: text/plain, Size: 821 bytes --]

On Mon, 2019-08-26 at 09:06 +0200, Christoph Hellwig wrote:
> On Tue, Aug 20, 2019 at 04:58:18PM +0200, Nicolas Saenz Julienne wrote:
> > -	if (IS_ENABLED(CONFIG_ZONE_DMA))
> > +	if (IS_ENABLED(CONFIG_ZONE_DMA)) {
> >  		arm64_dma_phys_limit = max_zone_dma_phys();
> > +		zone_dma_bits = ilog2((arm64_dma_phys_limit - 1) &
> > GENMASK_ULL(31, 0)) + 1;
>
Hi Christoph,
thanks for the rewiews.

> This adds a way too long line.

I know, I couldn't find a way to split the operation without making it even
harder to read. I'll find a solution.

> I also find the use of GENMASK_ULL
> horribly obsfucating, but I know that opinion is't shared by everyone.

Don't have any preference so I'll happily change it. Any suggestions? Using the
explicit 0xffffffffULL seems hard to read, how about SZ_4GB - 1?


[-- Attachment #1.2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 488 bytes --]

[-- Attachment #2: Type: text/plain, Size: 156 bytes --]

_______________________________________________
iommu mailing list
iommu@lists.linux-foundation.org
https://lists.linuxfoundation.org/mailman/listinfo/iommu

WARNING: multiple messages have this Message-ID (diff)
From: Nicolas Saenz Julienne <nsaenzjulienne@suse.de>
To: Christoph Hellwig <hch@lst.de>
Cc: linux-arch@vger.kernel.org, devicetree@vger.kernel.org,
	linux-rpi-kernel@lists.infradead.org, f.fainelli@gmail.com,
	will@kernel.org, eric@anholt.net, marc.zyngier@arm.com,
	catalin.marinas@arm.com, frowand.list@gmail.com,
	linux-kernel@vger.kernel.org, linux-mm@kvack.org,
	iommu@lists.linux-foundation.org, robh+dt@kernel.org,
	wahrenst@gmx.net, mbrugger@suse.com,
	linux-riscv@lists.infradead.org, m.szyprowski@samsung.com,
	Robin Murphy <robin.murphy@arm.com>,
	akpm@linux-foundation.org, linux-arm-kernel@lists.infradead.org,
	phill@raspberryi.org
Subject: Re: [PATCH v2 10/11] arm64: edit zone_dma_bits to fine tune dma-direct min mask
Date: Mon, 26 Aug 2019 13:08:50 +0200	[thread overview]
Message-ID: <4d8d18af22d6dcd122bc9b4d9c2bd49e8443c746.camel@suse.de> (raw)
In-Reply-To: <20190826070633.GB11331@lst.de>


[-- Attachment #1.1: Type: text/plain, Size: 821 bytes --]

On Mon, 2019-08-26 at 09:06 +0200, Christoph Hellwig wrote:
> On Tue, Aug 20, 2019 at 04:58:18PM +0200, Nicolas Saenz Julienne wrote:
> > -	if (IS_ENABLED(CONFIG_ZONE_DMA))
> > +	if (IS_ENABLED(CONFIG_ZONE_DMA)) {
> >  		arm64_dma_phys_limit = max_zone_dma_phys();
> > +		zone_dma_bits = ilog2((arm64_dma_phys_limit - 1) &
> > GENMASK_ULL(31, 0)) + 1;
>
Hi Christoph,
thanks for the rewiews.

> This adds a way too long line.

I know, I couldn't find a way to split the operation without making it even
harder to read. I'll find a solution.

> I also find the use of GENMASK_ULL
> horribly obsfucating, but I know that opinion is't shared by everyone.

Don't have any preference so I'll happily change it. Any suggestions? Using the
explicit 0xffffffffULL seems hard to read, how about SZ_4GB - 1?


[-- Attachment #1.2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 488 bytes --]

[-- Attachment #2: Type: text/plain, Size: 176 bytes --]

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2019-08-26 11:08 UTC|newest]

Thread overview: 131+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-08-20 14:58 [PATCH v2 00/11] Raspberry Pi 4 DMA addressing support Nicolas Saenz Julienne
2019-08-20 14:58 ` Nicolas Saenz Julienne
2019-08-20 14:58 ` Nicolas Saenz Julienne
2019-08-20 14:58 ` Nicolas Saenz Julienne
2019-08-20 14:58 ` Nicolas Saenz Julienne
2019-08-20 14:58 ` [PATCH v2 01/11] asm-generic: add dma_zone_size Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-26  7:09   ` Christoph Hellwig
2019-08-26  7:09     ` Christoph Hellwig
2019-08-26  7:09     ` Christoph Hellwig
2019-08-26  7:09     ` Christoph Hellwig
2019-08-26 13:46     ` Nicolas Saenz Julienne
2019-08-26 13:46       ` Nicolas Saenz Julienne
2019-08-26 13:46       ` Nicolas Saenz Julienne
2019-08-26 13:46       ` Nicolas Saenz Julienne
2019-08-26 13:46       ` Nicolas Saenz Julienne
2019-08-28  9:44       ` Nicolas Saenz Julienne
2019-08-28  9:44         ` Nicolas Saenz Julienne
2019-08-28  9:44         ` Nicolas Saenz Julienne
2019-08-28  9:44         ` Nicolas Saenz Julienne
2019-08-28  9:44         ` Nicolas Saenz Julienne
2019-08-30 14:45       ` Catalin Marinas
2019-08-30 14:45         ` Catalin Marinas
2019-08-30 14:45         ` Catalin Marinas
2019-08-30 14:45         ` Catalin Marinas
2019-08-30 17:24         ` Nicolas Saenz Julienne
2019-08-30 17:24           ` Nicolas Saenz Julienne
2019-08-30 17:24           ` Nicolas Saenz Julienne
2019-08-30 17:24           ` Nicolas Saenz Julienne
2019-08-30 17:24           ` Nicolas Saenz Julienne
2019-09-02 13:01           ` Christoph Hellwig
2019-09-02 13:01             ` Christoph Hellwig
2019-09-02 13:01             ` Christoph Hellwig
2019-09-02 13:01             ` Christoph Hellwig
2019-08-20 14:58 ` [PATCH v2 02/11] arm: use generic dma_zone_size Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58 ` [PATCH v2 03/11] of/fdt: add of_fdt_machine_is_compatible function Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 17:16   ` Rob Herring
2019-08-20 17:16     ` Rob Herring
2019-08-20 17:16     ` Rob Herring
2019-08-20 17:16     ` Rob Herring
2019-08-20 17:16     ` Rob Herring
2019-08-20 17:16     ` Rob Herring
2019-08-20 17:16     ` Rob Herring
2019-08-20 17:27     ` Nicolas Saenz Julienne
2019-08-20 17:27       ` Nicolas Saenz Julienne
2019-08-20 17:27       ` Nicolas Saenz Julienne
2019-08-20 17:27       ` Nicolas Saenz Julienne
2019-08-20 17:27       ` Nicolas Saenz Julienne
2019-08-20 17:27       ` Nicolas Saenz Julienne
2019-08-20 17:27       ` Nicolas Saenz Julienne
2019-08-20 14:58 ` [PATCH v2 04/11] of/fdt: add early_init_dt_get_dma_zone_size() Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 17:14   ` Rob Herring
2019-08-20 17:14     ` Rob Herring
2019-08-20 17:14     ` Rob Herring
2019-08-20 17:14     ` Rob Herring
2019-08-20 17:14     ` Rob Herring
2019-08-20 17:14     ` Rob Herring
2019-08-20 17:14     ` Rob Herring
2019-08-20 14:58 ` [PATCH v2 05/11] arm64: mm: use arm64_dma_phys_limit instead of calling max_zone_dma_phys() Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58 ` [PATCH v2 06/11] arm64: rename variables used to calculate ZONE_DMA32's size Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58 ` [PATCH v2 07/11] arm64: re-introduce max_zone_dma_phys() Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58 ` [PATCH v2 08/11] arm64: use both ZONE_DMA and ZONE_DMA32 Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58 ` [PATCH v2 09/11] dma-direct: turn ARCH_ZONE_DMA_BITS into a variable Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-26  7:05   ` Christoph Hellwig
2019-08-26  7:05     ` Christoph Hellwig
2019-08-26  7:05     ` Christoph Hellwig
2019-08-26  7:05     ` Christoph Hellwig
2019-08-26  7:05     ` Christoph Hellwig
2019-08-26  7:05     ` Christoph Hellwig
2019-08-26 11:33   ` Michael Ellerman
2019-08-26 11:33     ` Michael Ellerman
2019-08-26 11:33     ` Michael Ellerman
2019-08-26 11:33     ` Michael Ellerman
2019-08-26 11:33     ` Michael Ellerman
2019-08-26 11:33     ` Michael Ellerman
2019-08-26 11:33     ` Michael Ellerman
2019-08-20 14:58 ` [PATCH v2 10/11] arm64: edit zone_dma_bits to fine tune dma-direct min mask Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-26  7:06   ` Christoph Hellwig
2019-08-26  7:06     ` Christoph Hellwig
2019-08-26  7:06     ` Christoph Hellwig
2019-08-26  7:06     ` Christoph Hellwig
2019-08-26 11:08     ` Nicolas Saenz Julienne [this message]
2019-08-26 11:08       ` Nicolas Saenz Julienne
2019-08-26 11:08       ` Nicolas Saenz Julienne
2019-08-26 11:08       ` Nicolas Saenz Julienne
2019-08-26 11:08       ` Nicolas Saenz Julienne
2019-08-27  7:03       ` Petr Tesarik
2019-08-27  7:03         ` Petr Tesarik
2019-08-27  7:03         ` Petr Tesarik
2019-08-27  7:03         ` Petr Tesarik
2019-08-20 14:58 ` [PATCH v2 11/11] mm: refresh ZONE_DMA and ZONE_DMA32 comments in 'enum zone_type' Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-20 14:58   ` Nicolas Saenz Julienne
2019-08-26  7:07   ` Christoph Hellwig
2019-08-26  7:07     ` Christoph Hellwig
2019-08-26  7:07     ` Christoph Hellwig
2019-08-26  7:07     ` Christoph Hellwig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4d8d18af22d6dcd122bc9b4d9c2bd49e8443c746.camel@suse.de \
    --to=nsaenzjulienne@suse.de \
    --cc=akpm@linux-foundation.org \
    --cc=catalin.marinas@arm.com \
    --cc=devicetree@vger.kernel.org \
    --cc=eric@anholt.net \
    --cc=f.fainelli@gmail.com \
    --cc=frowand.list@gmail.com \
    --cc=hch@lst.de \
    --cc=iommu@lists.linux-foundation.org \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-riscv@lists.infradead.org \
    --cc=linux-rpi-kernel@lists.infradead.org \
    --cc=m.szyprowski@samsung.com \
    --cc=marc.zyngier@arm.com \
    --cc=mbrugger@suse.com \
    --cc=phill@raspberryi.org \
    --cc=robh+dt@kernel.org \
    --cc=robin.murphy@arm.com \
    --cc=wahrenst@gmx.net \
    --cc=will@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.