All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jaehoon Chung <jh80.chung@samsung.com>
To: u-boot@lists.denx.de
Subject: [U-Boot] [PATCH 2/7] mmc: sandbox: rename CONFIG, fix dependency, and use it in Makefile
Date: Tue, 31 Jan 2017 21:53:17 +0900	[thread overview]
Message-ID: <4db9b77e-b9d9-f543-cab0-d596182fa8c3@samsung.com> (raw)
In-Reply-To: <1485773215-8797-2-git-send-email-yamada.masahiro@socionext.com>

On 01/30/2017 07:46 PM, Masahiro Yamada wrote:
> [1] Rename CONFIG_SANDBOX_MMC to CONFIG_MMC_SANDBOX for consistency
>     I want all MMC driver options prefixed with CONFIG_MMC_.
> 
> [2] Fix dependency
>     Add necessary depends on to avoid compile error.
>     Instead "depends on MMC" is unneeded because this config entry
>     resides inside of "if MMC".
> 
> [3] Currently, this config symbol is not referenced at all.
>     Use it to enable/disable the driver in Makefile.
> 
> Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>

Applied on u-boot-mmc. Thanks!

Best Regards,
Jaehoon Chung

> ---
> 
> Changes in v2: None
> 
>  configs/sandbox_defconfig     | 2 +-
>  configs/sandbox_spl_defconfig | 2 +-
>  drivers/mmc/Kconfig           | 5 +++--
>  drivers/mmc/Makefile          | 6 +-----
>  4 files changed, 6 insertions(+), 9 deletions(-)
> 
> diff --git a/configs/sandbox_defconfig b/configs/sandbox_defconfig
> index 877aa94..01f6f5d 100644
> --- a/configs/sandbox_defconfig
> +++ b/configs/sandbox_defconfig
> @@ -94,7 +94,7 @@ CONFIG_CROS_EC_SPI=y
>  CONFIG_PWRSEQ=y
>  CONFIG_SPL_PWRSEQ=y
>  CONFIG_I2C_EEPROM=y
> -CONFIG_SANDBOX_MMC=y
> +CONFIG_MMC_SANDBOX=y
>  CONFIG_SPI_FLASH_SANDBOX=y
>  CONFIG_SPI_FLASH=y
>  CONFIG_SPI_FLASH_ATMEL=y
> diff --git a/configs/sandbox_spl_defconfig b/configs/sandbox_spl_defconfig
> index 0569647..896b15d 100644
> --- a/configs/sandbox_spl_defconfig
> +++ b/configs/sandbox_spl_defconfig
> @@ -104,7 +104,7 @@ CONFIG_CROS_EC_SANDBOX=y
>  CONFIG_CROS_EC_SPI=y
>  CONFIG_PWRSEQ=y
>  CONFIG_SPL_PWRSEQ=y
> -CONFIG_SANDBOX_MMC=y
> +CONFIG_MMC_SANDBOX=y
>  CONFIG_SPI_FLASH_SANDBOX=y
>  CONFIG_SPI_FLASH=y
>  CONFIG_SPI_FLASH_ATMEL=y
> diff --git a/drivers/mmc/Kconfig b/drivers/mmc/Kconfig
> index df4913b..97d245e 100644
> --- a/drivers/mmc/Kconfig
> +++ b/drivers/mmc/Kconfig
> @@ -187,9 +187,10 @@ config MMC_UNIPHIER
>  	help
>  	  This selects support for the SD/MMC Host Controller on UniPhier SoCs.
>  
> -config SANDBOX_MMC
> +config MMC_SANDBOX
>  	bool "Sandbox MMC support"
> -	depends on MMC && SANDBOX
> +	depends on SANDBOX
> +	depends on BLK && DM_MMC_OPS && OF_CONTROL
>  	help
>  	  This select a dummy sandbox MMC driver. At present this does nothing
>  	  other than allow sandbox to be build with MMC support. This
> diff --git a/drivers/mmc/Makefile b/drivers/mmc/Makefile
> index 6af7f79..2747deb 100644
> --- a/drivers/mmc/Makefile
> +++ b/drivers/mmc/Makefile
> @@ -40,11 +40,7 @@ obj-$(CONFIG_X86) += pci_mmc.o
>  obj-$(CONFIG_PXA_MMC_GENERIC) += pxa_mmc_gen.o
>  obj-$(CONFIG_SUPPORT_EMMC_RPMB) += rpmb.o
>  obj-$(CONFIG_S3C_SDI) += s3c_sdi.o
> -ifdef CONFIG_BLK
> -ifdef CONFIG_GENERIC_MMC
> -obj-$(CONFIG_SANDBOX) += sandbox_mmc.o
> -endif
> -endif
> +obj-$(CONFIG_MMC_SANDBOX)		+= sandbox_mmc.o
>  obj-$(CONFIG_SH_MMCIF) += sh_mmcif.o
>  obj-$(CONFIG_SH_SDHI) += sh_sdhi.o
>  obj-$(CONFIG_ZYNQ_SDHCI) += zynq_sdhci.o
> 

  reply	other threads:[~2017-01-31 12:53 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <CGME20170130104722epcas4p181b30c255a3031c3c5c4cf45f4c1a897@epcas4p1.samsung.com>
2017-01-30 10:46 ` [U-Boot] [PATCH 1/7] mmc: move CONFIG_GENERIC_MMC to Kconfig Masahiro Yamada
2017-01-30 10:46   ` [U-Boot] [PATCH 2/7] mmc: sandbox: rename CONFIG, fix dependency, and use it in Makefile Masahiro Yamada
2017-01-31 12:53     ` Jaehoon Chung [this message]
2017-01-30 10:46   ` [U-Boot] [PATCH 3/7] mmc: zynq: rename CONFIG_ZYNQ_SDHCI to CONFIG_MMC_SDHCI_ZYNQ Masahiro Yamada
2017-01-31 12:53     ` Jaehoon Chung
2017-01-30 10:46   ` [U-Boot] [PATCH 4/7] mmc: rockchip: rename CONFIG_ROCKCHIP_SDHCI to CONFIG_MMC_SDHCI_ROCKCHIP Masahiro Yamada
2017-01-31 12:53     ` Jaehoon Chung
2017-01-30 10:46   ` [U-Boot] [PATCH 5/7] mmc: msm: rename CONFIG_MSM_SDHCI to CONFIG_MMC_SDHCI_MSM Masahiro Yamada
2017-01-31 12:53     ` Jaehoon Chung
2017-01-30 10:46   ` [U-Boot] [PATCH 6/7] mmc: pic32: rename CONFIG_PIC32_SDHCI to CONFIG_MMC_SDHCI_PIC32 Masahiro Yamada
2017-01-31 12:54     ` Jaehoon Chung
2017-01-30 10:46   ` [U-Boot] [PATCH 7/7] mmc: atmel: rename CONFIG_ATMEL_SDHCI to CONFIG_MMC_SDHCI_ATMEL Masahiro Yamada
2017-01-31 12:54     ` Jaehoon Chung
2017-01-31 12:53   ` [U-Boot] [PATCH 1/7] mmc: move CONFIG_GENERIC_MMC to Kconfig Jaehoon Chung

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4db9b77e-b9d9-f543-cab0-d596182fa8c3@samsung.com \
    --to=jh80.chung@samsung.com \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.