All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jaehoon Chung <jh80.chung@samsung.com>
To: u-boot@lists.denx.de
Subject: [U-Boot] [PATCH 6/7] mmc: pic32: rename CONFIG_PIC32_SDHCI to CONFIG_MMC_SDHCI_PIC32
Date: Tue, 31 Jan 2017 21:54:18 +0900	[thread overview]
Message-ID: <b7f3e926-29fa-541c-8ecc-ce182c5afb53@samsung.com> (raw)
In-Reply-To: <1485773215-8797-6-git-send-email-yamada.masahiro@socionext.com>

On 01/30/2017 07:46 PM, Masahiro Yamada wrote:
> Make the naming scheme consistent; all SDHCI-base drivers prefixed
> with CONFIG_MMC_SDHCI_.
> 
> Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>


Applied on u-boot-mmc. Thanks!

Best Regards,
Jaehoon Chung


> ---
> 
> Changes in v2: None
> 
>  configs/pic32mzdask_defconfig |  2 +-
>  drivers/mmc/Kconfig           | 14 +++++++-------
>  drivers/mmc/Makefile          |  2 +-
>  3 files changed, 9 insertions(+), 9 deletions(-)
> 
> diff --git a/configs/pic32mzdask_defconfig b/configs/pic32mzdask_defconfig
> index 90a0d32..85c0d2a 100644
> --- a/configs/pic32mzdask_defconfig
> +++ b/configs/pic32mzdask_defconfig
> @@ -29,7 +29,7 @@ CONFIG_NET_RANDOM_ETHADDR=y
>  CONFIG_CLK=y
>  CONFIG_DM_GPIO=y
>  CONFIG_DM_MMC=y
> -CONFIG_PIC32_SDHCI=y
> +CONFIG_MMC_SDHCI_PIC32=y
>  CONFIG_MMC_SDHCI=y
>  CONFIG_DM_ETH=y
>  CONFIG_PIC32_ETH=y
> diff --git a/drivers/mmc/Kconfig b/drivers/mmc/Kconfig
> index c9a4ca9..520e7ea 100644
> --- a/drivers/mmc/Kconfig
> +++ b/drivers/mmc/Kconfig
> @@ -148,13 +148,6 @@ config SH_SDHI
>  	help
>  	  Support for the on-chip SDHI host controller on SuperH/Renesas ARM SoCs platform
>  
> -config PIC32_SDHCI
> -	bool "Microchip PIC32 on-chip SDHCI support"
> -	depends on DM_MMC && MACH_PIC32
> -	depends on MMC_SDHCI
> -	help
> -	  Support for Microchip PIC32 SDHCI controller.
> -
>  config MMC_UNIPHIER
>  	bool "UniPhier SD/MMC Host Controller support"
>  	depends on ARCH_UNIPHIER
> @@ -255,6 +248,13 @@ config MMC_SDHCI_MV
>  
>  	  If unsure, say N.
>  
> +config MMC_SDHCI_PIC32
> +	bool "Microchip PIC32 on-chip SDHCI support"
> +	depends on DM_MMC && MACH_PIC32
> +	depends on MMC_SDHCI
> +	help
> +	  Support for Microchip PIC32 SDHCI controller.
> +
>  config MMC_SDHCI_ROCKCHIP
>  	bool "Arasan SDHCI controller for Rockchip support"
>  	depends on ARCH_ROCKCHIP
> diff --git a/drivers/mmc/Makefile b/drivers/mmc/Makefile
> index 7693644..e63f439 100644
> --- a/drivers/mmc/Makefile
> +++ b/drivers/mmc/Makefile
> @@ -50,7 +50,6 @@ obj-$(CONFIG_SPL_SAVEENV) += mmc_write.o
>  else
>  obj-$(CONFIG_GENERIC_MMC) += mmc_write.o
>  endif
> -obj-$(CONFIG_PIC32_SDHCI) += pic32_sdhci.o
>  
>  # SDHCI
>  obj-$(CONFIG_MMC_SDHCI)			+= sdhci.o
> @@ -59,6 +58,7 @@ obj-$(CONFIG_MMC_SDHCI_CADENCE)		+= sdhci-cadence.o
>  obj-$(CONFIG_MMC_SDHCI_KONA)		+= kona_sdhci.o
>  obj-$(CONFIG_MMC_SDHCI_MSM)		+= msm_sdhci.o
>  obj-$(CONFIG_MMC_SDHCI_MV)		+= mv_sdhci.o
> +obj-$(CONFIG_MMC_SDHCI_PIC32)		+= pic32_sdhci.o
>  obj-$(CONFIG_MMC_SDHCI_ROCKCHIP)	+= rockchip_sdhci.o
>  obj-$(CONFIG_MMC_SDHCI_S5P)		+= s5p_sdhci.o
>  obj-$(CONFIG_MMC_SDHCI_SPEAR)		+= spear_sdhci.o
> 

  reply	other threads:[~2017-01-31 12:54 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <CGME20170130104722epcas4p181b30c255a3031c3c5c4cf45f4c1a897@epcas4p1.samsung.com>
2017-01-30 10:46 ` [U-Boot] [PATCH 1/7] mmc: move CONFIG_GENERIC_MMC to Kconfig Masahiro Yamada
2017-01-30 10:46   ` [U-Boot] [PATCH 2/7] mmc: sandbox: rename CONFIG, fix dependency, and use it in Makefile Masahiro Yamada
2017-01-31 12:53     ` Jaehoon Chung
2017-01-30 10:46   ` [U-Boot] [PATCH 3/7] mmc: zynq: rename CONFIG_ZYNQ_SDHCI to CONFIG_MMC_SDHCI_ZYNQ Masahiro Yamada
2017-01-31 12:53     ` Jaehoon Chung
2017-01-30 10:46   ` [U-Boot] [PATCH 4/7] mmc: rockchip: rename CONFIG_ROCKCHIP_SDHCI to CONFIG_MMC_SDHCI_ROCKCHIP Masahiro Yamada
2017-01-31 12:53     ` Jaehoon Chung
2017-01-30 10:46   ` [U-Boot] [PATCH 5/7] mmc: msm: rename CONFIG_MSM_SDHCI to CONFIG_MMC_SDHCI_MSM Masahiro Yamada
2017-01-31 12:53     ` Jaehoon Chung
2017-01-30 10:46   ` [U-Boot] [PATCH 6/7] mmc: pic32: rename CONFIG_PIC32_SDHCI to CONFIG_MMC_SDHCI_PIC32 Masahiro Yamada
2017-01-31 12:54     ` Jaehoon Chung [this message]
2017-01-30 10:46   ` [U-Boot] [PATCH 7/7] mmc: atmel: rename CONFIG_ATMEL_SDHCI to CONFIG_MMC_SDHCI_ATMEL Masahiro Yamada
2017-01-31 12:54     ` Jaehoon Chung
2017-01-31 12:53   ` [U-Boot] [PATCH 1/7] mmc: move CONFIG_GENERIC_MMC to Kconfig Jaehoon Chung

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=b7f3e926-29fa-541c-8ecc-ce182c5afb53@samsung.com \
    --to=jh80.chung@samsung.com \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.