All of lore.kernel.org
 help / color / mirror / Atom feed
From: BALATON Zoltan via <qemu-devel@nongnu.org>
To: qemu-devel@nongnu.org
Cc: Huacai Chen <chenhuacai@kernel.org>, f4bug@amsat.org
Subject: [PATCH 01/24] vt82c686: Rename AC97/MC97 parts from VT82C686B to VIA
Date: Sat, 02 Jan 2021 11:43:35 +0100	[thread overview]
Message-ID: <510ddb17836a2c2e68a27cf2dcaee420bc2efbc1.1609584215.git.balaton@eik.bme.hu> (raw)
In-Reply-To: <cover.1609584215.git.balaton@eik.bme.hu>

These parts are common between VT82C686B and VT8231 so can be shared
in the future. Rename them to VIA prefix accordingly.

Signed-off-by: BALATON Zoltan <balaton@eik.bme.hu>
Reviewed-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
---
 hw/isa/vt82c686.c | 28 ++++++++++++++--------------
 1 file changed, 14 insertions(+), 14 deletions(-)

diff --git a/hw/isa/vt82c686.c b/hw/isa/vt82c686.c
index b3170c70c3..2a0f85dea9 100644
--- a/hw/isa/vt82c686.c
+++ b/hw/isa/vt82c686.c
@@ -168,22 +168,22 @@ struct VT686PMState {
     uint32_t smb_io_base;
 };
 
-struct VT686AC97State {
+struct VIAAC97State {
     PCIDevice dev;
 };
 
-struct VT686MC97State {
+struct VIAMC97State {
     PCIDevice dev;
 };
 
 #define TYPE_VT82C686B_PM_DEVICE "VT82C686B_PM"
 OBJECT_DECLARE_SIMPLE_TYPE(VT686PMState, VT82C686B_PM_DEVICE)
 
-#define TYPE_VT82C686B_MC97_DEVICE "VT82C686B_MC97"
-OBJECT_DECLARE_SIMPLE_TYPE(VT686MC97State, VT82C686B_MC97_DEVICE)
+#define TYPE_VIA_MC97_DEVICE "VIA_MC97"
+OBJECT_DECLARE_SIMPLE_TYPE(VIAMC97State, VIA_MC97_DEVICE)
 
-#define TYPE_VT82C686B_AC97_DEVICE "VT82C686B_AC97"
-OBJECT_DECLARE_SIMPLE_TYPE(VT686AC97State, VT82C686B_AC97_DEVICE)
+#define TYPE_VIA_AC97_DEVICE "VIA_AC97"
+OBJECT_DECLARE_SIMPLE_TYPE(VIAAC97State, VIA_AC97_DEVICE)
 
 static void pm_update_sci(VT686PMState *s)
 {
@@ -260,7 +260,7 @@ static const VMStateDescription vmstate_acpi = {
 
 static void vt82c686b_ac97_realize(PCIDevice *dev, Error **errp)
 {
-    VT686AC97State *s = VT82C686B_AC97_DEVICE(dev);
+    VIAAC97State *s = VIA_AC97_DEVICE(dev);
     uint8_t *pci_conf = s->dev.config;
 
     pci_set_word(pci_conf + PCI_COMMAND, PCI_COMMAND_INVALIDATE |
@@ -274,7 +274,7 @@ void vt82c686b_ac97_init(PCIBus *bus, int devfn)
 {
     PCIDevice *dev;
 
-    dev = pci_new(devfn, TYPE_VT82C686B_AC97_DEVICE);
+    dev = pci_new(devfn, TYPE_VIA_AC97_DEVICE);
     pci_realize_and_unref(dev, bus, &error_fatal);
 }
 
@@ -293,9 +293,9 @@ static void via_ac97_class_init(ObjectClass *klass, void *data)
 }
 
 static const TypeInfo via_ac97_info = {
-    .name          = TYPE_VT82C686B_AC97_DEVICE,
+    .name          = TYPE_VIA_AC97_DEVICE,
     .parent        = TYPE_PCI_DEVICE,
-    .instance_size = sizeof(VT686AC97State),
+    .instance_size = sizeof(VIAAC97State),
     .class_init    = via_ac97_class_init,
     .interfaces = (InterfaceInfo[]) {
         { INTERFACE_CONVENTIONAL_PCI_DEVICE },
@@ -305,7 +305,7 @@ static const TypeInfo via_ac97_info = {
 
 static void vt82c686b_mc97_realize(PCIDevice *dev, Error **errp)
 {
-    VT686MC97State *s = VT82C686B_MC97_DEVICE(dev);
+    VIAMC97State *s = VIA_MC97_DEVICE(dev);
     uint8_t *pci_conf = s->dev.config;
 
     pci_set_word(pci_conf + PCI_COMMAND, PCI_COMMAND_INVALIDATE |
@@ -318,7 +318,7 @@ void vt82c686b_mc97_init(PCIBus *bus, int devfn)
 {
     PCIDevice *dev;
 
-    dev = pci_new(devfn, TYPE_VT82C686B_MC97_DEVICE);
+    dev = pci_new(devfn, TYPE_VIA_MC97_DEVICE);
     pci_realize_and_unref(dev, bus, &error_fatal);
 }
 
@@ -337,9 +337,9 @@ static void via_mc97_class_init(ObjectClass *klass, void *data)
 }
 
 static const TypeInfo via_mc97_info = {
-    .name          = TYPE_VT82C686B_MC97_DEVICE,
+    .name          = TYPE_VIA_MC97_DEVICE,
     .parent        = TYPE_PCI_DEVICE,
-    .instance_size = sizeof(VT686MC97State),
+    .instance_size = sizeof(VIAMC97State),
     .class_init    = via_mc97_class_init,
     .interfaces = (InterfaceInfo[]) {
         { INTERFACE_CONVENTIONAL_PCI_DEVICE },
-- 
2.21.3



  parent reply	other threads:[~2021-01-02 11:15 UTC|newest]

Thread overview: 33+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-01-02 10:43 [PATCH 00/24] vt82c686b clean ups and vt8231 emulation - all in one BALATON Zoltan via
2021-01-02 10:43 ` [PATCH 16/24] vt82c686: Fix up power management io base and config BALATON Zoltan via
2021-01-02 10:43 ` [PATCH 10/24] vt82c686: Remove unneeded includes and defines BALATON Zoltan via
2021-01-02 10:43 ` [PATCH 23/24] vt82c686: Add VT8231_SUPERIO based on VIA_SUPERIO BALATON Zoltan via
2021-01-02 10:43 ` [PATCH 09/24] vt82c686: Convert debug printf to trace points BALATON Zoltan via
2021-01-03 12:17   ` Philippe Mathieu-Daudé
2021-01-02 10:43 ` [PATCH 06/24] audio/via-ac97: Simplify code and set user_creatable to false BALATON Zoltan via
2021-01-02 10:43 ` [PATCH 13/24] vt82c686: Move superio memory region to SuperIOConfig struct BALATON Zoltan via
2021-01-02 10:43 ` [PATCH 21/24] vt82c686: Implement control of serial port io ranges via config regs BALATON Zoltan via
2021-01-02 10:43 ` [PATCH 07/24] vt82c686: Remove legacy vt82c686b_isa_init() function BALATON Zoltan via
2021-01-02 10:43 ` [PATCH 24/24] vt82c686: Add emulation of VT8231 south bridge BALATON Zoltan via
2021-01-02 10:43 ` [PATCH 11/24] vt82c686: Use shorter name for local variable holding object state BALATON Zoltan via
2021-01-03 12:16   ` Philippe Mathieu-Daudé
2021-01-02 10:43 ` [PATCH 22/24] vt82c686: QOM-ify superio related functionality BALATON Zoltan via
2021-01-02 10:43 ` [PATCH 05/24] vt82c686: Split off via-[am]c97 into separate file in hw/audio BALATON Zoltan via
2021-01-02 10:43 ` [PATCH 18/24] vt82c686: Simplify vt82c686b_realize() BALATON Zoltan via
2021-01-02 10:43 ` BALATON Zoltan via [this message]
2021-01-02 10:43 ` [PATCH 14/24] vt82c686: Reorganise code BALATON Zoltan via
2021-01-02 10:43 ` [PATCH 15/24] vt82c686: Fix SMBus IO base and configuration registers BALATON Zoltan via
2021-01-02 10:43 ` [PATCH 17/24] vt82c686: Make vt82c686b-pm an abstract base class and add vt8231-pm based on it BALATON Zoltan via
2021-01-02 10:43 ` [PATCH 19/24] vt82c686: Move creation of ISA devices to the ISA bridge BALATON Zoltan via
2021-01-02 10:43 ` [PATCH 08/24] vt82c686: Remove legacy vt82c686b_pm_init() function BALATON Zoltan via
2021-01-02 10:43 ` [PATCH 02/24] vt82c686: Remove unnecessary _DEVICE suffix from type macros BALATON Zoltan via
2021-01-02 10:43 ` [PATCH 20/24] vt82c686: Fix superio_cfg_{read,write}() functions BALATON Zoltan via
2021-01-02 10:43 ` [PATCH 03/24] vt82c686b: Rename VT82C686B to VT82C686B_ISA BALATON Zoltan via
2021-01-02 10:43 ` [PATCH 12/24] vt82c686: Rename superio config related parts BALATON Zoltan via
2021-01-03 12:16   ` Philippe Mathieu-Daudé
2021-01-02 10:43 ` [PATCH 04/24] vt82c686: Remove vt82c686b_[am]c97_init() functions BALATON Zoltan via
2021-01-03 13:55 ` [PATCH 00/24] vt82c686b clean ups and vt8231 emulation - all in one Philippe Mathieu-Daudé
2021-01-03 14:27   ` BALATON Zoltan via
2021-01-03 15:45     ` Philippe Mathieu-Daudé
2021-01-03 17:07       ` BALATON Zoltan via
2021-01-04  6:38         ` Jiaxun Yang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=510ddb17836a2c2e68a27cf2dcaee420bc2efbc1.1609584215.git.balaton@eik.bme.hu \
    --to=qemu-devel@nongnu.org \
    --cc=balaton@eik.bme.hu \
    --cc=chenhuacai@kernel.org \
    --cc=f4bug@amsat.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.