All of lore.kernel.org
 help / color / mirror / Atom feed
From: Christophe Leroy <christophe.leroy@csgroup.eu>
To: Kees Cook <keescook@chromium.org>
Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Paul Mackerras <paulus@samba.org>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Andrew Morton <akpm@linux-foundation.org>,
	"James E.J. Bottomley" <James.Bottomley@hansenpartnership.com>,
	Helge Deller <deller@gmx.de>, Arnd Bergmann <arnd@arndb.de>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	linux-kernel@vger.kernel.org, linuxppc-dev@lists.ozlabs.org,
	linux-ia64@vger.kernel.org, linux-parisc@vger.kernel.org,
	linux-arch@vger.kernel.org, linux-mm@kvack.org
Subject: Re: [PATCH v1 09/10] lkdtm: Fix lkdtm_EXEC_RODATA()
Date: Wed, 13 Oct 2021 09:35:34 +0200	[thread overview]
Message-ID: <5181d261-fe93-5e21-5013-321d85e22354@csgroup.eu> (raw)
In-Reply-To: <202110130008.EC5E957D4A@keescook>



Le 13/10/2021 à 09:09, Kees Cook a écrit :
> On Mon, Oct 11, 2021 at 05:25:36PM +0200, Christophe Leroy wrote:
>> Behind a location, lkdtm_EXEC_RODATA() executes a real function,
>> not a copy of do_nothing().
>>
>> So do it directly instead of using execute_location().
> 
> I don't understand this. Why does the next patch not fix this?

Well, probably it would, but it looked incorrect in my mind.

lkdtm_rodata_do_nothing() is a function which has its own function 
descriptor, it is not a copy of do_nothing().

If we use execute_location() as modified by next patch, then we will 
execute it using the function descriptor of do_nothing(). Allthough it 
most likely works (at least on powerpc as it uses the same TOC) it looks 
odd to me to do so.

Am I missing something ?

Christophe


> 
> -Kees
> 
>>
>> And fix displayed addresses by dereferencing the function descriptors.
>>
>> Signed-off-by: Christophe Leroy <christophe.leroy@csgroup.eu>
>> ---
>>   drivers/misc/lkdtm/perms.c | 9 ++++++++-
>>   1 file changed, 8 insertions(+), 1 deletion(-)
>>
>> diff --git a/drivers/misc/lkdtm/perms.c b/drivers/misc/lkdtm/perms.c
>> index 442d60ed25ef..da16564e1ecd 100644
>> --- a/drivers/misc/lkdtm/perms.c
>> +++ b/drivers/misc/lkdtm/perms.c
>> @@ -153,7 +153,14 @@ void lkdtm_EXEC_VMALLOC(void)
>>   
>>   void lkdtm_EXEC_RODATA(void)
>>   {
>> -	execute_location(lkdtm_rodata_do_nothing, CODE_AS_IS);
>> +	pr_info("attempting ok execution at %px\n",
>> +		dereference_symbol_descriptor(do_nothing));
>> +	do_nothing();
>> +
>> +	pr_info("attempting bad execution at %px\n",
>> +		dereference_symbol_descriptor(lkdtm_rodata_do_nothing));
>> +	lkdtm_rodata_do_nothing();
>> +	pr_err("FAIL: func returned\n");
>>   }
>>   
>>   void lkdtm_EXEC_USERSPACE(void)
>> -- 
>> 2.31.1
>>
> 

WARNING: multiple messages have this Message-ID (diff)
From: Christophe Leroy <christophe.leroy@csgroup.eu>
To: Kees Cook <keescook@chromium.org>
Cc: linux-arch@vger.kernel.org, linux-ia64@vger.kernel.org,
	linux-parisc@vger.kernel.org, Arnd Bergmann <arnd@arndb.de>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Helge Deller <deller@gmx.de>,
	linux-kernel@vger.kernel.org,
	"James E.J. Bottomley" <James.Bottomley@hansenpartnership.com>,
	linux-mm@kvack.org, Paul Mackerras <paulus@samba.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	linuxppc-dev@lists.ozlabs.org
Subject: Re: [PATCH v1 09/10] lkdtm: Fix lkdtm_EXEC_RODATA()
Date: Wed, 13 Oct 2021 09:35:34 +0200	[thread overview]
Message-ID: <5181d261-fe93-5e21-5013-321d85e22354@csgroup.eu> (raw)
In-Reply-To: <202110130008.EC5E957D4A@keescook>



Le 13/10/2021 à 09:09, Kees Cook a écrit :
> On Mon, Oct 11, 2021 at 05:25:36PM +0200, Christophe Leroy wrote:
>> Behind a location, lkdtm_EXEC_RODATA() executes a real function,
>> not a copy of do_nothing().
>>
>> So do it directly instead of using execute_location().
> 
> I don't understand this. Why does the next patch not fix this?

Well, probably it would, but it looked incorrect in my mind.

lkdtm_rodata_do_nothing() is a function which has its own function 
descriptor, it is not a copy of do_nothing().

If we use execute_location() as modified by next patch, then we will 
execute it using the function descriptor of do_nothing(). Allthough it 
most likely works (at least on powerpc as it uses the same TOC) it looks 
odd to me to do so.

Am I missing something ?

Christophe


> 
> -Kees
> 
>>
>> And fix displayed addresses by dereferencing the function descriptors.
>>
>> Signed-off-by: Christophe Leroy <christophe.leroy@csgroup.eu>
>> ---
>>   drivers/misc/lkdtm/perms.c | 9 ++++++++-
>>   1 file changed, 8 insertions(+), 1 deletion(-)
>>
>> diff --git a/drivers/misc/lkdtm/perms.c b/drivers/misc/lkdtm/perms.c
>> index 442d60ed25ef..da16564e1ecd 100644
>> --- a/drivers/misc/lkdtm/perms.c
>> +++ b/drivers/misc/lkdtm/perms.c
>> @@ -153,7 +153,14 @@ void lkdtm_EXEC_VMALLOC(void)
>>   
>>   void lkdtm_EXEC_RODATA(void)
>>   {
>> -	execute_location(lkdtm_rodata_do_nothing, CODE_AS_IS);
>> +	pr_info("attempting ok execution at %px\n",
>> +		dereference_symbol_descriptor(do_nothing));
>> +	do_nothing();
>> +
>> +	pr_info("attempting bad execution at %px\n",
>> +		dereference_symbol_descriptor(lkdtm_rodata_do_nothing));
>> +	lkdtm_rodata_do_nothing();
>> +	pr_err("FAIL: func returned\n");
>>   }
>>   
>>   void lkdtm_EXEC_USERSPACE(void)
>> -- 
>> 2.31.1
>>
> 

WARNING: multiple messages have this Message-ID (diff)
From: Christophe Leroy <christophe.leroy@csgroup.eu>
To: Kees Cook <keescook@chromium.org>
Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Paul Mackerras <paulus@samba.org>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Andrew Morton <akpm@linux-foundation.org>,
	"James E.J. Bottomley" <James.Bottomley@hansenpartnership.com>,
	Helge Deller <deller@gmx.de>, Arnd Bergmann <arnd@arndb.de>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	linux-kernel@vger.kernel.org, linuxppc-dev@lists.ozlabs.org,
	linux-ia64@vger.kernel.org, linux-parisc@vger.kernel.org,
	linux-arch@vger.kernel.org, linux-mm@kvack.org
Subject: Re: [PATCH v1 09/10] lkdtm: Fix lkdtm_EXEC_RODATA()
Date: Wed, 13 Oct 2021 07:35:34 +0000	[thread overview]
Message-ID: <5181d261-fe93-5e21-5013-321d85e22354@csgroup.eu> (raw)
In-Reply-To: <202110130008.EC5E957D4A@keescook>



Le 13/10/2021 à 09:09, Kees Cook a écrit :
> On Mon, Oct 11, 2021 at 05:25:36PM +0200, Christophe Leroy wrote:
>> Behind a location, lkdtm_EXEC_RODATA() executes a real function,
>> not a copy of do_nothing().
>>
>> So do it directly instead of using execute_location().
> 
> I don't understand this. Why does the next patch not fix this?

Well, probably it would, but it looked incorrect in my mind.

lkdtm_rodata_do_nothing() is a function which has its own function 
descriptor, it is not a copy of do_nothing().

If we use execute_location() as modified by next patch, then we will 
execute it using the function descriptor of do_nothing(). Allthough it 
most likely works (at least on powerpc as it uses the same TOC) it looks 
odd to me to do so.

Am I missing something ?

Christophe


> 
> -Kees
> 
>>
>> And fix displayed addresses by dereferencing the function descriptors.
>>
>> Signed-off-by: Christophe Leroy <christophe.leroy@csgroup.eu>
>> ---
>>   drivers/misc/lkdtm/perms.c | 9 ++++++++-
>>   1 file changed, 8 insertions(+), 1 deletion(-)
>>
>> diff --git a/drivers/misc/lkdtm/perms.c b/drivers/misc/lkdtm/perms.c
>> index 442d60ed25ef..da16564e1ecd 100644
>> --- a/drivers/misc/lkdtm/perms.c
>> +++ b/drivers/misc/lkdtm/perms.c
>> @@ -153,7 +153,14 @@ void lkdtm_EXEC_VMALLOC(void)
>>   
>>   void lkdtm_EXEC_RODATA(void)
>>   {
>> -	execute_location(lkdtm_rodata_do_nothing, CODE_AS_IS);
>> +	pr_info("attempting ok execution at %px\n",
>> +		dereference_symbol_descriptor(do_nothing));
>> +	do_nothing();
>> +
>> +	pr_info("attempting bad execution at %px\n",
>> +		dereference_symbol_descriptor(lkdtm_rodata_do_nothing));
>> +	lkdtm_rodata_do_nothing();
>> +	pr_err("FAIL: func returned\n");
>>   }
>>   
>>   void lkdtm_EXEC_USERSPACE(void)
>> -- 
>> 2.31.1
>>
> 

  reply	other threads:[~2021-10-13  7:35 UTC|newest]

Thread overview: 114+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-10-11 15:25 [PATCH v1 00/10] Fix LKDTM for PPC64/IA64/PARISC Christophe Leroy
2021-10-11 15:25 ` Christophe Leroy
2021-10-11 15:25 ` Christophe Leroy
2021-10-11 15:25 ` [PATCH v1 01/10] powerpc: Move 'struct ppc64_opd_entry' back into asm/elf.h Christophe Leroy
2021-10-11 15:25   ` Christophe Leroy
2021-10-11 15:25   ` Christophe Leroy
2021-10-12  7:10   ` Michael Ellerman
2021-10-12  7:10     ` Michael Ellerman
2021-10-12  7:10     ` Michael Ellerman
2021-10-12  8:02     ` Arnd Bergmann
2021-10-12  8:02       ` Arnd Bergmann
2021-10-12  8:02       ` Arnd Bergmann
2021-10-13  6:59   ` Kees Cook
2021-10-13  6:59     ` Kees Cook
2021-10-13  6:59     ` Kees Cook
2021-10-11 15:25 ` [PATCH v1 02/10] powerpc: Rename 'funcaddr' to 'addr' in 'struct ppc64_opd_entry' Christophe Leroy
2021-10-11 15:25   ` Christophe Leroy
2021-10-11 15:25   ` Christophe Leroy
2021-10-13  6:59   ` Kees Cook
2021-10-13  6:59     ` Kees Cook
2021-10-13  6:59     ` Kees Cook
2021-10-11 15:25 ` [PATCH v1 03/10] ia64: Rename 'ip' to 'addr' in 'struct fdesc' Christophe Leroy
2021-10-11 15:25   ` Christophe Leroy
2021-10-11 15:25   ` Christophe Leroy
2021-10-13  6:59   ` Kees Cook
2021-10-13  6:59     ` Kees Cook
2021-10-13  6:59     ` Kees Cook
2021-10-11 15:25 ` [PATCH v1 04/10] asm-generic: Use HAVE_DEREFERENCE_FUNCTION_DESCRIPTOR to define associated stubs Christophe Leroy
2021-10-11 15:25   ` Christophe Leroy
2021-10-11 15:25   ` Christophe Leroy
2021-10-12  6:02   ` Helge Deller
2021-10-12  6:02     ` [PATCH v1 04/10] asm-generic: Use HAVE_DEREFERENCE_FUNCTION_DESCRIPTOR to define associated stub Helge Deller
2021-10-12  6:02     ` [PATCH v1 04/10] asm-generic: Use HAVE_DEREFERENCE_FUNCTION_DESCRIPTOR to define associated stubs Helge Deller
2021-10-12  6:11     ` Christophe Leroy
2021-10-12  6:11       ` [PATCH v1 04/10] asm-generic: Use HAVE_DEREFERENCE_FUNCTION_DESCRIPTOR to define associated stub Christophe Leroy
2021-10-12  6:11       ` [PATCH v1 04/10] asm-generic: Use HAVE_DEREFERENCE_FUNCTION_DESCRIPTOR to define associated stubs Christophe Leroy
2021-10-12  6:48       ` Helge Deller
2021-10-12  6:48         ` [PATCH v1 04/10] asm-generic: Use HAVE_DEREFERENCE_FUNCTION_DESCRIPTOR to define associated stub Helge Deller
2021-10-12  6:48         ` [PATCH v1 04/10] asm-generic: Use HAVE_DEREFERENCE_FUNCTION_DESCRIPTOR to define associated stubs Helge Deller
2021-10-13  7:00   ` Kees Cook
2021-10-13  7:00     ` [PATCH v1 04/10] asm-generic: Use HAVE_DEREFERENCE_FUNCTION_DESCRIPTOR to define associated stub Kees Cook
2021-10-13  7:00     ` [PATCH v1 04/10] asm-generic: Use HAVE_DEREFERENCE_FUNCTION_DESCRIPTOR to define associated stubs Kees Cook
2021-10-14  7:20     ` Christophe Leroy
2021-10-14  7:20       ` [PATCH v1 04/10] asm-generic: Use HAVE_DEREFERENCE_FUNCTION_DESCRIPTOR to define associated stub Christophe Leroy
2021-10-14  7:20       ` [PATCH v1 04/10] asm-generic: Use HAVE_DEREFERENCE_FUNCTION_DESCRIPTOR to define associated stubs Christophe Leroy
2021-10-11 15:25 ` [PATCH v1 05/10] asm-generic: Define 'funct_descr_t' to commonly describe function descriptors Christophe Leroy
2021-10-11 15:25   ` Christophe Leroy
2021-10-11 15:25   ` Christophe Leroy
2021-10-13  7:01   ` Kees Cook
2021-10-13  7:01     ` Kees Cook
2021-10-13  7:01     ` Kees Cook
2021-10-13  7:23     ` Christophe Leroy
2021-10-13  7:23       ` Christophe Leroy
2021-10-13  7:23       ` Christophe Leroy
2021-10-13  7:27       ` Kees Cook
2021-10-13  7:27         ` Kees Cook
2021-10-13  7:27         ` Kees Cook
2021-10-11 15:25 ` [PATCH v1 06/10] asm-generic: Refactor dereference_[kernel]_function_descriptor() Christophe Leroy
2021-10-11 15:25   ` Christophe Leroy
2021-10-11 15:25   ` Christophe Leroy
2021-10-13  7:02   ` Kees Cook
2021-10-13  7:02     ` Kees Cook
2021-10-13  7:02     ` Kees Cook
2021-10-13 11:20     ` Christophe Leroy
2021-10-13 11:20       ` Christophe Leroy
2021-10-13 11:20       ` Christophe Leroy
2021-10-13 11:34       ` Arnd Bergmann
2021-10-13 11:34         ` Arnd Bergmann
2021-10-13 11:34         ` Arnd Bergmann
2021-10-11 15:25 ` [PATCH v1 07/10] lkdtm: Force do_nothing() out of line Christophe Leroy
2021-10-11 15:25   ` Christophe Leroy
2021-10-11 15:25   ` Christophe Leroy
2021-10-13  7:02   ` Kees Cook
2021-10-13  7:02     ` Kees Cook
2021-10-13  7:02     ` Kees Cook
2021-10-11 15:25 ` [PATCH v1 08/10] lkdtm: Really write into kernel text in WRITE_KERN Christophe Leroy
2021-10-11 15:25   ` Christophe Leroy
2021-10-11 15:25   ` Christophe Leroy
2021-10-13  7:05   ` Kees Cook
2021-10-13  7:05     ` Kees Cook
2021-10-13  7:05     ` Kees Cook
2021-10-13  7:29     ` Christophe Leroy
2021-10-13  7:29       ` Christophe Leroy
2021-10-13  7:29       ` Christophe Leroy
2021-10-11 15:25 ` [PATCH v1 09/10] lkdtm: Fix lkdtm_EXEC_RODATA() Christophe Leroy
2021-10-11 15:25   ` Christophe Leroy
2021-10-11 15:25   ` Christophe Leroy
2021-10-13  7:09   ` Kees Cook
2021-10-13  7:09     ` Kees Cook
2021-10-13  7:09     ` Kees Cook
2021-10-13  7:35     ` Christophe Leroy [this message]
2021-10-13  7:35       ` Christophe Leroy
2021-10-13  7:35       ` Christophe Leroy
2021-10-13  7:23   ` Kees Cook
2021-10-13  7:23     ` Kees Cook
2021-10-13  7:23     ` Kees Cook
2021-10-13  7:39     ` Christophe Leroy
2021-10-13  7:39       ` Christophe Leroy
2021-10-13  7:39       ` Christophe Leroy
2021-10-13  7:48       ` Christophe Leroy
2021-10-13  7:48         ` Christophe Leroy
2021-10-13  7:48         ` Christophe Leroy
2021-10-13 12:45         ` Christophe Leroy
2021-10-13 12:45           ` Christophe Leroy
2021-10-13 12:45           ` Christophe Leroy
2021-10-11 15:25 ` [PATCH v1 10/10] lkdtm: Fix execute_[user]_location() Christophe Leroy
2021-10-11 15:25   ` Christophe Leroy
2021-10-11 15:25   ` Christophe Leroy
2021-10-13  7:16   ` Kees Cook
2021-10-13  7:16     ` Kees Cook
2021-10-13  7:16     ` Kees Cook
2021-10-13 12:00     ` Christophe Leroy
2021-10-13 12:00       ` Christophe Leroy
2021-10-13 12:00       ` Christophe Leroy

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5181d261-fe93-5e21-5013-321d85e22354@csgroup.eu \
    --to=christophe.leroy@csgroup.eu \
    --cc=James.Bottomley@hansenpartnership.com \
    --cc=akpm@linux-foundation.org \
    --cc=arnd@arndb.de \
    --cc=benh@kernel.crashing.org \
    --cc=deller@gmx.de \
    --cc=gregkh@linuxfoundation.org \
    --cc=keescook@chromium.org \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-ia64@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-parisc@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=mpe@ellerman.id.au \
    --cc=paulus@samba.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.