All of lore.kernel.org
 help / color / mirror / Atom feed
* [U-Boot] [PATCH] gpio: s5p_gpio: Call s5p_gpio_set_value() instead of open-code
@ 2013-06-15 14:19 Axel Lin
  2013-06-25  1:58 ` Minkyu Kang
  0 siblings, 1 reply; 2+ messages in thread
From: Axel Lin @ 2013-06-15 14:19 UTC (permalink / raw)
  To: u-boot

Call s5p_gpio_set_value() to avoid code duplication.

Signed-off-by: Axel Lin <axel.lin@ingics.com>
---
 drivers/gpio/s5p_gpio.c | 9 +--------
 1 file changed, 1 insertion(+), 8 deletions(-)

diff --git a/drivers/gpio/s5p_gpio.c b/drivers/gpio/s5p_gpio.c
index 656bf4a..4efb768 100644
--- a/drivers/gpio/s5p_gpio.c
+++ b/drivers/gpio/s5p_gpio.c
@@ -48,15 +48,8 @@ void s5p_gpio_cfg_pin(struct s5p_gpio_bank *bank, int gpio, int cfg)
 
 void s5p_gpio_direction_output(struct s5p_gpio_bank *bank, int gpio, int en)
 {
-	unsigned int value;
-
 	s5p_gpio_cfg_pin(bank, gpio, GPIO_OUTPUT);
-
-	value = readl(&bank->dat);
-	value &= ~DAT_MASK(gpio);
-	if (en)
-		value |= DAT_SET(gpio);
-	writel(value, &bank->dat);
+	s5p_gpio_set_value(bank, gpio, en);
 }
 
 void s5p_gpio_direction_input(struct s5p_gpio_bank *bank, int gpio)
-- 
1.8.1.2

^ permalink raw reply related	[flat|nested] 2+ messages in thread

* [U-Boot] [PATCH] gpio: s5p_gpio: Call s5p_gpio_set_value() instead of open-code
  2013-06-15 14:19 [U-Boot] [PATCH] gpio: s5p_gpio: Call s5p_gpio_set_value() instead of open-code Axel Lin
@ 2013-06-25  1:58 ` Minkyu Kang
  0 siblings, 0 replies; 2+ messages in thread
From: Minkyu Kang @ 2013-06-25  1:58 UTC (permalink / raw)
  To: u-boot

On 15/06/13 23:19, Axel Lin wrote:
> Call s5p_gpio_set_value() to avoid code duplication.
> 
> Signed-off-by: Axel Lin <axel.lin@ingics.com>
> ---
>  drivers/gpio/s5p_gpio.c | 9 +--------
>  1 file changed, 1 insertion(+), 8 deletions(-)
> 
> diff --git a/drivers/gpio/s5p_gpio.c b/drivers/gpio/s5p_gpio.c
> index 656bf4a..4efb768 100644
> --- a/drivers/gpio/s5p_gpio.c
> +++ b/drivers/gpio/s5p_gpio.c
> @@ -48,15 +48,8 @@ void s5p_gpio_cfg_pin(struct s5p_gpio_bank *bank, int gpio, int cfg)
>  
>  void s5p_gpio_direction_output(struct s5p_gpio_bank *bank, int gpio, int en)
>  {
> -	unsigned int value;
> -
>  	s5p_gpio_cfg_pin(bank, gpio, GPIO_OUTPUT);
> -
> -	value = readl(&bank->dat);
> -	value &= ~DAT_MASK(gpio);
> -	if (en)
> -		value |= DAT_SET(gpio);
> -	writel(value, &bank->dat);
> +	s5p_gpio_set_value(bank, gpio, en);
>  }
>  
>  void s5p_gpio_direction_input(struct s5p_gpio_bank *bank, int gpio)
> 

applied to u-boot-samsung.

Thanks,
Minkyu Kang.

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2013-06-25  1:58 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-06-15 14:19 [U-Boot] [PATCH] gpio: s5p_gpio: Call s5p_gpio_set_value() instead of open-code Axel Lin
2013-06-25  1:58 ` Minkyu Kang

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.