All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/3] dtoc: Improve support for 'ranges' property
@ 2021-07-29  1:23 Simon Glass
  2021-07-29  1:23 ` [PATCH 1/3] dtoc: Rename is_wider_than() to reduce confusion Simon Glass
                   ` (5 more replies)
  0 siblings, 6 replies; 14+ messages in thread
From: Simon Glass @ 2021-07-29  1:23 UTC (permalink / raw)
  To: U-Boot Mailing List
  Cc: Tom Rini, Simon Glass, Heiko Schocher, Heinrich Schuchardt,
	Philippe Reynes, Vincent Stehlé,
	Walter Lozano

An empty ranges property confuses dtoc at present and it dies with an
error. This series fixes this and a few related things.


Simon Glass (3):
  dtoc: Rename is_wider_than() to reduce confusion
  dtoc: Fix widening an int array to an int
  dtoc: Support widening a bool value

 arch/sandbox/dts/sandbox.dtsi        |  2 ++
 test/dm/of_platdata.c                |  7 ++---
 tools/dtoc/fdt.py                    | 40 +++++++++++++++++++---------
 tools/dtoc/test/dtoc_test_simple.dts |  2 ++
 tools/dtoc/test_dtoc.py              |  9 ++++---
 tools/dtoc/test_fdt.py               | 29 +++++++++++++++++---
 6 files changed, 68 insertions(+), 21 deletions(-)

-- 
2.32.0.432.gabb21c7263-goog


^ permalink raw reply	[flat|nested] 14+ messages in thread

end of thread, other threads:[~2021-12-07 19:13 UTC | newest]

Thread overview: 14+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-07-29  1:23 [PATCH 0/3] dtoc: Improve support for 'ranges' property Simon Glass
2021-07-29  1:23 ` [PATCH 1/3] dtoc: Rename is_wider_than() to reduce confusion Simon Glass
2021-08-02  2:45   ` Walter Lozano
2021-08-02  2:50     ` Simon Glass
2021-08-02 19:28       ` Walter Lozano
2021-11-25  0:12         ` Simon Glass
2021-12-07 19:13           ` Walter Lozano
2021-07-29  1:23 ` [PATCH 2/3] dtoc: Fix widening an int array to an int Simon Glass
2021-08-02  2:45   ` Walter Lozano
2021-08-02  2:50     ` Simon Glass
2021-07-29  1:23 ` [PATCH 3/3] dtoc: Support widening a bool value Simon Glass
2021-07-31 23:03 ` Simon Glass
2021-07-31 23:03 ` [PATCH 2/3] dtoc: Fix widening an int array to an int Simon Glass
2021-07-31 23:03 ` [PATCH 1/3] dtoc: Rename is_wider_than() to reduce confusion Simon Glass

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.