All of lore.kernel.org
 help / color / mirror / Atom feed
* [Qemu-devel] [PATCH v4 0/4] Convert 'status' of MigrationInfo from open-coded 'str' to enum type
@ 2015-03-09  6:45 zhanghailiang
  2015-03-09  6:45 ` [Qemu-devel] [PATCH v4 1/4] migration: Rename abbreviated macro MIG_STATE_* to MIGRATION_STATUS_* zhanghailiang
                   ` (4 more replies)
  0 siblings, 5 replies; 14+ messages in thread
From: zhanghailiang @ 2015-03-09  6:45 UTC (permalink / raw)
  To: qemu-devel
  Cc: zhanghailiang, quintela, armbru, lcapitulino, amit.shah,
	peter.huangpeng, dgilbert

Hi,

This series converts open-coded 'str' type to enum type for 'status'.

This conversion will be more convenient for future extensibility.
Actually, I will add a MIG_STATE_COLO state for COLO, and i also
saw Dave added MIG_STATE_POSTCOPY_ACTIVE for postcopy.

Patch 1 and 2 are preparation for the conversion, patch 3 completes the conversion.
Besides, i add a additional patch (patch 4) to expose 'cancelling' to user,
it will influence libvirt side. And i have CC libvirt development. 

One more thing, i have to replace MIG_STATE_ERROR with MIGRATION_STATUS_FAILED,
and it begin from 0, not its original -1. I think it has no side effect.

Please review.

v4:
- Rename _ERROR to _FAILED in patch 1 instead of patch 4 (Eric)
- Add Reviewd-by for patch 2 and 4
- Fix some grammar in commit message of patch 4 (Eric)

v3:
- Use longer name for Migration status macro. (Eric Blake)
- Rename internal-only typename 'MigrationStatus' (Eric, Dave, Markus)
- Expose 'cancelling' state (Eric Blake)

v2:
- Remove '(since xyz)' strings. (Eric Blake)

Thanks for their comments. ;)

zhanghailiang (4):
  migration: Rename abbreviated macro MIG_STATE_* to 
    MIGRATION_STATUS_*
  hmp: Rename 'MigrationStatus' to 'HMPMigrationStatus'
  migration: Convert 'status' of MigrationInfo to use an enum type
  migration: Expose 'cancelling' status to user

 hmp.c                 | 15 ++++----
 migration/migration.c | 95 ++++++++++++++++++++++++---------------------------
 qapi-schema.json      | 34 +++++++++++++++---
 3 files changed, 81 insertions(+), 63 deletions(-)

-- 
1.7.12.4

^ permalink raw reply	[flat|nested] 14+ messages in thread

end of thread, other threads:[~2015-03-13 13:10 UTC | newest]

Thread overview: 14+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-03-09  6:45 [Qemu-devel] [PATCH v4 0/4] Convert 'status' of MigrationInfo from open-coded 'str' to enum type zhanghailiang
2015-03-09  6:45 ` [Qemu-devel] [PATCH v4 1/4] migration: Rename abbreviated macro MIG_STATE_* to MIGRATION_STATUS_* zhanghailiang
2015-03-12 19:29   ` Eric Blake
2015-03-09  6:45 ` [Qemu-devel] [PATCH v4 2/4] hmp: Rename 'MigrationStatus' to 'HMPMigrationStatus' zhanghailiang
2015-03-09  6:45 ` [Qemu-devel] [PATCH v4 3/4] migration: Convert 'status' of MigrationInfo to use an enum type zhanghailiang
2015-03-12 19:37   ` Eric Blake
2015-03-13  6:23     ` zhanghailiang
2015-03-09  6:45 ` [Qemu-devel] [PATCH v4 4/4] migration: Expose 'cancelling' status to user zhanghailiang
2015-03-13 10:49   ` Paolo Bonzini
2015-03-13 12:25     ` Eric Blake
2015-03-13 12:28       ` Dr. David Alan Gilbert
2015-03-13 13:10         ` Eric Blake
2015-03-12  1:06 ` [Qemu-devel] [PATCH v4 0/4] Convert 'status' of MigrationInfo from open-coded 'str' to enum type zhanghailiang
2015-03-12 19:30   ` [Qemu-devel] [for 2.3? PATCH " Eric Blake

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.