All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v1 0/3] Clean-up of datastructres and variable names in smmu.c
@ 2015-03-27  7:17 Manish Jaggi
  2015-03-27 12:57 ` Julien Grall
  0 siblings, 1 reply; 2+ messages in thread
From: Manish Jaggi @ 2015-03-27  7:17 UTC (permalink / raw)
  To: xen Devel, Kumar, Vijaya, Kapoor, Prasun, Ian Campbell,
	Stefano Stabellini, Julien Grall

This series of patches is a clean-up on the naming of the datastructures
and the variable names. It is sometimes hard to understand the flow of
the code and current code readability for understanding flow and making
changes it not intuitive.

Based on these I will send next set of patches for PCI passthrough support

manish (3):
   xen/arm: smmu: Rename arm_smmu_xen_device with device_iommu_info
   xen/arm: smmu: Renaming arm_smmu_xen_domain with domain_iommu_info
   xen/arm: smmu: Renaming struct iommu_domain *domain to struct
     iommu_domain *iommu_domain

  xen/drivers/passthrough/arm/smmu.c | 136 ++++++++++++++++++-------------------
  1 file changed, 68 insertions(+), 68 deletions(-)

-- 
1.9.1

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PATCH v1 0/3] Clean-up of datastructres and variable names in smmu.c
  2015-03-27  7:17 [PATCH v1 0/3] Clean-up of datastructres and variable names in smmu.c Manish Jaggi
@ 2015-03-27 12:57 ` Julien Grall
  0 siblings, 0 replies; 2+ messages in thread
From: Julien Grall @ 2015-03-27 12:57 UTC (permalink / raw)
  To: Manish Jaggi, xen Devel, Kumar, Vijaya, Kapoor, Prasun,
	Ian Campbell, Stefano Stabellini

Hello Manish,

As for the PCI support series, this patch series is not threaded.

Please use git-send-email. It will thread correctly your patch series.

Regards,

On 27/03/15 07:17, Manish Jaggi wrote:
> This series of patches is a clean-up on the naming of the datastructures
> and the variable names. It is sometimes hard to understand the flow of
> the code and current code readability for understanding flow and making
> changes it not intuitive.
> 
> Based on these I will send next set of patches for PCI passthrough support
> 
> manish (3):
>   xen/arm: smmu: Rename arm_smmu_xen_device with device_iommu_info
>   xen/arm: smmu: Renaming arm_smmu_xen_domain with domain_iommu_info
>   xen/arm: smmu: Renaming struct iommu_domain *domain to struct
>     iommu_domain *iommu_domain
> 
>  xen/drivers/passthrough/arm/smmu.c | 136
> ++++++++++++++++++-------------------
>  1 file changed, 68 insertions(+), 68 deletions(-)
> 


-- 
Julien Grall

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2015-03-27 12:57 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-03-27  7:17 [PATCH v1 0/3] Clean-up of datastructres and variable names in smmu.c Manish Jaggi
2015-03-27 12:57 ` Julien Grall

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.