All of lore.kernel.org
 help / color / mirror / Atom feed
From: Vlastimil Babka <vbabka@suse.cz>
To: David Rientjes <rientjes@google.com>,
	Mel Gorman <mgorman@techsingularity.net>
Cc: Andrew Morton <akpm@linux-foundation.org>,
	Johannes Weiner <hannes@cmpxchg.org>,
	Rik van Riel <riel@redhat.com>,
	Joonsoo Kim <iamjoonsoo.kim@lge.com>,
	Michal Hocko <mhocko@kernel.org>, Linux-MM <linux-mm@kvack.org>,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 03/10] mm, page_alloc: Remove unnecessary taking of a seqlock when cpusets are disabled
Date: Thu, 1 Oct 2015 09:35:49 +0200	[thread overview]
Message-ID: <560CE255.80303@suse.cz> (raw)
In-Reply-To: <alpine.DEB.2.10.1509301521380.23324@chino.kir.corp.google.com>

On 10/01/2015 12:22 AM, David Rientjes wrote:
> On Mon, 21 Sep 2015, Mel Gorman wrote:
>> @@ -115,6 +118,9 @@ static inline unsigned int read_mems_allowed_begin(void)
>>    */
>>   static inline bool read_mems_allowed_retry(unsigned int seq)
>>   {
>> +	if (!cpusets_enabled())
>> +		return false;
>> +
>>   	return read_seqcount_retry(&current->mems_allowed_seq, seq);
>>   }
>>
>
> I thought this was going to test nr_cpusets() <= 1?

That was another patch in prior iteration of the series, but turns out 
it was unnecessary, because cpusets_enabled() is already only true when 
nr_cpusets() > 1 - see https://lkml.org/lkml/2015/8/25/300

WARNING: multiple messages have this Message-ID (diff)
From: Vlastimil Babka <vbabka@suse.cz>
To: David Rientjes <rientjes@google.com>,
	Mel Gorman <mgorman@techsingularity.net>
Cc: Andrew Morton <akpm@linux-foundation.org>,
	Johannes Weiner <hannes@cmpxchg.org>,
	Rik van Riel <riel@redhat.com>,
	Joonsoo Kim <iamjoonsoo.kim@lge.com>,
	Michal Hocko <mhocko@kernel.org>, Linux-MM <linux-mm@kvack.org>,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 03/10] mm, page_alloc: Remove unnecessary taking of a seqlock when cpusets are disabled
Date: Thu, 1 Oct 2015 09:35:49 +0200	[thread overview]
Message-ID: <560CE255.80303@suse.cz> (raw)
In-Reply-To: <alpine.DEB.2.10.1509301521380.23324@chino.kir.corp.google.com>

On 10/01/2015 12:22 AM, David Rientjes wrote:
> On Mon, 21 Sep 2015, Mel Gorman wrote:
>> @@ -115,6 +118,9 @@ static inline unsigned int read_mems_allowed_begin(void)
>>    */
>>   static inline bool read_mems_allowed_retry(unsigned int seq)
>>   {
>> +	if (!cpusets_enabled())
>> +		return false;
>> +
>>   	return read_seqcount_retry(&current->mems_allowed_seq, seq);
>>   }
>>
>
> I thought this was going to test nr_cpusets() <= 1?

That was another patch in prior iteration of the series, but turns out 
it was unnecessary, because cpusets_enabled() is already only true when 
nr_cpusets() > 1 - see https://lkml.org/lkml/2015/8/25/300

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>

  reply	other threads:[~2015-10-01  7:35 UTC|newest]

Thread overview: 96+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-09-21 10:52 [PATCH 00/10] Remove zonelist cache and high-order watermark checking v4 Mel Gorman
2015-09-21 10:52 ` Mel Gorman
2015-09-21 10:52 ` [PATCH 01/10] mm, page_alloc: Remove unnecessary parameter from zone_watermark_ok_safe Mel Gorman
2015-09-21 10:52   ` Mel Gorman
2015-09-24 20:01   ` Johannes Weiner
2015-09-24 20:01     ` Johannes Weiner
2015-09-21 10:52 ` [PATCH 02/10] mm, page_alloc: Remove unnecessary recalculations for dirty zone balancing Mel Gorman
2015-09-21 10:52   ` Mel Gorman
2015-09-24 20:05   ` Johannes Weiner
2015-09-24 20:05     ` Johannes Weiner
2015-09-21 10:52 ` [PATCH 03/10] mm, page_alloc: Remove unnecessary taking of a seqlock when cpusets are disabled Mel Gorman
2015-09-21 10:52   ` Mel Gorman
2015-09-24 20:06   ` Johannes Weiner
2015-09-24 20:06     ` Johannes Weiner
2015-09-30 22:22   ` David Rientjes
2015-09-30 22:22     ` David Rientjes
2015-10-01  7:35     ` Vlastimil Babka [this message]
2015-10-01  7:35       ` Vlastimil Babka
2015-09-21 10:52 ` [PATCH 04/10] mm, page_alloc: Use masks and shifts when converting GFP flags to migrate types Mel Gorman
2015-09-21 10:52   ` Mel Gorman
2015-09-24 20:34   ` Johannes Weiner
2015-09-24 20:34     ` Johannes Weiner
2015-09-25 12:50     ` Mel Gorman
2015-09-25 12:50       ` Mel Gorman
2015-09-25 13:56       ` Johannes Weiner
2015-09-25 13:56         ` Johannes Weiner
2015-09-21 10:52 ` [PATCH 05/10] mm, page_alloc: Distinguish between being unable to sleep, unwilling to sleep and avoiding waking kswapd Mel Gorman
2015-09-21 10:52   ` Mel Gorman
2015-09-24 13:51   ` Michal Hocko
2015-09-24 13:51     ` Michal Hocko
2015-09-24 20:55   ` Johannes Weiner
2015-09-24 20:55     ` Johannes Weiner
2015-09-25 12:51     ` Mel Gorman
2015-09-25 12:51       ` Mel Gorman
2015-09-25 19:01       ` Johannes Weiner
2015-09-25 19:01         ` Johannes Weiner
2015-09-29 13:35         ` Mel Gorman
2015-09-29 13:35           ` Mel Gorman
2015-09-30 12:26           ` Vlastimil Babka
2015-09-30 12:26             ` Vlastimil Babka
2015-09-30 13:17             ` Mel Gorman
2015-09-30 13:17               ` Mel Gorman
2015-10-01  3:04             ` Drokin, Oleg
2015-10-01  3:04               ` Drokin, Oleg
2015-10-02 12:30               ` Mel Gorman
2015-10-02 12:30                 ` Mel Gorman
2015-09-21 10:52 ` [PATCH 06/10] mm, page_alloc: Rename __GFP_WAIT to __GFP_RECLAIM Mel Gorman
2015-09-21 10:52   ` Mel Gorman
2015-09-25 19:03   ` Johannes Weiner
2015-09-25 19:03     ` Johannes Weiner
2015-09-28 23:55   ` Andrew Morton
2015-09-28 23:55     ` Andrew Morton
2015-09-29 13:37     ` Mel Gorman
2015-09-29 13:37       ` Mel Gorman
2015-10-01  8:39       ` Vlastimil Babka
2015-10-01  8:39         ` Vlastimil Babka
2015-10-02 13:03         ` [PATCH] mm: page_alloc: Hide some GFP internals and document the bits and flag combinations -fix Mel Gorman
2015-10-02 13:03           ` Mel Gorman
2015-10-01 14:06       ` [PATCH 06/10] mm, page_alloc: Rename __GFP_WAIT to __GFP_RECLAIM Michal Hocko
2015-10-01 14:06         ` Michal Hocko
2015-09-30 22:25   ` David Rientjes
2015-09-30 22:25     ` David Rientjes
2015-09-21 10:52 ` [PATCH 07/10] mm, page_alloc: Delete the zonelist_cache Mel Gorman
2015-09-21 10:52   ` Mel Gorman
2015-09-25 19:09   ` Johannes Weiner
2015-09-25 19:09     ` Johannes Weiner
2015-09-21 10:52 ` [PATCH 08/10] mm, page_alloc: Remove MIGRATE_RESERVE Mel Gorman
2015-09-21 10:52   ` Mel Gorman
2015-09-21 10:52 ` [PATCH 09/10] mm, page_alloc: Reserve pageblocks for high-order atomic allocations on demand Mel Gorman
2015-09-21 10:52   ` Mel Gorman
2015-09-24 13:50   ` Michal Hocko
2015-09-24 13:50     ` Michal Hocko
2015-09-25 19:22   ` Johannes Weiner
2015-09-25 19:22     ` Johannes Weiner
2015-09-29 21:01   ` Andrew Morton
2015-09-29 21:01     ` Andrew Morton
2015-09-30  8:27     ` Mel Gorman
2015-09-30  8:27       ` Mel Gorman
2015-09-30 14:02       ` Vlastimil Babka
2015-09-30 14:02         ` Vlastimil Babka
2015-09-21 12:03 ` [PATCH 10/10] mm, page_alloc: Only enforce watermarks for order-0 allocations Mel Gorman
2015-09-21 12:03   ` Mel Gorman
2015-09-25 19:32   ` Johannes Weiner
2015-09-25 19:32     ` Johannes Weiner
2015-09-29 21:05   ` Andrew Morton
2015-09-29 21:05     ` Andrew Morton
2015-09-30  8:46     ` Mel Gorman
2015-09-30  8:46       ` Mel Gorman
2015-09-30 14:17       ` Vlastimil Babka
2015-09-30 14:17         ` Vlastimil Babka
2015-09-30 15:12         ` Mel Gorman
2015-09-30 15:12           ` Mel Gorman
2015-09-30 20:37           ` Andrew Morton
2015-09-30 20:37             ` Andrew Morton
2015-09-30 14:11   ` Vlastimil Babka
2015-09-30 14:11     ` Vlastimil Babka

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=560CE255.80303@suse.cz \
    --to=vbabka@suse.cz \
    --cc=akpm@linux-foundation.org \
    --cc=hannes@cmpxchg.org \
    --cc=iamjoonsoo.kim@lge.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=mgorman@techsingularity.net \
    --cc=mhocko@kernel.org \
    --cc=riel@redhat.com \
    --cc=rientjes@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.