All of lore.kernel.org
 help / color / mirror / Atom feed
* [patch net-next 00/14] rocker: add support for multiple worlds
@ 2015-10-04 21:25 Jiri Pirko
  2015-10-04 21:25 ` [patch net-next 01/14] rocker: remove unused rocker_port param from alloc funcs and shorten their names Jiri Pirko
                   ` (14 more replies)
  0 siblings, 15 replies; 37+ messages in thread
From: Jiri Pirko @ 2015-10-04 21:25 UTC (permalink / raw)
  To: netdev; +Cc: davem, sfeldma, idosch, eladr, tgraf, ast

From: Jiri Pirko <jiri@mellanox.com>

This patchset allows new rocker worlds to be easily added in future (like eBPF
based one I have been working on). The main part of the patchset is the OF-DPA
carve-out. It resuts in OF-DPA specific file. Clean cut.
The user is able to change rocker port world/mode using rtnl.

Jiri Pirko (14):
  rocker: remove unused rocker_port param from alloc funcs and shorten
    their names
  rocker: rename rocker.h to rocker_hw.h
  rocker: rename rocker.c to rocker_main.c
  rocker: push tlv processing into separate files
  rocker: implement set settings mode command
  rocker: introduce worlds infrastructure
  rocker: introduce OF-DPA world skeleton
  rocker: set default world on port probe and clean world on remove
  rocker: add rtnl ops for port mode [gs]etting
  rocker: pass "learning" value as a parameter to
    rocker_port_set_learning
  rocker: pre-allocate wait structures during cmd ring init
  rocker: remove trans parameter to rocker_cmd_exec function
  rocker: call rocker_cmd_exec function with "nowait" boolean instead of
    flags
  rocker: move OF-DPA stuff into separate file

 drivers/net/ethernet/rocker/Makefile       |    1 +
 drivers/net/ethernet/rocker/rocker.c       | 5478 ----------------------------
 drivers/net/ethernet/rocker/rocker.h       |  543 +--
 drivers/net/ethernet/rocker/rocker_hw.h    |  467 +++
 drivers/net/ethernet/rocker/rocker_main.c  | 3093 ++++++++++++++++
 drivers/net/ethernet/rocker/rocker_ofdpa.c | 2927 +++++++++++++++
 drivers/net/ethernet/rocker/rocker_tlv.c   |   54 +
 drivers/net/ethernet/rocker/rocker_tlv.h   |  202 +
 include/uapi/linux/if_link.h               |   11 +
 9 files changed, 6847 insertions(+), 5929 deletions(-)
 delete mode 100644 drivers/net/ethernet/rocker/rocker.c
 create mode 100644 drivers/net/ethernet/rocker/rocker_hw.h
 create mode 100644 drivers/net/ethernet/rocker/rocker_main.c
 create mode 100644 drivers/net/ethernet/rocker/rocker_ofdpa.c
 create mode 100644 drivers/net/ethernet/rocker/rocker_tlv.c
 create mode 100644 drivers/net/ethernet/rocker/rocker_tlv.h

-- 
1.9.3

^ permalink raw reply	[flat|nested] 37+ messages in thread

end of thread, other threads:[~2015-10-06  7:35 UTC | newest]

Thread overview: 37+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-10-04 21:25 [patch net-next 00/14] rocker: add support for multiple worlds Jiri Pirko
2015-10-04 21:25 ` [patch net-next 01/14] rocker: remove unused rocker_port param from alloc funcs and shorten their names Jiri Pirko
2015-10-04 21:25 ` [patch net-next 02/14] rocker: rename rocker.h to rocker_hw.h Jiri Pirko
2015-10-04 21:25 ` [patch net-next 03/14] rocker: rename rocker.c to rocker_main.c Jiri Pirko
2015-10-04 21:25 ` [patch net-next 04/14] rocker: push tlv processing into separate files Jiri Pirko
2015-10-04 21:25 ` [patch net-next 05/14] rocker: implement set settings mode command Jiri Pirko
2015-10-06  4:51   ` Scott Feldman
2015-10-04 21:25 ` [patch net-next 06/14] rocker: introduce worlds infrastructure Jiri Pirko
2015-10-04 21:25 ` [patch net-next 07/14] rocker: introduce OF-DPA world skeleton Jiri Pirko
2015-10-04 21:25 ` [patch net-next 08/14] rocker: set default world on port probe and clean world on remove Jiri Pirko
2015-10-04 21:25 ` [patch net-next 09/14] rocker: add rtnl ops for port mode [gs]etting Jiri Pirko
2015-10-05 15:41   ` Scott Feldman
2015-10-05 15:52     ` John Fastabend
2015-10-05 16:37       ` Jiri Pirko
2015-10-05 17:07         ` John Fastabend
2015-10-05 17:24           ` Jiri Pirko
2015-10-05 17:43             ` John Fastabend
2015-10-05 17:50               ` Jiri Pirko
2015-10-05 15:53     ` Jiri Pirko
2015-10-05 16:37       ` Scott Feldman
2015-10-05 16:50         ` Jiri Pirko
2015-10-05 17:00           ` Scott Feldman
2015-10-05 17:12             ` Jiri Pirko
2015-10-04 21:25 ` [patch net-next 10/14] rocker: pass "learning" value as a parameter to rocker_port_set_learning Jiri Pirko
2015-10-05 15:16   ` David Laight
2015-10-05 15:24     ` Jiri Pirko
2015-10-04 21:25 ` [patch net-next 11/14] rocker: pre-allocate wait structures during cmd ring init Jiri Pirko
2015-10-04 21:25 ` [patch net-next 12/14] rocker: remove trans parameter to rocker_cmd_exec function Jiri Pirko
2015-10-04 21:25 ` [patch net-next 13/14] rocker: call rocker_cmd_exec function with "nowait" boolean instead of flags Jiri Pirko
2015-10-04 21:25 ` [patch net-next 14/14] rocker: move OF-DPA stuff into separate file Jiri Pirko
2015-10-05 15:41 ` [patch net-next 00/14] rocker: add support for multiple worlds John Fastabend
2015-10-05 16:30   ` Jiri Pirko
2015-10-05 16:58     ` John Fastabend
2015-10-05 17:39       ` Jiri Pirko
2015-10-05 17:56         ` John Fastabend
2015-10-05 17:49       ` Scott Feldman
2015-10-06  7:34         ` John Fastabend

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.