All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Rafael J. Wysocki" <rjw@rjwysocki.net>
To: Ulf Hansson <ulf.hansson@linaro.org>
Cc: Daniel Lezcano <daniel.lezcano@linaro.org>,
	Sudeep Holla <sudeep.holla@arm.com>,
	Lorenzo Pieralisi <Lorenzo.Pieralisi@arm.com>,
	Mark Rutland <mark.rutland@arm.com>,
	Linux PM <linux-pm@vger.kernel.org>,
	"Raju P . L . S . S . S . N" <rplsssn@codeaurora.org>,
	Stephen Boyd <sboyd@kernel.org>, Tony Lindgren <tony@atomide.com>,
	Kevin Hilman <khilman@kernel.org>,
	Lina Iyer <ilina@codeaurora.org>,
	Viresh Kumar <viresh.kumar@linaro.org>,
	Vincent Guittot <vincent.guittot@linaro.org>,
	Geert Uytterhoeven <geert+renesas@glider.be>,
	Linux ARM <linux-arm-kernel@lists.infradead.org>,
	linux-arm-msm <linux-arm-msm@vger.kernel.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v10 01/27] PM / Domains: Add generic data pointer to genpd_power_state struct
Date: Fri, 11 Jan 2019 11:52:52 +0100	[thread overview]
Message-ID: <5682777.oKQsr9mDaT@aspire.rjw.lan> (raw)
In-Reply-To: <CAPDyKFp=z0TS5oDD7muRCSuqqJ5sj-vOUyTf9tUJfXgWyE64Mg@mail.gmail.com>

On Tuesday, December 18, 2018 12:53:28 PM CET Ulf Hansson wrote:
> On Tue, 18 Dec 2018 at 11:39, Daniel Lezcano <daniel.lezcano@linaro.org> wrote:
> >
> > On 29/11/2018 18:46, Ulf Hansson wrote:
> > > Let's add a data pointer to the genpd_power_state struct, to allow a genpd
> > > backend driver to store per state specific data. In order to introduce the
> > > pointer, we also need to adopt how genpd frees the allocated data for the
> > > default genpd_power_state struct, that it may allocate at pm_genpd_init().
> > >
> > > More precisely, let's use an internal genpd flag to understand when the
> > > states needs to be freed by genpd. When freeing the states data in
> > > genpd_remove(), let's also clear the corresponding genpd->states pointer
> > > and reset the genpd->state_count. In this way, a genpd backend driver
> > > becomes aware of when there is state specific data for it to free.
> > >
> > > Cc: Lina Iyer <ilina@codeaurora.org>
> > > Co-developed-by: Lina Iyer <lina.iyer@linaro.org>
> > > Signed-off-by: Ulf Hansson <ulf.hansson@linaro.org>
> > > ---
> > >
> > > Changes in v10:
> > >       - Update the patch allow backend drivers to free the states specific
> > >         data during genpd removal. Due to this added complexity, I decided to
> > >         keep the patch separate, rather than fold it into the patch that makes
> > >         use of the new void pointer, which was suggested by Rafael.
> > >       - Claim authorship of the patch as lots of changes has been done since
> > >         the original pick up from Lina Iyer.
> > >
> > > ---
> > >  drivers/base/power/domain.c | 8 ++++++--
> > >  include/linux/pm_domain.h   | 3 ++-
> > >  2 files changed, 8 insertions(+), 3 deletions(-)
> > >
> > > diff --git a/drivers/base/power/domain.c b/drivers/base/power/domain.c
> > > index 7f38a92b444a..e27b91d36a2a 100644
> > > --- a/drivers/base/power/domain.c
> > > +++ b/drivers/base/power/domain.c
> > > @@ -1620,7 +1620,7 @@ static int genpd_set_default_power_state(struct generic_pm_domain *genpd)
> > >
> > >       genpd->states = state;
> > >       genpd->state_count = 1;
> > > -     genpd->free = state;
> > > +     genpd->free_state = true;
> > >
> > >       return 0;
> > >  }
> > > @@ -1736,7 +1736,11 @@ static int genpd_remove(struct generic_pm_domain *genpd)
> > >       list_del(&genpd->gpd_list_node);
> > >       genpd_unlock(genpd);
> > >       cancel_work_sync(&genpd->power_off_work);
> > > -     kfree(genpd->free);
> > > +     if (genpd->free_state) {
> > > +             kfree(genpd->states);
> > > +             genpd->states = NULL;
> > > +             genpd->state_count = 0;
> >
> > Why these two initializations? After genpd_remove, this structure
> > shouldn't be used anymore, no ?
> 
> Correct.
> 
> >
> > > +     }
> >
> > Instead of a flag, replacing the 'free' pointer to a 'free' callback
> > will allow to keep the free path self-encapsulated in domain.c
> >
> > genpd->free(genpd->states);
> 
> Right, I get your idea and it makes sense. Let me convert to that.

OK, so I'm expecting an update here.

WARNING: multiple messages have this Message-ID (diff)
From: "Rafael J. Wysocki" <rjw@rjwysocki.net>
To: Ulf Hansson <ulf.hansson@linaro.org>
Cc: Mark Rutland <mark.rutland@arm.com>,
	Lorenzo Pieralisi <Lorenzo.Pieralisi@arm.com>,
	Vincent Guittot <vincent.guittot@linaro.org>,
	Geert Uytterhoeven <geert+renesas@glider.be>,
	Linux PM <linux-pm@vger.kernel.org>,
	Stephen Boyd <sboyd@kernel.org>,
	Viresh Kumar <viresh.kumar@linaro.org>,
	linux-arm-msm <linux-arm-msm@vger.kernel.org>,
	Daniel Lezcano <daniel.lezcano@linaro.org>,
	Kevin Hilman <khilman@kernel.org>,
	Lina Iyer <ilina@codeaurora.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Tony Lindgren <tony@atomide.com>,
	Sudeep Holla <sudeep.holla@arm.com>,
	"Raju P . L . S . S . S . N" <rplsssn@codeaurora.org>,
	Linux ARM <linux-arm-kernel@lists.infradead.org>
Subject: Re: [PATCH v10 01/27] PM / Domains: Add generic data pointer to genpd_power_state struct
Date: Fri, 11 Jan 2019 11:52:52 +0100	[thread overview]
Message-ID: <5682777.oKQsr9mDaT@aspire.rjw.lan> (raw)
In-Reply-To: <CAPDyKFp=z0TS5oDD7muRCSuqqJ5sj-vOUyTf9tUJfXgWyE64Mg@mail.gmail.com>

On Tuesday, December 18, 2018 12:53:28 PM CET Ulf Hansson wrote:
> On Tue, 18 Dec 2018 at 11:39, Daniel Lezcano <daniel.lezcano@linaro.org> wrote:
> >
> > On 29/11/2018 18:46, Ulf Hansson wrote:
> > > Let's add a data pointer to the genpd_power_state struct, to allow a genpd
> > > backend driver to store per state specific data. In order to introduce the
> > > pointer, we also need to adopt how genpd frees the allocated data for the
> > > default genpd_power_state struct, that it may allocate at pm_genpd_init().
> > >
> > > More precisely, let's use an internal genpd flag to understand when the
> > > states needs to be freed by genpd. When freeing the states data in
> > > genpd_remove(), let's also clear the corresponding genpd->states pointer
> > > and reset the genpd->state_count. In this way, a genpd backend driver
> > > becomes aware of when there is state specific data for it to free.
> > >
> > > Cc: Lina Iyer <ilina@codeaurora.org>
> > > Co-developed-by: Lina Iyer <lina.iyer@linaro.org>
> > > Signed-off-by: Ulf Hansson <ulf.hansson@linaro.org>
> > > ---
> > >
> > > Changes in v10:
> > >       - Update the patch allow backend drivers to free the states specific
> > >         data during genpd removal. Due to this added complexity, I decided to
> > >         keep the patch separate, rather than fold it into the patch that makes
> > >         use of the new void pointer, which was suggested by Rafael.
> > >       - Claim authorship of the patch as lots of changes has been done since
> > >         the original pick up from Lina Iyer.
> > >
> > > ---
> > >  drivers/base/power/domain.c | 8 ++++++--
> > >  include/linux/pm_domain.h   | 3 ++-
> > >  2 files changed, 8 insertions(+), 3 deletions(-)
> > >
> > > diff --git a/drivers/base/power/domain.c b/drivers/base/power/domain.c
> > > index 7f38a92b444a..e27b91d36a2a 100644
> > > --- a/drivers/base/power/domain.c
> > > +++ b/drivers/base/power/domain.c
> > > @@ -1620,7 +1620,7 @@ static int genpd_set_default_power_state(struct generic_pm_domain *genpd)
> > >
> > >       genpd->states = state;
> > >       genpd->state_count = 1;
> > > -     genpd->free = state;
> > > +     genpd->free_state = true;
> > >
> > >       return 0;
> > >  }
> > > @@ -1736,7 +1736,11 @@ static int genpd_remove(struct generic_pm_domain *genpd)
> > >       list_del(&genpd->gpd_list_node);
> > >       genpd_unlock(genpd);
> > >       cancel_work_sync(&genpd->power_off_work);
> > > -     kfree(genpd->free);
> > > +     if (genpd->free_state) {
> > > +             kfree(genpd->states);
> > > +             genpd->states = NULL;
> > > +             genpd->state_count = 0;
> >
> > Why these two initializations? After genpd_remove, this structure
> > shouldn't be used anymore, no ?
> 
> Correct.
> 
> >
> > > +     }
> >
> > Instead of a flag, replacing the 'free' pointer to a 'free' callback
> > will allow to keep the free path self-encapsulated in domain.c
> >
> > genpd->free(genpd->states);
> 
> Right, I get your idea and it makes sense. Let me convert to that.

OK, so I'm expecting an update here.


_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2019-01-11 10:52 UTC|newest]

Thread overview: 157+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-11-29 17:46 [PATCH v10 00/27] PM / Domains: Support hierarchical CPU arrangement (PSCI/ARM) Ulf Hansson
2018-11-29 17:46 ` Ulf Hansson
2018-11-29 17:46 ` Ulf Hansson
2018-11-29 17:46 ` [PATCH v10 01/27] PM / Domains: Add generic data pointer to genpd_power_state struct Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-12-18 10:39   ` Daniel Lezcano
2018-12-18 10:39     ` Daniel Lezcano
2018-12-18 11:53     ` Ulf Hansson
2018-12-18 11:53       ` Ulf Hansson
2019-01-11 10:52       ` Rafael J. Wysocki [this message]
2019-01-11 10:52         ` Rafael J. Wysocki
2018-11-29 17:46 ` [PATCH v10 02/27] PM / Domains: Add support for CPU devices to genpd Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-12-19  9:53   ` Daniel Lezcano
2018-12-19  9:53     ` Daniel Lezcano
2018-12-19 10:02     ` Ulf Hansson
2018-12-19 10:02       ` Ulf Hansson
2019-01-11 10:54       ` Rafael J. Wysocki
2019-01-11 10:54         ` Rafael J. Wysocki
2018-11-29 17:46 ` [PATCH v10 03/27] timer: Export next wakeup time of a CPU Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2019-01-11 11:06   ` Rafael J. Wysocki
2019-01-11 11:06     ` Rafael J. Wysocki
2019-01-11 11:06     ` Rafael J. Wysocki
2019-01-16  7:57     ` Ulf Hansson
2019-01-16  7:57       ` Ulf Hansson
2019-01-16  7:57       ` Ulf Hansson
2019-01-16 10:59       ` Rafael J. Wysocki
2019-01-16 10:59         ` Rafael J. Wysocki
2019-01-16 10:59         ` Rafael J. Wysocki
2019-01-16 12:00         ` Ulf Hansson
2019-01-16 12:00           ` Ulf Hansson
2019-01-16 12:00           ` Ulf Hansson
2019-01-25 10:04           ` Ulf Hansson
2019-01-25 10:04             ` Ulf Hansson
2019-01-25 10:04             ` Ulf Hansson
2019-01-25 10:18             ` Rafael J. Wysocki
2019-01-25 10:18               ` Rafael J. Wysocki
2019-01-25 10:18               ` Rafael J. Wysocki
2018-11-29 17:46 ` [PATCH v10 04/27] PM / Domains: Add genpd governor for CPUs Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-12-19  9:54   ` Daniel Lezcano
2018-12-19  9:54     ` Daniel Lezcano
2018-12-19 10:09     ` Ulf Hansson
2018-12-19 10:09       ` Ulf Hansson
2018-12-19 10:09       ` Ulf Hansson
2018-11-29 17:46 ` [PATCH v10 05/27] dt: psci: Update DT bindings to support hierarchical PSCI states Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-11-29 17:46 ` [PATCH v10 06/27] of: base: Add of_get_cpu_state_node() to get idle states for a CPU node Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-12-19 11:05   ` Daniel Lezcano
2018-12-19 11:05     ` Daniel Lezcano
2018-11-29 17:46 ` [PATCH v10 07/27] cpuidle: dt: Support hierarchical CPU idle states Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-12-19 11:20   ` Daniel Lezcano
2018-12-19 11:20     ` Daniel Lezcano
2018-11-29 17:46 ` [PATCH v10 08/27] ARM/ARM64: cpuidle: Let back-end init ops take the driver as input Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-11-29 17:46 ` [PATCH v10 09/27] drivers: firmware: psci: Move psci to separate directory Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-11-29 17:46 ` [PATCH v10 10/27] MAINTAINERS: Update files for PSCI Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-11-29 17:46 ` [PATCH v10 11/27] drivers: firmware: psci: Split psci_dt_cpu_init_idle() Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-11-29 17:46 ` [PATCH v10 12/27] drivers: firmware: psci: Simplify state node parsing Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-11-29 17:46 ` [PATCH v10 13/27] drivers: firmware: psci: Support hierarchical CPU idle states Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-12-19 12:11   ` Daniel Lezcano
2018-12-19 12:11     ` Daniel Lezcano
2018-12-19 12:53     ` Ulf Hansson
2018-12-19 12:53       ` Ulf Hansson
2018-11-29 17:46 ` [PATCH v10 14/27] drivers: firmware: psci: Simplify error path of psci_dt_init() Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-12-19 12:08   ` Daniel Lezcano
2018-12-19 12:08     ` Daniel Lezcano
2018-11-29 17:46 ` [PATCH v10 15/27] drivers: firmware: psci: Announce support for OS initiated suspend mode Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-12-20 13:11   ` Daniel Lezcano
2018-12-20 13:11     ` Daniel Lezcano
2018-11-29 17:46 ` [PATCH v10 16/27] drivers: firmware: psci: Prepare to use " Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-12-20 14:08   ` Daniel Lezcano
2018-12-20 14:08     ` Daniel Lezcano
2018-12-20 15:41     ` Ulf Hansson
2018-12-20 15:41       ` Ulf Hansson
2018-12-20 17:16       ` Daniel Lezcano
2018-12-20 17:16         ` Daniel Lezcano
2018-11-29 17:46 ` [PATCH v10 17/27] drivers: firmware: psci: Prepare to support PM domains Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-12-20 14:19   ` Daniel Lezcano
2018-12-20 14:19     ` Daniel Lezcano
2018-12-20 15:49     ` Ulf Hansson
2018-12-20 15:49       ` Ulf Hansson
2018-12-20 18:06       ` Daniel Lezcano
2018-12-20 18:06         ` Daniel Lezcano
2018-12-20 21:37         ` Ulf Hansson
2018-12-20 21:37           ` Ulf Hansson
2018-12-21  7:15           ` Daniel Lezcano
2018-12-21  7:15             ` Daniel Lezcano
2018-11-29 17:46 ` [PATCH v10 18/27] drivers: firmware: psci: Add support for PM domains using genpd Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-12-03 16:37   ` Lina Iyer
2018-12-03 16:37     ` Lina Iyer
2018-12-03 20:03     ` Ulf Hansson
2018-12-03 20:03       ` Ulf Hansson
2018-12-20 14:35   ` Daniel Lezcano
2018-12-20 14:35     ` Daniel Lezcano
2018-12-20 21:09     ` Ulf Hansson
2018-12-20 21:09       ` Ulf Hansson
2018-11-29 17:46 ` [PATCH v10 19/27] drivers: firmware: psci: Add hierarchical domain idle states converter Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-11-29 17:46 ` [PATCH v10 20/27] drivers: firmware: psci: Introduce psci_dt_topology_init() Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-11-29 17:46 ` [PATCH v10 21/27] drivers: firmware: psci: Add a helper to attach a CPU to its PM domain Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-12-04 18:45   ` Lina Iyer
2018-12-04 18:45     ` Lina Iyer
2018-12-06  9:15     ` Ulf Hansson
2018-12-06  9:15       ` Ulf Hansson
2018-11-29 17:46 ` [PATCH v10 22/27] drivers: firmware: psci: Attach the CPU's device " Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-11-29 17:46 ` [PATCH v10 23/27] drivers: firmware: psci: Manage runtime PM in the idle path for CPUs Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-11-29 17:46 ` [PATCH v10 24/27] drivers: firmware: psci: Support CPU hotplug for the hierarchical model Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-11-29 22:31   ` Lina Iyer
2018-11-29 22:31     ` Lina Iyer
2018-11-30  8:25     ` Ulf Hansson
2018-11-30  8:25       ` Ulf Hansson
2018-11-30 20:57       ` Lina Iyer
2018-11-30 20:57         ` Lina Iyer
2018-12-19 11:17   ` Lorenzo Pieralisi
2018-12-19 11:17     ` Lorenzo Pieralisi
2018-12-19 11:47     ` Ulf Hansson
2018-12-19 11:47       ` Ulf Hansson
2018-11-29 17:46 ` [PATCH v10 25/27] arm64: kernel: Respect the hierarchical CPU topology in DT for PSCI Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-11-29 17:46 ` [PATCH v10 26/27] arm64: dts: Convert to the hierarchical CPU topology layout for MSM8916 Ulf Hansson
2018-11-29 17:46   ` Ulf Hansson
2018-11-29 17:47 ` [PATCH v10 27/27] arm64: dts: hikey: Convert to the hierarchical CPU topology layout Ulf Hansson
2018-11-29 17:47   ` Ulf Hansson
2018-12-17 16:12 ` [PATCH v10 00/27] PM / Domains: Support hierarchical CPU arrangement (PSCI/ARM) Ulf Hansson
2018-12-17 16:12   ` Ulf Hansson
2019-01-11 11:08   ` Rafael J. Wysocki
2019-01-11 11:08     ` Rafael J. Wysocki
2019-01-03 12:06 ` Sudeep Holla
2019-01-03 12:06   ` Sudeep Holla
2019-01-03 12:06   ` Sudeep Holla
2019-01-16  9:10   ` Ulf Hansson
2019-01-16  9:10     ` Ulf Hansson
2019-01-17 17:44     ` Sudeep Holla
2019-01-17 17:44       ` Sudeep Holla
2019-01-17 17:44       ` Sudeep Holla
2019-01-18 11:56       ` Ulf Hansson
2019-01-18 11:56         ` Ulf Hansson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5682777.oKQsr9mDaT@aspire.rjw.lan \
    --to=rjw@rjwysocki.net \
    --cc=Lorenzo.Pieralisi@arm.com \
    --cc=daniel.lezcano@linaro.org \
    --cc=geert+renesas@glider.be \
    --cc=ilina@codeaurora.org \
    --cc=khilman@kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=mark.rutland@arm.com \
    --cc=rplsssn@codeaurora.org \
    --cc=sboyd@kernel.org \
    --cc=sudeep.holla@arm.com \
    --cc=tony@atomide.com \
    --cc=ulf.hansson@linaro.org \
    --cc=vincent.guittot@linaro.org \
    --cc=viresh.kumar@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.