All of lore.kernel.org
 help / color / mirror / Atom feed
From: Mike Christie <michaelc@cs.wisc.edu>
To: device-mapper development <dm-devel@redhat.com>, mchristi@redhat.com
Cc: linux-raid@vger.kernel.org,
	linux-f2fs-devel@lists.sourceforge.net,
	linux-scsi@vger.kernel.org, konrad.wilk@oracle.com,
	linux-ext4@vger.kernel.org, linux-kernel@vger.kernel.org,
	xfs@oss.sgi.com, linux-block@vger.kernel.org,
	linux-bcache@vger.kernel.org, target-devel@vger.kernel.org,
	linux-mtd@lists.infradead.org, osd-dev@open-osd.org,
	linux-fsdevel@vger.kernel.org, lars.ellenberg@linbit.com,
	philipp.reisner@linbit.com, drbd-dev@lists.linbit.com,
	ocfs2-devel@oss.oracle.com, linux-btrfs@vger.kernel.org
Subject: Re: [dm-devel] [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields
Date: Sat, 09 Jan 2016 19:21:12 -0600	[thread overview]
Message-ID: <5691B208.9060001@cs.wisc.edu> (raw)
In-Reply-To: <5691AC2E.2050403@cs.wisc.edu>

On 01/09/2016 06:56 PM, Mike Christie wrote:
> On 01/09/2016 07:37 AM, Christoph Hellwig wrote:
>> Seems like this is missing REQ_OP_FLUSH, which still hides as a write?
>>

Oh yeah, to answer the second part of your question, REQ_OP_FLUSH is
only a flush operation like what request_fn drivers wanted.

REQ_PREFLUSH can be set with a REQ_OP_WRITE bio when filesystems want to
do both.

There is then the case where filesystems and blkdev_issue_flush could
just want to request a flush. I left them as a REQ_PREFLUSH with
REQ_OP_WRITE set, so there would be a single code path.

> 
> I might have misunderstood what you wanted or am misunderstanding you now.
> 
> I did not change the flush related code until the last patches. I added
> REQ_OP_FLUSH in patch:
> 
> [PATCH 33/35] block, drivers: add REQ_OP_FLUSH operation
> commit 18dea20363ba245a47bc1bb54f6465b8a05b19af
> Author: Mike Christie <mchristi@redhat.com>
> Date:   Tue Jan 5 21:02:17 2016 -0600
> 
>     block, drivers: add REQ_OP_FLUSH operation
> 
> 
> and I added the REQ_PREFLUSH flag in
> 
> 
> [PATCH 35/35] block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH
> commit 303dc6a7cc3673065538ba041562fcd833a619af
> Author: Mike Christie <mchristi@redhat.com>
> Date:   Thu Jan 7 18:17:03 2016 -0600
> 
>     block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH
> 
> 
> I did them in separate patches, because I was not sure if they were
> correct with what you requested before, and because they were a little
> more tricky because of how request_fn drivers, make_request_fn drivers,
> and dm-multipath handle flushes differently.
> --
> To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> 

_______________________________________________
xfs mailing list
xfs@oss.sgi.com
http://oss.sgi.com/mailman/listinfo/xfs

WARNING: multiple messages have this Message-ID (diff)
From: Mike Christie <michaelc@cs.wisc.edu>
To: device-mapper development <dm-devel@redhat.com>, mchristi@redhat.com
Cc: linux-bcache@vger.kernel.org, linux-block@vger.kernel.org,
	xfs@oss.sgi.com, linux-scsi@vger.kernel.org,
	konrad.wilk@oracle.com, linux-kernel@vger.kernel.org,
	philipp.reisner@linbit.com,
	linux-f2fs-devel@lists.sourceforge.net,
	linux-raid@vger.kernel.org, ocfs2-devel@oss.oracle.com,
	target-devel@vger.kernel.org, linux-mtd@lists.infradead.org,
	osd-dev@open-osd.org, linux-fsdevel@vger.kernel.org,
	lars.ellenberg@linbit.com, linux-ext4@vger.kernel.org,
	linux-btrfs@vger.kernel.org, drbd-dev@lists.linbit.com
Subject: Re: [dm-devel] [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields
Date: Sat, 09 Jan 2016 19:21:12 -0600	[thread overview]
Message-ID: <5691B208.9060001@cs.wisc.edu> (raw)
In-Reply-To: <5691AC2E.2050403@cs.wisc.edu>

On 01/09/2016 06:56 PM, Mike Christie wrote:
> On 01/09/2016 07:37 AM, Christoph Hellwig wrote:
>> Seems like this is missing REQ_OP_FLUSH, which still hides as a write?
>>

Oh yeah, to answer the second part of your question, REQ_OP_FLUSH is
only a flush operation like what request_fn drivers wanted.

REQ_PREFLUSH can be set with a REQ_OP_WRITE bio when filesystems want to
do both.

There is then the case where filesystems and blkdev_issue_flush could
just want to request a flush. I left them as a REQ_PREFLUSH with
REQ_OP_WRITE set, so there would be a single code path.

> 
> I might have misunderstood what you wanted or am misunderstanding you now.
> 
> I did not change the flush related code until the last patches. I added
> REQ_OP_FLUSH in patch:
> 
> [PATCH 33/35] block, drivers: add REQ_OP_FLUSH operation
> commit 18dea20363ba245a47bc1bb54f6465b8a05b19af
> Author: Mike Christie <mchristi@redhat.com>
> Date:   Tue Jan 5 21:02:17 2016 -0600
> 
>     block, drivers: add REQ_OP_FLUSH operation
> 
> 
> and I added the REQ_PREFLUSH flag in
> 
> 
> [PATCH 35/35] block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH
> commit 303dc6a7cc3673065538ba041562fcd833a619af
> Author: Mike Christie <mchristi@redhat.com>
> Date:   Thu Jan 7 18:17:03 2016 -0600
> 
>     block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH
> 
> 
> I did them in separate patches, because I was not sure if they were
> correct with what you requested before, and because they were a little
> more tricky because of how request_fn drivers, make_request_fn drivers,
> and dm-multipath handle flushes differently.
> --
> To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> 


WARNING: multiple messages have this Message-ID (diff)
From: Mike Christie <michaelc@cs.wisc.edu>
To: device-mapper development <dm-devel@redhat.com>, mchristi@redhat.com
Cc: linux-raid@vger.kernel.org,
	linux-f2fs-devel@lists.sourceforge.net,
	linux-scsi@vger.kernel.org, konrad.wilk@oracle.com,
	linux-ext4@vger.kernel.org, linux-kernel@vger.kernel.org,
	xfs@oss.sgi.com, linux-block@vger.kernel.org,
	linux-bcache@vger.kernel.org, target-devel@vger.kernel.org,
	linux-mtd@lists.infradead.org, osd-dev@open-osd.org,
	linux-fsdevel@vger.kernel.org, lars.ellenberg@linbit.com,
	philipp.reisner@linbit.com, drbd-dev@lists.linbit.com,
	ocfs2-devel@oss.oracle.com, linux-btrfs@vger.kernel.org
Subject: [Ocfs2-devel] [dm-devel] [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields
Date: Sat, 09 Jan 2016 19:21:12 -0600	[thread overview]
Message-ID: <5691B208.9060001@cs.wisc.edu> (raw)
In-Reply-To: <5691AC2E.2050403@cs.wisc.edu>

On 01/09/2016 06:56 PM, Mike Christie wrote:
> On 01/09/2016 07:37 AM, Christoph Hellwig wrote:
>> Seems like this is missing REQ_OP_FLUSH, which still hides as a write?
>>

Oh yeah, to answer the second part of your question, REQ_OP_FLUSH is
only a flush operation like what request_fn drivers wanted.

REQ_PREFLUSH can be set with a REQ_OP_WRITE bio when filesystems want to
do both.

There is then the case where filesystems and blkdev_issue_flush could
just want to request a flush. I left them as a REQ_PREFLUSH with
REQ_OP_WRITE set, so there would be a single code path.

> 
> I might have misunderstood what you wanted or am misunderstanding you now.
> 
> I did not change the flush related code until the last patches. I added
> REQ_OP_FLUSH in patch:
> 
> [PATCH 33/35] block, drivers: add REQ_OP_FLUSH operation
> commit 18dea20363ba245a47bc1bb54f6465b8a05b19af
> Author: Mike Christie <mchristi@redhat.com>
> Date:   Tue Jan 5 21:02:17 2016 -0600
> 
>     block, drivers: add REQ_OP_FLUSH operation
> 
> 
> and I added the REQ_PREFLUSH flag in
> 
> 
> [PATCH 35/35] block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH
> commit 303dc6a7cc3673065538ba041562fcd833a619af
> Author: Mike Christie <mchristi@redhat.com>
> Date:   Thu Jan 7 18:17:03 2016 -0600
> 
>     block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH
> 
> 
> I did them in separate patches, because I was not sure if they were
> correct with what you requested before, and because they were a little
> more tricky because of how request_fn drivers, make_request_fn drivers,
> and dm-multipath handle flushes differently.
> --
> To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
> the body of a message to majordomo at vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> 

  reply	other threads:[~2016-01-10  1:21 UTC|newest]

Thread overview: 182+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-01-05 20:53 [PATCH 00/35 v2] separate operations from flags in the bio/request structs mchristi
2016-01-05 20:53 ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53 ` mchristi
2016-01-05 20:53 ` [PATCH 01/35] block/fs/drivers: remove rw argument from submit_bio mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-06 15:59   ` [dm-devel] " Bart Van Assche
2016-01-06 15:59     ` [Ocfs2-devel] " Bart Van Assche
2016-01-06 15:59     ` Bart Van Assche
2016-01-06 15:59     ` Bart Van Assche
2016-01-09 13:34   ` Christoph Hellwig
2016-01-09 13:34     ` [Ocfs2-devel] " Christoph Hellwig
2016-01-09 13:34     ` Christoph Hellwig
2016-01-10  0:43     ` Mike Christie
2016-01-10  0:43       ` [Ocfs2-devel] " Mike Christie
2016-01-10  0:43       ` Mike Christie
2016-01-05 20:53 ` [PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
     [not found]   ` <1452027218-32303-3-git-send-email-mchristi-H+wXaHxf7aLQT0dZR+AlfA@public.gmane.org>
2016-01-06 23:17     ` Martin K. Petersen
2016-01-06 23:17       ` [Ocfs2-devel] " Martin K. Petersen
2016-01-06 23:17       ` Martin K. Petersen
2016-01-06 23:17       ` Martin K. Petersen
2016-01-09 13:37   ` Christoph Hellwig
2016-01-09 13:37     ` [Ocfs2-devel] " Christoph Hellwig
2016-01-09 13:37     ` Christoph Hellwig
2016-01-10  0:56     ` [dm-devel] " Mike Christie
2016-01-10  0:56       ` [Ocfs2-devel] " Mike Christie
2016-01-10  0:56       ` Mike Christie
2016-01-10  1:21       ` Mike Christie [this message]
2016-01-10  1:21         ` [Ocfs2-devel] " Mike Christie
2016-01-10  1:21         ` Mike Christie
2016-01-10  7:15         ` Christoph Hellwig
2016-01-10  7:15           ` [Ocfs2-devel] " Christoph Hellwig
2016-01-10  7:15           ` Christoph Hellwig
2016-01-10  7:14       ` Christoph Hellwig
2016-01-10  7:14         ` [Ocfs2-devel] " Christoph Hellwig
2016-01-10  7:14         ` Christoph Hellwig
2016-01-05 20:53 ` [PATCH 03/35] block, fs, mm, drivers: set bi_op to REQ_OP mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 04/35] fs: have submit_bh users pass in op and flags separately mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 05/35] fs: have ll_rw_block " mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 23:20   ` kbuild test robot
2016-01-05 23:20     ` [Ocfs2-devel] " kbuild test robot
2016-01-05 23:20     ` kbuild test robot
2016-01-05 23:20     ` kbuild test robot
2016-01-05 23:20     ` kbuild test robot
2016-01-05 20:53 ` [PATCH 06/35] direct-io: set bi_op to REQ_OP mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 07/35] btrfs: have submit_one_bio users setup bio bi_op mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 08/35] btrfs: set bi_op tp REQ_OP mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 09/35] btrfs: update __btrfs_map_block for bi_op transition mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 10/35] btrfs: don't pass rq_flag_bits if there is a bio mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 11/35] f2fs: set bi_op to REQ_OP mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 12/35] gfs2: " mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 13/35] xfs: " mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-07  3:11   ` Dave Chinner
2016-01-07  3:11     ` [Ocfs2-devel] " Dave Chinner
2016-01-07  3:11     ` Dave Chinner
2016-01-05 20:53 ` [PATCH 14/35] hfsplus: " mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 15/35] mpage: " mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 16/35] nilfs: " mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 17/35] ocfs2: " mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 18/35] pm: " mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 19/35] dm: " mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 20/35] dm: pass dm stats data dir instead of bi_rw mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 21/35] bcache: set bi_op to REQ_OP mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 22/35] drbd: " mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 23/35] md/raid: " mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 24/35] xen: " mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 25/35] target: " mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-06 19:06   ` Nicholas A. Bellinger
2016-01-06 19:06     ` Nicholas A. Bellinger
2016-01-06 19:06     ` [Ocfs2-devel] " Nicholas A. Bellinger
2016-01-06 19:06     ` Nicholas A. Bellinger
2016-01-05 20:53 ` [PATCH 26/35] block: set op " mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-09 13:39   ` Christoph Hellwig
2016-01-09 13:39     ` [Ocfs2-devel] " Christoph Hellwig
2016-01-09 13:39     ` Christoph Hellwig
2016-01-05 20:53 ` [PATCH 27/35] drivers: set request " mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 28/35] blktrace: get op from req->op/bio->bi_op mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 29/35] ide cd: do not set REQ_WRITE on requests mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 30/35] block, fs, drivers: do not test bi_rw for REQ_OPs mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 31/35] block, fs: remove old REQ definitions mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 32/35] block: shrink bi_rw and bi_op mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 33/35] block, drivers: add REQ_OP_FLUSH operation mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 20:53 ` [PATCH 34/35] block: add QUEUE_FLAGs for flush and fua mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 23:46   ` kbuild test robot
2016-01-05 23:46     ` [Ocfs2-devel] " kbuild test robot
2016-01-05 23:46     ` kbuild test robot
2016-01-05 23:46     ` kbuild test robot
2016-01-05 23:46     ` kbuild test robot
     [not found]   ` <1452027218-32303-35-git-send-email-mchristi-H+wXaHxf7aLQT0dZR+AlfA@public.gmane.org>
2016-01-09  8:04     ` Christoph Hellwig
2016-01-09  8:04       ` [Ocfs2-devel] " Christoph Hellwig
2016-01-09  8:04       ` Christoph Hellwig
2016-01-09  8:04       ` Christoph Hellwig
2016-01-05 20:53 ` [PATCH 35/35] block, drivers, fs: rename REQ_FLUSH to REQ_PREFLUSH mchristi
2016-01-05 20:53   ` [Ocfs2-devel] " mchristi at redhat.com
2016-01-05 20:53   ` mchristi
2016-01-05 23:53   ` kbuild test robot
2016-01-05 23:53     ` [Ocfs2-devel] " kbuild test robot
2016-01-05 23:53     ` kbuild test robot
2016-01-05 23:53     ` kbuild test robot
2016-01-05 23:53     ` kbuild test robot
     [not found] ` <1452027218-32303-1-git-send-email-mchristi-H+wXaHxf7aLQT0dZR+AlfA@public.gmane.org>
2016-01-07  1:40   ` [PATCH 00/35 v2] separate operations from flags in the bio/request structs Martin K. Petersen
2016-01-07  1:40     ` [Ocfs2-devel] " Martin K. Petersen
2016-01-07  1:40     ` Martin K. Petersen
2016-01-07  1:40     ` Martin K. Petersen
2016-01-07  3:13     ` Dave Chinner
2016-01-07  3:13       ` [Ocfs2-devel] " Dave Chinner
2016-01-07  3:13       ` Dave Chinner
2016-01-08 13:32 ` Christoph Hellwig
2016-01-08 13:32   ` [Ocfs2-devel] " Christoph Hellwig
2016-01-08 13:32   ` Christoph Hellwig
2016-01-08 20:50   ` Mike Christie
2016-01-08 20:50     ` [Ocfs2-devel] " Mike Christie
2016-01-08 20:50     ` Mike Christie
2016-01-08 23:07     ` Mike Snitzer
2016-01-08 23:07       ` [Ocfs2-devel] " Mike Snitzer
2016-01-08 23:07       ` Mike Snitzer

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5691B208.9060001@cs.wisc.edu \
    --to=michaelc@cs.wisc.edu \
    --cc=dm-devel@redhat.com \
    --cc=drbd-dev@lists.linbit.com \
    --cc=konrad.wilk@oracle.com \
    --cc=lars.ellenberg@linbit.com \
    --cc=linux-bcache@vger.kernel.org \
    --cc=linux-block@vger.kernel.org \
    --cc=linux-btrfs@vger.kernel.org \
    --cc=linux-ext4@vger.kernel.org \
    --cc=linux-f2fs-devel@lists.sourceforge.net \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mtd@lists.infradead.org \
    --cc=linux-raid@vger.kernel.org \
    --cc=linux-scsi@vger.kernel.org \
    --cc=mchristi@redhat.com \
    --cc=ocfs2-devel@oss.oracle.com \
    --cc=osd-dev@open-osd.org \
    --cc=philipp.reisner@linbit.com \
    --cc=target-devel@vger.kernel.org \
    --cc=xfs@oss.sgi.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.