All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] watchdog: tango: rename ARCH_TANGOX to ARCH_TANGO
@ 2016-01-18 19:50 Mason
  2016-01-18 20:27 ` Guenter Roeck
  0 siblings, 1 reply; 8+ messages in thread
From: Mason @ 2016-01-18 19:50 UTC (permalink / raw)
  To: Wim Van Sebroeck, Guenter Roeck; +Cc: Mans Rullgard, linux-watchdog

From: Marc Gonzalez <marc_gonzalez@sigmadesigns.com>

Requested by arm-soc maintainer Kevin Hilman in v9 review.
http://article.gmane.org/gmane.linux.ports.arm.kernel/456331

Signed-off-by: Marc Gonzalez <marc_gonzalez@sigmadesigns.com>
---
Can this fix be pushed into 4.5 ?

(The 'x' in tangox is a wild-card; tango3 is legacy,
tango4 is current, tango5 is next.)
---
 drivers/watchdog/Kconfig | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/watchdog/Kconfig b/drivers/watchdog/Kconfig
index 4f0e7be0da34..e723e0169f88 100644
--- a/drivers/watchdog/Kconfig
+++ b/drivers/watchdog/Kconfig
@@ -145,7 +145,7 @@ config MENF21BMC_WATCHDOG
 config TANGOX_WATCHDOG
 	tristate "Sigma Designs SMP86xx/SMP87xx watchdog"
 	select WATCHDOG_CORE
-	depends on ARCH_TANGOX || COMPILE_TEST
+	depends on ARCH_TANGO || COMPILE_TEST
 	help
 	  Support for the watchdog in Sigma Designs SMP86xx (tango3)
 	  and SMP87xx (tango4) family chips.


^ permalink raw reply related	[flat|nested] 8+ messages in thread

* Re: [PATCH] watchdog: tango: rename ARCH_TANGOX to ARCH_TANGO
  2016-01-18 19:50 [PATCH] watchdog: tango: rename ARCH_TANGOX to ARCH_TANGO Mason
@ 2016-01-18 20:27 ` Guenter Roeck
  2016-01-19 10:32   ` Mason
  0 siblings, 1 reply; 8+ messages in thread
From: Guenter Roeck @ 2016-01-18 20:27 UTC (permalink / raw)
  To: Mason, Wim Van Sebroeck; +Cc: Mans Rullgard, linux-watchdog

On 01/18/2016 11:50 AM, Mason wrote:
> From: Marc Gonzalez <marc_gonzalez@sigmadesigns.com>
>
> Requested by arm-soc maintainer Kevin Hilman in v9 review.
> http://article.gmane.org/gmane.linux.ports.arm.kernel/456331
>

The reference should be after the '---' (it doesn't explain
the changes, but provides a reference to the change request),
and the explanation should be what you have after '---' below,
ie that the architecture is tango, that the 'x' is a wildcard,
and that it therefore makes more sense to use ARCH_TANGO
instead of ARCH_TANGOX.

> Signed-off-by: Marc Gonzalez <marc_gonzalez@sigmadesigns.com>
> ---
> Can this fix be pushed into 4.5 ?
>

Depends. Is the definition of ARCH_TANGO going to make it in ?

Guenter

> (The 'x' in tangox is a wild-card; tango3 is legacy,
> tango4 is current, tango5 is next.)
> ---
>   drivers/watchdog/Kconfig | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/watchdog/Kconfig b/drivers/watchdog/Kconfig
> index 4f0e7be0da34..e723e0169f88 100644
> --- a/drivers/watchdog/Kconfig
> +++ b/drivers/watchdog/Kconfig
> @@ -145,7 +145,7 @@ config MENF21BMC_WATCHDOG
>   config TANGOX_WATCHDOG
>   	tristate "Sigma Designs SMP86xx/SMP87xx watchdog"
>   	select WATCHDOG_CORE
> -	depends on ARCH_TANGOX || COMPILE_TEST
> +	depends on ARCH_TANGO || COMPILE_TEST
>   	help
>   	  Support for the watchdog in Sigma Designs SMP86xx (tango3)
>   	  and SMP87xx (tango4) family chips.
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-watchdog" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
>


^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: [PATCH] watchdog: tango: rename ARCH_TANGOX to ARCH_TANGO
  2016-01-18 20:27 ` Guenter Roeck
@ 2016-01-19 10:32   ` Mason
  2016-01-19 12:15     ` Mason
  2016-01-19 13:18     ` Guenter Roeck
  0 siblings, 2 replies; 8+ messages in thread
From: Mason @ 2016-01-19 10:32 UTC (permalink / raw)
  To: Guenter Roeck, Wim Van Sebroeck; +Cc: Mans Rullgard, linux-watchdog

On 18/01/2016 21:27, Guenter Roeck wrote:

> On 01/18/2016 11:50 AM, Mason wrote:
> 
>> Requested by arm-soc maintainer Kevin Hilman in v9 review.
>> http://article.gmane.org/gmane.linux.ports.arm.kernel/456331
> 
> The reference should be after the '---' (it doesn't explain
> the changes, but provides a reference to the change request),
> and the explanation should be what you have after '---' below,
> ie that the architecture is tango, that the 'x' is a wildcard,
> and that it therefore makes more sense to use ARCH_TANGO
> instead of ARCH_TANGOX.

Hello Guenter,

Thanks for the review.

For the commit message, I am just following Michael's advice:
(one of the clk maintainers)

"Just a single line explaining that the change was requested by the
arm-soc devs in the commit log is helpful. I typically reference these
discussions in the commit log with a link"

Note, I submitted the same patch to clk.
http://article.gmane.org/gmane.linux.kernel.clk/3164

I'd rather have the same commit message for all these trivial fixups.

>> Can this fix be pushed into 4.5 ?
> 
> Depends. Is the definition of ARCH_TANGO going to make it in ?

Indeed.

https://git.kernel.org/cgit/linux/kernel/git/next/linux-next.git/tree/arch/arm/mach-tango/Kconfig

Regards.

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: [PATCH] watchdog: tango: rename ARCH_TANGOX to ARCH_TANGO
  2016-01-19 10:32   ` Mason
@ 2016-01-19 12:15     ` Mason
  2016-01-19 12:35       ` Måns Rullgård
  2016-01-19 13:18     ` Guenter Roeck
  1 sibling, 1 reply; 8+ messages in thread
From: Mason @ 2016-01-19 12:15 UTC (permalink / raw)
  To: Guenter Roeck, Wim Van Sebroeck; +Cc: Mans Rullgard, linux-watchdog

Hello again,

While I'm at it, should I also rename TANGOX_WATCHDOG ?
Or should it be left as is, to minimize churn?

Regards.


^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: [PATCH] watchdog: tango: rename ARCH_TANGOX to ARCH_TANGO
  2016-01-19 12:15     ` Mason
@ 2016-01-19 12:35       ` Måns Rullgård
  2016-01-19 13:08         ` Guenter Roeck
  0 siblings, 1 reply; 8+ messages in thread
From: Måns Rullgård @ 2016-01-19 12:35 UTC (permalink / raw)
  To: Mason; +Cc: Guenter Roeck, Wim Van Sebroeck, linux-watchdog

Mason <slash.tmp@free.fr> writes:

> Hello again,
>
> While I'm at it, should I also rename TANGOX_WATCHDOG ?
> Or should it be left as is, to minimize churn?

I don't really care either way.

-- 
Måns Rullgård

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: [PATCH] watchdog: tango: rename ARCH_TANGOX to ARCH_TANGO
  2016-01-19 12:35       ` Måns Rullgård
@ 2016-01-19 13:08         ` Guenter Roeck
  0 siblings, 0 replies; 8+ messages in thread
From: Guenter Roeck @ 2016-01-19 13:08 UTC (permalink / raw)
  To: Måns Rullgård, Mason; +Cc: Wim Van Sebroeck, linux-watchdog

On 01/19/2016 04:35 AM, Måns Rullgård wrote:
> Mason <slash.tmp@free.fr> writes:
>
>> Hello again,
>>
>> While I'm at it, should I also rename TANGOX_WATCHDOG ?
>> Or should it be left as is, to minimize churn?
>
> I don't really care either way.
>
Me not either.

Guenter


^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: [PATCH] watchdog: tango: rename ARCH_TANGOX to ARCH_TANGO
  2016-01-19 10:32   ` Mason
  2016-01-19 12:15     ` Mason
@ 2016-01-19 13:18     ` Guenter Roeck
  2016-01-21 14:36       ` Mason
  1 sibling, 1 reply; 8+ messages in thread
From: Guenter Roeck @ 2016-01-19 13:18 UTC (permalink / raw)
  To: Mason, Wim Van Sebroeck; +Cc: Mans Rullgard, linux-watchdog, Michael Turquette

On 01/19/2016 02:32 AM, Mason wrote:
> On 18/01/2016 21:27, Guenter Roeck wrote:
>
>> On 01/18/2016 11:50 AM, Mason wrote:
>>
>>> Requested by arm-soc maintainer Kevin Hilman in v9 review.
>>> http://article.gmane.org/gmane.linux.ports.arm.kernel/456331
>>
>> The reference should be after the '---' (it doesn't explain
>> the changes, but provides a reference to the change request),
>> and the explanation should be what you have after '---' below,
>> ie that the architecture is tango, that the 'x' is a wildcard,
>> and that it therefore makes more sense to use ARCH_TANGO
>> instead of ARCH_TANGOX.
>
> Hello Guenter,
>
> Thanks for the review.
>
> For the commit message, I am just following Michael's advice:
> (one of the clk maintainers)
>
> "Just a single line explaining that the change was requested by the
> arm-soc devs in the commit log is helpful. I typically reference these
> discussions in the commit log with a link"
>

I'd have expected that as a comment, not in the commit log.

Michael, is that something new ? It isn't really obvious in the drivers/clk
logs and appears to be quite unusual.

Guenter

> Note, I submitted the same patch to clk.
> http://article.gmane.org/gmane.linux.kernel.clk/3164
>
> I'd rather have the same commit message for all these trivial fixups.
>
>>> Can this fix be pushed into 4.5 ?
>>
>> Depends. Is the definition of ARCH_TANGO going to make it in ?
>
> Indeed.
>
> https://git.kernel.org/cgit/linux/kernel/git/next/linux-next.git/tree/arch/arm/mach-tango/Kconfig
>
> Regards.
>
>


^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: [PATCH] watchdog: tango: rename ARCH_TANGOX to ARCH_TANGO
  2016-01-19 13:18     ` Guenter Roeck
@ 2016-01-21 14:36       ` Mason
  0 siblings, 0 replies; 8+ messages in thread
From: Mason @ 2016-01-21 14:36 UTC (permalink / raw)
  To: Guenter Roeck, Wim Van Sebroeck
  Cc: Mans Rullgard, linux-watchdog, Michael Turquette

On 19/01/2016 14:18, Guenter Roeck wrote:

> On 01/19/2016 02:32 AM, Mason wrote:
>
>> On 18/01/2016 21:27, Guenter Roeck wrote:
>>
>>> On 01/18/2016 11:50 AM, Mason wrote:
>>>
>>>> Requested by arm-soc maintainer Kevin Hilman in v9 review.
>>>> http://article.gmane.org/gmane.linux.ports.arm.kernel/456331
>>>
>>> The reference should be after the '---' (it doesn't explain
>>> the changes, but provides a reference to the change request),
>>> and the explanation should be what you have after '---' below,
>>> ie that the architecture is tango, that the 'x' is a wildcard,
>>> and that it therefore makes more sense to use ARCH_TANGO
>>> instead of ARCH_TANGOX.
>>
>> Hello Guenter,
>>
>> Thanks for the review.
>>
>> For the commit message, I am just following Michael's advice:
>> (one of the clk maintainers)
>>
>> "Just a single line explaining that the change was requested by the
>> arm-soc devs in the commit log is helpful. I typically reference these
>> discussions in the commit log with a link"
> 
> I'd have expected that as a comment, not in the commit log.
> 
> Michael, is that something new ? It isn't really obvious in the drivers/clk
> logs and appears to be quite unusual.

Hello Guenter,

I have sent v2 with an updated commit message.

Note that Mike's address has changed.

Regards.

^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2016-01-21 14:36 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-01-18 19:50 [PATCH] watchdog: tango: rename ARCH_TANGOX to ARCH_TANGO Mason
2016-01-18 20:27 ` Guenter Roeck
2016-01-19 10:32   ` Mason
2016-01-19 12:15     ` Mason
2016-01-19 12:35       ` Måns Rullgård
2016-01-19 13:08         ` Guenter Roeck
2016-01-19 13:18     ` Guenter Roeck
2016-01-21 14:36       ` Mason

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.