All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2] watchdog: tango: rename ARCH_TANGOX to ARCH_TANGO
@ 2016-01-21 14:27 Mason
  2016-01-21 14:28 ` Måns Rullgård
  2016-01-21 20:42 ` Guenter Roeck
  0 siblings, 2 replies; 7+ messages in thread
From: Mason @ 2016-01-21 14:27 UTC (permalink / raw)
  To: Wim Van Sebroeck, Guenter Roeck; +Cc: Mans Rullgard, linux-watchdog

From: Marc Gonzalez <marc_gonzalez@sigmadesigns.com>

This change was requested by arm-soc maintainer Kevin Hilman
because the X in TANGOX is a wildcard.

Signed-off-by: Marc Gonzalez <marc_gonzalez@sigmadesigns.com>
---
 drivers/watchdog/Kconfig | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/watchdog/Kconfig b/drivers/watchdog/Kconfig
index 4f0e7be0da34..e723e0169f88 100644
--- a/drivers/watchdog/Kconfig
+++ b/drivers/watchdog/Kconfig
@@ -145,7 +145,7 @@ config MENF21BMC_WATCHDOG
 config TANGOX_WATCHDOG
 	tristate "Sigma Designs SMP86xx/SMP87xx watchdog"
 	select WATCHDOG_CORE
-	depends on ARCH_TANGOX || COMPILE_TEST
+	depends on ARCH_TANGO || COMPILE_TEST
 	help
 	  Support for the watchdog in Sigma Designs SMP86xx (tango3)
 	  and SMP87xx (tango4) family chips.


^ permalink raw reply related	[flat|nested] 7+ messages in thread

* Re: [PATCH v2] watchdog: tango: rename ARCH_TANGOX to ARCH_TANGO
  2016-01-21 14:27 [PATCH v2] watchdog: tango: rename ARCH_TANGOX to ARCH_TANGO Mason
@ 2016-01-21 14:28 ` Måns Rullgård
  2016-01-21 20:42 ` Guenter Roeck
  1 sibling, 0 replies; 7+ messages in thread
From: Måns Rullgård @ 2016-01-21 14:28 UTC (permalink / raw)
  To: Mason; +Cc: Wim Van Sebroeck, Guenter Roeck, linux-watchdog

Mason <slash.tmp@free.fr> writes:

> From: Marc Gonzalez <marc_gonzalez@sigmadesigns.com>
>
> This change was requested by arm-soc maintainer Kevin Hilman
> because the X in TANGOX is a wildcard.
>
> Signed-off-by: Marc Gonzalez <marc_gonzalez@sigmadesigns.com>
> ---
>  drivers/watchdog/Kconfig | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Acked-by: Mans Rullgard <mans@mansr.com>

> diff --git a/drivers/watchdog/Kconfig b/drivers/watchdog/Kconfig
> index 4f0e7be0da34..e723e0169f88 100644
> --- a/drivers/watchdog/Kconfig
> +++ b/drivers/watchdog/Kconfig
> @@ -145,7 +145,7 @@ config MENF21BMC_WATCHDOG
>  config TANGOX_WATCHDOG
>  	tristate "Sigma Designs SMP86xx/SMP87xx watchdog"
>  	select WATCHDOG_CORE
> -	depends on ARCH_TANGOX || COMPILE_TEST
> +	depends on ARCH_TANGO || COMPILE_TEST
>  	help
>  	  Support for the watchdog in Sigma Designs SMP86xx (tango3)
>  	  and SMP87xx (tango4) family chips.
>

-- 
Måns Rullgård

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH v2] watchdog: tango: rename ARCH_TANGOX to ARCH_TANGO
  2016-01-21 14:27 [PATCH v2] watchdog: tango: rename ARCH_TANGOX to ARCH_TANGO Mason
  2016-01-21 14:28 ` Måns Rullgård
@ 2016-01-21 20:42 ` Guenter Roeck
  2016-01-22 11:14   ` Måns Rullgård
  1 sibling, 1 reply; 7+ messages in thread
From: Guenter Roeck @ 2016-01-21 20:42 UTC (permalink / raw)
  To: Mason; +Cc: Wim Van Sebroeck, Mans Rullgard, linux-watchdog

On Thu, Jan 21, 2016 at 03:27:07PM +0100, Mason wrote:
> From: Marc Gonzalez <marc_gonzalez@sigmadesigns.com>
> 
> This change was requested by arm-soc maintainer Kevin Hilman
> because the X in TANGOX is a wildcard.
> 
Not what I was looking for, but not worth arguing about it, so

> Signed-off-by: Marc Gonzalez <marc_gonzalez@sigmadesigns.com>

Reviewed-by: Guenter Roeck <linux@roeck-us.net>

> ---
>  drivers/watchdog/Kconfig | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/watchdog/Kconfig b/drivers/watchdog/Kconfig
> index 4f0e7be0da34..e723e0169f88 100644
> --- a/drivers/watchdog/Kconfig
> +++ b/drivers/watchdog/Kconfig
> @@ -145,7 +145,7 @@ config MENF21BMC_WATCHDOG
>  config TANGOX_WATCHDOG
>  	tristate "Sigma Designs SMP86xx/SMP87xx watchdog"
>  	select WATCHDOG_CORE
> -	depends on ARCH_TANGOX || COMPILE_TEST
> +	depends on ARCH_TANGO || COMPILE_TEST
>  	help
>  	  Support for the watchdog in Sigma Designs SMP86xx (tango3)
>  	  and SMP87xx (tango4) family chips.
> 
> --
> To unsubscribe from this list: send the line "unsubscribe linux-watchdog" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH v2] watchdog: tango: rename ARCH_TANGOX to ARCH_TANGO
  2016-01-21 20:42 ` Guenter Roeck
@ 2016-01-22 11:14   ` Måns Rullgård
  2016-01-22 14:16     ` Guenter Roeck
  0 siblings, 1 reply; 7+ messages in thread
From: Måns Rullgård @ 2016-01-22 11:14 UTC (permalink / raw)
  To: Guenter Roeck; +Cc: Mason, Wim Van Sebroeck, linux-watchdog

Guenter Roeck <linux@roeck-us.net> writes:

> On Thu, Jan 21, 2016 at 03:27:07PM +0100, Mason wrote:
>> From: Marc Gonzalez <marc_gonzalez@sigmadesigns.com>
>> 
>> This change was requested by arm-soc maintainer Kevin Hilman
>> because the X in TANGOX is a wildcard.
>> 
> Not what I was looking for, but not worth arguing about it, so

It would be better if the commit message simply mentioned the fact that
the platform support uses ARCH_TANGO and this has to match.  The details
of why it got named that way are less important.

>> Signed-off-by: Marc Gonzalez <marc_gonzalez@sigmadesigns.com>
>
> Reviewed-by: Guenter Roeck <linux@roeck-us.net>
>
>> ---
>>  drivers/watchdog/Kconfig | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>> 
>> diff --git a/drivers/watchdog/Kconfig b/drivers/watchdog/Kconfig
>> index 4f0e7be0da34..e723e0169f88 100644
>> --- a/drivers/watchdog/Kconfig
>> +++ b/drivers/watchdog/Kconfig
>> @@ -145,7 +145,7 @@ config MENF21BMC_WATCHDOG
>>  config TANGOX_WATCHDOG
>>  	tristate "Sigma Designs SMP86xx/SMP87xx watchdog"
>>  	select WATCHDOG_CORE
>> -	depends on ARCH_TANGOX || COMPILE_TEST
>> +	depends on ARCH_TANGO || COMPILE_TEST
>>  	help
>>  	  Support for the watchdog in Sigma Designs SMP86xx (tango3)
>>  	  and SMP87xx (tango4) family chips.
>> 
>> --
>> To unsubscribe from this list: send the line "unsubscribe linux-watchdog" in
>> the body of a message to majordomo@vger.kernel.org
>> More majordomo info at  http://vger.kernel.org/majordomo-info.html

-- 
Måns Rullgård
--
To unsubscribe from this list: send the line "unsubscribe linux-watchdog" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH v2] watchdog: tango: rename ARCH_TANGOX to ARCH_TANGO
  2016-01-22 11:14   ` Måns Rullgård
@ 2016-01-22 14:16     ` Guenter Roeck
  2016-01-22 14:51       ` Mason
  0 siblings, 1 reply; 7+ messages in thread
From: Guenter Roeck @ 2016-01-22 14:16 UTC (permalink / raw)
  To: Måns Rullgård; +Cc: Mason, Wim Van Sebroeck, linux-watchdog

On 01/22/2016 03:14 AM, Måns Rullgård wrote:
> Guenter Roeck <linux@roeck-us.net> writes:
>
>> On Thu, Jan 21, 2016 at 03:27:07PM +0100, Mason wrote:
>>> From: Marc Gonzalez <marc_gonzalez@sigmadesigns.com>
>>>
>>> This change was requested by arm-soc maintainer Kevin Hilman
>>> because the X in TANGOX is a wildcard.
>>>
>> Not what I was looking for, but not worth arguing about it, so
>
> It would be better if the commit message simply mentioned the fact that
> the platform support uses ARCH_TANGO and this has to match.  The details
> of why it got named that way are less important.
>
Agreed. That is why I had asked to move that information after the "---".
But as I said, this is not worth an endless argument.

Guenter

>>> Signed-off-by: Marc Gonzalez <marc_gonzalez@sigmadesigns.com>
>>
>> Reviewed-by: Guenter Roeck <linux@roeck-us.net>
>>
>>> ---
>>>   drivers/watchdog/Kconfig | 2 +-
>>>   1 file changed, 1 insertion(+), 1 deletion(-)
>>>
>>> diff --git a/drivers/watchdog/Kconfig b/drivers/watchdog/Kconfig
>>> index 4f0e7be0da34..e723e0169f88 100644
>>> --- a/drivers/watchdog/Kconfig
>>> +++ b/drivers/watchdog/Kconfig
>>> @@ -145,7 +145,7 @@ config MENF21BMC_WATCHDOG
>>>   config TANGOX_WATCHDOG
>>>   	tristate "Sigma Designs SMP86xx/SMP87xx watchdog"
>>>   	select WATCHDOG_CORE
>>> -	depends on ARCH_TANGOX || COMPILE_TEST
>>> +	depends on ARCH_TANGO || COMPILE_TEST
>>>   	help
>>>   	  Support for the watchdog in Sigma Designs SMP86xx (tango3)
>>>   	  and SMP87xx (tango4) family chips.
>>>
>>> --
>>> To unsubscribe from this list: send the line "unsubscribe linux-watchdog" in
>>> the body of a message to majordomo@vger.kernel.org
>>> More majordomo info at  http://vger.kernel.org/majordomo-info.html
>

--
To unsubscribe from this list: send the line "unsubscribe linux-watchdog" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH v2] watchdog: tango: rename ARCH_TANGOX to ARCH_TANGO
  2016-01-22 14:16     ` Guenter Roeck
@ 2016-01-22 14:51       ` Mason
  2016-01-22 15:41         ` Guenter Roeck
  0 siblings, 1 reply; 7+ messages in thread
From: Mason @ 2016-01-22 14:51 UTC (permalink / raw)
  To: Guenter Roeck; +Cc: Mans Rullgard, Wim Van Sebroeck, linux-watchdog

On 22/01/2016 15:16, Guenter Roeck wrote:

> On 01/22/2016 03:14 AM, Måns Rullgård wrote:
> 
>> Guenter Roeck <linux@roeck-us.net> writes:
>> 
>>> On Thu, Jan 21, 2016 at 03:27:07PM +0100, Mason wrote:
>>>> From: Marc Gonzalez <marc_gonzalez@sigmadesigns.com>
>>>>
>>>> This change was requested by arm-soc maintainer Kevin Hilman
>>>> because the X in TANGOX is a wildcard.
>>>
>>> Not what I was looking for, but not worth arguing about it, so
>>
>> It would be better if the commit message simply mentioned the fact that
>> the platform support uses ARCH_TANGO and this has to match.  The details
>> of why it got named that way are less important.
>>
> Agreed. That is why I had asked to move that information after the "---".
> But as I said, this is not worth an endless argument.

As long as the patch makes it into v4.5, I don't mind a different
commit message. You can reword as you wish.

Regards.

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH v2] watchdog: tango: rename ARCH_TANGOX to ARCH_TANGO
  2016-01-22 14:51       ` Mason
@ 2016-01-22 15:41         ` Guenter Roeck
  0 siblings, 0 replies; 7+ messages in thread
From: Guenter Roeck @ 2016-01-22 15:41 UTC (permalink / raw)
  To: Mason; +Cc: Mans Rullgard, Wim Van Sebroeck, linux-watchdog

On 01/22/2016 06:51 AM, Mason wrote:
> On 22/01/2016 15:16, Guenter Roeck wrote:
>
>> On 01/22/2016 03:14 AM, Måns Rullgård wrote:
>>
>>> Guenter Roeck <linux@roeck-us.net> writes:
>>>
>>>> On Thu, Jan 21, 2016 at 03:27:07PM +0100, Mason wrote:
>>>>> From: Marc Gonzalez <marc_gonzalez@sigmadesigns.com>
>>>>>
>>>>> This change was requested by arm-soc maintainer Kevin Hilman
>>>>> because the X in TANGOX is a wildcard.
>>>>
>>>> Not what I was looking for, but not worth arguing about it, so
>>>
>>> It would be better if the commit message simply mentioned the fact that
>>> the platform support uses ARCH_TANGO and this has to match.  The details
>>> of why it got named that way are less important.
>>>
>> Agreed. That is why I had asked to move that information after the "---".
>> But as I said, this is not worth an endless argument.
>
> As long as the patch makes it into v4.5, I don't mind a different
> commit message. You can reword as you wish.
>

Wim is the maintainer. If anything, he would have to do the rewording.

I would like you to keep one thing in mind, though, for your future patches.
Maintainers tend to be busy. It helps to make life easy for them.

Thanks,
Guenter


^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2016-01-22 15:41 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-01-21 14:27 [PATCH v2] watchdog: tango: rename ARCH_TANGOX to ARCH_TANGO Mason
2016-01-21 14:28 ` Måns Rullgård
2016-01-21 20:42 ` Guenter Roeck
2016-01-22 11:14   ` Måns Rullgård
2016-01-22 14:16     ` Guenter Roeck
2016-01-22 14:51       ` Mason
2016-01-22 15:41         ` Guenter Roeck

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.