All of lore.kernel.org
 help / color / mirror / Atom feed
From: Julien Grall <julien.grall@arm.com>
To: Corneliu ZUZU <czuzu@bitdefender.com>, xen-devel@lists.xen.org
Cc: Andre Przywara <andre.przywara@arm.com>,
	Stefano Stabellini <sstabellini@kernel.org>,
	Tamas K Lengyel <tamas@tklengyel.com>,
	Razvan Cojocaru <rcojocaru@bitdefender.com>,
	Steve Capper <Steve.Capper@arm.com>
Subject: Re: [PATCH 7/7] vm-event/arm: implement support for control-register write vm-events
Date: Thu, 23 Jun 2016 12:11:29 +0100	[thread overview]
Message-ID: <576BC3E1.1080707@arm.com> (raw)
In-Reply-To: <4c219b45-adde-4794-0992-95b7ee32f09a@bitdefender.com>

Hello,

On 23/06/16 06:49, Corneliu ZUZU wrote:
> On 6/23/2016 8:31 AM, Corneliu ZUZU wrote:
>> On 6/22/2016 10:41 PM, Julien Grall wrote:
>>>
>>>
>>> On 22/06/2016 20:37, Corneliu ZUZU wrote:
>>>> I've also realized that it's a bit complicated to avoid writing HCR
>>>> from
>>>> 2 places.
>>>> That's because:
>>>> - p2m_restore_state is part of the process of switching to another vCPU
>>>> and the HCR write _must be committed_ here because other components
>>>> depend on that, like address-translation functions
>>>> - I want vm_event_vcpu_enter to be called _after_ the switch to the
>>>> vCPU
>>>> is completed
>>>> - I want HCR_TVM to be set in vm_event_vcpu_enter because setting
>>>> necessary traps _for cr vm-events_ to work should be done there
>>>> (setting
>>>> HCR_TVM bit makes sense to be there and the purpose is to centralize
>>>> operations such as this for code comprehensibility; also, on the X86
>>>> counterpart a similar operation is done for trapping CR3, so it
>>>> would be
>>>> nice to keep the symmetry)
>>>>
>>>> Would it be such a stretch to have HCR written in 2 places? (the second
>>>> time happens rarely anyway: it's unlikely(..) to have to do the
>>>> write in
>>>> vm_event_vcpu_enter)
>>>
>>> Not really. It was mostly to avoid setting/clearing HCR bits in
>>> different place in the code. It makes more difficult to know what is
>>> the final result of the register.
>>>
>>> Anyway, let's skip it for now, if it is too difficult.
>>>
>>> Regards,
>>>
>>
>> Then perhaps something like the following would be suitable:
>>
>> 1. store hcr in arch_domain (register_t hcr)
>>
>> 2. add a function in asm-arm/processor.h (or where else?) which only
>> does:
>>     static inline void update_hcr(struct domain *d)
>>     {
>>         WRITE_SYSREG(d->arch.hcr, HCR_EL2);
>>         isb();
>>     }
>>
>> 3.  modify p2m_restore_state to do:
>>     n->domain->arch.hcr &= ~HCR_VM;
>>     update_hcr(n->domain);
>>     p2m_load_VTTBR(n->domain);
>>
>>     n->domain->arch.hcr |= HCR_VM;
>>
>>     if ( is_32bit_domain(n->domain) )
>>         n->domain->arch.hcr &= ~HCR_RW;
>>     else
>>         n->domain->arch.hcr |= HCR_RW;

This is not safe at all, p2m_restore_state is vCPU specific at you 
modify domain information.

However, if we store the hcr per domain, overriding every context switch 
is pointless as the domain will always be 32-bit/64-bit.

>>
>>     update_hcr(n->domain);
>>
>>     WRITE_SYSREG(n->arch.sctlr, SCTLR_EL1);
>>     isb();
>>
>> 4. and vcpu_enter_adjust_traps to
>>
>>     if ( unlikely(0 != v->domain->arch.monitor.write_ctrlreg_enabled) )
>>     {
>>          if ( likely(v->domain->arch.hcr & HCR_TVM) )
>>              return;
>>          v->domain->arch.hcr |= HCR_TVM;
>>     }
>>     else
>>     {
>>          if ( likely(!(v->domain->arch.hcr & HCR_TVM)) )
>>              return;
>>          v->domain->arch.hcr &= ~HCR_TVM;
>>     }

This does not need to be done in vcpu_enter_adjust_traps everytime. You 
can set the bit in arch.hcr in DOMCTL_MONITOR_EVENT_WRITE_CTRLREG.

>>
>>     update_hcr(v->domain);
>>
>> That way at least it's easier to follow where update_hcr is called.

I don't see much reason to store the value in the domain and have 
multiple update_hcr. If we store the value, then we should only call 
update_hcr once when returning to the guest.

> And also set the initial value of HCR at the moment of creation, i.e. in
> arch_domain_create as
>
> d->arch.hcr = READ_SYSREG(HCR_EL2)

We control the value of HCR_EL2, so it would be better to assign the 
list of flags here.

Regards,

-- 
Julien Grall

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel

  reply	other threads:[~2016-06-23 11:11 UTC|newest]

Thread overview: 73+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-06-16 14:04 [PATCH 0/7] vm-event: Implement ARM support for control-register writes Corneliu ZUZU
2016-06-16 14:06 ` [PATCH 1/7] minor (formatting) fixes Corneliu ZUZU
2016-06-16 14:24   ` Jan Beulich
2016-06-16 19:19     ` Corneliu ZUZU
2016-06-17  7:06       ` Jan Beulich
2016-06-17 10:46         ` Corneliu ZUZU
2016-06-16 16:02   ` Tamas K Lengyel
2016-06-17  8:33     ` Corneliu ZUZU
2016-06-17  8:36       ` Razvan Cojocaru
2016-06-17  9:29         ` Andrew Cooper
2016-06-17  9:35           ` Jan Beulich
2016-06-17  9:33         ` Jan Beulich
2016-06-17  9:36           ` Razvan Cojocaru
2016-06-17  9:40             ` Jan Beulich
2016-06-17  9:42               ` Razvan Cojocaru
2016-06-17 19:05           ` Tamas K Lengyel
2016-06-16 14:07 ` [PATCH 2/7] vm-event: VM_EVENT_FLAG_DENY requires VM_EVENT_FLAG_VCPU_PAUSED Corneliu ZUZU
2016-06-16 16:11   ` Tamas K Lengyel
2016-06-17  8:43     ` Corneliu ZUZU
2016-06-21 11:26     ` Corneliu ZUZU
2016-06-21 15:09       ` Tamas K Lengyel
2016-06-22  8:34         ` Corneliu ZUZU
2016-06-16 14:08 ` [PATCH 3/7] vm-event: introduce vm_event_vcpu_enter Corneliu ZUZU
2016-06-16 14:51   ` Jan Beulich
2016-06-16 20:10     ` Corneliu ZUZU
2016-06-16 20:33       ` Razvan Cojocaru
2016-06-17 10:41         ` Corneliu ZUZU
2016-06-17  7:17       ` Jan Beulich
2016-06-17 11:13         ` Corneliu ZUZU
2016-06-17 11:27           ` Jan Beulich
2016-06-17 12:13             ` Corneliu ZUZU
2016-06-16 16:17   ` Tamas K Lengyel
2016-06-17  9:19     ` Corneliu ZUZU
2016-06-17  8:55   ` Julien Grall
2016-06-17 11:40     ` Corneliu ZUZU
2016-06-17 13:22       ` Julien Grall
2016-06-16 14:09 ` [PATCH 4/7] vm-event/x86: use vm_event_vcpu_enter properly Corneliu ZUZU
2016-06-16 15:00   ` Jan Beulich
2016-06-16 20:20     ` Corneliu ZUZU
2016-06-17  7:20       ` Jan Beulich
2016-06-17 11:23         ` Corneliu ZUZU
2016-06-16 16:27   ` Tamas K Lengyel
2016-06-17  9:24     ` Corneliu ZUZU
2016-06-16 14:10 ` [PATCH 5/7] x86: replace monitor_write_data.do_write with enum Corneliu ZUZU
2016-06-16 14:12 ` [PATCH 6/7] vm-event/arm: move hvm_event_cr->common vm_event_monitor_cr Corneliu ZUZU
2016-06-16 15:16   ` Jan Beulich
2016-06-17  8:25     ` Corneliu ZUZU
2016-06-17  8:38       ` Jan Beulich
2016-06-17 11:31         ` Corneliu ZUZU
2016-06-21  7:08       ` Corneliu ZUZU
2016-06-21  7:20         ` Jan Beulich
2016-06-21 15:22           ` Tamas K Lengyel
2016-06-22  6:33             ` Jan Beulich
2016-06-16 16:55   ` Tamas K Lengyel
2016-06-17 10:37     ` Corneliu ZUZU
2016-06-16 14:13 ` [PATCH 7/7] vm-event/arm: implement support for control-register write vm-events Corneliu ZUZU
2016-06-16 14:26   ` Julien Grall
2016-06-16 19:24     ` Corneliu ZUZU
2016-06-16 21:28       ` Julien Grall
2016-06-17 11:46         ` Corneliu ZUZU
2016-06-16 16:49   ` Julien Grall
2016-06-17 10:36     ` Corneliu ZUZU
2016-06-17 13:18       ` Julien Grall
2016-06-22 16:35       ` Corneliu ZUZU
2016-06-22 17:17         ` Julien Grall
2016-06-22 18:39           ` Corneliu ZUZU
2016-06-22 19:37             ` Corneliu ZUZU
2016-06-22 19:41               ` Julien Grall
2016-06-23  5:31                 ` Corneliu ZUZU
2016-06-23  5:49                   ` Corneliu ZUZU
2016-06-23 11:11                     ` Julien Grall [this message]
2016-06-24  9:32                       ` Corneliu ZUZU
2016-06-23 11:00           ` Julien Grall

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=576BC3E1.1080707@arm.com \
    --to=julien.grall@arm.com \
    --cc=Steve.Capper@arm.com \
    --cc=andre.przywara@arm.com \
    --cc=czuzu@bitdefender.com \
    --cc=rcojocaru@bitdefender.com \
    --cc=sstabellini@kernel.org \
    --cc=tamas@tklengyel.com \
    --cc=xen-devel@lists.xen.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.