All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2 0/2]kernel-shark:add new plugin for xenomai cobalt_switch_context events
@ 2021-12-22  6:40 Hongzhan Chen
  2021-12-22  6:40 ` [PATCH v2 1/2] kernel-shark: Move common APIs and definitions out to avoid duplication Hongzhan Chen
                   ` (3 more replies)
  0 siblings, 4 replies; 8+ messages in thread
From: Hongzhan Chen @ 2021-12-22  6:40 UTC (permalink / raw)
  To: linux-trace-devel, y.karadz

1. To avoid code duplication, move some common APIs and definitions
   out to create new files and share with other plugins.
2. add new plugin for handling xenomai cobalt_switch_context events
   to visualize OOB state of RT tasks.

I tried to move common APIs and definitions to KsPlugins.cpp/hpp but
found these definitions finally depend on KsMainWindow object used
by _doubleClick of LatencyBox assigned by plugin_set_gui_ptr via
KSHARK_MENU_PLUGIN_INITIALIZER. 
I do not know how to remove this dependency so I create new files to
avoid code duplication. Please suggest if there is better way. 

Hongzhan Chen (2):
  kernel-shark: Move common APIs and definitions out to avoid
    duplication
  kernel-shark: Add plugin for handling Xenomai cobalt_context_switch

 src/libkshark-tepdata.c                    |   1 +
 src/plugins/CMakeLists.txt                 |   6 +-
 src/plugins/CobaltSwitchEvents.cpp         | 125 +++++++++++++++
 src/plugins/CommonSched.hpp                |  99 ++++++++++++
 src/plugins/SchedEvents.cpp                |  87 +----------
 src/plugins/common_sched.c                 |  37 +++++
 src/plugins/common_sched.h                 |  50 ++++++
 src/plugins/sched_events.c                 |  37 +----
 src/plugins/sched_events.h                 |  12 +-
 src/plugins/xenomai_cobalt_switch_events.c | 169 +++++++++++++++++++++
 src/plugins/xenomai_cobalt_switch_events.h |  54 +++++++
 11 files changed, 545 insertions(+), 132 deletions(-)
 create mode 100644 src/plugins/CobaltSwitchEvents.cpp
 create mode 100644 src/plugins/CommonSched.hpp
 create mode 100644 src/plugins/common_sched.c
 create mode 100644 src/plugins/common_sched.h
 create mode 100644 src/plugins/xenomai_cobalt_switch_events.c
 create mode 100644 src/plugins/xenomai_cobalt_switch_events.h

-- 
2.17.1


^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2022-01-06 18:32 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-12-22  6:40 [PATCH v2 0/2]kernel-shark:add new plugin for xenomai cobalt_switch_context events Hongzhan Chen
2021-12-22  6:40 ` [PATCH v2 1/2] kernel-shark: Move common APIs and definitions out to avoid duplication Hongzhan Chen
2022-01-05 11:34   ` Yordan Karadzhov
2021-12-22  6:40 ` [PATCH v2 2/2] kernel-shark: Add plugin for handling Xenomai cobalt_context_switch Hongzhan Chen
2022-01-05 11:32 ` [PATCH v2 0/2]kernel-shark:add new plugin for xenomai cobalt_switch_context events Yordan Karadzhov
2022-01-06 17:18 ` Steven Rostedt
2022-01-06 17:32   ` Yordan Karadzhov
2022-01-06 18:32     ` Steven Rostedt

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.